Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
pulseaudio, systemd and KDE
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Barade
n00b
n00b


Joined: 03 Feb 2009
Posts: 30

PostPosted: Tue Aug 19, 2014 4:44 pm    Post subject: pulseaudio, systemd and KDE Reply with quote

Hi,
as the wiki says nobody should be in group "audio" so I removed everyone.
When logging in KDE a pulseaudio process is started:
Code:

12431 ?        S<l    0:00 /usr/bin/pulseaudio --start --log-target=syslog

Unfortunately, kmix and phonon control show the usual ALSA list of hardware devices.
After killing pulsaudio once:
Code:

killall -9 pulseaudio

or
Code:

pulseaudio -k

it restarts immediately and at least phonon sound control shows now only "pulse audio sound server".
After killing kmix and starting it again it still shows the ALSA list.

How can pulseaudio be started properly in KDE that I do not need to kill it manually once?
And how can I fix kmix?

Without using systemd killing kmix once was just enough.

edit:
I am also wondering how to configure things I can configure in alsamixer when using pulseaudio. KMix won't offer me enough and pavucontrol doesn't offer the options as well.
Alsamixer shows me all "channels" of the soundcard but with pulseaudio I have to use the nongui tool alsamixer for that.
One unified tool would be easier.
Back to top
View user's profile Send private message
Logicien
l33t
l33t


Joined: 16 Sep 2005
Posts: 862
Location: Montréal

PostPosted: Tue Aug 19, 2014 10:53 pm    Post subject: Reply with quote

Did you set Alsa default sound card to Pulseaudio? /etc/asound.conf and/or $HOME/.asoundrc:
Code:
pcm.pulse {
    type pulse
}

ctl.pulse {
    type pulse
}

pcm.!default {
    type pulse
}

ctl.!default {
    type pulse
}

With that, Kmix and Phonon can use Pulseaudio. With Alsamixer, you can use the F6 key to access other sound cards than Pulseaudio.
_________________
Paul
Back to top
View user's profile Send private message
Barade
n00b
n00b


Joined: 03 Feb 2009
Posts: 30

PostPosted: Sun Aug 31, 2014 12:54 pm    Post subject: Reply with quote

thx that worked. Do you know how to prevent ALSA/PulseAudio from resetting the alsa speaker volume to 0 every time I reboot?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum