Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
perl-5.18 update
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
mno
Guru
Guru


Joined: 29 Dec 2003
Posts: 452
Location: Toronto, Canada

PostPosted: Mon Aug 18, 2014 11:45 am    Post subject: perl-5.18 update Reply with quote

Hi everyone,

I was trying to find the steps to update perl (from 5.16 to 5.18 ). As always, it comes with a bazillion blockers, etc:

Code:
[blocks B      ] <perl-core/Pod-Parser-1.600.0 ("<perl-core/Pod-Parser-1.600.0" is blocking virtual/perl-Pod-Parser-1.600.0)

Total: 56 packages (43 upgrades, 12 new, 1 in new slot, 5 uninstalls), Size of downloads: 181,076 kB
Conflict: 6 blocks (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.16.3::gentoo, installed) pulled in by
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-Daemon-0.480.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/PlRPC-0.202.0-r2::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-SSLeay-1.550::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/DelimMatch-1.06-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Cookies-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Test-Harness-3.260.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Negotiate-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/MIME-Types-2.020.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/DBI-1.623.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-vcs/git-1.8.5.5::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/IO-Socket-SSL-1.953.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/TimeDate-2.300.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Crypt-SSLeay-0.640.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Digest-SHA-5.820.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Mail-DKIM-0.400.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-HTTP-6.60.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/NetAddr-IP-4.72.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Error-0.170.210::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/libwww-perl-6.50.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/WWW-RobotRules-6.20.0::gentoo, installed)

  (dev-lang/perl-5.18.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.18* required by (virtual/perl-ExtUtils-CBuilder-0.280.210-r1::gentoo, ebuild scheduled for merge)
    (and 20 more with the same problem)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (perl-core/Pod-Parser-1.510.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/Pod-Parser required by @selected

  (virtual/perl-Pod-Parser-1.600.0::gentoo, ebuild scheduled for merge) pulled in by
    >=virtual/perl-Pod-Parser-1.510.0-r2 required by (mail-filter/spamassassin-3.4.0::gentoo, ebuild scheduled for merge)
    =virtual/perl-Pod-Parser-1.600.0 required by (mail-filter/spamassassin-3.4.0::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by app-portage/layman-2.1.0-r2
# required by @selected
# required by @world (argument)
=dev-python/ssl-fetch-0.2.1 ~amd64
# required by dev-python/ssl-fetch-0.2.1[python_targets_python2_7]
# required by app-portage/layman-2.1.0-r2
# required by @selected
# required by @world (argument)
=dev-python/ndg-httpsclient-0.3.2 ~amd64

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.


Do I just --oneshot it and then hope perl-cleaner solves it all?

Thanks in advance!
_________________
"Hello and goodbye. As always." | You can't use &nbsp; here?? | Unanswered
Back to top
View user's profile Send private message
RazielFMX
l33t
l33t


Joined: 23 Apr 2005
Posts: 835
Location: NY, USA

PostPosted: Mon Aug 18, 2014 1:03 pm    Post subject: Reply with quote

See this thread:

https://forums.gentoo.org/viewtopic-t-996578-highlight-.html
Back to top
View user's profile Send private message
Sulman
n00b
n00b


Joined: 15 Feb 2014
Posts: 63

PostPosted: Mon Aug 18, 2014 1:09 pm    Post subject: Reply with quote

I'm always puzzled by these, and I seem to see the Perl ones quite a lot. I'm wary of masking packages as I don't fully understand the ramifications of it.

I once broke Perl big time by unmerge and remerging it; took me a day to fix.
Back to top
View user's profile Send private message
Horatio
Apprentice
Apprentice


Joined: 25 Feb 2004
Posts: 246
Location: Houston, TX

PostPosted: Tue Aug 19, 2014 5:52 am    Post subject: Reply with quote

I think I just wrestled with this in https://forums.gentoo.org/viewtopic-t-998010-highlight-.html See my third update
Quote:
I'm now running the following modified output from a "perl-cleaner --allmodules" which I basically removed all the virtual types of the blocks shown. I'm not sure why a virtual would be pulled in just to be blocked, but what ever. This is going through and updating all the modules for perl 5.18.2 from 5.16.3
and the code block of my modified emerge from the output of perl-cleaner. At least these are the version numbers I was moving from and to.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum