Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Perl Clean Fails required by other packages git ffmpeg [SOLV
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Horatio
Apprentice
Apprentice


Joined: 25 Feb 2004
Posts: 246
Location: Houston, TX

PostPosted: Sun Aug 17, 2014 7:07 pm    Post subject: Perl Clean Fails required by other packages git ffmpeg [SOLV Reply with quote

So I started out trying to do a deep update to fix Amarok which is not playing wma files. This failed at git. So I disabled building the documentation as suggested here https://forums.gentoo.org/viewtopic-p-6546887.html?sid=f653a5c413610cce9fb5ffeb9108848a

But then the deep, New use build on Amarok failed at building ffmpeg

Code:

make: *** [doc/ffmpeg.html] Error 2
make: *** Waiting for unfinished jobs....
Can't locate Text/Unidecode.pm in @INC (you may need to install the Text::Unidecode module) (@INC contains: /usr/share/texi2html/lib/Unicode-EastAsianWidth/lib /usr/share/texi2html/lib/libintl-perl/lib /etc/perl /usr/local/lib64/perl5/5.18.2/x86_64-linux /usr/local/lib64/perl5/5.18.2 /usr/lib64/perl5/vendor_perl/5.18.2/x86_64-linux /usr/lib64/perl5/vendor_perl/5.18.2 /usr/local/lib64/perl5 /usr/lib64/perl5/vendor_perl /usr/lib64/perl5/5.18.2/x86_64-linux /usr/lib64/perl5/5.18.2 .) at /usr/bin/texi2html line 31679.
make: *** [doc/ffplay.html] Error 2
Can't locate Text/Unidecode.pm in @INC (you may need to install the Text::Unidecode module) (@INC contains: /usr/share/texi2html/lib/Unicode-EastAsianWidth/lib /usr/share/texi2html/lib/libintl-perl/lib /etc/perl /usr/local/lib64/perl5/5.18.2/x86_64-linux /usr/local/lib64/perl5/5.18.2 /usr/lib64/perl5/vendor_perl/5.18.2/x86_64-linux /usr/lib64/perl5/vendor_perl/5.18.2 /usr/local/lib64/perl5 /usr/lib64/perl5/vendor_perl /usr/lib64/perl5/5.18.2/x86_64-linux /usr/lib64/perl5/5.18.2 .) at /usr/bin/texi2html line 31679.
make: *** [doc/ffprobe.html] Error 2
 * ERROR: media-video/ffmpeg-1.2.6-r1::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=media-video/ffmpeg-1.2.6-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-video/ffmpeg-1.2.6-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/media-video/ffmpeg-1.2.6-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-video/ffmpeg-1.2.6-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/media-video/ffmpeg-1.2.6-r1/work/ffmpeg-1.2.6-abi_x86_64.amd64'
 * S: '/var/tmp/portage/media-video/ffmpeg-1.2.6-r1/work/ffmpeg-1.2.6'


Again it looks like an issue with building the documentation using perl.

I tried a perl-cleaner. Although it's confusing me as to what to do about fixing the media-libs/x264 conflict and the blocks.

For example this package seems to be blocking it self O.o
<perl-core/Module-CoreList-3.30.0 ("<perl-core/Module-CoreList-3.30.0" is blocking virtual/perl-Module-CoreList-3.30.0)

I'm not even sure how to report this, if this is a bug. It's probably the way I have my use set up. But I'm not sure.
Code:

# perl-cleaner --modules

 * Locating packages for an update
 *   Adding to list: app-text/po4a:0
 *   Adding to list: dev-perl/Unicode-Map:0
 *   Adding to list: dev-perl/Digest-Perl-MD5:0
 *   Adding to list: dev-perl/File-DesktopEntry:0
 *   Adding to list: dev-perl/DBD-mysql:0
 *   Adding to list: dev-perl/DateTime-Locale:0
 *   Adding to list: dev-perl/DateTime-Format-Builder:0
 *   Adding to list: dev-perl/Crypt-RC4:0
 *   Adding to list: dev-perl/LWP-MediaTypes:0
 *   Adding to list: dev-perl/TermReadKey:0
 *   Adding to list: dev-perl/Locale-gettext:0
 *   Adding to list: dev-perl/Net-SMTP-SSL:0
 *   Adding to list: dev-perl/HTML-Tagset:0
 *   Adding to list: dev-perl/Spreadsheet-ParseExcel:0
 *   Adding to list: dev-perl/List-MoreUtils:0
 *   Adding to list: dev-perl/OLE-StorageLite:0
 *   Adding to list: dev-perl/Module-Implementation:0
 *   Adding to list: dev-perl/Params-Util:0
 *   Adding to list: dev-perl/HTTP-Message:0
 *   Adding to list: dev-perl/HTML-Parser:0
 *   Adding to list: dev-perl/XML-NamespaceSupport:0
 *   Adding to list: dev-perl/LWP-Protocol-https:0
 *   Adding to list: dev-perl/HTTP-Daemon:0
 *   Adding to list: dev-perl/JSON:0
 *   Adding to list: dev-perl/HTTP-Date:0
 *   Adding to list: dev-perl/Package-DeprecationManager:0
 *   Adding to list: dev-perl/XML-LibXML:0
 *   Adding to list: dev-perl/Digest-HMAC:0
 *   Adding to list: dev-perl/HTML-Tree:0
 *   Adding to list: dev-perl/File-Listing:0
 *   Adding to list: dev-perl/File-MimeInfo:0
 *   Adding to list: dev-perl/GSSAPI:0
 *   Adding to list: dev-perl/Params-Validate:0
 *   Adding to list: dev-perl/Class-Factory-Util:0
 *   Adding to list: dev-perl/Sub-Install:0
 *   Adding to list: dev-perl/SGMLSpm:0
 *   Adding to list: dev-perl/Class-Load:0
 *   Adding to list: dev-perl/Dist-CheckConflicts:0
 *   Adding to list: dev-perl/Module-Runtime:0
 *   Adding to list: dev-perl/Encode-Locale:0
 *   Adding to list: dev-perl/Authen-SASL:0
 *   Adding to list: dev-perl/IO-stringy:0
 *   Adding to list: dev-perl/libintl-perl:0
 *   Adding to list: dev-perl/Text-Unidecode:0
 *   Adding to list: dev-perl/File-BaseDir:0
 *   Adding to list: dev-perl/Class-Singleton:0
 *   Adding to list: dev-perl/DateTime-Format-ISO8601:0
 *   Adding to list: dev-perl/XML-SAX-Base:0
 *   Adding to list: dev-perl/Unicode-EastAsianWidth:0
 *   Adding to list: dev-perl/Data-OptList:0
 *   Adding to list: dev-perl/Text-WrapI18N:0
 *   Adding to list: dev-perl/DateTime-Format-Strptime:0
 *   Adding to list: dev-perl/XML-SAX:0
 *   Adding to list: dev-perl/Text-CharWidth:0
 *   Adding to list: perl-core/CPAN-Meta-Requirements:0
 *                   virtual/perl-CPAN-Meta-Requirements:0
 *   Adding to list: perl-core/Scalar-List-Utils:0
 *                   virtual/perl-Scalar-List-Utils:0
 *   Adding to list: perl-core/Module-CoreList:0
 *                   virtual/perl-Module-CoreList:0
 *   Adding to list: perl-core/ExtUtils-CBuilder:0
 *                   virtual/perl-ExtUtils-CBuilder:0
 *   Adding to list: perl-core/File-Spec:0
 *                   virtual/perl-File-Spec:0
 *   Adding to list: perl-core/Params-Check:0
 *                   virtual/perl-Params-Check:0
 *   Adding to list: perl-core/Pod-Simple:0
 *   Adding to list: perl-core/Parse-CPAN-Meta:0
 *                   virtual/perl-Parse-CPAN-Meta:0
 *   Adding to list: perl-core/ExtUtils-Manifest:0
 *                   virtual/perl-ExtUtils-Manifest:0
 *   Adding to list: perl-core/Archive-Tar:0
 *                   virtual/perl-Archive-Tar:0
 *   Adding to list: perl-core/IO-Compress:0
 *                   virtual/perl-IO-Compress:0
 *   Adding to list: perl-core/ExtUtils-Install:0
 *                   virtual/perl-ExtUtils-Install:0
 *   Adding to list: perl-core/Digest-MD5:0
 *                   virtual/perl-Digest-MD5:0
 *   Adding to list: perl-core/Module-Metadata:0
 *                   virtual/perl-Module-Metadata:0
 *   Adding to list: perl-core/Module-Load:0
 *                   virtual/perl-Module-Load:0
 *   Adding to list: perl-core/Sys-Syslog:0
 *                   virtual/perl-Sys-Syslog:0
 *   Adding to list: perl-core/Compress-Raw-Zlib:0
 *                   virtual/perl-Compress-Raw-Zlib:0
 *   Adding to list: perl-core/CPAN-Meta-YAML:0
 *                   virtual/perl-CPAN-Meta-YAML:0
 *   Adding to list: perl-core/Module-Build:0
 *                   virtual/perl-Module-Build:0
 *   Adding to list: perl-core/CPAN-Meta:0
 *                   virtual/perl-CPAN-Meta:0
 *   Adding to list: perl-core/IPC-Cmd:0
 *                   virtual/perl-IPC-Cmd:0
 *   Adding to list: perl-core/ExtUtils-ParseXS:0
 *                   virtual/perl-ExtUtils-ParseXS:0
 *   Adding to list: perl-core/Compress-Raw-Bzip2:0
 *                   virtual/perl-Compress-Raw-Bzip2:0
 *   Adding to list: perl-core/Time-Local:0
 *                   virtual/perl-Time-Local:0
 *   Adding to list: perl-core/version:0
 *                   virtual/perl-version:0
 *   Adding to list: perl-core/Module-Load-Conditional:0
 *                   virtual/perl-Module-Load-Conditional:0
 *   Adding to list: perl-core/Test-Harness:0
 *                   virtual/perl-Test-Harness:0
 * emerge -vD1 --backtrack=30 app-text/po4a:0 dev-perl/Unicode-Map:0 dev-perl/Digest-Perl-MD5:0 dev-perl/File-DesktopEntry:0 dev-perl/DBD-mysql:0 dev-perl/DateTime-Locale:0 dev-perl/DateTime-Format-Builder:0 dev-perl/Crypt-RC4:0 dev-perl/LWP-MediaTypes:0 dev-perl/TermReadKey:0 dev-perl/Locale-gettext:0 dev-perl/Net-SMTP-SSL:0 dev-perl/HTML-Tagset:0 dev-perl/Spreadsheet-ParseExcel:0 dev-perl/List-MoreUtils:0 dev-perl/OLE-StorageLite:0 dev-perl/Module-Implementation:0 dev-perl/Params-Util:0 dev-perl/HTTP-Message:0 dev-perl/HTML-Parser:0 dev-perl/XML-NamespaceSupport:0 dev-perl/LWP-Protocol-https:0 dev-perl/HTTP-Daemon:0 dev-perl/JSON:0 dev-perl/HTTP-Date:0 dev-perl/Package-DeprecationManager:0 dev-perl/XML-LibXML:0 dev-perl/Digest-HMAC:0 dev-perl/HTML-Tree:0 dev-perl/File-Listing:0 dev-perl/File-MimeInfo:0 dev-perl/GSSAPI:0 dev-perl/Params-Validate:0 dev-perl/Class-Factory-Util:0 dev-perl/Sub-Install:0 dev-perl/SGMLSpm:0 dev-perl/Class-Load:0 dev-perl/Dist-CheckConflicts:0 dev-perl/Module-Runtime:0 dev-perl/Encode-Locale:0 dev-perl/Authen-SASL:0 dev-perl/IO-stringy:0 dev-perl/libintl-perl:0 dev-perl/Text-Unidecode:0 dev-perl/File-BaseDir:0 dev-perl/Class-Singleton:0 dev-perl/DateTime-Format-ISO8601:0 dev-perl/XML-SAX-Base:0 dev-perl/Unicode-EastAsianWidth:0 dev-perl/Data-OptList:0 dev-perl/Text-WrapI18N:0 dev-perl/DateTime-Format-Strptime:0 dev-perl/XML-SAX:0 dev-perl/Text-CharWidth:0 perl-core/CPAN-Meta-Requirements:0 virtual/perl-CPAN-Meta-Requirements:0 perl-core/Scalar-List-Utils:0 virtual/perl-Scalar-List-Utils:0 perl-core/Module-CoreList:0 virtual/perl-Module-CoreList:0 perl-core/ExtUtils-CBuilder:0 virtual/perl-ExtUtils-CBuilder:0 perl-core/File-Spec:0 virtual/perl-File-Spec:0 perl-core/Params-Check:0 virtual/perl-Params-Check:0 perl-core/Pod-Simple:0 perl-core/Parse-CPAN-Meta:0 virtual/perl-Parse-CPAN-Meta:0 perl-core/ExtUtils-Manifest:0 virtual/perl-ExtUtils-Manifest:0 perl-core/Archive-Tar:0 virtual/perl-Archive-Tar:0 perl-core/IO-Compress:0 virtual/perl-IO-Compress:0 perl-core/ExtUtils-Install:0 virtual/perl-ExtUtils-Install:0 perl-core/Digest-MD5:0 virtual/perl-Digest-MD5:0 perl-core/Module-Metadata:0 virtual/perl-Module-Metadata:0 perl-core/Module-Load:0 virtual/perl-Module-Load:0 perl-core/Sys-Syslog:0 virtual/perl-Sys-Syslog:0 perl-core/Compress-Raw-Zlib:0 virtual/perl-Compress-Raw-Zlib:0 perl-core/CPAN-Meta-YAML:0 virtual/perl-CPAN-Meta-YAML:0 perl-core/Module-Build:0 virtual/perl-Module-Build:0 perl-core/CPAN-Meta:0 virtual/perl-CPAN-Meta:0 perl-core/IPC-Cmd:0 virtual/perl-IPC-Cmd:0 perl-core/ExtUtils-ParseXS:0 virtual/perl-ExtUtils-ParseXS:0 perl-core/Compress-Raw-Bzip2:0 virtual/perl-Compress-Raw-Bzip2:0 perl-core/Time-Local:0 virtual/perl-Time-Local:0 perl-core/version:0 virtual/perl-version:0 perl-core/Module-Load-Conditional:0 virtual/perl-Module-Load-Conditional:0 perl-core/Test-Harness:0 virtual/perl-Test-Harness:0

 * IMPORTANT: 10 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


 * IMPORTANT: 3 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     UD ] media-libs/x264-0.0.20111220:0/0 [0.0.20140308:0/142] USE="interlaced threads -10bit -custom-cflags% -debug% -pic -static-libs (-opencl%) (-sse%*)" ABI_X86="(-32%) (-64%*) (-x32%)" 0 kB
[ebuild   R    ] virtual/perl-Scalar-List-Utils-1.270.0-r2  0 kB
[ebuild   R    ] virtual/perl-File-Spec-3.400.0-r2  0 kB
[ebuild   R    ] virtual/perl-IO-Compress-2.60.0-r1  0 kB
[ebuild   R    ] dev-perl/LWP-MediaTypes-6.20.0  0 kB
[ebuild   R    ] dev-perl/List-MoreUtils-0.330.0  0 kB
[ebuild   R    ] dev-perl/Sub-Install-0.926.0  USE="{-test}" 0 kB
[ebuild   R    ] virtual/perl-Compress-Raw-Zlib-2.60.0-r2  0 kB
[ebuild   R    ] dev-perl/HTML-Tagset-3.200.0  0 kB
[ebuild   R    ] dev-perl/Encode-Locale-1.30.0  0 kB
[ebuild   R    ] virtual/perl-Digest-MD5-2.520.0-r2  0 kB
[ebuild   R    ] virtual/perl-Time-Local-1.230.0-r1  0 kB
[ebuild   R    ] dev-perl/JSON-2.590.0  0 kB
[ebuild   R    ] dev-perl/Class-Singleton-1.400.0  0 kB
[ebuild   R    ] virtual/perl-Sys-Syslog-0.320.0-r2  0 kB
[ebuild   R    ] virtual/perl-Module-Build-0.400.300-r1  0 kB
[ebuild     U  ] virtual/perl-version-0.990.200-r1 [0.990.100] 0 kB
[ebuild     U  ] virtual/perl-CPAN-Meta-YAML-0.8.0-r2 [0.8.0] 0 kB
[ebuild   R    ] dev-perl/XML-NamespaceSupport-1.110.0  0 kB
[ebuild     U  ] virtual/perl-ExtUtils-CBuilder-0.280.210-r1 [0.280.205] 0 kB
[ebuild     U  ] virtual/perl-Params-Check-0.360.0-r1 [0.360.0] 0 kB
[ebuild     U  ] virtual/perl-Parse-CPAN-Meta-1.440.400-r1 [1.440.400] 0 kB
[ebuild     U  ] virtual/perl-Module-Metadata-1.0.11-r1 [1.0.11] 0 kB
[ebuild   R    ] dev-perl/Unicode-Map-0.112.0  0 kB
[ebuild   R    ] dev-perl/Digest-Perl-MD5-1.800.0  0 kB
[ebuild   R    ] dev-perl/Crypt-RC4-2.020.0  0 kB
[ebuild   R    ] dev-perl/TermReadKey-2.300.200  37 kB
[ebuild   R    ] dev-perl/OLE-StorageLite-0.190.0  0 kB
[ebuild   R    ] dev-perl/SGMLSpm-1.03-r7  92 kB
[ebuild   R    ] dev-perl/IO-stringy-2.110.0  0 kB
[ebuild   R    ] dev-perl/XML-SAX-Base-1.80.0  0 kB
[ebuild   R    ] dev-perl/Text-CharWidth-0.40.0  9 kB
[ebuild     U  ] virtual/perl-CPAN-Meta-Requirements-2.122.0-r2 [2.122.0] 0 kB
[ebuild     U  ] virtual/perl-Module-CoreList-3.30.0 [2.840.0] 0 kB
[ebuild     U  ] virtual/perl-Archive-Tar-1.900.0-r2 [1.900.0] 0 kB
[ebuild     U  ] virtual/perl-Module-Load-0.240.0-r1 [0.240.0] 0 kB
[ebuild     U  ] virtual/perl-CPAN-Meta-2.120.921-r2 [2.120.921] 0 kB
[ebuild     U  ] virtual/perl-IPC-Cmd-0.800.0-r1 [0.780.0] 0 kB
[ebuild     U  ] virtual/perl-ExtUtils-ParseXS-3.180.0-r2 [3.180.0] 0 kB
[ebuild     U  ] virtual/perl-Compress-Raw-Bzip2-2.60.0-r2 [2.60.0] 0 kB
[ebuild     U  ] virtual/perl-Module-Load-Conditional-0.540.0-r1 [0.540.0] 0 kB
[ebuild   R    ] virtual/perl-Test-Harness-3.260.0-r2  0 kB
[ebuild  N     ] perl-core/Perl-OSType-1.2.0-r1  USE="{-test}" 12 kB
[ebuild  N     ] perl-core/File-Temp-0.220.0-r1  38 kB
[ebuild  N     ] perl-core/Locale-Maketext-Simple-0.210.0-r1  10 kB
[ebuild  N     ] perl-core/Pod-Escapes-1.40.0-r1  10 kB
[ebuild  N     ] perl-core/JSON-PP-2.272.0-r1  41 kB
[ebuild  N     ] perl-core/Package-Constants-0.20.0-r1  3 kB
[ebuild   R    ] dev-perl/libintl-perl-1.200.0  0 kB
[ebuild   R    ] dev-perl/Text-Unidecode-0.40.0  0 kB
[ebuild   R    ] perl-core/Scalar-List-Utils-1.270.0  68 kB
[ebuild   R    ] perl-core/Module-CoreList-2.840.0  59 kB
[ebuild   R    ] perl-core/File-Spec-3.400.0  137 kB
[ebuild     U  ] perl-core/ExtUtils-Manifest-1.610.0-r1 [1.610.0] 29 kB
[ebuild     U  ] virtual/perl-ExtUtils-Manifest-1.630.0-r1 [1.610.0] 0 kB
[ebuild     U  ] perl-core/ExtUtils-Install-1.540.0-r1 [1.540.0] 66 kB
[ebuild     U  ] virtual/perl-ExtUtils-Install-1.590.0-r1 [1.540.0] 0 kB
[ebuild   R    ] perl-core/Module-Load-0.240.0  6 kB
[ebuild     U  ] perl-core/Sys-Syslog-0.320.0-r1 [0.320.0] 0 kB
[ebuild   R    ] perl-core/Compress-Raw-Zlib-2.60.0  231 kB
[ebuild     U  ] perl-core/CPAN-Meta-YAML-0.8.0-r1 [0.8.0] 31 kB
[ebuild   R    ] perl-core/Compress-Raw-Bzip2-2.60.0  133 kB
[ebuild     U  ] perl-core/Time-Local-1.230.0-r1 [1.230.0] 0 kB
[ebuild     U  ] perl-core/version-0.990.100-r1 [0.990.100] 105 kB
[ebuild   R    ] perl-core/Test-Harness-3.260.0  288 kB
[ebuild   R    ] dev-perl/HTTP-Date-6.20.0  0 kB
[ebuild   R    ] dev-perl/Params-Util-1.60.0  0 kB
[ebuild   R    ] dev-perl/HTML-Parser-3.710.0  USE="{-test}" 0 kB
[ebuild   R    ] dev-perl/Module-Runtime-0.13.0  USE="{-test}" 0 kB
[ebuild   R    ] dev-perl/File-BaseDir-0.30.0  USE="{-test}" 0 kB
[ebuild   R    ] dev-perl/Class-Factory-Util-1.700.0  0 kB
[ebuild   R    ] dev-perl/Text-WrapI18N-0.60.0  4 kB
[ebuild  N     ] perl-core/IO-Zlib-1.100.0  10 kB
[ebuild  N     ] perl-core/Digest-1.170.0-r1  9 kB
[ebuild   R    ] dev-perl/Spreadsheet-ParseExcel-0.590.0  USE="unicode -cjk {-test}" 0 kB
[ebuild   R    ] dev-perl/Unicode-EastAsianWidth-1.330.0  0 kB
[ebuild     U  ] perl-core/CPAN-Meta-Requirements-2.122.0-r1 [2.122.0] 21 kB
[ebuild   R    ] perl-core/IO-Compress-2.60.0  238 kB
[ebuild     U  ] perl-core/Module-Metadata-1.0.11-r1 [1.0.11] 27 kB
[ebuild     U  ] perl-core/ExtUtils-ParseXS-3.180.0-r1 [3.180.0] 62 kB
[ebuild   R    ] dev-perl/HTTP-Message-6.30.0  0 kB
[ebuild   R    ] dev-perl/Module-Implementation-0.60.0  USE="{-test}" 0 kB
[ebuild   R    ] dev-perl/Data-OptList-0.108.0  USE="{-test}" 0 kB
[ebuild   R    ] dev-perl/File-DesktopEntry-0.40.0  USE="{-test}" 0 kB
[ebuild   R    ] dev-perl/Package-DeprecationManager-0.130.0  USE="{-test}" 0 kB
[ebuild   R    ] dev-perl/Digest-HMAC-1.30.0  0 kB
[ebuild   R    ] dev-perl/HTML-Tree-4.200.0  0 kB
[ebuild   R    ] dev-perl/File-Listing-6.40.0  0 kB
[ebuild     U  ] perl-core/ExtUtils-CBuilder-0.280.205-r1 [0.280.205] 34 kB
[ebuild     U  ] perl-core/Params-Check-0.360.0-r1 [0.360.0] 12 kB
[ebuild     U  ] perl-core/Pod-Simple-3.230.0-r1 [3.230.0] 0 kB
[ebuild     U  ] perl-core/Parse-CPAN-Meta-1.440.400-r1 [1.440.400] 8 kB
[ebuild     U  ] perl-core/Module-Build-0.400.300-r1 [0.400.300] USE="{-test}" 301 kB
[ebuild     U  ] perl-core/CPAN-Meta-2.120.921-r1 [2.120.921] 75 kB
[ebuild     U  ] perl-core/IPC-Cmd-0.780.0-r1 [0.780.0] 27 kB
[ebuild   R    ] perl-core/Module-Load-Conditional-0.540.0  13 kB
[ebuild   R    ] dev-perl/Params-Validate-1.70.0  USE="{-test}" 0 kB
[ebuild   R    ] dev-perl/HTTP-Daemon-6.10.0  0 kB
[ebuild     U  ] perl-core/Archive-Tar-1.900.0-r1 [1.900.0] 57 kB
[ebuild     U  ] perl-core/Digest-MD5-2.520.0-r1 [2.520.0] 0 kB
[ebuild   R    ] dev-perl/DateTime-Locale-0.450.0  0 kB
[ebuild   R    ] dev-perl/Dist-CheckConflicts-0.20.0  USE="{-test}" 0 kB
[ebuild   R    ] dev-perl/Class-Load-0.200.0  USE="{-test}" 0 kB
[ebuild   R    ] dev-perl/DateTime-Format-Strptime-1.540.0  0 kB
[ebuild   R    ] dev-perl/DateTime-Format-Builder-0.810.0  USE="{-test}" 0 kB
[ebuild   R    ] dev-perl/DateTime-Format-ISO8601-0.80.0  USE="{-test}" 0 kB
[ebuild   R    ] dev-perl/GSSAPI-0.280.0  USE="{-test}" 0 kB
[ebuild   R    ] dev-perl/Net-SMTP-SSL-1.10.0  0 kB
[ebuild   R    ] dev-perl/LWP-Protocol-https-6.30.0  0 kB
[ebuild   R    ] dev-perl/Authen-SASL-2.160.0  USE="kerberos" 0 kB
[ebuild   R    ] dev-perl/XML-SAX-0.990.0  0 kB
[ebuild   R    ] dev-perl/File-MimeInfo-0.170.0  USE="{-test}" 0 kB
[ebuild   R    ] dev-perl/XML-LibXML-2.1.400  USE="{-test}" 0 kB
[ebuild   R    ] dev-perl/DBD-mysql-4.20.0  USE="-embedded" 0 kB
[ebuild   R    ] dev-perl/Locale-gettext-1.50.0  8 kB
[ebuild   R    ] app-text/po4a-0.42  USE="{-test}" 1,957 kB
[blocks B      ] <perl-core/Module-CoreList-3.30.0 ("<perl-core/Module-CoreList-3.30.0" is blocking virtual/perl-Module-CoreList-3.30.0)
[blocks B      ] <perl-core/ExtUtils-Install-1.590.0 ("<perl-core/ExtUtils-Install-1.590.0" is blocking virtual/perl-ExtUtils-Install-1.590.0-r1)
[blocks B      ] <perl-core/ExtUtils-CBuilder-0.280.210 ("<perl-core/ExtUtils-CBuilder-0.280.210" is blocking virtual/perl-ExtUtils-CBuilder-0.280.210-r1)
[blocks B      ] <perl-core/IPC-Cmd-0.800.0 ("<perl-core/IPC-Cmd-0.800.0" is blocking virtual/perl-IPC-Cmd-0.800.0-r1)
[blocks B      ] <perl-core/ExtUtils-Manifest-1.630.0 ("<perl-core/ExtUtils-Manifest-1.630.0" is blocking virtual/perl-ExtUtils-Manifest-1.630.0-r1)
[blocks B      ] <perl-core/version-0.990.200 ("<perl-core/version-0.990.200" is blocking virtual/perl-version-0.990.200-r1)

Total: 116 packages (35 upgrades, 1 downgrade, 8 new, 72 reinstalls), Size of downloads: 4,250 kB
Conflict: 6 blocks (6 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

media-libs/x264:0

  (media-libs/x264-0.0.20111220::gentoo, ebuild scheduled for merge) pulled in by
    >=media-libs/x264-0.0.20090923:0/0= required by (media-video/vlc-2.1.2::gentoo, installed)

  (media-libs/x264-0.0.20140308::gentoo, installed) pulled in by
    >=media-libs/x264-0.0.20130506:=[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?] required by (media-plugins/gst-plugins-x264-0.10.19-r1::gentoo, installed)
    (and 1 more with the same problem)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (virtual/perl-ExtUtils-Manifest-1.630.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    virtual/perl-ExtUtils-Manifest:0

  (perl-core/Module-CoreList-2.840.0::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/Module-CoreList:0

  (perl-core/IPC-Cmd-0.780.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/IPC-Cmd:0

  (perl-core/ExtUtils-Install-1.540.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/ExtUtils-Install:0

  (perl-core/version-0.990.100-r1::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/version:0

  (virtual/perl-IPC-Cmd-0.800.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    virtual/perl-IPC-Cmd:0
    virtual/perl-IPC-Cmd required by (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild scheduled for merge)
    =virtual/perl-IPC-Cmd-0.800.0-r1 required by (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild scheduled for merge)

  (virtual/perl-ExtUtils-CBuilder-0.280.210-r1::gentoo, ebuild scheduled for merge) pulled in by
    =virtual/perl-ExtUtils-CBuilder-0.280.210-r1 required by (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for merge)
    virtual/perl-ExtUtils-CBuilder:0
    virtual/perl-ExtUtils-CBuilder required by (perl-core/ExtUtils-ParseXS-3.180.0-r1::gentoo, ebuild scheduled for merge)
    >=virtual/perl-ExtUtils-CBuilder-0.27 required by (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for merge)
    =virtual/perl-ExtUtils-CBuilder-0.280.210-r1 required by (perl-core/ExtUtils-ParseXS-3.180.0-r1::gentoo, ebuild scheduled for merge)

  (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/ExtUtils-CBuilder:0

  (virtual/perl-ExtUtils-Install-1.590.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    virtual/perl-ExtUtils-Install:0

  (virtual/perl-version-0.990.200-r1::gentoo, ebuild scheduled for merge) pulled in by
    =virtual/perl-version-0.990.200-r1 required by (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for merge)
    >=virtual/perl-version-0.870 required by (perl-core/Module-Metadata-1.0.11-r1::gentoo, ebuild scheduled for merge)
    =virtual/perl-version-0.990.200-r1 required by (perl-core/Module-Metadata-1.0.11-r1::gentoo, ebuild scheduled for merge)
    =virtual/perl-version-0.990.200-r1 required by (perl-core/CPAN-Meta-Requirements-2.122.0-r1::gentoo, ebuild scheduled for merge)
    virtual/perl-version:0
    >=virtual/perl-version-0.77 required by (perl-core/CPAN-Meta-Requirements-2.122.0-r1::gentoo, ebuild scheduled for merge)
    =virtual/perl-version-0.990.200-r1 required by (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild scheduled for merge)
    >=virtual/perl-version-0.82 required by (perl-core/CPAN-Meta-2.120.921-r1::gentoo, ebuild scheduled for merge)
    >=virtual/perl-version-0.87 required by (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for merge)
    =virtual/perl-version-0.990.200-r1 required by (perl-core/Module-Build-0.400.300-r1::gentoo, ebuild scheduled for merge)
    virtual/perl-version required by (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild scheduled for merge)

  (virtual/perl-Module-CoreList-3.30.0::gentoo, ebuild scheduled for merge) pulled in by
    >=virtual/perl-Module-CoreList-0.22 required by (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild scheduled for merge)
    =virtual/perl-Module-CoreList-3.30.0 required by (perl-core/Module-Load-Conditional-0.540.0::gentoo, ebuild scheduled for merge)
    virtual/perl-Module-CoreList:0

  (perl-core/ExtUtils-Manifest-1.610.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/ExtUtils-Manifest:0


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

 * perl-cleaner is stopping here:
 * Fix the problem and start perl-cleaner again.
 *
 * If you encounter blockers involving virtuals and perl-core, here are
 * some things to try:
 *   Remove all perl-core packages from your world file
 *     emerge --deselect --ask $(qlist -IC 'perl-core/*')
 *   Update all the installed Perl virtuals
 *     emerge -uD1a $(qlist -IC 'virtual/perl-*')
 *   Afterwards re-run perl-cleaner
 *
 * Note that upgrading Perl with emerge option --ignore-built-slot-operator-deps=y is not supported.



Code:

# cat make.conf
# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-march=barcelona -O2 -pipe"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j4"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.
USE="bindist mmx sse sse2 \
3dnow 3dnowext \
a52 aac acpi aim alsa apm \
bash-completion bluetooth bzip2 \
cdb cdda cddb cdparanoia cdr crypt css cups \
dbus dvb dvd dvdr \
encode examples \
ffmpeg flac fontconfig ftp \
gif gimp git glut gnuplot gnutls gphoto2 gpm graphviz gsm gzip \
handbook hardened iconv icq icu ieee1394 imagemagick imap imlib inotify ipod \
jabber javascript jingle jit joystick jpeg jpeg2k kde kerberos kolab kontact \
lame latex libcaca libnotify libwww lirc lm_sensors lua lzma lzo \
mad maildir mbox memlimit mhash mime mms mmx mmxext mng modplug mozilla mp3 mp4 mpeg mplayer msn mtp multilib musepack musicbrainz mysql mysqli \
nas nsplugin \
offensive ofx ogg openal openexr opengl oscar \
pdf plasma plotutils png posix postscript ppds pulseaudio \
qt4 qt5 quicktime \
radius raw rdesktop readline rss ruby \
samba scanner sdl semantic-desktop session sharedmem shorten simplexml skey slp smp sndfile snmp soap sockets socks5 sound sox speex spell sqlite sqlite3 ssl svg syslog \
taglib tcpd theora threads tidy tiff tokenizer truetype \
unicode usb \
v4l vcd videos vnc vorbis \
wavpack wifi wmf \
x264 xattr xcomposite xine xinerama xinetd xmpp xosd xpm xscreensaver xv xvid \
yahoo zlib zsh-completion \
 \
vim-syntax"
INPUT_DEVICES="evdev keyboard mouse joystick vmmouse wacom"
VIDEO_CARDS="dummy fbdev glint intel  nv radeon v4l vesa vmware nvidia virtualbox"

PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"


Code:

# cat package.use
# Circular Dependancies - These can be commented out onces they are resolved
net-misc/curl -idn   
app-text/xmlto -latex
#app-text/texlive  doc extra png truetype cjk context epspdf games graphics humanities metapost music pstricks publishers science tex4ht texi2html xetex

# Compile Failed
media-libs/libtheora -examples

# Emerge Requests
=media-libs/mesa-10.0.4 gbm xa
=x11-libs/libdrm-2.4.52 libkms

# Specific Package Flags
app-text/texlive extra
dev-vcs/git -doc mediawiki
net-misc/curl ssh
media-sound/lame mp3rtp
app-editors/vim cscope perl python vim-pager
media-video/ffmpeg schroedinger
media-libs/libquicktime schroedinger
media-video/vlc schroedinger
app-misc/strigi clucene
media-libs/mediastreamer video
x11-base/xorg-server ipv6 nptl suid udev xorg dmx doc uvm
kde-base/kdepim-runtime facebook google
media-libs/phonon gstreamer vlc

# Extras Fonts
media-libs/freetype  bzip2 doc fontforge utils
# media-fonts/dejavu fontforge

# Documentation
kde-base/kdelibs doc
media-video/ffmpeg doc
app-text/texlive doc
media-gfx/gimp doc
app-text/texlive-core doc
dev-texlive/texlive-basic
app-crypt/gnupg doc
net-fs/samba doc
# should be for mysql 5.x branch
virtual/mysql embedded
dev-db/mysql embedded
net-analyzer/wireshark doc doc-pdf -gtk3
media-sound/sox alsa encode ffmpeg flac mad ogg openmp pmg pulseaudio nsdfile wavpack id3tag
app-cdr/k3b dvd encode ffmpeg flac handbook mad mp3 musepack sndfile sox taglib vcd vorbis emovix
mail-client/thunderbird mozdom system-cairo system-icu system-jpeg -system-sqlite



Last edited by Horatio on Mon Aug 18, 2014 5:15 pm; edited 1 time in total
Back to top
View user's profile Send private message
Horatio
Apprentice
Apprentice


Joined: 25 Feb 2004
Posts: 246
Location: Houston, TX

PostPosted: Mon Aug 18, 2014 8:01 am    Post subject: Reply with quote

I'm still guessing use flag spaghetti. I've made some changes and this has successfully got past the dependency check, but I'm getting some error on ffmpeg during compilation.


Code:

# emerge -vDN1p --backtrack=30 app-text/po4a:0 dev-perl/Unicode-Map:0 dev-perl/Digest-Perl-MD5:0 dev-perl/File-DesktopEntry:0 dev-perl/DBD-mysql:0 dev-perl/DateTime-Locale:0 dev-perl/DateTime-Format-Builder:0 dev-perl/Crypt-RC4:0 dev-perl/LWP-MediaTypes:0 dev-perl/TermReadKey:0 dev-perl/Locale-gettext:0 dev-perl/Net-SMTP-SSL:0 dev-perl/HTML-Tagset:0 dev-perl/Spreadsheet-ParseExcel:0 dev-perl/List-MoreUtils:0 dev-perl/OLE-StorageLite:0 dev-perl/Module-Implementation:0 dev-perl/Params-Util:0 dev-perl/HTTP-Message:0 dev-perl/HTML-Parser:0 dev-perl/XML-NamespaceSupport:0 dev-perl/LWP-Protocol-https:0 dev-perl/HTTP-Daemon:0 dev-perl/JSON:0 dev-perl/HTTP-Date:0 dev-perl/Package-DeprecationManager:0 dev-perl/XML-LibXML:0 dev-perl/Digest-HMAC:0 dev-perl/HTML-Tree:0 dev-perl/File-Listing:0 dev-perl/File-MimeInfo:0 dev-perl/GSSAPI:0 dev-perl/Params-Validate:0 dev-perl/Class-Factory-Util:0 dev-perl/Sub-Install:0 dev-perl/SGMLSpm:0 dev-perl/Class-Load:0 dev-perl/Dist-CheckConflicts:0 dev-perl/Module-Runtime:0 dev-perl/Encode-Locale:0 dev-perl/Authen-SASL:0 dev-perl/IO-stringy:0 dev-perl/libintl-perl:0 dev-perl/Text-Unidecode:0 dev-perl/File-BaseDir:0 dev-perl/Class-Singleton:0 dev-perl/DateTime-Format-ISO8601:0 dev-perl/XML-SAX-Base:0 dev-perl/Unicode-EastAsianWidth:0 dev-perl/Data-OptList:0 dev-perl/Text-WrapI18N:0 dev-perl/DateTime-Format-Strptime:0 dev-perl/XML-SAX:0 dev-perl/Text-CharWidth:0 perl-core/CPAN-Meta-Requirements:0 virtual/perl-CPAN-Meta-Requirements:0 perl-core/Scalar-List-Utils:0 virtual/perl-Scalar-List-Utils:0 perl-core/Module-CoreList:0 virtual/perl-Module-CoreList:0 perl-core/ExtUtils-CBuilder:0 virtual/perl-ExtUtils-CBuilder:0 perl-core/File-Spec:0 virtual/perl-File-Spec:0 perl-core/Params-Check:0 virtual/perl-Params-Check:0 perl-core/Pod-Simple:0 perl-core/Parse-CPAN-Meta:0 virtual/perl-Parse-CPAN-Meta:0 perl-core/ExtUtils-Manifest:0 virtual/perl-ExtUtils-Manifest:0 perl-core/Archive-Tar:0 virtual/perl-Archive-Tar:0 perl-core/IO-Compress:0 virtual/perl-IO-Compress:0 perl-core/ExtUtils-Install:0 virtual/perl-ExtUtils-Install:0 perl-core/Digest-MD5:0 virtual/perl-Digest-MD5:0 perl-core/Module-Metadata:0 virtual/perl-Module-Metadata:0 perl-core/Module-Load:0 virtual/perl-Module-Load:0 perl-core/Sys-Syslog:0 virtual/perl-Sys-Syslog:0 perl-core/Compress-Raw-Zlib:0 virtual/perl-Compress-Raw-Zlib:0 perl-core/CPAN-Meta-YAML:0 virtual/perl-CPAN-Meta-YAML:0 perl-core/Module-Build:0 virtual/perl-Module-Build:0 perl-core/CPAN-Meta:0 virtual/perl-CPAN-Meta:0 perl-core/IPC-Cmd:0 virtual/perl-IPC-Cmd:0 perl-core/ExtUtils-ParseXS:0 virtual/perl-ExtUtils-ParseXS:0 perl-core/Compress-Raw-Bzip2:0 virtual/perl-Compress-Raw-Bzip2:0 perl-core/Time-Local:0 virtual/perl-Time-Local:0 perl-core/version:0 virtual/perl-version:0 perl-core/Module-Load-Conditional:0 virtual/perl-Module-Load-Conditional:0 perl-core/Test-Harness:0 virtual/perl-Test-Harness:0

 * IMPORTANT: 3 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  rR    ] perl-core/Module-CoreList-2.840.0  59 kB
[ebuild  rR    ] perl-core/Module-Load-0.240.0  6 kB
[ebuild  rR    ] perl-core/Compress-Raw-Bzip2-2.60.0  133 kB
[ebuild  N     ] perl-core/Locale-Maketext-Simple-0.210.0-r1  10 kB
[ebuild  rR    ] dev-perl/SGMLSpm-1.03-r7  92 kB
[ebuild  rR    ] perl-core/Scalar-List-Utils-1.270.0  68 kB
[ebuild  rR    ] perl-core/File-Spec-3.400.0  137 kB
[ebuild  rR    ] perl-core/Compress-Raw-Zlib-2.60.0  231 kB
[ebuild  rR    ] perl-core/Test-Harness-3.260.0  288 kB
[ebuild  N     ] perl-core/Perl-OSType-1.2.0-r1  USE="{-test}" 12 kB
[ebuild  N     ] perl-core/File-Temp-0.220.0-r1  38 kB
[ebuild  N     ] perl-core/Pod-Escapes-1.40.0-r1  10 kB
[ebuild  N     ] perl-core/JSON-PP-2.272.0-r1  41 kB
[ebuild  N     ] perl-core/Package-Constants-0.20.0-r1  3 kB
[ebuild  N     ] perl-core/IO-Zlib-1.100.0  10 kB
[ebuild  N     ] perl-core/Digest-1.170.0-r1  9 kB
[ebuild  rR    ] perl-core/IO-Compress-2.60.0  238 kB
[ebuild  rR    ] perl-core/Module-Load-Conditional-0.540.0  13 kB
[ebuild   R    ] media-libs/libquicktime-1.2.4  USE="X aac alsa encode gtk jpeg mmx opengl png schroedinger vorbis x264 -doc -dv -ffmpeg* -lame* -static-libs" 0 kB
[ebuild     U  ] media-video/ffmpeg-1.2.6-r1 [1.2.6] USE="3dnow 3dnowext X aac alsa bindist bzip2 doc encode examples fontconfig gnutls gsm hardcoded-tables iconv ieee1394 jpeg2k libcaca mmx mmxext modplug mp3 network openal pulseaudio schroedinger sdl speex threads truetype v4l vorbis x264 xvid zlib -aacplus (-altivec) -amr -avx -bluray -cdio (-celt) -cpudetection -debug -faac -fdk -flite -frei0r -iec61883 -jack -libass -libsoxr -libv4l (-neon) -openssl -opus -oss -pic -rtmp -ssse3 -static-libs {-test} -theora* -twolame -vaapi -vdpau (-vis) -vpx" ABI_X86="(64%*) (-32) (-x32)" FFTOOLS="aviocat cws2fws ffescape ffeval fourcc2pixfmt graph2dot ismindex pktdumper qt-faststart trasher" 0 kB
[ebuild   R    ] media-video/mjpegtools-2.1.0-r1:1  USE="gtk mmx png quicktime sdl v4l -dga -dv -sdlgfx -static-libs" 0 kB
[ebuild     U  ] virtual/ffmpeg-9-r1 [0.10.3] USE="X encode gsm jpeg2k mp3 sdl speex threads truetype x264 -opus% -theora* -vaapi -vdpau" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] media-plugins/gst-plugins-mplex-0.10.23-r1:0.10 [0.10.23:0.10] ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] media-plugins/gst-plugins-ffmpeg-0.10.13_p201211-r2:0.10 [0.10.13_p201211-r1:0.10] USE="orc" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] net-libs/libproxy-0.4.11-r2 [0.4.11-r1] USE="kde -gnome -mono -networkmanager -perl -python -spidermonkey {-test} -webkit" ABI_X86="(64%*) (-32) (-x32)" PYTHON_TARGETS="python2_7 (-python2_6%)" 0 kB
[ebuild     U  ] net-libs/glib-networking-2.40.1-r1 [2.38.2] USE="gnome libproxy ssl -smartcard {-test}" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] net-libs/libsoup-2.46.0-r1:2.4 [2.44.2:2.4] USE="introspection samba ssl -debug {-test}" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild  rR    ] media-video/vlc-2.1.2:0/5-7  USE="X a52 alsa avcodec avformat cdda cddb dbus dts dvb dvbpsi dvd encode ffmpeg flac fontconfig gcrypt ieee1394 kde libcaca libnotify lirc lua mmx modplug mp3 mpeg mtp musepack ncurses ogg opengl png postproc pulseaudio qt4 samba schroedinger sdl speex sse svg swscale taglib theora truetype udev v4l vorbis x264 xcb xml xv -aalib (-altivec) -atmo (-audioqueue) -avahi -bidi -bluray -chromaprint -dc1394 -debug -dirac -directfb (-directx) (-dxva2) -egl -faad -fdk -fluidsynth -gme -gnome (-gnutls) -growl -httpd (-ios-vout) -jack -kate -libass -libsamplerate -libtar -libtiger -linsys -live (-macosx) (-macosx-audio) (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-qtkit) (-macosx-quartztext) (-macosx-vout) -matroska (-media-library) (-neon) -omxil -opencv -optimisememory (-opus) -projectm (-qt5) -rdp -rtsp -run-as-root -sdl-image -sftp -shout -sid -skins {-test} -tremor -twolame -upnp -vaapi -vcdx (-vdpau) -vlm -wma-fixed -zvbi" 0 kB
[ebuild     U  ] media-plugins/gst-plugins-soup-0.10.31-r1:0.10 [0.10.31:0.10] ABI_X86="(64%*) (-32) (-x32)" 0 kB

Total: 29 packages (8 upgrades, 8 new, 13 reinstalls), Size of downloads: 1,390 kB

WARNING: One or more updates have been skipped due to a dependency conflict:

media-plugins/gst-plugins-meta:0.10

  (media-plugins/gst-plugins-meta-0.10-r9::gentoo, ebuild scheduled for merge) conflicts with
    media-plugins/gst-plugins-meta:0.10[ffmpeg] required by (www-client/firefox-24.6.0::gentoo, installed)
  (media-plugins/gst-plugins-meta-0.10-r9::gentoo, ebuild scheduled for merge) conflicts with
    media-plugins/gst-plugins-meta:0.10[ffmpeg] required by (mail-client/thunderbird-24.6.0::gentoo, installed)


 * IMPORTANT: 10 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


Code:

cd ./libavresample/ && ln -s -f libavresample.so.1 libavresample.so
cd ./libpostproc/ && ln -s -f libpostproc.so.52 libpostproc.so
awk '/^@(verbatim)?include/ { printf "doc/ffmpeg.html: doc/%s\n", $2 }' </var/tmp/portage/media-video/ffmpeg-1.2.6-r1/work/ffmpeg-1.2.6/doc/ffmpeg.texi >doc/ffmpeg.html.d
texi2html -I doc -monolithic --init-file /var/tmp/portage/media-video/ffmpeg-1.2.6-r1/work/ffmpeg-1.2.6/doc/t2h.init --output doc/ffmpeg.html /var/tmp/portage/media-video/ffmpeg-1.2.6-r1/work/ffmpeg-1.2.6/doc/ffmpeg.texi
awk '/^@(verbatim)?include/ { printf "doc/ffplay.html: doc/%s\n", $2 }' </var/tmp/portage/media-video/ffmpeg-1.2.6-r1/work/ffmpeg-1.2.6/doc/ffplay.texi >doc/ffplay.html.d
texi2html -I doc -monolithic --init-file /var/tmp/portage/media-video/ffmpeg-1.2.6-r1/work/ffmpeg-1.2.6/doc/t2h.init --output doc/ffplay.html /var/tmp/portage/media-video/ffmpeg-1.2.6-r1/work/ffmpeg-1.2.6/doc/ffplay.texi
awk '/^@(verbatim)?include/ { printf "doc/ffprobe.html: doc/%s\n", $2 }' </var/tmp/portage/media-video/ffmpeg-1.2.6-r1/work/ffmpeg-1.2.6/doc/ffprobe.texi >doc/ffprobe.html.d
texi2html -I doc -monolithic --init-file /var/tmp/portage/media-video/ffmpeg-1.2.6-r1/work/ffmpeg-1.2.6/doc/t2h.init --output doc/ffprobe.html /var/tmp/portage/media-video/ffmpeg-1.2.6-r1/work/ffmpeg-1.2.6/doc/ffprobe.texi
awk '/^@(verbatim)?include/ { printf "doc/ffserver.html: doc/%s\n", $2 }' </var/tmp/portage/media-video/ffmpeg-1.2.6-r1/work/ffmpeg-1.2.6/doc/ffserver.texi >doc/ffserver.html.d
texi2html -I doc -monolithic --init-file /var/tmp/portage/media-video/ffmpeg-1.2.6-r1/work/ffmpeg-1.2.6/doc/t2h.init --output doc/ffserver.html /var/tmp/portage/media-video/ffmpeg-1.2.6-r1/work/ffmpeg-1.2.6/doc/ffserver.texi
Can't locate Text/Unidecode.pm in @INC (you may need to install the Text::Unidecode module) (@INC contains: /usr/share/texi2html/lib/Unicode-EastAsianWidth/lib /usr/share/texi2html/lib/libintl-perl/lib /etc/perl /usr/local/lib64/perl5/5.18.2/x86_64-linux /usr/local/lib64/perl5/5.18.2 /usr/lib64/perl5/vendor_perl/5.18.2/x86_64-linux /usr/lib64/perl5/vendor_perl/5.18.2 /usr/local/lib64/perl5 /usr/lib64/perl5/vendor_perl /usr/lib64/perl5/5.18.2/x86_64-linux /usr/lib64/perl5/5.18.2 .) at /usr/bin/texi2html line 31679.
make: *** [doc/ffplay.html] Error 2
make: *** Waiting for unfinished jobs....
Can't locate Text/Unidecode.pm in @INC (you may need to install the Text::Unidecode module) (@INC contains: /usr/share/texi2html/lib/Unicode-EastAsianWidth/lib /usr/share/texi2html/lib/libintl-perl/lib /etc/perl /usr/local/lib64/perl5/5.18.2/x86_64-linux /usr/local/lib64/perl5/5.18.2 /usr/lib64/perl5/vendor_perl/5.18.2/x86_64-linux /usr/lib64/perl5/vendor_perl/5.18.2 /usr/local/lib64/perl5 /usr/lib64/perl5/vendor_perl /usr/lib64/perl5/5.18.2/x86_64-linux /usr/lib64/perl5/5.18.2 .) at /usr/bin/texi2html line 31679.
make: *** [doc/ffmpeg.html] Error 2
Can't locate Text/Unidecode.pm in @INC (you may need to install the Text::Unidecode module) (@INC contains: /usr/share/texi2html/lib/Unicode-EastAsianWidth/lib /usr/share/texi2html/lib/libintl-perl/lib /etc/perl /usr/local/lib64/perl5/5.18.2/x86_64-linux /usr/local/lib64/perl5/5.18.2 /usr/lib64/perl5/vendor_perl/5.18.2/x86_64-linux /usr/lib64/perl5/vendor_perl/5.18.2 /usr/local/lib64/perl5 /usr/lib64/perl5/vendor_perl /usr/lib64/perl5/5.18.2/x86_64-linux /usr/lib64/perl5/5.18.2 .) at /usr/bin/texi2html line 31679.
make: *** [doc/ffprobe.html] Error 2
Can't locate Text/Unidecode.pm in @INC (you may need to install the Text::Unidecode module) (@INC contains: /usr/share/texi2html/lib/Unicode-EastAsianWidth/lib /usr/share/texi2html/lib/libintl-perl/lib /etc/perl /usr/local/lib64/perl5/5.18.2/x86_64-linux /usr/local/lib64/perl5/5.18.2 /usr/lib64/perl5/vendor_perl/5.18.2/x86_64-linux /usr/lib64/perl5/vendor_perl/5.18.2 /usr/local/lib64/perl5 /usr/lib64/perl5/vendor_perl /usr/lib64/perl5/5.18.2/x86_64-linux /usr/lib64/perl5/5.18.2 .) at /usr/bin/texi2html line 31679.
make: *** [doc/ffserver.html] Error 2
 * ERROR: media-video/ffmpeg-1.2.6-r1::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=media-video/ffmpeg-1.2.6-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-video/ffmpeg-1.2.6-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/media-video/ffmpeg-1.2.6-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-video/ffmpeg-1.2.6-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/media-video/ffmpeg-1.2.6-r1/work/ffmpeg-1.2.6-abi_x86_64.amd64'
 * S: '/var/tmp/portage/media-video/ffmpeg-1.2.6-r1/work/ffmpeg-1.2.6'

>>> Failed to emerge media-video/ffmpeg-1.2.6-r1, Log file:

>>>  '/var/tmp/portage/media-video/ffmpeg-1.2.6-r1/temp/build.log'

 * Messages for package media-video/mjpegtools-2.1.0-r1:

 * Current versions of mjpegtools only support V4L1 which is not available
 * for kernel versions 2.6.38 and above. V4L1 will be disabled.

 * Messages for package media-video/ffmpeg-1.2.6-r1:

 * ERROR: media-video/ffmpeg-1.2.6-r1::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=media-video/ffmpeg-1.2.6-r1::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=media-video/ffmpeg-1.2.6-r1::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/media-video/ffmpeg-1.2.6-r1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/media-video/ffmpeg-1.2.6-r1/temp/environment'.
 * Working directory: '/var/tmp/portage/media-video/ffmpeg-1.2.6-r1/work/ffmpeg-1.2.6-abi_x86_64.amd64'
 * S: '/var/tmp/portage/media-video/ffmpeg-1.2.6-r1/work/ffmpeg-1.2.6'

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: media-libs/x264-0.0.20140308
 *  - /usr/lib64/libx264.so.120
 *      used by /usr/bin/mencoder (media-video/mplayer-1.1.1-r1)
 *      used by /usr/lib64/libavcodec.so.54.92.100 (media-video/ffmpeg-1.2.6)
 *      used by /usr/lib64/libquicktime/lqt_x264.so (media-libs/libquicktime-1.2.4)
 *      used by 3 other files
>>> package: media-video/ffmpeg-1.2.6
 *  - /usr/lib64/libavutil.so.51
 *  - /usr/lib64/libavutil.so.51.73.101
 *      used by /usr/lib64/alsa-lib/libasound_module_pcm_a52.so (media-plugins/alsa-plugins-1.0.27-r1)
 *      used by /usr/lib64/gstreamer-0.10/libgstffmpeg.so (media-plugins/gst-plugins-ffmpeg-0.10.13_p201211-r1)
 *      used by /usr/lib64/gstreamer-0.10/libgstffmpegscale.so (media-plugins/gst-plugins-ffmpeg-0.10.13_p201211-r1)
 *      used by 6 other files
>>> package: dev-db/mysql-5.5.39
 *  - /usr/lib64/libmysqlclient.so.16
 *  - /usr/lib64/mysql/libmysqlclient.so.16
 *  - /usr/lib64/mysql/libmysqlclient.so.16.0.0
 *      used by /usr/lib64/kde4/amarok_collection-mysqlservercollection.so (media-sound/amarok-2.8.0)
 *      used by /usr/lib64/perl5/vendor_perl/5.16.3/x86_64-linux/auto/DBD/mysql/mysql.so (dev-perl/DBD-mysql-4.20.0)
 *      used by /usr/lib64/sasl2/libsql.so.3.0.0 (dev-libs/cyrus-sasl-2.1.26-r3)
>>> package: media-libs/libmng-2.0.2-r1
 *  - /usr/lib64/libmng.so.1
 *  - /usr/lib64/libmng.so.1.0.0
 *      used by /usr/bin/mencoder (media-video/mplayer-1.1.1-r1)
 *      used by /usr/bin/mplayer (media-video/mplayer-1.1.1-r1)
 *      used by /usr/lib64/gimp/2.0/plug-ins/file-mng (media-gfx/gimp-2.8.10-r1)
Use emerge @preserved-rebuild to rebuild packages using these libraries

 * IMPORTANT: 4 config files in '/etc' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.

 * IMPORTANT: 10 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.



Code:

# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-march=barcelona -O2 -pipe"
CXXFLAGS="${CFLAGS}"
MAKEOPTS="-j4"
# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"

###############################################################################
#      Global Use Flags in addition to those provide by the profile           #
#   used for building.                                                        #
###############################################################################
USE="bindist mmx sse sse2 \
3dnow 3dnowext \
acpi alsa apm \
bash-completion bluetooth bzip2 \
cdb cdda cddb cdparanoia cdr crypt css cups \
dbus dvb dvd dvdr \
encode examples \
fontconfig ftp \
gif gimp git glut gnuplot gnutls gphoto2 gpm graphviz gzip \
handbook hardened iconv icu ieee1394 imagemagick imap imlib inotify ipod \
javascript jingle jit joystick jpeg jpeg2k kde kerberos kolab kontact \
latex libcaca libnotify libwww lirc lm_sensors lua lzma lzo \
maildir mbox memlimit mhash mime mms mmx mmxext mng modplug mozilla mtp multilib musepack mysql mysqli \
nas nsplugin \
offensive ofx openal openexr opengl \
pdf plasma plotutils png posix postscript ppds pulseaudio \
qt4 qt5 \
radius raw rdesktop readline rss ruby \
samba scanner sdl semantic-desktop session sharedmem shorten simplexml skey slp smp sndfile snmp soap sockets socks5 sound sox speex spell sqlite sqlite3 ssl svg syslog \
taglib tcpd threads tidy tiff tokenizer truetype \
unicode usb \
v4l vcd videos vnc \
wavpack wifi wmf \
xattr xcomposite xinerama xinetd xosd xpm xscreensaver xv xvid \
zlib zsh-completion \
 \
vim-syntax"

### Use flags by Protocol and API ###
# aim icq jabber msn musicbrainz oscar xmpp yahoo

### Use flags by Image format ###
#

### Use flags by audio backend
# ffmpeg mplayer xine

### Use flags by Multimedia Encoding ###
# a52 aac flac gsm lame mad mp3 mp4 mpeg ogg quicktime theora vorbis x264


INPUT_DEVICES="evdev keyboard mouse joystick vmmouse wacom"
VIDEO_CARDS="dummy fbdev glint intel  nv radeon v4l vesa vmware nvidia virtualbox"

PORTDIR="/usr/portage"
DISTDIR="${PORTDIR}/distfiles"
PKGDIR="${PORTDIR}/packages"



Code:

###############################################################################
#  Circular Dependancies - These can be commented out onces they are resolved #
###############################################################################
net-misc/curl -idn   
app-text/xmlto -latex
#app-text/texlive  doc extra png truetype cjk context epspdf games graphics humanities metapost music pstricks publishers science tex4ht texi2html xetex

###############################################################################
#      Compile Failed                                                         #
###############################################################################
media-libs/libtheora -examples

###############################################################################
#      Emerge Requests                                                        #
###############################################################################
# Emerge Requests
=media-libs/mesa-10.0.4 gbm xa
=x11-libs/libdrm-2.4.52 libkms

###############################################################################
#      Specific Package Flags                                                 #
###############################################################################
app-text/texlive extra
dev-vcs/git -doc mediawiki
net-misc/curl ssh
media-sound/lame mp3rtp
app-editors/vim cscope perl python vim-pager
media-video/vlc schroedinger
app-misc/strigi clucene
media-libs/mediastreamer video
x11-base/xorg-server ipv6 nptl suid udev xorg dmx doc uvm
kde-base/kdepim-runtime facebook google
media-libs/phonon gstreamer vlc

### Audio Environment ###
media-plugins/alsa-plugins pulseaudio speex -debug ffmpeg -jack -libsamplerate

### Audio Backend ###
virtual/ffmpeg encode gsm jpeg2k mp3 sdl speex theorat hreads truetype x264 
media-video/ffmpeg bzip2 doc encode fontconfig gnutls gsm jpeg2k mp3 network openal pulseaudio schroedinger sdl speex theora truetype v4l vorbis x264 xvid zlib
media-video/vlc dvd encode ffmpeg flac fontconfig gcrypt ieee1394 libcaca libnotify lirc lua modplug mp3 mpeg mtp musepack ncurses ogg opengl png postproc pulseaudio qt4 samba schroedinger sdl speex svg swscale taglib theora truetype udev v4l vorbis x264

### Multimedia Utilites ###
media-video/mjpegtools png sdl v4l quicktime

### Multimedia Libraries ###
media-libs/libquicktime aac encode ffmpeg jpeg lame png schroedinger vorbis x264

### KDE Desktop Environment ###
app-misc/strigi clucene dbus exif fam inotify qt4 ffmpeg
kde-base/nepomuk-core exif pdf taglib ffmpeg

# Extras Fonts
media-libs/freetype  bzip2 doc fontforge utils
# media-fonts/dejavu fontforge

# Documentation
kde-base/kdelibs doc
app-text/texlive doc
media-gfx/gimp doc
app-text/texlive-core doc
dev-texlive/texlive-basic
app-crypt/gnupg doc
net-fs/samba doc
# should be for mysql 5.x branch
virtual/mysql embedded
dev-db/mysql embedded
net-analyzer/wireshark doc doc-pdf -gtk3
media-sound/sox alsa encode ffmpeg flac mad ogg openmp pmg pulseaudio nsdfile wavpack id3tag
app-cdr/k3b dvd encode ffmpeg flac handbook mad mp3 musepack sndfile sox taglib vcd vorbis emovix
mail-client/thunderbird mozdom system-cairo system-icu system-jpeg -system-sqlite
Back to top
View user's profile Send private message
Horatio
Apprentice
Apprentice


Joined: 25 Feb 2004
Posts: 246
Location: Houston, TX

PostPosted: Mon Aug 18, 2014 8:45 am    Post subject: Reply with quote

I'm now running the following modified output from a "perl-cleaner --allmodules" which I basically removed all the virtual types of the blocks shown. I'm not sure why a virtual would be pulled in just to be blocked, but what ever. This is going through and updating all the modules for perl 5.18.2 from 5.16.3

Code:

emerge -vD1 --backtrack=30 dev-vcs/git:0 app-text/po4a:0 dev-perl/Unicode-Map:0 dev-perl/Digest-Perl-MD5:0 dev-perl/File-DesktopEntry:0 dev-perl/libwww-perl:0 dev-perl/DBD-mysql:0 dev-perl/DateTime-Locale:0 dev-perl/Package-Stash:0 dev-perl/DateTime-Format-Builder:0 dev-perl/Crypt-RC4:0 dev-perl/LWP-MediaTypes:0 dev-perl/TermReadKey:0 dev-perl/Net-HTTP:0 dev-perl/DateTime-TimeZone:0 dev-perl/Locale-gettext:0 dev-perl/WWW-RobotRules:0 dev-perl/Sub-Exporter:0 dev-perl/DBI:0 dev-perl/Net-SMTP-SSL:0 dev-perl/HTML-Tagset:0 dev-perl/Spreadsheet-ParseExcel:0 dev-perl/List-MoreUtils:0 dev-perl/OLE-StorageLite:0 dev-perl/Module-Implementation:0 dev-perl/Params-Util:0 dev-perl/HTTP-Message:0 dev-perl/HTML-Parser:0 dev-perl/XML-NamespaceSupport:0 dev-perl/Error:0 dev-perl/LWP-Protocol-https:0 dev-perl/URI:0 dev-perl/HTTP-Cookies:0 dev-perl/Text-CSV_XS:0 dev-perl/HTTP-Daemon:0 dev-perl/Try-Tiny:0 dev-perl/JSON:0 dev-perl/HTTP-Date:0 dev-perl/Package-DeprecationManager:0 dev-perl/Net-Daemon:0 dev-perl/DateTime:0 dev-perl/XML-LibXML:0 dev-perl/HTTP-Negotiate:0 dev-perl/Digest-HMAC:0 dev-perl/HTML-Tree:0 dev-perl/File-Listing:0 dev-perl/File-MimeInfo:0 dev-perl/GSSAPI:0 dev-perl/Params-Validate:0 dev-perl/IO-Socket-SSL:0 dev-perl/Class-Factory-Util:0 dev-perl/Sub-Install:0 dev-perl/SGMLSpm:0 dev-perl/Class-Load:0 dev-perl/PlRPC:0 dev-perl/Net-SSLeay:0 dev-perl/Dist-CheckConflicts:0 dev-perl/Module-Runtime:0 dev-perl/XML-Parser:0 dev-perl/Algorithm-Diff:0 dev-perl/Encode-Locale:0 dev-perl/Package-Stash-XS:0 dev-perl/Authen-SASL:0 dev-perl/IO-stringy:0 dev-perl/libintl-perl:0 dev-perl/Text-Unidecode:0 dev-perl/File-BaseDir:0 dev-perl/Class-Singleton:0 dev-perl/DateTime-Format-ISO8601:0 dev-perl/XML-SAX-Base:0 dev-perl/Unicode-EastAsianWidth:0 dev-perl/Data-OptList:0 dev-perl/MediaWiki-API:0 dev-perl/Text-WrapI18N:0 dev-perl/DateTime-Format-Strptime:0 dev-perl/XML-SAX:0 dev-perl/Text-CharWidth:0 perl-core/Pod-Escapes:0 virtual/perl-Pod-Escapes:0 perl-core/Package-Constants:0 virtual/perl-Package-Constants:0 perl-core/File-Temp:0 perl-core/CPAN-Meta-Requirements:0 virtual/perl-CPAN-Meta-Requirements:0 perl-core/Scalar-List-Utils:0 virtual/perl-Scalar-List-Utils:0 perl-core/Module-CoreList:0 perl-core/ExtUtils-CBuilder:0 perl-core/File-Spec:0 virtual/perl-File-Spec:0 perl-core/Params-Check:0 virtual/perl-Params-Check:0 perl-core/Pod-Simple:0 perl-core/Parse-CPAN-Meta:0 virtual/perl-Parse-CPAN-Meta:0 perl-core/ExtUtils-Manifest:0 perl-core/Archive-Tar:0 virtual/perl-Archive-Tar:0 perl-core/IO-Zlib:0 virtual/perl-IO-Zlib:0 perl-core/IO-Compress:0 virtual/perl-IO-Compress:0 perl-core/Locale-Maketext-Simple:0 virtual/perl-Locale-Maketext-Simple:0 perl-core/ExtUtils-Install:0 perl-core/Digest-MD5:0 virtual/perl-Digest-MD5:0 perl-core/Module-Metadata:0 virtual/perl-Module-Metadata:0 perl-core/Module-Load:0 virtual/perl-Module-Load:0 perl-core/Sys-Syslog:0 virtual/perl-Sys-Syslog:0 perl-core/Perl-OSType:0 perl-core/JSON-PP:0 perl-core/Compress-Raw-Zlib:0 virtual/perl-Compress-Raw-Zlib:0 perl-core/CPAN-Meta-YAML:0 virtual/perl-CPAN-Meta-YAML:0 perl-core/Digest:0 virtual/perl-Digest:0 perl-core/Module-Build:0 virtual/perl-Module-Build:0 perl-core/CPAN-Meta:0 virtual/perl-CPAN-Meta:0 perl-core/IPC-Cmd:0 perl-core/ExtUtils-ParseXS:0 virtual/perl-ExtUtils-ParseXS:0 perl-core/Compress-Raw-Bzip2:0 virtual/perl-Compress-Raw-Bzip2:0 perl-core/Time-Local:0 virtual/perl-Time-Local:0 perl-core/version:0 perl-core/Module-Load-Conditional:0 virtual/perl-Module-Load-Conditional:0 perl-core/Test-Harness:0 virtual/perl-Test-Harness:0 perl-core/Digest-SHA:0 virtual/perl-Digest-SHA:0
Back to top
View user's profile Send private message
Horatio
Apprentice
Apprentice


Joined: 25 Feb 2004
Posts: 246
Location: Houston, TX

PostPosted: Mon Aug 18, 2014 5:14 pm    Post subject: Reply with quote

Well, after that fix to rebuild perl modules completed, I was able to rebuild Amarok with a "emerge -DNu amarok". Even better, I can now play WMAs. I'm not sure how that fixes things. I'm just going to hope I don't break Amarok or the system again with all my use flag selection spaghetti.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum