Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
strange freezing screen issue. gnome/openbox
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
mreff555
Apprentice
Apprentice


Joined: 10 Mar 2011
Posts: 231
Location: Philadelphia

PostPosted: Wed Aug 13, 2014 3:03 am    Post subject: strange freezing screen issue. gnome/openbox Reply with quote

This has been going on for too long. I have been having a very annoying problem that I have ignored because the band-aid is quick and easy, and the problem is difficult to describe. However, I'd really like to fix this.

About every hour of operation my screen will freeze. When I switch to the console I see different messages every time. The messages seem to have something to do with xrandr. This is only a guess, but most of the messages seem to have something to do with graphics and occasionally I see
Quote:

setversion 1.4 failed: Permission denied


The other message I see, in fact this is the most common message I see associated with this behavior is
Quote:

reporting 2 4 17 22


Sorry I can't offer logs, I've hunted through my log files and I am unable to find these instances. I have no idea where these messages come from.

As soon as I switch back to ptty7 the problem is fixed, for another hour or so anyway.

has anyone ever seen anything like this?
Back to top
View user's profile Send private message
cyberjun
Apprentice
Apprentice


Joined: 06 Nov 2005
Posts: 293

PostPosted: Wed Aug 13, 2014 8:01 am    Post subject: Reply with quote

Hi,
I see a similar behaviour. I don't know how often it happens. But it does happen. The entire screen and mouse would freeze. However if I switch to console and then switch back, everything would work as normal. In fact it appears that the freeze is only with display. The mouse and keyboard probably work. For example, if the screen is frozen as described above, and I right-click or move mouse, when I switch-to-console and switch back, the right click menu would be open. I use XFCE.

From your logs, it looks like you are also using nvidia-drivers. I have a Lenovo G500s laptop (with Nvidia Optimus). This behaviour happens only when I use nvidia-drivers (with intel). It does not happen when I use intel exclusively.

I use the latest nvidia-drivers-340.24. Did you try downgrading?

--cyberjun
Back to top
View user's profile Send private message
mreff555
Apprentice
Apprentice


Joined: 10 Mar 2011
Posts: 231
Location: Philadelphia

PostPosted: Wed Aug 13, 2014 6:09 pm    Post subject: Reply with quote

You are correct. It appears to only affect the screen, not the actual inputs, and yes I am running NVIDIA drivers. I update them as often as I can. I don't know the current version but I assume it's the latest.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum