Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Completely broken layman... Help?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
allenh1
n00b
n00b


Joined: 16 Jun 2014
Posts: 16
Location: Brentwood, TN

PostPosted: Mon Jul 06, 2015 5:20 pm    Post subject: Completely broken layman... Help? Reply with quote

So I've been working on installing ROS (Robot Operating System) on my Gentoo computer. I have been doing a lot of work and created an overlay and got really close. Then I installed an upgraded version of pip. Installing the packages I installed with my overlay with pip 7.4.1 completed broke layman. :roll:

Code:

allenh1@tuxbox ~ $ sudo layman -S
Password:
ERROR: Cannot find required rosinstall library version, check your installation (also of vcstools) is up-to-date. One frequent cause is that rosinstall 0.5 is still installed in /usr/local/lib.
No module named 'wstool'


wstool is one of the packages. I have uninstalled everything related to ros and reinstalled layman. I think Python got seriously messed up here. Anyone have any words of wisdom?
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 3488

PostPosted: Mon Jul 06, 2015 5:46 pm    Post subject: Reply with quote

Did you forget to delete all /var/lib/layman stuff?
Back to top
View user's profile Send private message
allenh1
n00b
n00b


Joined: 16 Jun 2014
Posts: 16
Location: Brentwood, TN

PostPosted: Mon Jul 06, 2015 7:25 pm    Post subject: Reply with quote

Quote:
Did you forget to delete all /var/lib/layman stuff?



I did! But, unfortunately, that didn't help. I did the following:

Code:
# emerge -C layman
# rm -rf /var/lib/layman
# emerge layman


and this was at the very end of the emerge.

Code:
>>> Installing (1 of 1) app-portage/layman-2.2.0-r7
 * Running layman-updater...
ERROR: Cannot find required rosinstall library version, check your installation (also of vcstools) is up-to-date. One frequent cause is that rosinstall 0.5 is still installed in /usr/local/lib.
No module named 'wstool'
 *

>>> Recording app-portage/layman in "world" favorites file...
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.


This is pretty obnoxious. I still don't know how things got this broken. I suspect python got messed up somehow.
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 3488

PostPosted: Tue Jul 07, 2015 4:51 am    Post subject: Reply with quote

In case your version of layman used the repos.conf method there is chance that you still have something in /etc/portage/repos.conf/layman.conf.
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Tue Jul 07, 2015 1:58 pm    Post subject: Reply with quote

There are several threads here about running pip as root and how it breaks portage, with solutions.
Back to top
View user's profile Send private message
allenh1
n00b
n00b


Joined: 16 Jun 2014
Posts: 16
Location: Brentwood, TN

PostPosted: Tue Jul 07, 2015 3:15 pm    Post subject: Reply with quote

Figured it out. All I needed to do was

Code:
# emerge -C python-exec
#emerge python-exec


and layman is back to normal.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum