Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HOWTO: >=skype-4.3 with alsa and minimal pulseaudio
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
steveL
Watchman
Watchman


Joined: 13 Sep 2006
Posts: 5153
Location: The Peanut Gallery

PostPosted: Fri Nov 14, 2014 7:03 pm    Post subject: Reply with quote

Naib wrote:
MS are making Skype a webapp to work in chrome,FF ...

Yay open your browser to the proprietary plugin, as if a separated process which has access to everything you do weren't enough.
Back to top
View user's profile Send private message
pablo_supertux
Advocate
Advocate


Joined: 25 Jan 2004
Posts: 2740
Location: Somewhere between reality and Middle-Earth and in Freiburg (Germany)

PostPosted: Mon Nov 24, 2014 10:22 pm    Post subject: Reply with quote

I still having troubles with apulse. I tested it today with a debian 6 and it worked like a charm. So when I got home, I tried to install it on my gentoo but it's a mess with all the dependencies and blocks...

I have an amd64 system, so I guess I need to build some libs as 32bit.

I've read some of the problems encountered in the thread and did what it was suggested:

I put -abi_x86_32 in /etc/portage/profile/use.mask, uninstalled pulseaudio and made an emerge @preserved-rebuild to rebuild the libraries. At first it all went wrong, because emul-linux-x86-soundlibs conflicts with apulse. So I uninstalled emul-linux-x86-soundlibs and skype without pulseaudio and apulse were installed. after that a emerge @preserved-rebuild showed me errors again:

Code:

emerge @preserved-rebuild -pv

 Calculating dependencies... done!
 [ebuild   R    ] media-plugins/alsa-plugins-1.0.28  USE="ffmpeg -debug -jack -libsamplerate -pulseaudio* -speex" ABI_X86="(64) -32 (-x32)" 0 kB
 [ebuild   R    ] media-video/mplayer2-2.0_p20130428-r1  USE="X alsa cdio directfb dvd dvdnav enca gif iconv ipv6 jpeg lcms libass mmx mng mp3 network opengl png postproc quvi shm sse sse2 threads unicode xscreensaver xv -3dnow -3dnowext (-altivec) (-aqua) -bluray -bs2b -cddb -cpudetection -debug -doc -dvb -ftp -jack -joystick -ladspa -libcaca -lirc -md5sum -mmxext -oss -pnm -portaudio -pulseaudio -pvr -radio -samba (-selinux) -ssse3 -symlink -tga -v4l -vcd -vdpau -xinerama -yuv4mpeg" 1,867 kB
 [ebuild   R    ] app-emulation/emul-linux-x86-medialibs-20140508-r6  USE="development" ABI_X86="-32" 11,058 kB
 [ebuild  N     ] app-emulation/emul-linux-x86-soundlibs-20140508  USE="alsa development (-pulseaudio)" ABI_X86="-32" 7,090 kB
 [ebuild   R    ] app-emulation/emul-linux-x86-sdl-20140508-r1  USE="development" ABI_X86="-32" 0 kB
 [ebuild     U  ] net-libs/webkit-gtk-2.4.4-r1:3/25 [2.2.6:3/29] USE="X%* egl geoloc gstreamer introspection jit opengl spell webgl (-aqua) -coverage -debug -gles2 -libsecret {-test} -wayland%" 0 kB
 [ebuild     U  ] net-libs/webkit-gtk-2.4.4-r201:2 [2.4.4-r200:2] USE="X egl geoloc gstreamer introspection jit opengl spell webgl (-aqua) -coverage -debug -gles2 -libsecret {-test}" 0 kB
 [blocks B      ] app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)] ("app-emulation/emul-linux-x86-soundlibs[-abi_x86_32(-)]" is blocking media-libs/alsa-lib-1.0.28)


This is the error I always get, app-emulation/emul-linux-x86-soundlibs gets in the way of media-libs/alsa-lib and I cannot figure out what I've got to do to get everything running without causing major blocks.

So i reverted now to my old setup with pulseaudio (I start it only when I use skype and after that I close pulseaudio again), its not nice but at least it's working again.
_________________
A! Elbereth Gilthoniel!
silivren penna míriel
o menel aglar elenath,
Gilthoniel, A! Elbereth!
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6293

PostPosted: Mon Nov 24, 2014 10:47 pm    Post subject: Reply with quote

Meanwhile it is possible to unmerge and mask all emul-linux-* packages: The tree contains now qt ebuilds which know abi_x86_32 (you have to put everything from dev-qt which you have into /etc/portage/package.accept_keywords, of course, currently).

Thus, the best way to switch to to abi_x86_32 completely is currently probably:

  • emerge --unmerge $(eix -I# emul-linux)
  • Switch to the new profile default/linux/amd64/13.0/no-emul-linux-x86
    This masks the emul-linux-* packages and unmasks the abi_x86_32 flag
  • Add some packages to package.accept_keywords (see below)
  • Add abi_x86_32 for a lot of packages to /etc/portage/package.use (see below)

An updated list for the last two points is here:
/etc/portage/package.accept_keywords/multlilib wrote:
~dev-qt/qt3support-4.8.6
~dev-qt/qtcore-4.8.6
~dev-qt/qtdbus-4.8.6
~dev-qt/qtdeclarative-4.8.6
~dev-qt/qtgui-4.8.6
~dev-qt/qtopengl-4.8.6
~dev-qt/qtscript-4.8.6
~dev-qt/qtsql-4.8.6
~dev-qt/qtsvg-4.8.6
~dev-qt/qtwebkit-4.8.6
~dev-qt/qtxmlpatterns-4.8.6
~media-libs/fontconfig-2.10.93
~x11-libs/cairo-1.12.16
~x11-libs/libSM-1.2.2

/etc/portage/package.use/multilib wrote:
# These mv wants as multilib:

app-emulation/wine abi_x86_32

# The rest mv is *forced* to take...

# net-im/skype:

dev-qt/qtcore abi_x86_32
dev-qt/qtdbus abi_x86_32
dev-qt/qtgui abi_x86_32
dev-qt/qtwebkit abi_x86_32
media-libs/alsa-lib abi_x86_32
media-sound/apulse abi_x86_32
x11-libs/libXScrnSaver abi_x86_32
x11-libs/libXext abi_x86_32
x11-libs/libXv abi_x86_32

# app-emulation/wine:

media-libs/alsa-lib abi_x86_32
media-libs/libpng abi_x86_32
sys-libs/ncurses abi_x86_32
virtual/glu abi_x86_32
virtual/jpeg:0 abi_x86_32
virtual/opengl abi_x86_32
x11-libs/libXcursor abi_x86_32
x11-libs/libXext abi_x86_32
x11-libs/libXi abi_x86_32
x11-libs/libXrandr abi_x86_32
x11-libs/libXxf86vm abi_x86_32

# app-emulation/acroread:

dev-libs/atk abi_x86_32
dev-libs/glib abi_x86_32
dev-libs/libffi abi_x86_32
dev-libs/libxml2 abi_x86_32
dev-libs/openssl:0.9.8 abi_x86_32
media-libs/fontconfig abi_x86_32
net-dns/libidn abi_x86_32
net-nds/openldap abi_x86_32
sys-apps/attr abi_x86_32
sys-libs/zlib abi_x86_32
#virtual/glu abi_x86_32
virtual/libffi abi_x86_32
virtual/libiconv abi_x86_32
x11-libs/gdk-pixbuf abi_x86_32
x11-libs/gtk+:2 abi_x86_32
#x11-libs/libXext abi_x86_32
x11-libs/libXt abi_x86_32
x11-libs/pango abi_x86_32
x11-libs/pangox-compat abi_x86_32

# Implicit of media-sound/skype:

dev-db/sqlite abi_x86_32
dev-libs/openssl:0 abi_x86_32
dev-qt/qt3support abi_x86_32
dev-qt/qtscript abi_x86_32
dev-qt/qtsql abi_x86_32
dev-qt/qtxmlpatterns abi_x86_32
dev-util/pkgconf abi_x86_32
media-libs/libmng abi_x86_32
sys-apps/dbus abi_x86_32
virtual/pkgconfig abi_x86_32
x11-libs/libICE abi_x86_32
x11-libs/libX11 abi_x86_32
x11-proto/renderproto abi_x86_32
x11-proto/scrnsaverproto abi_x86_32

# Implicit of app-emulation/wine (but maybe also implicit of skype):

dev-libs/expat abi_x86_32
media-libs/glu abi_x86_32
media-libs/jbigkit abi_x86_32
media-libs/libjpeg-turbo abi_x86_32
media-libs/mesa abi_x86_32
media-libs/tiff abi_x86_32
sys-apps/systemd abi_x86_32
sys-libs/gpm abi_x86_32
virtual/libudev abi_x86_32
x11-libs/libXau abi_x86_32
x11-libs/libXdmcp abi_x86_32
x11-libs/libXrender abi_x86_32
x11-libs/libXvMC abi_x86_32
x11-libs/libdrm abi_x86_32
x11-libs/libpciaccess abi_x86_32
x11-libs/libvdpau abi_x86_32
x11-libs/libxcb abi_x86_32
x11-libs/libxshmfence abi_x86_32
x11-proto/dri2proto abi_x86_32
x11-proto/dri3proto abi_x86_32
x11-proto/glproto abi_x86_32
x11-proto/presentproto abi_x86_32
x11-proto/randrproto abi_x86_32
x11-proto/xcb-proto abi_x86_32
x11-proto/xf86driproto abi_x86_32
x11-proto/xf86vidmodeproto abi_x86_32

# Implicit of app-emulation/acroread (but maybe also implicit of skype or wine):

app-arch/bzip2 abi_x86_32
app-arch/xz-utils abi_x86_32
dev-libs/gmp abi_x86_32
dev-libs/icu abi_x86_32
dev-libs/lzo abi_x86_32
media-gfx/graphite2 abi_x86_32
media-libs/freetype abi_x86_32
media-libs/harfbuzz abi_x86_32
sys-apps/util-linux abi_x86_32
x11-libs/cairo abi_x86_32
x11-libs/libSM abi_x86_32
x11-libs/libXcomposite abi_x86_32
x11-libs/libXdamage abi_x86_32
x11-libs/libXfixes abi_x86_32
x11-libs/libXft abi_x86_32
x11-libs/libXrender abi_x86_32
x11-libs/pixman abi_x86_32
x11-proto/compositeproto abi_x86_32
x11-proto/damageproto abi_x86_32
x11-proto/fixesproto abi_x86_32
x11-proto/xextproto abi_x86_32
x11-proto/xproto abi_x86_32

The data might vary in your case: It depends on which use-flags (of skype, wine, acroread and others of the above packages) you have activated, and it also depends on which packages you have installed to satisfy some virtual/* packages.
Back to top
View user's profile Send private message
neumond
n00b
n00b


Joined: 22 Nov 2014
Posts: 5

PostPosted: Wed Nov 26, 2014 9:19 am    Post subject: Reply with quote

Installed skype with apulse via multilib (abi_x86_32). Experienced many bugs: skype hangs when someone calls me, it's only possible to speak if you start the call. The strangest thing was minecraft sigsegv. OpenAL application tries to open device with some bad name causing segmentation fault on standard C function strlen! Decided to install pulseaudio :)
Back to top
View user's profile Send private message
Levns
n00b
n00b


Joined: 02 Dec 2014
Posts: 7

PostPosted: Wed Dec 03, 2014 10:20 am    Post subject: Reply with quote

I just made the whole migration from pulseaudio to apulse (finally !) and.. nope, Skype does not produce any sound.

Basically, I have a peculiar setup: a Loopback interface that all my ALSA applications use (hw:0,0) and I have a JACK server running which links the over side of this loopback interface (hw:0,1) to my actual audio cards (using zita-ajbridge, from the pro-audio overlay), both for input and output. This setup works well for all my ALSA applications.

However, even when running

Code:
APULSE_CAPTURE_DEVICE="hw:0,0" APULSE_PLAYBACK_DEVICE="hw:0,0" apulse skype


Skype does not produce any sound.

Would someone have any insight, or a link to a sample PulseAudio client that I could use to debug my setup ?
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6293

PostPosted: Wed Dec 03, 2014 1:11 pm    Post subject: Reply with quote

Just for anybody who follows this thread:
With apulse-0.1.4, it is not sufficient just to run "skype": I edited the first post correspondingly.
Also I gave a hint in the first post to some ~/.asoundrc which was recommended to me in another thread and which works fine for me.

@Levns: However, this is only a simple setup; I never tried to combine things with jack.
Back to top
View user's profile Send private message
Levns
n00b
n00b


Joined: 02 Dec 2014
Posts: 7

PostPosted: Wed Dec 03, 2014 4:44 pm    Post subject: Reply with quote

@mv: Well thanks for editing your first post. It had in fact nothing to do with my setup, I was just missing the LD_LIBRARY_PATH thing.

Seems to work now. :D
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6293

PostPosted: Sun Dec 07, 2014 5:54 pm    Post subject: Reply with quote

Editing the first post again: Wrapper scripts are no longer needed with >=skype-4.3.0.37-r5.
Note, however, that if you run a pax kernel you should probably wait for the next release of the skype ebuild which hopefully contains a fix for the bug which was introduced by that latest change in the skype ebuild (or you must manually paxmark /opt/bin/skype-bin).
Back to top
View user's profile Send private message
sl70
Guru
Guru


Joined: 18 Jun 2002
Posts: 377
Location: Chicago, USA

PostPosted: Tue Dec 16, 2014 12:05 am    Post subject: Reply with quote

This is really driving me crazy. I went through the whole procedure and finally was able to build @world with no emu_x86 packages. But then when I went to build skype and acroread, no luck at all.

Typical pattern:
    needs gtk+:2 with abi_x86_32 -- do it
    needs cups with abi_x86_32 -- do it
    now it needs gtk+:2 with -abi_x86_32 -- do it
    now it needs cups with -abi_x86_32 -- do it
    now it needs cups with abi_x86_32 -- I throw my hands in the air


I really need acroread and skype for work. Any help?
Back to top
View user's profile Send private message
v_andal
Guru
Guru


Joined: 26 Aug 2008
Posts: 523
Location: Germany

PostPosted: Tue Dec 16, 2014 8:32 am    Post subject: Reply with quote

I just created 32-bit chroot and install there applications that need emu_x86 packages. Maybe does not look as nice as abi_x86_32, but it works without much hassle.
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6293

PostPosted: Tue Dec 16, 2014 12:19 pm    Post subject: Reply with quote

sl70 wrote:
now it needs gtk+:2 with -abi_x86_32

If you are "switching" to no-emul, never marks something as -abi_x86_32: If portage suggests this, it means that some of its dependencies are not abi_x86_32, e.g. because the corresponding version is not stable.
Never emerge something, before emerge -NaDu @world show no errors/warnings.
It can help to choose the no-emul profile.
Back to top
View user's profile Send private message
sl70
Guru
Guru


Joined: 18 Jun 2002
Posts: 377
Location: Chicago, USA

PostPosted: Tue Dec 16, 2014 9:40 pm    Post subject: Reply with quote

mv wrote:
sl70 wrote:
now it needs gtk+:2 with -abi_x86_32

If you are "switching" to no-emul, never marks something as -abi_x86_32: If portage suggests this, it means that some of its dependencies are not abi_x86_32, e.g. because the corresponding version is not stable.
Never emerge something, before emerge -NaDu @world show no errors/warnings.
It can help to choose the no-emul profile.


MV, I appreciate the help. I've get my profile set to no-emul:
Code:
 eselect profile show
Current /etc/make.profile symlink:
  default/linux/amd64/13.0/no-emul-linux-x86

and I've removed all the -abi_x86_32 in package.use and added tons of other packages. Now when I try to emerge @world I get this:
Code:

emerge: there are no ebuilds built with USE flags to satisfy ">=net-libs/gnutls-2.12.23-r6[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]".
!!! One of the following packages is required to complete your request:
- net-print/cups-1.7.5::gentoo (Change USE: -abi_x86_32)
(dependency required by "net-print/cups-1.7.5" [ebuild])
(dependency required by "x11-libs/gtk+-2.24.24[cups]" [ebuild])
(dependency required by "app-dicts/kasumi-2.5-r1" [installed])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])


I'm stuck. cups, gtk+, kasumi and gnutls are all marked as abi_x86_32 in package.use. Don't know how to proceed from here.
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6293

PostPosted: Tue Dec 16, 2014 10:11 pm    Post subject: Reply with quote

sl70 wrote:
emerge: there are no ebuilds built with USE flags to satisfy ">=net-libs/gnutls-2.12.23[...]

The error message seems rather clear to me: You need to emerge gnutls with USE=abi_x86_32.
eix shows that the current stable gnutls does not provide this use-flag, so you have to install the testing version.

An alternative (if you want to compile the least number of programs with 32 bit support): compile cups with USE=-gnutls. Of course, this means you have no encryption support in cups.

Another alternative is to compile gtk+2 iwth USE=-cups, so that you do not have to compile cups with USE=abi_x86_32, either. Of course, this means that you have no special printing support in gtk+2.

These are the disadvantages of the multilib approach: You cannot choose the USE-flags for the 32-bit and the 64-bit version separately. If you want some support in the 64 bit version, you must provide this support also in the 32 bit version.
Back to top
View user's profile Send private message
sl70
Guru
Guru


Joined: 18 Jun 2002
Posts: 377
Location: Chicago, USA

PostPosted: Tue Dec 16, 2014 11:07 pm    Post subject: Reply with quote

Ah, I see! Thanks very much, MV.
Back to top
View user's profile Send private message
sl70
Guru
Guru


Joined: 18 Jun 2002
Posts: 377
Location: Chicago, USA

PostPosted: Sat Dec 20, 2014 12:28 am    Post subject: Reply with quote

OK, another problem. Thanks to the kind help of MV, I was able to emerge @world and acroread without emul libs, but now when I try to build skype I'm failing. skype requires qtdbus[abi_x86_32] (among others), which is only available for the testing version, ~qtdbus-4.8.6-r1. However, the dev-qt packages also require qtchooser, the only version of which, 0_p20140613, requires <dev-qt/qtdbus-4.8.6:4 (and all the other qt* less than 4.8.6).

Any idea how to resolve these blocks?
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6293

PostPosted: Sun Dec 21, 2014 12:04 am    Post subject: Reply with quote

sl70 wrote:
qtchooser [...] requires <dev-qt/qtdbus-4.8.6:4

Quite the opposite: There is "!<dev-qt/qtdbus-4.8.6:4" in RDPEPEND, i.e., a blocker to this old version.
Back to top
View user's profile Send private message
mani001
Guru
Guru


Joined: 04 Dec 2004
Posts: 358
Location: Oleiros

PostPosted: Wed Dec 31, 2014 4:51 pm    Post subject: Reply with quote

Although I can install skype with apulse without a glitch, this is not working for me... I'm trying to use a USB Logitech webcam...which is not the problem since I'm able to record audio from Audacity. I also checked the volume and it's fine...Any suggestion?

Cheers
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 3387

PostPosted: Tue Jan 06, 2015 1:24 am    Post subject: Reply with quote

I began looking at this whole multilib/no-emul thing today, and find a serious blocker...

It appears to me that in order to get abi_x86_32 you need qtsql-4.8.6-r1.
But qtsql-4.8.6-r1 also requires virtual/mysql-5.6-r2, which in turn needs either dev-db/mydql-5.6+ or dev-db/mariadb-10.0+. Either of these has a horrible knock-on rippling through the rest of the installation. For instance, apr-util-1.5.3-r2 requires virtual/mysql-5.5, and there are others.

I guess I give up, for now. On bugzilla this is listed as "working as intended", but that's quite a big difference between qtsql-4.8.5 and qtsql-4.8.6-r1.
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
mv
Watchman
Watchman


Joined: 20 Apr 2005
Posts: 6293

PostPosted: Tue Jan 06, 2015 7:53 am    Post subject: Reply with quote

depontius wrote:
But qtsql-4.8.6-r1 also requires virtual/mysql-5.6-r2

No. You can USE="sqlite -mysql" with qtsql
Back to top
View user's profile Send private message
depontius
Advocate
Advocate


Joined: 05 May 2004
Posts: 3387

PostPosted: Tue Jan 06, 2015 1:04 pm    Post subject: Reply with quote

mv wrote:
depontius wrote:
But qtsql-4.8.6-r1 also requires virtual/mysql-5.6-r2

No. You can USE="sqlite -mysql" with qtsql


Not if I eventually want to run MythTV on that machine. Right now it's the only machine in the house with no MythTV client. (>=dev-qt/qtsql-4.7.2:4=[mysql]) I'm also using this machine as an experimental platform, and would eventually like to move my other machines to work this way, and all except one server have MythTV on them. (One server of course has MythTV, too.)

I've also seen something about running the no-emul-linux-x86 profile, and unmasking emul-linux-x86-qtlibs. If I read things right, it looks like emul-linux-x86-qtlibs-20140508-r1 can be used in a mix'n'match fashion, perhaps as the only emul-linux-x86 piece left in an otherwise multilib system? (Looking at the ebuild now...)
_________________
.sigs waste space and bandwidth
Back to top
View user's profile Send private message
Naib
Watchman
Watchman


Joined: 21 May 2004
Posts: 5673
Location: Removed by Neddy

PostPosted: Sat May 30, 2015 4:55 pm    Post subject: Reply with quote

Naib wrote:
There might be a neater solution around the corner.

MS are making Skype a webapp to work in chrome,FF ...

Looks like it is in Skype for Web is in beta https://login.skype.com.
It seems to actively check useragent string but when I switch it it IE8 it logs in. So far it seems focused on making called so no access to VOIP or chat
But as I stated, no plugin required (uses webRTc) :) whether MS makes it useragent Agnostic is another thing. BUT if you still need skype (and unfortunately some do...)
_________________
The best argument against democracy is a five-minute conversation with the average voter
Great Britain is a republic, with a hereditary president, while the United States is a monarchy with an elective king
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Goto page Previous  1, 2, 3
Page 3 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum