Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Not able to see Physical interfaces in ifconfig -a
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
manu_leo
Guru
Guru


Joined: 20 Jan 2014
Posts: 457
Location: India

PostPosted: Sat Aug 09, 2014 5:56 pm    Post subject: [SOLVED] Not able to see Physical interfaces in ifconfig -a Reply with quote

Hi Experts,

I am little confused here. I was in the process of upgrading the server with Gentoo. Before the upgrade, the interface was enp6s0 which had an ip configured on it.

Before the upgrade :-

ls -lth /sys/class/net/

lrwxrwxrwx 1 root root 0 Mar 23 08:34 enp6s0
lrwxrwxrwx 1 root root 0 Mar 23 08:34 lo0

This is not correct as well, because I have 4*1G interface on the server and I see just 1 which is enp6s0. I thought that after the upgrade, the interface (eno1-4) would show up , but that dint happen. After the upgrade I have lost the enp6s0 interface as well.


After the upgrade:-

ls -lth /sys/class/net/

lrwxrwxrwx 1 root root 0 Mar 23 08:34 sit0
lrwxrwxrwx 1 root root 0 Mar 23 08:34 lo0

Now I see a new interface sit0. I am not sure from where did it came. I dont see any interface EXCEPT sit0 AND lo0 .

Please let me know what I missed.

Appreciate all your help in advance.


Last edited by manu_leo on Mon Aug 11, 2014 5:37 pm; edited 1 time in total
Back to top
View user's profile Send private message
Hu
Moderator
Moderator


Joined: 06 Mar 2007
Posts: 14169

PostPosted: Sat Aug 09, 2014 6:06 pm    Post subject: Reply with quote

What exactly did you upgrade? Changes in available interfaces should only happen if you change the kernel or its modules.
Back to top
View user's profile Send private message
manu_leo
Guru
Guru


Joined: 20 Jan 2014
Posts: 457
Location: India

PostPosted: Sat Aug 09, 2014 6:16 pm    Post subject: Reply with quote

Thanks Hu for the prompt reply. I upgraded the OS and Kernel. Before, CentOS was installed on the server. I FORMAT all the partitions and did a fresh Gentoo installation on it. Built the kernel from scratch.
Back to top
View user's profile Send private message
manu_leo
Guru
Guru


Joined: 20 Jan 2014
Posts: 457
Location: India

PostPosted: Sat Aug 09, 2014 6:57 pm    Post subject: Reply with quote

Guys would really appreciate if you could help me in getting this fixed. I dont see any interfaces except the sit0 and I am not sure how did that came.
Back to top
View user's profile Send private message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 4258
Location: Dallas area

PostPosted: Sat Aug 09, 2014 7:15 pm    Post subject: Reply with quote

It looks like the name changed from enp6s0 to sit0.
I would imagine it's the same device since the other one is lo0.
_________________
Asus m5a99fx, FX 8320 - nouveau, oss4, rx550 for qemu passthrough
Acer laptop E5-575, i3-7100u - i965, alsa
---both---
5.0.13 zen kernel, profile 17.1 (no-pie & modified) amd64-no-multilib
gcc 8.2.0, eudev, openrc, openbox, palemoon
Back to top
View user's profile Send private message
manu_leo
Guru
Guru


Joined: 20 Jan 2014
Posts: 457
Location: India

PostPosted: Sat Aug 09, 2014 7:21 pm    Post subject: Reply with quote

So what should I do to get this fixed ?
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7258
Location: Saint Amant, Acadiana

PostPosted: Sat Aug 09, 2014 7:24 pm    Post subject: Reply with quote

Run lspci -nnk, this will tell you if kernel driver is loaded or not and give you PCI ID which you can put in http://kmuto.jp/debian/hcl/
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43755
Location: 56N 3W

PostPosted: Sat Aug 09, 2014 7:33 pm    Post subject: Reply with quote

manu_leo,

sit0 is an IPv6 over IPv4 tunnel endpoint. That you have it means that you have IPv6 on in the kernel.
It looks like your network card module is not built or loaded, or both.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
manu_leo
Guru
Guru


Joined: 20 Jan 2014
Posts: 457
Location: India

PostPosted: Sat Aug 09, 2014 8:10 pm    Post subject: Reply with quote

Thanks for looking into this. So how could I find the drivers for the interface so that i could built it because I dont see anything thing in lsmod or lspci -v.
Back to top
View user's profile Send private message
Jaglover
Watchman
Watchman


Joined: 29 May 2005
Posts: 7258
Location: Saint Amant, Acadiana

PostPosted: Sat Aug 09, 2014 8:15 pm    Post subject: Reply with quote

Jaglover wrote:
Run lspci -nnk, this will tell you if kernel driver is loaded or not and give you PCI ID which you can put in http://kmuto.jp/debian/hcl/


manu_leo wrote:
So how could I find the drivers for the interface so that i could built it because I dont see anything thing in lsmod or lspci -v.


Why you ask for help if you do not read replies? To be successful in Gentoo you need to pay attention to all details, sometimes even my postings can contain something useful.
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
manu_leo
Guru
Guru


Joined: 20 Jan 2014
Posts: 457
Location: India

PostPosted: Sun Aug 10, 2014 5:38 am    Post subject: Reply with quote

My apologies for missing your help Jaglover. I see it now, and will try to get that piece of info.

Appreciate everyone's help.
Back to top
View user's profile Send private message
manu_leo
Guru
Guru


Joined: 20 Jan 2014
Posts: 457
Location: India

PostPosted: Sun Aug 10, 2014 5:51 pm    Post subject: Reply with quote

Hi Jaglover, I booted the service using live cd and ran the command mentioned 'lspci -nnk'

livecd ~ # lspci -nnk
00:00.0 Host bridge [0600]: Intel Corporation 5520 I/O Hub to ESI Port [8086:3406] (rev 22)
Subsystem: Dell Device [1028:026d]
00:01.0 PCI bridge [0604]: Intel Corporation 5520/5500/X58 I/O Hub PCI Express Root Port 1 [8086:3408] (rev 22)
Kernel driver in use: pcieport
00:03.0 PCI bridge [0604]: Intel Corporation 5520/5500/X58 I/O Hub PCI Express Root Port 3 [8086:340a] (rev 22)
Kernel driver in use: pcieport
00:07.0 PCI bridge [0604]: Intel Corporation 5520/5500/X58 I/O Hub PCI Express Root Port 7 [8086:340e] (rev 22)
Kernel driver in use: pcieport
00:14.0 PIC [0800]: Intel Corporation 7500/5520/5500/X58 I/O Hub System Management Registers [8086:342e] (rev 22)
Subsystem: Device [0028:006d]
00:14.1 PIC [0800]: Intel Corporation 7500/5520/5500/X58 I/O Hub GPIO and Scratch Pad Registers [8086:3422] (rev 22)
Subsystem: Device [0028:006d]
00:14.2 PIC [0800]: Intel Corporation 7500/5520/5500/X58 I/O Hub Control Status and RAS Registers [8086:3423] (rev 22)
Subsystem: Device [0028:006d]
00:1a.0 USB controller [0c03]: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #4 [8086:3a37]
Subsystem: Dell Device [1028:026d]
Kernel driver in use: uhci_hcd
Kernel modules: uhci_hcd
00:1a.1 USB controller [0c03]: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #5 [8086:3a38]
Subsystem: Dell Device [1028:026d]
Kernel driver in use: uhci_hcd
Kernel modules: uhci_hcd
00:1a.2 USB controller [0c03]: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #6 [8086:3a39]
Subsystem: Dell Device [1028:026d]
Kernel driver in use: uhci_hcd
Kernel modules: uhci_hcd
00:1a.7 USB controller [0c03]: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #2 [8086:3a3c]
Subsystem: Dell Device [1028:026d]
Kernel driver in use: ehci-pci
00:1b.0 Audio device [0403]: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller [8086:3a3e]
Subsystem: Dell Device [1028:026d]
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel
00:1c.0 PCI bridge [0604]: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 1 [8086:3a40]
Kernel driver in use: pcieport
00:1c.5 PCI bridge [0604]: Intel Corporation 82801JI (ICH10 Family) PCI Express Root Port 6 [8086:3a4a]

Kernel driver in use: pcieport
00:1d.0 USB controller [0c03]: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #1 [8086:3a34]
Subsystem: Dell Device [1028:026d]
Kernel driver in use: uhci_hcd
Kernel modules: uhci_hcd
00:1d.1 USB controller [0c03]: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #2 [8086:3a35]
Subsystem: Dell Device [1028:026d]
Kernel driver in use: uhci_hcd
Kernel modules: uhci_hcd
00:1d.2 USB controller [0c03]: Intel Corporation 82801JI (ICH10 Family) USB UHCI Controller #3 [8086:3a36]
Subsystem: Dell Device [1028:026d]
Kernel driver in use: uhci_hcd
Kernel modules: uhci_hcd
00:1d.7 USB controller [0c03]: Intel Corporation 82801JI (ICH10 Family) USB2 EHCI Controller #1 [8086:3a3a]
Subsystem: Dell Device [1028:026d]
Kernel driver in use: ehci-pci
00:1e.0 PCI bridge [0604]: Intel Corporation 82801 PCI Bridge [8086:244e] (rev 90)
00:1f.0 ISA bridge [0601]: Intel Corporation 82801JIR (ICH10R) LPC Interface Controller [8086:3a16]
Subsystem: Dell Device [1028:026d]
00:1f.2 SATA controller [0106]: Intel Corporation 82801JI (ICH10 Family) SATA AHCI Controller [8086:3a22]
Subsystem: Dell Device [1028:026d]
Kernel driver in use: ahci
Kernel modules: ahci

00:1f.3 SMBus [0c05]: Intel Corporation 82801JI (ICH10 Family) SMBus Controller [8086:3a30]
Subsystem: Dell Device [1028:026d]
01:00.0 PCI bridge [0604]: Pericom Semiconductor PCI Express to PCI-XPI7C9X130 PCI-X Bridge [12d8:e130] (rev 04)
04:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Redwood XT GL [FirePro V4800] [1002:68c8]
Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] Device [1002:240a]
04:00.1 Audio device [0403]: Advanced Micro Devices, Inc. [AMD/ATI] Redwood HDMI Audio [Radeon HD 5000 Series] [1002:aa60]
Subsystem: Advanced Micro Devices, Inc. [AMD/ATI] Redwood HDMI Audio [Radeon HD 5000 Series] [1002:aa60]
Kernel driver in use: snd_hda_intel
Kernel modules: snd_hda_intel

05:00.0 SCSI storage controller [0100]: LSI Logic / Symbios Logic SAS1068E PCI-Express Fusion-MPT SAS [1000:0058] (rev 08)
Subsystem: Dell SAS 6/iR Integrated Workstations RAID Controller [1028:021d]
Kernel driver in use: mptsas
Kernel modules: mptsas
06:00.0 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM5761 Gigabit Ethernet PCIe [14e4:1681] (rev 10)
Subsystem: Dell Device [1028:026d]
Kernel driver in use: tg3
Kernel modules: tg3

07:0a.0 FireWire (IEEE 1394) [0c00]: Texas Instruments TSB43AB22A IEEE-1394a-2000 Controller (PHY/Link) [iOHCI-Lynx] [104c:8023]
Subsystem: Dell Device [1028:026d]
20:03.0 PCI bridge [0604]: Intel Corporation 5520/5500/X58 I/O Hub PCI Express Root Port 3 [8086:340a] (rev 22)
Kernel driver in use: pcieport
20:07.0 PCI bridge [0604]: Intel Corporation 5520/5500/X58 I/O Hub PCI Express Root Port 7 [8086:340e] (rev 22)
Kernel driver in use: pcieport
20:09.0 PCI bridge [0604]: Intel Corporation 7500/5520/5500/X58 I/O Hub PCI Express Root Port 9 [8086:3410] (rev 22)
Kernel driver in use: pcieport
20:14.0 PIC [0800]: Intel Corporation 7500/5520/5500/X58 I/O Hub System Management Registers [8086:342e] (rev 22)
20:14.1 PIC [0800]: Intel Corporation 7500/5520/5500/X58 I/O Hub GPIO and Scratch Pad Registers [8086:3422] (rev 22)
20:14.2 PIC [0800]: Intel Corporation 7500/5520/5500/X58 I/O Hub Control Status and RAS Registers [8086:3423] (rev 22)
24:00.0 RAID bus controller [0104]: LSI Logic / Symbios Logic MegaRAID SAS 1078 [1000:0060] (rev 04)
Subsystem: Dell PERC 6/i Adapter RAID Controller [1028:1f0b]
Kernel driver in use: megaraid_sas
Kernel modules: megaraid_sas
3f:00.0 Host bridge [0600]: Intel Corporation Xeon 5600 Series QuickPath Architecture Generic Non-core Registers [8086:2c70] (rev 02)
Subsystem: Intel Corporation Device [8086:8086]
3f:00.1 Host bridge [0600]: Intel Corporation Xeon 5600 Series QuickPath Architecture System Address Decoder [8086:2d81] (rev 02)
Subsystem: Intel Corporation Device [8086:8086]
3f:02.0 Host bridge [0600]: Intel Corporation Xeon 5600 Series QPI Link 0 [8086:2d90] (rev 02)
Subsystem: Intel Corporation Device [8086:8086]
3f:02.1 Host bridge [0600]: Intel Corporation Xeon 5600 Series QPI Physical 0 [8086:2d91] (rev 02)
Subsystem: Intel Corporation Device [8086:8086]
3f:02.2 Host bridge [0600]: Intel Corporation Xeon 5600 Series Mirror Port Link 0 [8086:2d92] (rev 02)
Subsystem: Intel Corporation Device [8086:8086]
3f:02.3 Host bridge [0600]: Intel Corporation Xeon 5600 Series Mirror Port Link 1 [8086:2d93] (rev 02)
Subsystem: Intel Corporation Device [8086:8086]
3f:02.4 Host bridge [0600]: Intel Corporation Xeon 5600 Series QPI Link 1 [8086:2d94] (rev 02)
Subsystem: Intel Corporation Device [8086:8086]
3f:02.5 Host bridge [0600]: Intel Corporation Xeon 5600 Series QPI Physical 1 [8086:2d95] (rev 02)
Subsystem: Intel Corporation Device [8086:8086]
3f:03.0 Host bridge [0600]: Intel Corporation Xeon 5600 Series Integrated Memory Controller Registers [8086:2d98] (rev 02)
Subsystem: Intel Corporation Device [8086:8086]
3f:03.1 Host bridge [0600]: Intel Corporation Xeon 5600 Series Integrated Memory Controller Target Address Decoder [8086:2d99] (rev 02)
Subsystem: Intel Corporation Device [8086:8086]
3f:03.2 Host bridge [0600]: Intel Corporation Xeon 5600 Series Integrated Memory Controller RAS Registers [8086:2d9a] (rev 02)
Subsystem: Intel Corporation Device [8086:8086]
3f:03.4 Host bridge [0600]: Intel Corporation Xeon 5600 Series Integrated Memory Controller Test Registers [8086:2d9c] (rev 02)
Subsystem: Intel Corporation Device [8086:8086]
3f:04.0 Host bridge [0600]: Intel Corporation Xeon 5600 Series Integrated Memory Controller Channel 0 Control [8086:2da0] (rev 02)
Subsystem: Intel Corporation Device [8086:8086]
3f:04.1 Host bridge [0600]: Intel Corporation Xeon 5600 Series Integrated Memory Controller Channel 0 Address [8086:2da1] (rev 02)
Subsystem: Intel Corporation Device [8086:8086]
3f:04.2 Host bridge [0600]: Intel Corporation Xeon 5600 Series Integrated Memory Controller Channel 0 Rank [8086:2da2] (rev 02)
Subsystem: Intel Corporation Device [8086:8086]
3f:04.3 Host bridge [0600]: Intel Corporation Xeon 5600 Series Integrated Memory Controller Channel 0 Thermal Control [8086:2da3] (rev 02)
Subsystem: Intel Corporation Device [8086:8086]
3f:05.0 Host bridge [0600]: Intel Corporation Xeon 5600 Series Integrated Memory Controller Channel 1 Control [8086:2da8] (rev 02)
Subsystem: Intel Corporation Device [8086:8086]
3f:05.1 Host bridge [0600]: Intel Corporation Xeon 5600 Series Integrated Memory Controller Channel 1 Address [8086:2da9] (rev 02)
Subsystem: Intel Corporation Device [8086:8086]
3f:05.2 Host bridge [0600]: Intel Corporation Xeon 5600 Series Integrated Memory Controller Channel 1 Rank [8086:2daa] (rev 02)
Subsystem: Intel Corporation Device [8086:8086]
3f:05.3 Host bridge [0600]: Intel Corporation Xeon 5600 Series Integrated Memory Controller Channel 1 Thermal Control [8086:2dab] (rev 02)
Subsystem: Intel Corporation Device [8086:8086]
3f:06.0 Host bridge [0600]: Intel Corporation Xeon 5600 Series Integrated Memory Controller Channel 2 Control [8086:2db0] (rev 02)
Subsystem: Intel Corporation Device [8086:8086]
3f:06.1 Host bridge [0600]: Intel Corporation Xeon 5600 Series Integrated Memory Controller Channel 2 Address [8086:2db1] (rev 02)
Subsystem: Intel Corporation Device [8086:8086]
3f:06.2 Host bridge [0600]: Intel Corporation Xeon 5600 Series Integrated Memory Controller Channel 2 Rank [8086:2db2] (rev 02)
Subsystem: Intel Corporation Device [8086:8086]
3f:06.3 Host bridge [0600]: Intel Corporation Xeon 5600 Series Integrated Memory Controller Channel 2 Thermal Control [8086:2db3] (rev 02)
Subsystem: Intel Corporation Device [8086:8086]
livecd ~ #


I see the network card module there.

06:00.0 Ethernet controller [0200]: Broadcom Corporation NetXtreme BCM5761 Gigabit Ethernet PCIe [14e4:1681] (rev 10)
Subsystem: Dell Device [1028:026d]
Kernel driver in use: tg3
Kernel modules: tg3

And it is there, build with the kernel as a module. PCI ID I entered in the tool is 14e4:1681 but it does'nt really gives me anything.

Please let me know if I missed something and how this can be fixed. When I boot from the livecd, enp6s0 gets an dhcp ip and I am able to ssh, but the moment I boot it without the CD, enp6s0 gets disaapeared and sit0 interface comes up.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43755
Location: 56N 3W

PostPosted: Sun Aug 10, 2014 9:31 pm    Post subject: Reply with quote

manu_leo,

manu_leo wrote:
And it is there, build with the kernel as a module.

network drivers are one of the few modules not auto loaded.

Add tg3 to /etc/conf.d/modules or make tg3 built in.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
manu_leo
Guru
Guru


Joined: 20 Jan 2014
Posts: 457
Location: India

PostPosted: Mon Aug 11, 2014 3:58 am    Post subject: Reply with quote

Thanks Neddy for the info. Will try that and update the ticket accordingly.

Appreciate that,
Back to top
View user's profile Send private message
manu_leo
Guru
Guru


Joined: 20 Jan 2014
Posts: 457
Location: India

PostPosted: Mon Aug 11, 2014 4:45 pm    Post subject: Reply with quote

Hi Neddy, I applied the steps mentioned by you as follows :-

Booted the system using livecd

cd /usr/src/linux
make menuconfig

Here, I selected Network Driver as Broadcom and marked it as *. Then I selected Boradcom Tg3 driver and marked it with M.

Then, I did

make -j12 && make -j12 modules_install

Then I copied the bzImage to the appropriate file
cp arch/x86/boot/bzImage /boot/kernel-3.12.13-gentoo

Then configured the grub.

Is this the correct way to configure. I just want to be sure before I implement this.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43755
Location: 56N 3W

PostPosted: Mon Aug 11, 2014 4:50 pm    Post subject: Reply with quote

manu_leo,

If you made a separate /boot partition, you need to mount it before cp arch/x86/boot/bzImage /boot/kernel-3.12.13-gentoo
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
manu_leo
Guru
Guru


Joined: 20 Jan 2014
Posts: 457
Location: India

PostPosted: Mon Aug 11, 2014 4:53 pm    Post subject: Reply with quote

Yes Neddy, the mounting part is all done. After the mounting and then chrooting, I will perform the steps mentioned . I hope that is the correct sequence of doing it.
Back to top
View user's profile Send private message
NeddySeagoon
Administrator
Administrator


Joined: 05 Jul 2003
Posts: 43755
Location: 56N 3W

PostPosted: Mon Aug 11, 2014 5:28 pm    Post subject: Reply with quote

manu_leo,

Thats it.
_________________
Regards,

NeddySeagoon

Computer users fall into two groups:-
those that do backups
those that have never had a hard drive fail.
Back to top
View user's profile Send private message
manu_leo
Guru
Guru


Joined: 20 Jan 2014
Posts: 457
Location: India

PostPosted: Mon Aug 11, 2014 5:33 pm    Post subject: Reply with quote

Thanks Neddy, Jaglover, and everyone for your time and advice. The issue is now fixed. I followed the exact steps mentioned and that fixed the issue. I now see enp6s0 and sit0 interface both and I am able to connect to it externally using ssh.

Thanku everyone , Cheers !!, You guys rock.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum