Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]Need help with KDE installtion for VNC
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
manu_leo
Guru
Guru


Joined: 20 Jan 2014
Posts: 442
Location: India

PostPosted: Thu Aug 07, 2014 6:46 pm    Post subject: [SOLVED]Need help with KDE installtion for VNC Reply with quote

HI Experts, I need help in installing KDE on the gentoo server as I am not able to view the desktop using vnc. It is coming up with a grey screen with a cross. I have selected my profile to point at kde.

Newton ~ # eselect profile list
Available profile symlink targets:
[1] default/linux/amd64/13.0
[2] default/linux/amd64/13.0/selinux
[3] default/linux/amd64/13.0/desktop
[4] default/linux/amd64/13.0/desktop/gnome
[5] default/linux/amd64/13.0/desktop/gnome/systemd
[6] default/linux/amd64/13.0/desktop/kde *

Now when I doing, emerge --ask kdebase-meta, it is throwing up with bunch of error messages :-

[blocks B ] sys-fs/udev ("sys-fs/udev" is blocking sys-apps/systemd-212-r5, sys-apps/gentoo-systemd-integration-4)
[blocks B ] sys-apps/gentoo-systemd-integration ("sys-apps/gentoo-systemd-i ntegration" is blocking sys-fs/udev-212-r1)
[blocks B ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/udev-21 2-r1)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-libs/zlib:0

(sys-libs/zlib-1.2.8-r1::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(sys-libs/zlib-1.2.8-r1::gentoo, ebuild scheduled for merge) pulled in by
>=sys-libs/zlib-1.2.5.1-r2:0[minizip] required by (dev-db/virtuoso-server-6. 1.6::gentoo, ebuild scheduled for merge)

dev-libs/libxml2:2

(dev-libs/libxml2-2.9.1-r4::gentoo, ebuild scheduled for merge) pulled in by
dev-libs/libxml2[python,python_targets_python2_7(-),python_single_target_pyt hon2_7(+)] required by (media-libs/mesa-10.0.4::gentoo, ebuild scheduled for mer ge)

(dev-libs/libxml2-2.9.1-r4::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)


!!! Enabling --newuse and --update might solve this conflict.
!!! If not, it might help emerge to give a more specific suggestion.


* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(sys-fs/udev-212-r1::gentoo, installed) pulled in by
>=sys-fs/udev-208-r1:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_m ips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_ s390_32(-)?,abi_s390_64(-)?,static-libs?] (>=sys-fs/udev-208-r1:0/0[abi_x86_64(- )]) required by (virtual/libudev-208::gentoo, installed)
>=sys-fs/udev-208 required by (virtual/udev-208-r2::gentoo, installed)

(sys-apps/systemd-212-r5::gentoo, ebuild scheduled for merge) pulled in by
>=sys-apps/systemd-212-r5:0/2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?, abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)? ,abi_s390_32(-)?,abi_s390_64(-)?,gudev,introspection?,static-libs(-)?] (>=sys-ap ps/systemd-212-r5:0/2[abi_x86_64(-),gudev,introspection]) required by (virtual/l ibgudev-208::gentoo, ebuild scheduled for merge)
>=sys-apps/systemd-207 required by (sys-apps/gentoo-systemd-integration-4::g entoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


please help me in getting this resolved. Appreciate all your help.


Last edited by manu_leo on Fri Aug 08, 2014 9:03 am; edited 1 time in total
Back to top
View user's profile Send private message
Cyker
Veteran
Veteran


Joined: 15 Jun 2006
Posts: 1746

PostPosted: Thu Aug 07, 2014 7:27 pm    Post subject: Reply with quote

I think changing your profile has changed a lot of useflags which will really screw up portage.

The simplest thing is try putting your profile back to what it was before, then try it again.

Otherwise, you will likely have to recompile large chunks of your system before you can even think about emerging something as complex as kde!
Back to top
View user's profile Send private message
manu_leo
Guru
Guru


Joined: 20 Jan 2014
Posts: 442
Location: India

PostPosted: Fri Aug 08, 2014 3:27 am    Post subject: Reply with quote

Thanks for looking into this. I have set the profile back to what it was

Newton ~ # eselect profile list
Available profile symlink targets:
[1] default/linux/amd64/13.0
[2] default/linux/amd64/13.0/selinux
[3] default/linux/amd64/13.0/desktop
[4] default/linux/amd64/13.0/desktop/gnome
[5] default/linux/amd64/13.0/desktop/gnome/systemd
[6] default/linux/amd64/13.0/desktop/kde
[7] default/linux/amd64/13.0/desktop/kde/systemd
[8] default/linux/amd64/13.0/developer
[9] default/linux/amd64/13.0/no-multilib *


Now, when I do emege, i get the below message :-

Newton ~ # emerge --ask kdebase-meta

* IMPORTANT: 6 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! The ebuild selected to satisfy ">=kde-base/kwin-4.11:4[aqua=]" has unmet req uirements.
- kde-base/kwin-4.11.9::gentoo USE="(-aqua) -debug -gles -opengl -wayland"

The following REQUIRED_USE flag constraints are unsatisfied:
!opengl? ( gles ) !gles? ( opengl )

The above constraints are a subset of the following complete expression:
!opengl? ( gles ) !gles? ( opengl ) wayland? ( gles )

(dependency required by "kde-base/kdebase-meta-4.12.5" [ebuild])
(dependency required by "kdebase-meta" [argument])


Appreciate all your help in getting this resolved for me.
Back to top
View user's profile Send private message
wraeth
Developer
Developer


Joined: 08 May 2007
Posts: 71
Location: Australia

PostPosted: Fri Aug 08, 2014 3:35 am    Post subject: Reply with quote

The reason you are getting a simple grey screen with a cross is because you don't have a desktop environment installed - you're viewing pure Xorg server with nothing running. Give that you're trying to install KDE, I guess you already suspect that.

I would recommend against installing KDE, though, particularly if this is on a server. KDE is a very large desktop environment, and is designed more for a desktop machine rather than server. You may want to consider something more lightweight like XFCE or LXDE, which are designed specifically to be lightweight and are well suited for server environments.
Back to top
View user's profile Send private message
manu_leo
Guru
Guru


Joined: 20 Jan 2014
Posts: 442
Location: India

PostPosted: Fri Aug 08, 2014 4:50 am    Post subject: Reply with quote

Thanks a lot for guiding me. I completely got your point, here is what I have tried :-

Newton ~ # emerge --ask xfce

* IMPORTANT: 6 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "xfce".

emerge: searching for similar names...
emerge: Maybe you meant any of these: x11-misc/xfe, media-video/cxfe, games-arcade/xsfcave?
Newton ~ # emerge --ask lxde

* IMPORTANT: 6 news items need reading for repository 'gentoo'.
* Use eselect news to read news items.


These are the packages that would be merged, in order:

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "lxde".

emerge: searching for similar names...
emerge: Maybe you meant any of these: sys-fs/lde, lxde-base/lxdm, games-emulation/lxdream?


Is there any packages out of these which I need to emerge in order to get this installed ?

Thanks.
Back to top
View user's profile Send private message
wraeth
Developer
Developer


Joined: 08 May 2007
Posts: 71
Location: Australia

PostPosted: Fri Aug 08, 2014 4:53 am    Post subject: Reply with quote

The wiki pages I linked above suggest
Code:
emerge --ask xfce4-meta xfce4-notifyd

for installing XFCE and
Code:
emerge -av lxde-meta

for installing LXDE.
Back to top
View user's profile Send private message
manu_leo
Guru
Guru


Joined: 20 Jan 2014
Posts: 442
Location: India

PostPosted: Fri Aug 08, 2014 5:15 am    Post subject: Reply with quote

Thanks, so here what I have done so far :-

I tried emerge --ask xfce4-meta, and got the message that following USE flags are required. So I made an entry as below :-

vim /etc/portage/make.conf
USE="-gnome -kde -minimal -qt4 dbus jpeg lock session startup-notification thunar udev X"
Esc:wq!

Now when I do ,
# emerge --ask xfce4-meta
The following USE changes are necessary to proceed:
(see "package.use" in the portage(5) man page for more details)
# required by gnome-base/gvfs-1.18.3-r1[udev]
# required by xfce-base/thunar-1.6.3[udev]
# required by xfce-base/xfdesktop-4.10.2[thunar]
# required by xfce-base/xfce4-meta-4.10
# required by xfce4-meta (argument)
>=virtual/udev-208-r2 gudev
# required by virtual/libgudev-208
# required by sys-fs/udisks-2.1.3
# required by gnome-base/gvfs-1.18.3-r1[udisks]
# required by xfce-base/thunar-1.6.3[udev]
# required by xfce-base/xfdesktop-4.10.2[thunar]
# required by xfce-base/xfce4-meta-4.10
# required by xfce4-meta (argument)
=sys-fs/udev-212-r1 gudev
# required by sys-auth/polkit-0.112-r1[-systemd]
# required by sys-fs/udisks-2.1.3
# required by gnome-base/gvfs-1.18.3-r1[udisks]
# required by xfce-base/thunar-1.6.3[udev]
# required by xfce-base/xfdesktop-4.10.2[thunar]
# required by xfce-base/xfce4-meta-4.10
# required by xfce4-meta (argument)
>=sys-auth/consolekit-0.4.6 policykit
# required by xfce-base/thunar-1.6.3[udev]
# required by xfce-base/xfdesktop-4.10.2[thunar]
# required by xfce-base/xfce4-meta-4.10
# required by xfce4-meta (argument)
=gnome-base/gvfs-1.18.3-r1 udisks

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.


So in order to get this fixed, I made an entry as below :-

cat /etc/portage/package.use

virtual/udev-208-r2 gudev
sys-fs/udev-212-r1 gudev
sys-auth/consolekit-0.4.6 policykit
gnome-base/gvfs-1.18.3-r1 udisks
Esc:wq!

Now , when I try emerge again, I get the below message :-

Newton ~ # emerge --ask xfce4-meta
--- Invalid atom in /etc/portage/package.use: sys-fs/udev-212-r1
--- Invalid atom in /etc/portage/package.use: gnome-base/gvfs-1.18.3-r1
--- Invalid atom in /etc/portage/package.use: virtual/udev-208-r2

The following USE changes are necessary to proceed:
(see "package.use" in the portage(5) man page for more details)
# required by gnome-base/gvfs-1.18.3-r1[udev]
# required by xfce-base/thunar-1.6.3[udev]
# required by xfce-base/xfdesktop-4.10.2[thunar]
# required by xfce-base/xfce4-meta-4.10
# required by xfce4-meta (argument)
>=virtual/udev-208-r2 gudev
# required by virtual/libgudev-208
# required by sys-fs/udisks-2.1.3
# required by gnome-base/gvfs-1.18.3-r1[udisks]
# required by xfce-base/thunar-1.6.3[udev]
# required by xfce-base/xfdesktop-4.10.2[thunar]
# required by xfce-base/xfce4-meta-4.10
# required by xfce4-meta (argument)
=sys-fs/udev-212-r1 gudev
# required by sys-auth/polkit-0.112-r1[-systemd]
# required by sys-fs/udisks-2.1.3
# required by gnome-base/gvfs-1.18.3-r1[udisks]
# required by xfce-base/thunar-1.6.3[udev]
# required by xfce-base/xfdesktop-4.10.2[thunar]
# required by xfce-base/xfce4-meta-4.10
# required by xfce4-meta (argument)
>=sys-auth/consolekit-0.4.6 policykit
# required by xfce-base/thunar-1.6.3[udev]
# required by xfce-base/xfdesktop-4.10.2[thunar]
# required by xfce-base/xfce4-meta-4.10
# required by xfce4-meta (argument)
=gnome-base/gvfs-1.18.3-r1 udisks

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.


Thanks for all your help and patience.
Back to top
View user's profile Send private message
wraeth
Developer
Developer


Joined: 08 May 2007
Posts: 71
Location: Australia

PostPosted: Fri Aug 08, 2014 5:24 am    Post subject: Reply with quote

manu_leo wrote:
virtual/udev-208-r2 gudev
sys-fs/udev-212-r1 gudev
sys-auth/consolekit-0.4.6 policykit
gnome-base/gvfs-1.18.3-r1 udisks

These are not valid package atoms. You need to either specify the package itself with no version, or a specific version prefixed with an '='.

For example:
Code:
virtual/udev gudev
sys-fs/udev gudev
sys-auth/consolekit policykit
gnome-base/gvfs udisks

will apply those use flag changes to all versions of those packages; or alternatively

Code:
=virtual/udev-208-r2 gudev
=sys-fs/udev-212-r1 gudev
=sys-auth/consolekit-0.4.6 policykit
=gnome-base/gvfs-1.18.3-r1 udisks

will apply those use flags to only those specific versions, meaning when they need to be updated, you will be prompted to re-set those use flags.
Back to top
View user's profile Send private message
manu_leo
Guru
Guru


Joined: 20 Jan 2014
Posts: 442
Location: India

PostPosted: Fri Aug 08, 2014 6:50 am    Post subject: Reply with quote

You are the man !! thank you so much for helping me out with this.

I am done with the xfce4-meta installation, but still when I try to connect to the server via vnc (tight vnc), I see a grey screen with an X. I believe we need to tell the vnc to use xfce to display ? please correct me if I am wrong.

I have configured the vnc under the config file /etc/conf.d/vnc as :-

cat /etc/conf.d/vnc
DISPLAYS="vnc:1"
VNC_OPTS="-name Remote_WM -geometry 800x600 -depth 24"

vnc@Newton ~ $ cat ~/.vnc/xstartup
#!/bin/sh

[ -x /etc/vnc/xstartup ] && exec /etc/vnc/xstartup
vncconfig -iconic &
xterm -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" &
gnome-session &


Thanks again for all the great help.
Back to top
View user's profile Send private message
wraeth
Developer
Developer


Joined: 08 May 2007
Posts: 71
Location: Australia

PostPosted: Fri Aug 08, 2014 7:00 am    Post subject: Reply with quote

You may want something like this in your ~/.vnc/xstartup:
Code:
exec startxfce4 --with-ck-launch

Note that this code snippet is based on you having consolekit installed (based on your earlier post mentioning setting a useflag for consolekit).

Otherwise, have a look at the wiki for ways to start it.
Back to top
View user's profile Send private message
manu_leo
Guru
Guru


Joined: 20 Jan 2014
Posts: 442
Location: India

PostPosted: Fri Aug 08, 2014 7:39 am    Post subject: Reply with quote

Thank you very much wraeth''. I am now able to launch the vnc and open firefox in it. You are the man and honestly appreciate all your help in getting things up.
Back to top
View user's profile Send private message
wraeth
Developer
Developer


Joined: 08 May 2007
Posts: 71
Location: Australia

PostPosted: Fri Aug 08, 2014 8:49 am    Post subject: Reply with quote

I was happy to help, and glad you got it working.

Since this is resolved, can you edit your first post and add "[SOLVED]" to the start of the subject.

Enjoy!
Back to top
View user's profile Send private message
manu_leo
Guru
Guru


Joined: 20 Jan 2014
Posts: 442
Location: India

PostPosted: Fri Aug 08, 2014 9:04 am    Post subject: Reply with quote

Done, and appreciate all your help again.

Cheers!!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum