Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
perl upgrade slot conflict
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1593

PostPosted: Wed Aug 06, 2014 12:17 pm    Post subject: perl upgrade slot conflict Reply with quote

I'm trying to upgrade to perl 5.18. I get lots of slot conflict.

Code:
 emerge -pv --backtrack=30 perl

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] dev-lang/perl-5.18.2-r1:0/5.18 [5.16.3:0/5.16] USE="berkdb gdbm -debug -doc -ithreads" 13,746 kB

Total: 1 package (1 upgrade), Size of downloads: 13,746 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.18.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.18* required by (virtual/perl-Module-Build-0.400.300-r1::gentoo, installed)
    (and 28 more with the same problem)

  (dev-lang/perl-5.16.3::gentoo, installed) pulled in by
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/ExtUtils-Command-1.170.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/DBI-1.623.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/IPC-Cmd-0.780.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Archive-Tar-1.900.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-SSLeay-1.550::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Digest-SHA-5.820.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Digest-1.170.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Negotiate-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/CPAN-Meta-YAML-0.8.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Cairo-1.103.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-Daemon-0.480.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Pango-1.224.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-vcs/git-1.8.5.5::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Time-Local-1.230.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Digest-MD5-2.520.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/ExtUtils-Manifest-1.610.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/JSON-PP-2.272.0-r1::gentoo, installed)
    =dev-lang/perl-5.16* required by (virtual/perl-Version-Requirements-0.101.22::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Storable-2.390.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/gtk2-perl-1.247.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Params-Check-0.360.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-HTTP-6.60.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/version-0.990.100-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Parse-CPAN-Meta-1.440.400-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/DateManip-6.410.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Geo-IP-1.420.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/CPAN-Meta-2.120.921-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Sys-Syslog-0.320.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/extutils-depends-0.306.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Encode-2.470.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/URI-1.600.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/IO-Socket-SSL-1.953.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Module-Metadata-1.0.11-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Cookies-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/glib-perl-1.301.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/IO-1.25-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Perl-OSType-1.2.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Module-Build-0.400.300-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/libwww-perl-6.50.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/pcsc-perl-1.4.13-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Error-0.170.210::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/CPAN-Meta-Requirements-2.122.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/PlRPC-0.202.0-r2::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/XML-Parser-2.410.0-r2::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/WWW-RobotRules-6.20.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/ExtUtils-ParseXS-3.180.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/MIME-Base64-3.130.0-r1::gentoo, installed)
    (and 3 more with the same problems)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.



I tried few approaches but it didn't help. How can I solve this issue
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Wed Aug 06, 2014 12:43 pm    Post subject: Reply with quote

Going by that list (though it would be good to know those "3 more"), you need to ad virtual/perl-Version-Requirements to the line.
Well, that is unless that virtual went away in 5.18.
Back to top
View user's profile Send private message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1593

PostPosted: Wed Aug 06, 2014 12:59 pm    Post subject: Reply with quote

VoidMage wrote:
Going by that list (though it would be good to know those "3 more"), you need to ad virtual/perl-Version-Requirements to the line.
Well, that is unless that virtual went away in 5.18.


Code:
eix virtual/perl-Version-Requirements
[I] virtual/perl-Version-Requirements
     Available versions:  0.101.22
     Installed versions:  0.101.22(01:35:42 AM 08/06/2014)
     Description:         Virtual for Version-Requirements


It's installed. So how do I know what are the "3 more" ?
Back to top
View user's profile Send private message
dataking
Apprentice
Apprentice


Joined: 20 Apr 2005
Posts: 246

PostPosted: Wed Aug 06, 2014 4:56 pm    Post subject: Reply with quote

Every time I've run into this issue, it's required me to uninstall the things pulling in perl 5.16, then reinstall them afterwards (if I thought they were important/needed). My list has been considerably shorter, however.
_________________
-= the D@7@k|n& =-
Back to top
View user's profile Send private message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1593

PostPosted: Wed Aug 06, 2014 6:01 pm    Post subject: Reply with quote

Here is the output of the perl related packages that need to be updated.
In one of the outputs it was written that Pod-Simple Test-simple can break the system. Somehow related to perl 5.20. So I didn't try to emerge these packages. Someone knows anything about it?

So, which packages, I should emerge first? It's weird that I get so many slot conflicts and portage doesn't manage to solve it.
I usually emerge few packages at a time, and then try again to emerge perl. I already emerged in this way about 10 packages.

Code:
 eix -I perl-core/ |grep U
[I] perl-core/ExtUtils-CBuilder
     Homepage:            http://search.cpan.org/dist/ExtUtils-CBuilder/
[I] perl-core/ExtUtils-Command
     Homepage:            http://search.cpan.org/dist/ExtUtils-Command/
     Description:         Utilities to replace common UNIX commands in Makefiles etc
[I] perl-core/ExtUtils-MakeMaker
     Homepage:            http://makemaker.org http://search.cpan.org/dist/ExtUtils-MakeMaker/
[I] perl-core/ExtUtils-Manifest
     Homepage:            http://search.cpan.org/dist/ExtUtils-Manifest/
     Description:         Utilities to write and check a MANIFEST file
[I] perl-core/ExtUtils-ParseXS
     Homepage:            http://search.cpan.org/dist/ExtUtils-ParseXS/
[I] perl-core/Scalar-List-Utils
     Homepage:            http://search.cpan.org/dist/Scalar-List-Utils/
     Description:         Scalar-List-Utils module for perl
[U] perl-core/Test-Simple


Code:
 eix -I dev-perl/ |grep U
     Description:         Use the Freedesktop.org base directory specification
     Description:         Provide https support for LWP::UserAgent
     Description:         A Perl module for accessing the GNU locale utilities
[I] dev-perl/Text-Unidecode
     Homepage:            http://search.cpan.org/dist/Text-Unidecode/
     Description:         US-ASCII transliterations of Unicode text
[I] dev-perl/URI
     Homepage:            http://search.cpan.org/dist/URI/
     Description:         A URI Perl Module
[I] dev-perl/Unicode-EastAsianWidth
     Homepage:            http://search.cpan.org/dist/Unicode-EastAsianWidth/
     Homepage:            http://search.cpan.org/dist/ExtUtils-Depends/
     Homepage:            http://search.cpan.org/dist/ExtUtils-PkgConfig/
     Description:         High-Level Interface to Uniforum Message Translation


Code:
eix -I virtual/perl |grep U
[U] virtual/perl-Digest
[U] virtual/perl-Encode
[U] virtual/perl-ExtUtils-CBuilder
     Description:         Virtual for ExtUtils-CBuilder
[I] virtual/perl-ExtUtils-Command
     Description:         Virtual for ExtUtils-Command
[U] virtual/perl-ExtUtils-Install
     Description:         Virtual for ExtUtils-Install
[U] virtual/perl-ExtUtils-MakeMaker
     Description:         Virtual for ExtUtils-MakeMaker
[U] virtual/perl-ExtUtils-Manifest
     Description:         Virtual for ExtUtils-Manifest
[I] virtual/perl-ExtUtils-ParseXS
     Description:         Virtual for ExtUtils-ParseXS
[U] virtual/perl-File-Temp
[U] virtual/perl-Getopt-Long
[U] virtual/perl-IO
[U] virtual/perl-IPC-Cmd
[U] virtual/perl-JSON-PP
[U] virtual/perl-Module-CoreList
[U] virtual/perl-Perl-OSType
[U] virtual/perl-Pod-Simple
[I] virtual/perl-Scalar-List-Utils
     Description:         Virtual for Scalar::Util and List::Util, also distributed as Scalar::List::Utils
[U] virtual/perl-Storable
[U] virtual/perl-version

[code]
Back to top
View user's profile Send private message
dataking
Apprentice
Apprentice


Joined: 20 Apr 2005
Posts: 246

PostPosted: Wed Aug 06, 2014 6:33 pm    Post subject: Reply with quote

Your regex isn't quite specific enough.

Try
Code:
eix -I perl-core/ | grep "^\[U\]"

Code:
eix -I dev-perl/ | grep "^\[U\]"

Code:
eix -I virtual-perl/ | grep "^\[U\]"

_________________
-= the D@7@k|n& =-
Back to top
View user's profile Send private message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1593

PostPosted: Wed Aug 06, 2014 7:06 pm    Post subject: Reply with quote

dataking wrote:
Your regex isn't quite specific enough.

Try
Code:
eix -I perl-core/ | grep "^\[U\]"

Code:
eix -I dev-perl/ | grep "^\[U\]"

Code:
eix -I virtual-perl/ | grep "^\[U\]"


Code:
eix -I perl-core/ | grep "^\[U\]"
[U] perl-core/Test-Simple

Code:
eix -I dev-perl/ | grep "^\[U\]"
doesn't give anything to update.
Code:
eix -I virtual-perl/ | grep "^\[U\]"
is not correct, because there is no such thing as virtual-perl but virtual/perl.

Code:

 eix -I virtual/perl | grep "^\[U\]"
[U] virtual/perl-Digest
[U] virtual/perl-Encode
[U] virtual/perl-ExtUtils-CBuilder
[U] virtual/perl-ExtUtils-Install
[U] virtual/perl-ExtUtils-MakeMaker
[U] virtual/perl-ExtUtils-Manifest
[U] virtual/perl-File-Temp
[U] virtual/perl-Getopt-Long
[U] virtual/perl-IO
[U] virtual/perl-IPC-Cmd
[U] virtual/perl-JSON-PP
[U] virtual/perl-Module-CoreList
[U] virtual/perl-Perl-OSType
[U] virtual/perl-Pod-Simple
[U] virtual/perl-Storable
[U] virtual/perl-version


Here is some more slot conflicts. I am not sure what I need: perl-core/Storable or virtual/perl-Storable?

Code:
emerge perl-Digest perl-Encode perl-version perl-StorableCalculating dependencies... done!
[ebuild     U  ] dev-lang/perl-5.18.2-r1 [5.16.3]
[ebuild     U  ] virtual/perl-Encode-2.490.0-r2 [2.470.0]
[ebuild     U  ] virtual/perl-Storable-2.410.0-r1 [2.390.0]
[ebuild     U  ] virtual/perl-Digest-1.170.0-r3 [1.170.0-r1]
[ebuild     U  ] virtual/perl-version-0.990.200-r1 [0.990.100]
[blocks B      ] <perl-core/Storable-2.410.0 ("<perl-core/Storable-2.410.0" is blocking virtual/perl-Storable-2.410.0-r1)
[blocks B      ] <perl-core/Encode-2.490.0 ("<perl-core/Encode-2.490.0" is blocking virtual/perl-Encode-2.490.0-r2)
[blocks B      ] <perl-core/version-0.990.200 ("<perl-core/version-0.990.200" is blocking virtual/perl-version-0.990.200-r1)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.18.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.18* required by (virtual/perl-IO-Zlib-1.100.0-r4::gentoo, installed)
    (and 32 more with the same problem)

  (dev-lang/perl-5.16.3::gentoo, installed) pulled in by
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Cookies-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/CPAN-Meta-YAML-0.8.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/ExtUtils-ParseXS-3.180.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/gtk2-perl-1.247.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-SSLeay-1.550::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Cairo-1.103.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Module-Build-0.400.300-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/version-0.990.100-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/IO-Socket-SSL-1.953.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Digest-MD5-2.520.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Digest-1.170.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Perl-OSType-1.2.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-Daemon-0.480.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/IPC-Cmd-0.780.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/XML-Parser-2.410.0-r2::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-vcs/git-1.8.5.5::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Pango-1.224.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Module-Metadata-1.0.11-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/glib-perl-1.301.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/DateManip-6.410.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/PlRPC-0.202.0-r2::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Encode-2.470.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Sys-Syslog-0.320.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/CPAN-Meta-2.120.921-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/IO-1.25-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Parse-CPAN-Meta-1.440.400-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Geo-IP-1.420.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/extutils-depends-0.306.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/libwww-perl-6.50.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/MIME-Base64-3.130.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Negotiate-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Storable-2.390.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/URI-1.600.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Params-Check-0.360.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Digest-SHA-5.820.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/DBI-1.623.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/ExtUtils-Command-1.170.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/CPAN-Meta-Requirements-2.122.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Archive-Tar-1.900.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/ExtUtils-Manifest-1.610.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Time-Local-1.230.0-r1::gentoo, installed)
    =dev-lang/perl-5.16* required by (virtual/perl-File-Temp-0.220.0-r3::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-HTTP-6.60.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/WWW-RobotRules-6.20.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/pcsc-perl-1.4.13-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Error-0.170.210::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/JSON-PP-2.272.0-r1::gentoo, installed)
    (and 3 more with the same problems)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (virtual/perl-Encode-2.490.0-r2::gentoo, ebuild scheduled for merge) pulled in by
    perl-Encode
    virtual/perl-Encode required by @selected
    >=virtual/perl-Encode-2.12 required by (dev-perl/HTTP-Message-6.30.0::gentoo, installed)
    =virtual/perl-Encode-2.490.0-r2 required by (dev-perl/HTTP-Message-6.30.0::gentoo, installed)

  (perl-core/Encode-2.470.0-r1::gentoo, installed) pulled in by
    perl-core/Encode required by @selected

  (perl-core/version-0.990.100-r1::gentoo, installed) pulled in by
    perl-core/version required by @selected

  (virtual/perl-Storable-2.410.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    perl-Storable
    >=virtual/perl-Storable-1.0.7 required by (dev-perl/PlRPC-0.202.0-r2::gentoo, installed)
    =virtual/perl-Storable-2.410.0-r1 required by (dev-perl/PlRPC-0.202.0-r2::gentoo, installed)
    virtual/perl-Storable required by @selected
    =virtual/perl-Storable-2.410.0-r1 required by (dev-perl/DateManip-6.410.0::gentoo, installed)
    virtual/perl-Storable required by (dev-perl/DateManip-6.410.0::gentoo, installed)

  (virtual/perl-version-0.990.200-r1::gentoo, ebuild scheduled for merge) pulled in by
    =virtual/perl-version-0.990.200-r1 required by (perl-core/CPAN-Meta-Requirements-2.122.0-r1::gentoo, installed)
    >=virtual/perl-version-0.82 required by (perl-core/CPAN-Meta-2.120.921-r1::gentoo, installed)
    >=virtual/perl-version-0.87 required by (perl-core/Module-Build-0.400.300-r1::gentoo, installed)
    =virtual/perl-version-0.990.200-r1 required by (perl-core/Module-Metadata-1.0.11-r1::gentoo, installed)
    =virtual/perl-version-0.990.200-r1 required by (perl-core/Module-Build-0.400.300-r1::gentoo, installed)
    perl-version
    >=virtual/perl-version-0.77 required by (perl-core/CPAN-Meta-Requirements-2.122.0-r1::gentoo, installed)
    virtual/perl-version required by @selected
    =virtual/perl-version-0.990.200-r1 required by (perl-core/CPAN-Meta-2.120.921-r1::gentoo, installed)
    >=virtual/perl-version-0.870 required by (perl-core/Module-Metadata-1.0.11-r1::gentoo, installed)

  (perl-core/Storable-2.390.0-r1::gentoo, installed) pulled in by
    perl-core/Storable required by @selected


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked
Back to top
View user's profile Send private message
dataking
Apprentice
Apprentice


Joined: 20 Apr 2005
Posts: 246

PostPosted: Wed Aug 06, 2014 7:16 pm    Post subject: Reply with quote

queen wrote:

Code:
eix -I perl-core/ | grep "^\[U\]"
[U] perl-core/Test-Simple

Code:
eix -I dev-perl/ | grep "^\[U\]"
doesn't give anything to update.

Then there's nothing to update.
queen wrote:

Code:
eix -I virtual-perl/ | grep "^\[U\]"
is not correct, because there is no such thing as virtual-perl but virtual/perl.

Code:

 eix -I virtual/perl | grep "^\[U\]"
[U] virtual/perl-Digest
[U] virtual/perl-Encode
[U] virtual/perl-ExtUtils-CBuilder
[U] virtual/perl-ExtUtils-Install
[U] virtual/perl-ExtUtils-MakeMaker
[U] virtual/perl-ExtUtils-Manifest
[U] virtual/perl-File-Temp
[U] virtual/perl-Getopt-Long
[U] virtual/perl-IO
[U] virtual/perl-IPC-Cmd
[U] virtual/perl-JSON-PP
[U] virtual/perl-Module-CoreList
[U] virtual/perl-Perl-OSType
[U] virtual/perl-Pod-Simple
[U] virtual/perl-Storable
[U] virtual/perl-version

You are correct here. I missed that particular detail.

The difference in the regex is that yours greps anything with the character class "U". So you were getting packages that didn't actually need to be updated.
_________________
-= the D@7@k|n& =-
Back to top
View user's profile Send private message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1593

PostPosted: Wed Aug 06, 2014 7:33 pm    Post subject: Reply with quote

Ok. But what I need?

perl-core/Storable or virtual/perl-Storable ?
Back to top
View user's profile Send private message
Navar
Guru
Guru


Joined: 20 Aug 2012
Posts: 353

PostPosted: Wed Aug 06, 2014 7:52 pm    Post subject: Reply with quote

queen wrote:
Ok. But what I need? perl-core/Storable or virtual/perl-Storable ?

Both. Revisions of one (the virtuals) seem to be causing blocks of the related core.

Presuming you do not have perl packages in your world file,

Have you tried emerge -1auD $(qlist -IC 'virtual/perl-*') to update the virtual packages first and then re-tried perl-cleaner --all?
Back to top
View user's profile Send private message
dataking
Apprentice
Apprentice


Joined: 20 Apr 2005
Posts: 246

PostPosted: Wed Aug 06, 2014 7:53 pm    Post subject: Reply with quote

queen wrote:
Ok. But what I need?

perl-core/Storable or virtual/perl-Storable ?


Both actually, assuming I'm understanding correctly. I have both installed on my system.

I think you're getting the blockage because virtual/perl-Storable (and other virtuals) is expecting perl 5.16 internally. As stated earlier, I usually resolve these conflicts by uninstalling the virtuals, update perl, then re-emerge the virtuals. Once you have perl 5.18 installed, you should get the virtuals associated with perl 5.18.
_________________
-= the D@7@k|n& =-
Back to top
View user's profile Send private message
dataking
Apprentice
Apprentice


Joined: 20 Apr 2005
Posts: 246

PostPosted: Wed Aug 06, 2014 7:55 pm    Post subject: Reply with quote

Navar wrote:

Have you tried emerge -1auD $(qlist -IC 'virtual/perl-*') to update the virtual packages first and then re-tried perl-cleaner --all?

This might work too, and save you all the unmerging and remerging.
_________________
-= the D@7@k|n& =-
Back to top
View user's profile Send private message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1593

PostPosted: Wed Aug 06, 2014 8:46 pm    Post subject: Reply with quote

dataking wrote:
Navar wrote:

Have you tried emerge -1auD $(qlist -IC 'virtual/perl-*') to update the virtual packages first and then re-tried perl-cleaner --all?

This might work too, and save you all the unmerging and remerging.



I didn't try it yet. I ran now the command you suggested with pretend flag to see what it will give me. It still throws slot conflicts. Probably, I will have to uninistall everything related to virtual.

Code:
 emerge -1auDpv $(qlist -IC 'virtual/perl-*')

These are the packages that would be merged, in order:

Calculating dependencies... done!

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.18.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.18* required by (virtual/perl-Getopt-Long-2.390.0-r1::gentoo, ebuild scheduled for merge)
    (and 12 more with the same problem)

  (dev-lang/perl-5.16.3::gentoo, installed) pulled in by
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Archive-Tar-1.900.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Compress-Raw-Zlib-2.60.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Test-Harness-3.260.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Module-Metadata-1.0.11-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/ExtUtils-ParseXS-3.180.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Digest-MD5-2.520.0-r1::gentoo, installed)
    =dev-lang/perl-5.16* required by (virtual/perl-ExtUtils-Command-1.170.0-r5::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Scalar-List-Utils-1.270.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/CPAN-Meta-YAML-0.8.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Module-Load-0.240.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/CPAN-Meta-Requirements-2.122.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/XML-Parser-2.410.0-r2::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Compress-Raw-Bzip2-2.60.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Module-Build-0.400.300-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/IO-Compress-2.60.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Digest-SHA-5.820.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Module-Load-Conditional-0.540.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Params-Check-0.360.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Parse-CPAN-Meta-1.440.400-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/File-Spec-3.400.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/CPAN-Meta-2.120.921-r1::gentoo, installed)
    (and 7 more with the same problems)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


!!! All ebuilds that could satisfy "=dev-lang/perl-5.20*" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-lang/perl-5.20.0-r1::gentoo (masked by: package.mask, ~amd64 keyword)
/usr/portage/profiles/package.mask:
# Vladimir Smirnov <civil@gentoo.org> (27 May 2014)
# Masked for testing, will defenitely cause major breakage
# Single modules with 5.20 versions added here too -dilfridge


(dependency required by "virtual/perl-Pod-Simple-3.280.0-r1" [ebuild])
(dependency required by "virtual/perl-Pod-Simple" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


Now it throws that it can break the system. Why it throws about version 5.20 at all?

Do I need to uninstall all the installed [I] and needed upgrades [U] of virtual/perl or just those that are [U]? If it's both, then it's a list of 30 packages.
Back to top
View user's profile Send private message
Navar
Guru
Guru


Joined: 20 Aug 2012
Posts: 353

PostPosted: Wed Aug 06, 2014 9:04 pm    Post subject: Reply with quote

queen wrote:
Now it throws that it can break the system. Why it throws about version 5.20 at all?

I get exactly your output when trying to emerge >5.18, since 5.20 is currently hardmasked. Do you have perl '**' keyworded somewhere? (e.g. grep -i perl -R /etc/portage/*)

Maybe heed developer advice and avoid 5.20 unless you want testing environment with breakage.
Back to top
View user's profile Send private message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1593

PostPosted: Wed Aug 06, 2014 9:45 pm    Post subject: Reply with quote

Navar wrote:
queen wrote:
Now it throws that it can break the system. Why it throws about version 5.20 at all?

I get exactly your output when trying to emerge >5.18, since 5.20 is currently hardmasked. Do you have perl '**' keyworded somewhere? (e.g. grep -i perl -R /etc/portage/*)

Maybe heed developer advice and avoid 5.20 unless you want testing environment with breakage.


I don't want the testing version at all.

Thanks for the tip. I found a package that was keyworded. I disabled that line. Still it throws about version 5.20. In any case I won't allow version 5.20 to be installed. In any case, it doesn't even wants to install 5.20.It tries to pull 5.18. So on this side, I am safe
Back to top
View user's profile Send private message
steveL
Advocate
Advocate


Joined: 13 Sep 2006
Posts: 4790
Location: The Peanut Gallery

PostPosted: Thu Aug 07, 2014 8:57 am    Post subject: Reply with quote

If you haven't upgraded perl yet, you need to add it to the list:
Code:
emerge -1 -avDN '=dev-lang/perl-5.18*' $(qlist -IC 'virtual/perl-*') dev-perl/extutils-pkgconfig
as discussed here (and next couple of posts. I'd forgotten we can use qlist -IC for this.)

You should be able to run perl-cleaner--reallyall after that, though you might want to do it after world, or split it (see man perl-cleaner.)

dev-perl/extutils-pkgconfig isn't a virtual, but is needed for building other perl modules. You don't want -u as in some cases it will be the same version of the package, and we still want it remerged to record newer deps in the vdb.

If you're still getting blocks for perl packages, add those to the list too; I'd like to know what those are if you do.
Back to top
View user's profile Send private message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1593

PostPosted: Thu Aug 07, 2014 8:32 pm    Post subject: Reply with quote

I still get conflicts:

Code:
 emerge -1 -avDN '=dev-lang/perl-5.18*' $(qlist -IC 'virtual/perl-*') dev-perl/extutils-pkgconfig

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] virtual/libintl-0-r1 [0] ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild   R    ] dev-lang/python-exec-2.0.1-r1:2  PYTHON_TARGETS="(jython2_5) (jython2_7) (pypy) (python2_7) (python3_2) (python3_3) (-python3_4) (-python2_6%*)" 0 kB
[ebuild     U  ] sys-devel/autoconf-wrapper-13 [12] 0 kB
[ebuild     U  ] app-misc/pax-utils-0.7 [0.4] USE="-caps -python%" 89 kB
[ebuild     U  ] sys-devel/flex-2.5.39-r1 [2.5.37] USE="nls -static {-test}" ABI_X86="(64%*) -32% (-x32)" 1,316 kB
[ebuild     U  ] dev-libs/elfutils-0.158 [0.149] USE="bzip2 nls utils%* zlib -lzma -static-libs% {-test%} (-threads)" ABI_X86="(64%*) (-32) (-x32)" 4,938 kB
[ebuild     U  ] sys-devel/libtool-2.4.2-r1:2 [2.4.2:2] USE="-static-libs {-test} -vanilla" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] sys-libs/db-4.8.30-r1:4.8 [4.8.30:4.8] USE="cxx -doc -examples -java -tcl {-test}" ABI_X86="(64%*) (-32) (-x32)" 22,351 kB
[ebuild     U  ] sys-libs/gpm-1.20.7-r2 [1.20.7-r1] USE="(-selinux) -static-libs" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] dev-lang/perl-5.18.2-r1:0/5.18 [5.16.3:0/5.16] USE="berkdb gdbm -debug -doc -ithreads" 13,746 kB
[ebuild  N     ] virtual/perl-Pod-Parser-1.600.0  0 kB
[ebuild  N     ] perl-core/File-Temp-0.220.0-r1  38 kB
[ebuild  N     ] perl-core/Pod-Simple-3.230.0-r1  0 kB
[ebuild  N     ] perl-core/Getopt-Long-2.380.0-r1  41 kB
[ebuild  N     ] perl-core/Version-Requirements-0.101.22-r1  16 kB

Total: 15 packages (9 upgrades, 5 new, 1 reinstall), Size of downloads: 42,532 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.16.3::gentoo, installed) pulled in by
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Module-Metadata-1.0.11-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Geo-IP-1.420.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Params-Check-0.360.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/IO-1.25-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/ExtUtils-Command-1.170.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/version-0.990.100-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/ExtUtils-ParseXS-3.180.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/gtk2-perl-1.247.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-vcs/git-1.8.5.5::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Storable-2.390.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Module-CoreList-2.840.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Digest-1.170.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Parse-CPAN-Meta-1.440.400-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/IPC-Cmd-0.780.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Cookies-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/WWW-RobotRules-6.20.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/ExtUtils-Manifest-1.610.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Cairo-1.103.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Time-Local-1.230.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Perl-OSType-1.2.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-Daemon-0.480.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Sys-Syslog-0.320.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/XML-Parser-2.410.0-r2::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Error-0.170.210::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Pango-1.224.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/extutils-depends-0.306.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/libwww-perl-6.50.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Negotiate-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/glib-perl-1.301.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/DateManip-6.410.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/MIME-Base64-3.130.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/pcsc-perl-1.4.13-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/PlRPC-0.202.0-r2::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-SSLeay-1.550::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/IO-Socket-SSL-1.953.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Digest-SHA-5.820.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/CPAN-Meta-YAML-0.8.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/URI-1.600.0-r1::gentoo, installed)
    =dev-lang/perl-5.16* required by (virtual/perl-ExtUtils-Install-1.580.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Archive-Tar-1.900.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Digest-MD5-2.520.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/JSON-PP-2.272.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/extutils-pkgconfig-1.140.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/CPAN-Meta-2.120.921-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/DBI-1.623.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/CPAN-Meta-Requirements-2.122.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Module-Build-0.400.300-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Encode-2.470.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-HTTP-6.60.0::gentoo, installed)

  (dev-lang/perl-5.18.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.18* required by (virtual/perl-ExtUtils-Command-1.170.0-r5::gentoo, installed)
    (and 30 more with the same problem)


However, there is some progress with this command:

Here I get some blocks. I"ll be glad to get your suggestion about it:

Code:
 EIX_LIMIT=0 emerge -auvDN -1 =dev-lang/perl-5.18* $(eix '-I#' virtual/perl-*)

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] virtual/libintl-0-r1 [0] ABI_X86="(64%*) -32% (-x32)" 0 kB
[ebuild   R    ] dev-lang/python-exec-2.0.1-r1:2  PYTHON_TARGETS="(jython2_5) (jython2_7) (pypy) (python2_7) (python3_2) (python3_3) (-python3_4) (-python2_6%*)" 0 kB
[ebuild     U  ] sys-devel/autoconf-wrapper-13 [12] 0 kB
[ebuild     U  ] app-misc/pax-utils-0.7 [0.4] USE="-caps -python%" 89 kB
[ebuild     U  ] sys-devel/flex-2.5.39-r1 [2.5.37] USE="nls -static {-test}" ABI_X86="(64%*) -32% (-x32)" 1,316 kB
[ebuild     U  ] dev-libs/elfutils-0.158 [0.149] USE="bzip2 nls utils%* zlib -lzma -static-libs% {-test%} (-threads)" ABI_X86="(64%*) (-32) (-x32)" 4,938 kB
[ebuild     U  ] dev-lang/python-2.7.7:2.7 [2.7.6:2.7] USE="gdbm ipv6 ncurses readline sqlite ssl threads (wide-unicode) xml -berkdb -build -doc -examples -hardened -tk -wininst" 10,264 kB
[ebuild     U  ] sys-devel/libtool-2.4.2-r1:2 [2.4.2:2] USE="-static-libs {-test} -vanilla" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] sys-libs/db-4.8.30-r1:4.8 [4.8.30:4.8] USE="cxx -doc -examples -java -tcl {-test}" ABI_X86="(64%*) (-32) (-x32)" 22,351 kB
[ebuild     U  ] sys-libs/gpm-1.20.7-r2 [1.20.7-r1] USE="(-selinux) -static-libs" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ] dev-lang/perl-5.18.2-r1:0/5.18 [5.16.3:0/5.16] USE="berkdb gdbm -debug -doc -ithreads" 13,746 kB
[ebuild     U  ] virtual/perl-IO-1.280.0-r1 [1.25] 0 kB
[ebuild     U  ] virtual/perl-Encode-2.490.0-r2 [2.470.0] 0 kB
[ebuild     U  ] virtual/perl-Storable-2.410.0-r1 [2.390.0] 0 kB
[ebuild     U  ] virtual/perl-version-0.990.200-r1 [0.990.100] 0 kB
[ebuild     U  ] virtual/perl-Digest-1.170.0-r3 [1.170.0-r1] 0 kB
[ebuild     U  ] virtual/perl-ExtUtils-CBuilder-0.280.210-r1 [0.280.205] 0 kB
[ebuild     U  ] virtual/perl-ExtUtils-Install-1.590.0-r1 [1.580.0-r1] 0 kB
[ebuild     U  ] virtual/perl-ExtUtils-MakeMaker-6.660.0-r1 [6.640.0] 0 kB
[ebuild     U  ] virtual/perl-ExtUtils-Manifest-1.630.0-r1 [1.610.0] 0 kB
[ebuild     U  ] virtual/perl-File-Temp-0.230.0 [0.220.0-r3] 0 kB
[ebuild     U  ] virtual/perl-Getopt-Long-2.390.0-r1 [2.380.0-r3] 0 kB
[ebuild     U  ] virtual/perl-IPC-Cmd-0.800.0-r1 [0.780.0] 0 kB
[ebuild     U  ] virtual/perl-JSON-PP-2.272.20-r1 [2.272.0-r2] 0 kB
[ebuild     U  ] virtual/perl-Perl-OSType-1.3.0-r1 [1.2.0-r2] 0 kB
[ebuild     U  ] virtual/perl-Pod-Simple-3.280.0-r1 [3.230.0] 0 kB
[ebuild     U  ] dev-util/intltool-0.50.2-r1 [0.50.2] 186 kB
[ebuild  N     ] perl-core/Version-Requirements-0.101.22-r1  16 kB
[ebuild     U  ] x11-misc/shared-mime-info-1.2-r1 [1.0] USE="{-test%}" 503 kB
[ebuild     U  ] virtual/perl-Module-CoreList-3.30.0 [2.840.0] 0 kB
[uninstall     ] perl-core/Module-CoreList-2.840.0
[blocks b      ] <perl-core/Module-CoreList-3.30.0 ("<perl-core/Module-CoreList-3.30.0" is blocking virtual/perl-Module-CoreList-3.30.0)
[blocks B      ] <perl-core/IPC-Cmd-0.800.0 ("<perl-core/IPC-Cmd-0.800.0" is blocking virtual/perl-IPC-Cmd-0.800.0-r1)
[blocks B      ] <perl-core/ExtUtils-CBuilder-0.280.210 ("<perl-core/ExtUtils-CBuilder-0.280.210" is blocking virtual/perl-ExtUtils-CBuilder-0.280.210-r1)
[blocks B      ] <perl-core/ExtUtils-MakeMaker-6.660.0 ("<perl-core/ExtUtils-MakeMaker-6.660.0" is blocking virtual/perl-ExtUtils-MakeMaker-6.660.0-r1)
[blocks B      ] <perl-core/IO-1.280.0 ("<perl-core/IO-1.280.0" is blocking virtual/perl-IO-1.280.0-r1)
[blocks B      ] <perl-core/version-0.990.200 ("<perl-core/version-0.990.200" is blocking virtual/perl-version-0.990.200-r1)
[blocks B      ] <perl-core/ExtUtils-Manifest-1.630.0 ("<perl-core/ExtUtils-Manifest-1.630.0" is blocking virtual/perl-ExtUtils-Manifest-1.630.0-r1)
[blocks B      ] <perl-core/Encode-2.490.0 ("<perl-core/Encode-2.490.0" is blocking virtual/perl-Encode-2.490.0-r2)
[blocks B      ] <perl-core/JSON-PP-2.272.20 ("<perl-core/JSON-PP-2.272.20" is blocking virtual/perl-JSON-PP-2.272.20-r1)
[blocks B      ] <perl-core/Storable-2.410.0 ("<perl-core/Storable-2.410.0" is blocking virtual/perl-Storable-2.410.0-r1)
[blocks B      ] <perl-core/Perl-OSType-1.3.0 ("<perl-core/Perl-OSType-1.3.0" is blocking virtual/perl-Perl-OSType-1.3.0-r1)

Total: 30 packages (28 upgrades, 1 new, 1 reinstall, 1 uninstall), Size of downloads: 53,406 kB
Conflict: 11 blocks (10 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.18.2-r1::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.18* required by (virtual/perl-Module-Load-Conditional-0.540.0-r1::gentoo, installed)
    (and 44 more with the same problem)

  (dev-lang/perl-5.16.3::gentoo, installed) pulled in by
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/pcsc-perl-1.4.13-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/CPAN-Meta-Requirements-2.122.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Cookies-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Perl-OSType-1.2.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Archive-Tar-1.900.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Error-0.170.210::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-HTTP-6.60.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/XML-Parser-2.410.0-r2::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-SSLeay-1.550::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/ExtUtils-Manifest-1.610.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Module-Build-0.400.300-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Digest-1.170.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Digest-SHA-5.820.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/ExtUtils-CBuilder-0.280.205-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/DBI-1.623.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Cairo-1.103.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-vcs/git-1.8.5.5::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/libwww-perl-6.50.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Params-Check-0.360.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/ExtUtils-MakeMaker-6.640.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/PlRPC-0.202.0-r2::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/URI-1.600.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/CPAN-Meta-2.120.921-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/ExtUtils-ParseXS-3.180.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Storable-2.390.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Geo-IP-1.420.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Pango-1.224.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/gtk2-perl-1.247.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/IPC-Cmd-0.780.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/JSON-PP-2.272.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/IO-Socket-SSL-1.953.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Time-Local-1.230.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/IO-1.25-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Sys-Syslog-0.320.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-Daemon-0.480.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/WWW-RobotRules-6.20.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/extutils-depends-0.306.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/version-0.990.100-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Module-Metadata-1.0.11-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Digest-MD5-2.520.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Parse-CPAN-Meta-1.440.400-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Encode-2.470.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/MIME-Base64-3.130.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/DateManip-6.410.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/glib-perl-1.301.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Negotiate-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/ExtUtils-Command-1.170.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/CPAN-Meta-YAML-0.8.0-r1::gentoo, installed)


What I can do with blocks B which is unresolved conflict. Which ones should I remove? the perl-core/Module-CoreList or the virtual/perl-Module-CoreList etc?
Back to top
View user's profile Send private message
dataking
Apprentice
Apprentice


Joined: 20 Apr 2005
Posts: 246

PostPosted: Thu Aug 07, 2014 8:42 pm    Post subject: Reply with quote

The lower case "b" are blocks that portage can resolve itself.

These are the troublesome bits:
Code:

[blocks B      ] <perl-core/IPC-Cmd-0.800.0 ("<perl-core/IPC-Cmd-0.800.0" is blocking virtual/perl-IPC-Cmd-0.800.0-r1)
[blocks B      ] <perl-core/ExtUtils-CBuilder-0.280.210 ("<perl-core/ExtUtils-CBuilder-0.280.210" is blocking virtual/perl-ExtUtils-CBuilder-0.280.210-r1)
[blocks B      ] <perl-core/ExtUtils-MakeMaker-6.660.0 ("<perl-core/ExtUtils-MakeMaker-6.660.0" is blocking virtual/perl-ExtUtils-MakeMaker-6.660.0-r1)
[blocks B      ] <perl-core/IO-1.280.0 ("<perl-core/IO-1.280.0" is blocking virtual/perl-IO-1.280.0-r1)
[blocks B      ] <perl-core/version-0.990.200 ("<perl-core/version-0.990.200" is blocking virtual/perl-version-0.990.200-r1)
[blocks B      ] <perl-core/ExtUtils-Manifest-1.630.0 ("<perl-core/ExtUtils-Manifest-1.630.0" is blocking virtual/perl-ExtUtils-Manifest-1.630.0-r1)
[blocks B      ] <perl-core/Encode-2.490.0 ("<perl-core/Encode-2.490.0" is blocking virtual/perl-Encode-2.490.0-r2)
[blocks B      ] <perl-core/JSON-PP-2.272.20 ("<perl-core/JSON-PP-2.272.20" is blocking virtual/perl-JSON-PP-2.272.20-r1)
[blocks B      ] <perl-core/Storable-2.410.0 ("<perl-core/Storable-2.410.0" is blocking virtual/perl-Storable-2.410.0-r1)
[blocks B      ] <perl-core/Perl-OSType-1.3.0 ("<perl-core/Perl-OSType-1.3.0" is blocking virtual/perl-Perl-OSType-1.3.0-r1)


If it were me, I'd write down the list; uninstall them; upgrade perl; then reinstall. Then run perl-cleaner --reallyall.
_________________
-= the D@7@k|n& =-
Back to top
View user's profile Send private message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1593

PostPosted: Thu Aug 07, 2014 10:03 pm    Post subject: Reply with quote

dataking wrote:
The lower case "b" are blocks that portage can resolve itself.

These are the troublesome bits:
Code:

[blocks B      ] <perl-core/IPC-Cmd-0.800.0 ("<perl-core/IPC-Cmd-0.800.0" is blocking virtual/perl-IPC-Cmd-0.800.0-r1)
[blocks B      ] <perl-core/ExtUtils-CBuilder-0.280.210 ("<perl-core/ExtUtils-CBuilder-0.280.210" is blocking virtual/perl-ExtUtils-CBuilder-0.280.210-r1)
[blocks B      ] <perl-core/ExtUtils-MakeMaker-6.660.0 ("<perl-core/ExtUtils-MakeMaker-6.660.0" is blocking virtual/perl-ExtUtils-MakeMaker-6.660.0-r1)
[blocks B      ] <perl-core/IO-1.280.0 ("<perl-core/IO-1.280.0" is blocking virtual/perl-IO-1.280.0-r1)
[blocks B      ] <perl-core/version-0.990.200 ("<perl-core/version-0.990.200" is blocking virtual/perl-version-0.990.200-r1)
[blocks B      ] <perl-core/ExtUtils-Manifest-1.630.0 ("<perl-core/ExtUtils-Manifest-1.630.0" is blocking virtual/perl-ExtUtils-Manifest-1.630.0-r1)
[blocks B      ] <perl-core/Encode-2.490.0 ("<perl-core/Encode-2.490.0" is blocking virtual/perl-Encode-2.490.0-r2)
[blocks B      ] <perl-core/JSON-PP-2.272.20 ("<perl-core/JSON-PP-2.272.20" is blocking virtual/perl-JSON-PP-2.272.20-r1)
[blocks B      ] <perl-core/Storable-2.410.0 ("<perl-core/Storable-2.410.0" is blocking virtual/perl-Storable-2.410.0-r1)
[blocks B      ] <perl-core/Perl-OSType-1.3.0 ("<perl-core/Perl-OSType-1.3.0" is blocking virtual/perl-Perl-OSType-1.3.0-r1)


If it were me, I'd write down the list; uninstall them; upgrade perl; then reinstall. Then run perl-cleaner --reallyall.


Which ones to uninstall? The packages of perl-core/... or the virtual/...? or both?
Back to top
View user's profile Send private message
steveL
Advocate
Advocate


Joined: 13 Sep 2006
Posts: 4790
Location: The Peanut Gallery

PostPosted: Thu Aug 07, 2014 10:42 pm    Post subject: Reply with quote

queen wrote:
Which ones to uninstall? The packages of perl-core/... or the virtual/...? or both?

The perl-core ones less than a certain version; they are blocking the incoming virtuals, which are likely provided as part of perl itself.

However you have other things in there as well; it's interesting that you're getting more with eix, when using -u.
Personally I'd just get what I needed in, so do something along the lines of:
Code:
emerge -av -1 --no-deps =dev-lang/perl-5.18* $(eix '-I#' 'virtual/perl-*') dev-perl/extutils-pkgconfig
perl-cleaner --reallyall --  -av
emerge -avuDN world --with-bdeps=y

You don't need to worry about EIX_LIMIT since it's being captured (so no tty.)

Not sure if you'd actually need to clean manually, but it might be required if perl-cleaner can't resolve; I'd hope it would cope. And as I said before, you might want to do world before main perl-cleaner, in which case do perl-cleaner --all before emerge world, and perl-cleaner --modules after to catch any which haven't been upgraded, before you depclean. Guess that might be better after depclean. As you can no doubt tell, we're just exploring this problem-domain.. ;)

We're looking to remove virtuals/pkgconfig (ie those in that list) which are installed but have been removed from tree. There might be other things we need to check, though like dev-perl/* and perl-core/*; and you can add those, though you'll need a separate eix call for each iirc. Be sure to 'quote' them so it's eix which is interpreting them, and not the shell.

Out of interest, what is the output of the qlist vs the eix commands above, on their own (latter with EIX_LIMIT if you're getting the 50+ message)? ie what list are we passing to emerge; I'd like to know if -u is adding extra packages, somehow.
Back to top
View user's profile Send private message
mephinet
n00b
n00b


Joined: 15 May 2008
Posts: 17

PostPosted: Sun Aug 10, 2014 3:04 pm    Post subject: Reply with quote

steveL wrote:
Personally I'd just get what I needed in, so do something along the lines of:
Code:
emerge -av -1 --no-deps =dev-lang/perl-5.18* $(eix '-I#' 'virtual/perl-*') dev-perl/extutils-pkgconfig
perl-cleaner --reallyall --  -av
emerge -avuDN world --with-bdeps=y


Thanks, steveL, that did it for me!
Back to top
View user's profile Send private message
steveL
Advocate
Advocate


Joined: 13 Sep 2006
Posts: 4790
Location: The Peanut Gallery

PostPosted: Thu Aug 14, 2014 1:14 pm    Post subject: Reply with quote

Yay :D Glad to hear it mephinet, I'll code it in to update over next few days, so this is automatic in future.
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Thu Aug 14, 2014 4:08 pm    Post subject: Reply with quote

I went through this upgrade yesterday.

IIRC, on amd64 things went quite smoothly - I think I needed to add only one more package to the emerge line, subslots managed to pull the rest.
On x86 (where I needed to keyword a few things - arch team is lagging there), to make the first step, 'emerge -1pv dev-lang/perl `qlist -IC virtual/perl-`' sufficed, but I've got very few perl packages.
Back to top
View user's profile Send private message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1593

PostPosted: Sat Aug 30, 2014 10:51 pm    Post subject: Reply with quote

Hi Steve

Thanks a lot for the reply. Sorry for the delay, I was busy with other things. I ran the command
Code:

emerge -av -1 --nodeps =dev-lang/perl-5.18* $(eix '-I#' 'virtual/perl-*') dev-perl/extutils-pkgconfig
and it went smoothly. Pay attention it should be --nodeps instead of --no-deps.

However when I ran
Code:
 perl-cleaner --reallyall --  -av
it failed with blocks
Code:

* perl-cleaner is stopping here:
 * Fix the problem and start perl-cleaner again.
 *
 * If you encounter blockers involving virtuals and perl-core, here are
 * some things to try:
 *   Remove all perl-core packages from your world file
 *     emerge --deselect --ask $(qlist -IC 'perl-core/*')
 *   Update all the installed Perl virtuals
 *     emerge -uD1a $(qlist -IC 'virtual/perl-*')
 *   Afterwards re-run perl-cleaner


So, I followed the instructions and the deselect command worked well, but on the line of
Code:
  emerge -uD1a $(qlist -IC 'virtual/perl-*')
it failed with blocks.

Code:
emerge -uD1a $(qlist -IC 'virtual/perl-*')

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] virtual/libintl-0-r1 [0] ABI_X86="(64%*) -32% (-x32)"
[ebuild     U  ] sys-devel/autoconf-wrapper-13 [12]
[ebuild     U  ] app-misc/pax-utils-0.7 [0.4] USE="-python%"
[ebuild     U  ] sys-devel/flex-2.5.39-r1 [2.5.37] ABI_X86="(64%*) -32% (-x32)"
[ebuild     U  ] dev-libs/elfutils-0.158 [0.149] USE="utils%* -static-libs% {-test%} (-threads)" ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] dev-lang/python-2.7.7 [2.7.6]
[ebuild     U  ] sys-devel/libtool-2.4.2-r1 [2.4.2] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] sys-libs/db-4.8.30-r1 [4.8.30] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     U  ] sys-libs/gpm-1.20.7-r2 [1.20.7-r1] ABI_X86="(64%*) (-32) (-x32)"
[ebuild     UD ] dev-lang/perl-5.16.3 [5.18.2-r1]
[ebuild     U  ] dev-util/intltool-0.50.2-r1 [0.50.2]
[ebuild     U  ] x11-misc/shared-mime-info-1.2-r1 [1.0] USE="{-test%}"

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.18.2-r1::gentoo, installed) pulled in by
    =dev-lang/perl-5.18* required by (virtual/perl-ExtUtils-Install-1.590.0-r1::gentoo, installed)
    (and 14 more with the same problem)

  (dev-lang/perl-5.16.3::gentoo, ebuild scheduled for merge) pulled in by
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Pango-1.224.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Geo-IP-1.420.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Authen-SASL-2.160.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/CPAN-Meta-Requirements-2.122.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/LWP-MediaTypes-6.20.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/WWW-RobotRules-6.20.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTML-Tagset-3.200.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/XML-Simple-2.200.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/ExtUtils-ParseXS-3.180.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTML-Parser-3.710.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Inline-0.500.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/XML-Parser-2.410.0-r2::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/File-MimeInfo-0.170.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/libintl-perl-1.200.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Compress-Raw-Bzip2-2.60.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Cookies-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Encode-Locale-1.30.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Archive-Tar-1.900.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Daemon-6.10.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/PlRPC-0.202.0-r2::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/gtk2-perl-1.247.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/YAML-Syck-1.200.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Text-Unidecode-0.40.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/extutils-depends-0.306.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Parse-CPAN-Meta-1.440.400-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/glib-perl-1.301.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Sys-Syslog-0.320.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/libwww-perl-6.50.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/File-Listing-6.40.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Test-Harness-3.260.0::gentoo, installed)
    =dev-lang/perl-5.16* required by (virtual/perl-MIME-Base64-3.130.0-r3::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-SSLeay-1.550::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Module-Load-0.240.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Module-Load-Conditional-0.540.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Digest-HMAC-1.30.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Archive-Zip-1.300.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Time-Local-1.230.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/File-DesktopEntry-0.40.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/XML-LibXML-2.1.400-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/URI-1.600.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-HTTP-6.60.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Cairo-1.103.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/File-Spec-3.400.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Digest-SHA1-2.130.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/LWP-Protocol-https-6.30.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/DateManip-6.410.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Locale-gettext-1.50.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-Daemon-0.480.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/CPAN-Meta-2.120.921-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Digest-MD5-2.520.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Unicode-EastAsianWidth-1.330.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/CPAN-Meta-YAML-0.8.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/File-BaseDir-0.30.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-SMTP-SSL-1.10.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/XML-SAX-Base-1.80.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Module-Metadata-1.0.11-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/XML-SAX-0.990.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Error-0.170.210::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/XML-NamespaceSupport-1.110.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Compress-Raw-Zlib-2.60.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/DBI-1.623.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Params-Check-0.360.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Crypt-PasswdMD5-1.300.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Module-Build-0.400.300-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Scalar-List-Utils-1.270.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Date-6.20.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/IO-Socket-SSL-1.953.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Parse-RecDescent-1.967.9-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/DBD-mysql-4.20.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Message-6.30.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-vcs/git-1.8.5.5::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Digest-SHA-5.820.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Negotiate-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/IO-Compress-2.60.0::gentoo, installed)
    (and 10 more with the same problems)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.

Back to top
View user's profile Send private message
Navar
Guru
Guru


Joined: 20 Aug 2012
Posts: 353

PostPosted: Sat Sep 06, 2014 1:49 am    Post subject: Reply with quote

OP, did you resolve your issue? I'm going suggest what worked fine for me on x86 and amd64 without knowing more details on your end.

  • Consider a current tree sync just to help eliminate any unknowns as I cannot recreate your issue.
  • On both I did a standard emerge -avuND @world which updated perl and later errored out elsewhere (another package) with the post messages (w.r.t. perl core package from world file removal and updating perl virtuals).
  • The next step following that suggestion was to ensure no perl-core packages were in your world file and to then update the perl virtuals. This should and seems to eliminate the blocker issues (for most of us).
  • Once prior step was successful then run perl-cleaner --reallyall.
  • Finally, if successful, resume emerge -avuND @world.
  • If that succeeded, then a emerge -ac after (aka depclean).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page 1, 2, 3  Next
Page 1 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum