Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
perl upgrade slot conflict
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1636

PostPosted: Wed Sep 10, 2014 8:13 pm    Post subject: Reply with quote

Navar wrote:
OP, did you resolve your issue? I'm going suggest what worked fine for me on x86 and amd64 without knowing more details on your end.

  • Consider a current tree sync just to help eliminate any unknowns as I cannot recreate your issue.
  • On both I did a standard emerge -avuND @world which updated perl and later errored out elsewhere (another package) with the post messages (w.r.t. perl core package from world file removal and updating perl virtuals).
  • The next step following that suggestion was to ensure no perl-core packages were in your world file and to then update the perl virtuals. This should and seems to eliminate the blocker issues (for most of us).
  • Once prior step was successful then run perl-cleaner --reallyall.
  • Finally, if successful, resume emerge -avuND @world.
  • If that succeeded, then a emerge -ac after (aka depclean).



The problem is partially solved. I have perl updated to 5.18 and all the rest packages updated as well (perl virtuals, dev-perl, dev-lang/perl). However in update-world script, it tries to pull perl 5.16 and I get also slot conflict. There is no perl-core in world file. here is a partial output of the slot conflict

Code:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.16.3::gentoo, ebuild scheduled for merge) pulled in by
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/XML-SAX-Base-1.80.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/XML-Simple-2.200.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/XML-NamespaceSupport-1.110.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/LWP-MediaTypes-6.20.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/libintl-perl-1.200.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/LWP-Protocol-https-6.30.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Text-Unidecode-0.40.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-vcs/git-1.8.5.5::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/YAML-Syck-1.200.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/XML-SAX-0.990.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/XML-Parser-2.410.0-r2::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Parse-RecDescent-1.967.9-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Unicode-EastAsianWidth-1.330.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Pango-1.224.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/DBI-1.623.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTML-Tagset-3.200.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Locale-gettext-1.50.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Cookies-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/IO-Socket-SSL-1.953.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Inline-0.500.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/libwww-perl-6.50.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/glib-perl-1.301.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/File-DesktopEntry-0.40.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Message-6.30.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTML-Parser-3.710.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-SMTP-SSL-1.10.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Archive-Zip-1.300.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/File-MimeInfo-0.170.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/WWW-RobotRules-6.20.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Error-0.170.210::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/extutils-depends-0.306.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-SSLeay-1.550::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/gtk2-perl-1.247.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Authen-SASL-2.160.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Negotiate-6.0.1-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Crypt-PasswdMD5-1.300.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Geo-IP-1.420.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Daemon-6.10.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Cairo-1.103.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (perl-core/Digest-SHA-5.820.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/XML-LibXML-2.1.400-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/DateManip-6.410.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-Daemon-0.480.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/DBD-mysql-4.20.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/File-BaseDir-0.30.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/URI-1.600.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/File-Listing-6.40.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-HTTP-6.60.0::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Digest-SHA1-2.130.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/HTTP-Date-6.20.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Encode-Locale-1.30.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Digest-HMAC-1.30.0-r1::gentoo, installed)
    dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/PlRPC-0.202.0-r2::gentoo, installed)

  (dev-lang/perl-5.18.2-r1::gentoo, installed) pulled in by
    =dev-lang/perl-5.18* required by (virtual/perl-Archive-Tar-1.900.0-r2::gentoo, installed)
    dev-lang/perl:0/5.18=[-build(-)] required by (perl-core/Version-Requirements-0.101.22-r1::gentoo, installed)
    (and 42 more with the same problems)
Back to top
View user's profile Send private message
charles17
Advocate
Advocate


Joined: 02 Mar 2008
Posts: 3246

PostPosted: Thu Sep 11, 2014 9:43 am    Post subject: Reply with quote

Did you happen to forget to run emerge --depclean?
Back to top
View user's profile Send private message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1636

PostPosted: Fri Sep 12, 2014 5:01 pm    Post subject: Reply with quote

charles17 wrote:
Did you happen to forget to run emerge --depclean?


No.

I managed to solve the problem. I ran perl-cleaner --reallyall after everything was updated to 5.18. In the end I ran update-world script which actually runs
Code:
emerge -puvD world
. https://forums.gentoo.org/viewtopic-t-497125.html
Back to top
View user's profile Send private message
Navar
Guru
Guru


Joined: 20 Aug 2012
Posts: 353

PostPosted: Sat Sep 13, 2014 4:03 am    Post subject: Reply with quote

So perhaps marking the topic as [solved] would be good. ;)
Back to top
View user's profile Send private message
steveL
Watchman
Watchman


Joined: 13 Sep 2006
Posts: 5153
Location: The Peanut Gallery

PostPosted: Sat Sep 13, 2014 11:56 am    Post subject: Reply with quote

queen wrote:
However in update-world script, it tries to pull perl 5.16 and I get also slot conflict.
..
I ran update-world script which actually runs
Code:
emerge -puvD world

Really you want to be doing:
Code:
emerge -auvDN world --with-bdeps=y
for your full upgrade, especially for perl stuff, much of which is used at build-time. (with -p instead of -a in the script, ofc)

update does this by default (when run with no target and tree options), and provides -U as a shortcut for --changed-use (vs -N/--newuse).

I tend to run: update -uDU most of the time; it adds --with-bdeps=y when setting a default @system @world target, so I use update -uDU world (or equivalently -uDN world for main check) when I don't want the bdeps added (which won't happen when building to a ROOT, in any case.)

If you do try it, you want the 9999 version, as the other one is very out of date; it'll get updated once I've completed automation of perl/TC ABI warnings, but practically everyone I know who uses it, does so from git. Griz64 chases the QA end of it, very effectively imo, since he does too, and most of the people he supports aren't expert users (aka Gentooistas ;) like the forums-crowd.

Oh, add -a if you want it to ask for confirmation after the emerge --pretend run; otherwise it'll just go ahead, assuming it can, except when you've run it with no target: if it's interactive, in that case it'll ask, since you're doing the main run. More usually you have to confirm USE changes and the like.
Use -E to go straight to a dialog list. Otherwise you can select it with E/e (for edit list) when you're asked for confirmation.
And ofc, use -p if you just want to see what it'll do. update -h and --help are separate texts.
(Sorry for plug, didn't mean to go on so long: just don't want anyone to get a bad impression, if they do try it.)
Back to top
View user's profile Send private message
proteusx
Apprentice
Apprentice


Joined: 21 Jan 2008
Posts: 277

PostPosted: Sat Sep 27, 2014 12:24 am    Post subject: Reply with quote

I had the same problem.
After the last world update many such unresolved conflicts appeared and
perl-cleaner would stop because of many conflicts between several perl
virtuals and perl-core packages. The offending perl-core modules had to be
uninstalled but they were far too many (and this had to be done for several
computers) to remove by hand, so I put together a small perl script to find
the perl-core's that conflicted with perl-virtuals:
Code:

# conflicts.pl

my @virtuals = `qlist -IC virtual/perl-*`;
s/virtual\/perl-// foreach @virtuals;

my @cores = `qlist -IC perl-core\/*`;
s/perl-core\/// foreach @cores;

my ($core, $virtual);
foreach $virtual (@virtuals)
{
  chomp $virtual;
  foreach $core (@cores)
  {
    chomp $core;
    if ($core eq $virtual)
    {
      print "$virtual ";
      last;
    }
  }
}

The script prints the names of all the conflicting packages, separated by
spaces, in a single line so it can be passed to emerge to remove them:
Code:
emerge -Ca $(perl ./conflicts.pl)

Then I did:
Code:
perl-cleaner --reallyall -- -a
emerge -aDuN world --with-bdeps=y

Whereby everything was back to normal.
Back to top
View user's profile Send private message
miroR
l33t
l33t


Joined: 05 Mar 2008
Posts: 826

PostPosted: Tue Oct 14, 2014 2:21 pm    Post subject: Reply with quote

proteusx wrote:

...[snip]...
Code:

#!/usr/bin/perl

# conflicts.pl

my @virtuals = `qlist -IC virtual/perl-*`;
s/virtual\/perl-// foreach @virtuals;

my @cores = `qlist -IC perl-core\/*`;
s/perl-core\/// foreach @cores;

my ($core, $virtual);
foreach $virtual (@virtuals)
{
  chomp $virtual;
  foreach $core (@cores)
  {
    chomp $core;
    if ($core eq $virtual)
    {
      print "$virtual ";
      last;
    }
  }
}

...[snip]...

But I'm lying. You didn't provide the two top lines (second is empty) in the script. I added it for the rare newbie who would not know it otherwise... I know it's rare on these forums, but there happen them as well...
Thanks. Saved lots of pasting, typing and things.
Back to top
View user's profile Send private message
proteusx
Apprentice
Apprentice


Joined: 21 Jan 2008
Posts: 277

PostPosted: Tue Oct 14, 2014 7:23 pm    Post subject: Reply with quote

miroR wrote:

You didn't provide the two top lines (second is empty) in the script. I added it for the rare newbie who would not know it otherwise... I know it's rare on these forums, but there happen them as well...


I omitted the shebang on purpose; since we call perl to execute the script, the shebang is immaterial.
Code:
emerge -Ca $(perl ./conflicts.pl)


Otherwise we have to make the script executable:
Code:
chmod +x conflicts.pl
emerge -Ca $(./conflicts.pl)
Back to top
View user's profile Send private message
miroR
l33t
l33t


Joined: 05 Mar 2008
Posts: 826

PostPosted: Tue Oct 14, 2014 9:01 pm    Post subject: Reply with quote

proteusx wrote:
miroR wrote:

You didn't provide the two top lines (second is empty) in the script. I added it for the rare newbie who would not know it otherwise... I know it's rare on these forums, but there happen them as well...


I omitted the shebang on purpose; since we call perl to execute the script, the shebang is immaterial.
Code:
emerge -Ca $(perl ./conflicts.pl)


Otherwise we have to make the script executable:
Code:
chmod +x conflicts.pl
emerge -Ca $(./conflicts.pl)

OK. Don't really remember my exact steps all these hours later. I surely found all the rest of the info in the previous posts (and wouldn't get to perl-5.20 --which I happily now have-- without extra pasting and typing had you not provided this nice snippet of code). So, it's just fine. :)
Back to top
View user's profile Send private message
sr66
n00b
n00b


Joined: 30 May 2005
Posts: 56

PostPosted: Sun Nov 16, 2014 5:40 pm    Post subject: Reply with quote

steveL wrote:

Code:
emerge -av -1 --no-deps =dev-lang/perl-5.18* $(eix '-I#' 'virtual/perl-*') dev-perl/extutils-pkgconfig
perl-cleaner --reallyall --  -av
emerge -avuDN world --with-bdeps=y


Thanks. This worked for me as well.
Back to top
View user's profile Send private message
dilfridge
Developer
Developer


Joined: 18 Sep 2010
Posts: 111
Location: Regensburg, Germany

PostPosted: Wed Feb 11, 2015 2:21 pm    Post subject: Reply with quote

queen wrote:
Code:
emerge -uD1a $(qlist -IC 'virtual/perl-*')


Try ommitting the -D
Back to top
View user's profile Send private message
quad
n00b
n00b


Joined: 23 Jan 2007
Posts: 19

PostPosted: Wed Feb 11, 2015 5:57 pm    Post subject: Reply with quote

Hi,

I've also had these problems when upgrading from 5.16 to 5.18, which I fought through much trial and error. I've just encountered the same issue upgrading from 5.18 to 5.20 and here's the command line that actually worked by itself without uninstalling anything:

Code:
sudo emerge -va1D dev-lang/perl $(qlist -CI dev-perl/) $(qlist -CI virtual/perl)
Back to top
View user's profile Send private message
dilfridge
Developer
Developer


Joined: 18 Sep 2010
Posts: 111
Location: Regensburg, Germany

PostPosted: Fri Feb 13, 2015 12:25 am    Post subject: Reply with quote

Navar wrote:
OP, did you resolve your issue? I'm going suggest what worked fine for me on x86 and amd64 without knowing more details on your end.

  • Consider a current tree sync just to help eliminate any unknowns as I cannot recreate your issue.
  • On both I did a standard emerge -avuND @world which updated perl and later errored out elsewhere (another package) with the post messages (w.r.t. perl core package from world file removal and updating perl virtuals).
  • The next step following that suggestion was to ensure no perl-core packages were in your world file and to then update the perl virtuals. This should and seems to eliminate the blocker issues (for most of us).
  • Once prior step was successful then run perl-cleaner --reallyall.
  • Finally, if successful, resume emerge -avuND @world.
  • If that succeeded, then a emerge -ac after (aka depclean).


It might be worth trying
Code:
emerge -uNav world

(i.e. without the -D option). There might be a bug in portage triggered by -D.
Back to top
View user's profile Send private message
The_Great_Sephiroth
Veteran
Veteran


Joined: 03 Oct 2014
Posts: 1414
Location: Fayetteville, NC, USA

PostPosted: Fri Feb 13, 2015 12:30 am    Post subject: Reply with quote

Perl is really messing up right now, but John helped me resolve it this morning. I have a thread here about it. Something was wrong with the dependency resolver and there may be a portage tree issue. At least those are his suspicions.

*EDIT*

Here's a link to the second page, where we figured it all out. Note that this was on a new install and it was udev-init-scripts which was at fault. After updating it, then updating openrc, the Perl stuff disappeared.

Perl, Portage, and a possible solution
_________________
Ever picture systemd as what runs "The Borg"?
Back to top
View user's profile Send private message
carlosp
n00b
n00b


Joined: 21 Sep 2006
Posts: 31

PostPosted: Fri Feb 13, 2015 10:10 pm    Post subject: Reply with quote

Thanks quad. That worked here.
_________________
Live is complex - it has both real and imaginary parts. (Anonymous)
Back to top
View user's profile Send private message
CheerfulBoy
n00b
n00b


Joined: 12 Apr 2008
Posts: 19

PostPosted: Sun Jun 14, 2015 7:04 am    Post subject: Reply with quote

quad wrote:
Hi,

I've also had these problems when upgrading from 5.16 to 5.18, which I fought through much trial and error. I've just encountered the same issue upgrading from 5.18 to 5.20 and here's the command line that actually worked by itself without uninstalling anything:

Code:
sudo emerge -va1D dev-lang/perl $(qlist -CI dev-perl/) $(qlist -CI virtual/perl)


Big thanks! Thats works for me.
Back to top
View user's profile Send private message
dilfridge
Developer
Developer


Joined: 18 Sep 2010
Posts: 111
Location: Regensburg, Germany

PostPosted: Sun Jun 14, 2015 4:23 pm    Post subject: Reply with quote

CheerfulBoy wrote:
quad wrote:
Hi,

I've also had these problems when upgrading from 5.16 to 5.18, which I fought through much trial and error. I've just encountered the same issue upgrading from 5.18 to 5.20 and here's the command line that actually worked by itself without uninstalling anything:

Code:
sudo emerge -va1D dev-lang/perl $(qlist -CI dev-perl/) $(qlist -CI virtual/perl)


Big thanks! Thats works for me.


Excellent. Brace yourself, Perl 5.22 is coming to ~arch soon... :)
Back to top
View user's profile Send private message
msst
Apprentice
Apprentice


Joined: 07 Jun 2011
Posts: 245

PostPosted: Sun Jul 12, 2015 11:13 pm    Post subject: Reply with quote

And it got me already. Huge amount of blocks all centering around perl 5.20 and 5.22 slot conflict.

Code:
emerge -va1D dev-lang/perl $(qlist -CI dev-perl/) $(qlist -CI virtual/perl)


this time also does not work. So I unmerged the whole perl crap now with

Quote:
emerge --unmerge $(qlist -CI dev-perl/) $(qlist -CI virtual/perl)


and hope to reconstruct it. Let us see, if that monster task works.

Really, something has to change with perl and portage...
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1756

PostPosted: Mon Jul 13, 2015 3:21 am    Post subject: Reply with quote

I will say, just blindly uninstalling stuff and not paying attention is a easy recipe to break your system.
Back to top
View user's profile Send private message
proteusx
Apprentice
Apprentice


Joined: 21 Jan 2008
Posts: 277

PostPosted: Mon Jul 13, 2015 11:36 am    Post subject: Reply with quote

mas- wrote:

and hope to reconstruct it. Let us see, if that monster task works.

Any luck?
Back to top
View user's profile Send private message
Buffoon
Veteran
Veteran


Joined: 17 Jun 2015
Posts: 1074
Location: EU or US

PostPosted: Mon Jul 13, 2015 1:56 pm    Post subject: Reply with quote

I backed up my old perl with quickpkg, then emerge -av1u --nodeps perl, followed by perl-cleaner --all and depclean. Seems everything is fine now.
Back to top
View user's profile Send private message
frostschutz
Advocate
Advocate


Joined: 22 Feb 2005
Posts: 2971
Location: Germany

PostPosted: Mon Jul 13, 2015 5:08 pm    Post subject: Reply with quote

It's 2015 and Gentoo is still Gentoo 8O. Wheee! :lol: :D
Back to top
View user's profile Send private message
msst
Apprentice
Apprentice


Joined: 07 Jun 2011
Posts: 245

PostPosted: Thu Aug 06, 2015 9:30 pm    Post subject: Reply with quote

Quote:
Any luck?


Yes, it took a while and was quite painful though. After unmerging quite a lot I did

1) First emerge -av package separately on everything that wasn't directly pulling perl in, so that the complexity of the emerge world go down

2) Then what finally did the trick was emerge --with-bdeps=y --backtrack=64 world. It needed the insane high backtrack (30 and also 48 failed) and took almost 20 minutes per try. Until this "magic combo" finally started to work. Huge recompile.

3) Followed by a crazy perl-updater and revdep-rebuild run.

Really, the complexity of the perl update interdependancies are getting close to kill the gentoo build system. Could some perl-metapackages help bringing that down perhaps?
Back to top
View user's profile Send private message
sebekk23
n00b
n00b


Joined: 29 Mar 2015
Posts: 42

PostPosted: Mon Aug 31, 2015 6:57 pm    Post subject: Reply with quote

mephinet wrote:
steveL wrote:
Personally I'd just get what I needed in, so do something along the lines of:
Code:
emerge -av -1 --no-deps =dev-lang/perl-5.18* $(eix '-I#' 'virtual/perl-*') dev-perl/extutils-pkgconfig
perl-cleaner --reallyall --  -av
emerge -avuDN world --with-bdeps=y


Thanks, steveL, that did it for me!


i'm grateful - really, on my old gento it helps me a lot with perl dependencies ;)...thx
Back to top
View user's profile Send private message
Naib
Watchman
Watchman


Joined: 21 May 2004
Posts: 5818
Location: Removed by Neddy

PostPosted: Tue Sep 01, 2015 11:52 pm    Post subject: Reply with quote

this perl upgrade does appear to be a right mess... I have been trying for a couple of weeks w.r.t. perl 5.20 -> perl-5.22 and multiple slot conflicts keep causing issues (perl-cleaner is equally failing...)

2weeks later and the list of other packages that need updating is growing as well...

Code:

perl-cleaner --reallyall
 * Removing perl-core packages from world file
 *    emerge --deselect  perl-core/CPAN-Meta perl-core/Data-Dumper perl-core/Encode perl-core/ExtUtils-MakeMaker perl-core/ExtUtils-Manifest perl-core/File-Temp perl-core/libnet perl-core/Module-CoreList
>>> No matching atoms found in "world" favorites file...
 * Updating installed Perl virtuals
 *    emerge -u1  virtual/perl-Archive-Tar virtual/perl-Carp virtual/perl-Compress-Raw-Bzip2 virtual/perl-Compress-Raw-Zlib virtual/perl-CPAN-Meta virtual/perl-CPAN-Meta-Requirements virtual/perl-CPAN-Meta-YAML virtual/perl-Data-Dumper virtual/perl-Digest virtual/perl-Digest-MD5 virtual/perl-Digest-SHA virtual/perl-Encode virtual/perl-Exporter virtual/perl-ExtUtils-CBuilder virtual/perl-ExtUtils-Command virtual/perl-ExtUtils-Install virtual/perl-ExtUtils-MakeMaker virtual/perl-ExtUtils-Manifest virtual/perl-ExtUtils-ParseXS virtual/perl-File-Path virtual/perl-File-Spec virtual/perl-File-Temp virtual/perl-Getopt-Long virtual/perl-IO virtual/perl-IO-Compress virtual/perl-JSON-PP virtual/perl-libnet virtual/perl-MIME-Base64 virtual/perl-Module-Build virtual/perl-Module-CoreList virtual/perl-Module-Metadata virtual/perl-Parse-CPAN-Meta virtual/perl-Perl-OSType virtual/perl-Storable virtual/perl-Test-Harness virtual/perl-Test-Simple virtual/perl-Text-ParseWords virtual/perl-Time-Local virtual/perl-version

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.

Calculating dependencies... done!
>>> Jobs: 0 of 0 complete                           Load avg: 2.20, 3.62, 3.64
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * Beginning a clean up of .ph files
 * Excluding files for 0.0.0 and 0.0.0/x86_64-linux from cleaning

 * Locating ph files for removal

 * Updating ph files.
 * Ignore all "No such file..." messages!
Can't open machine/ansi.h: No such file or directory
Can't open sys/_types.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory
Can't open gnu/stubs-x32.h: No such file or directory

 * Locating packages for an update
 * Locating ebuilds linked against libperl
 *   Adding to list: net-fs/samba:0
 *   Adding to list: net-irc/pisg:0
 *   Adding to list: net-irc/irssi:0
 *   Adding to list: dev-vcs/gitolite:0
 *   Adding to list: dev-vcs/git:0
 *   Adding to list: perl-core/ExtUtils-Manifest:0
 *                   virtual/perl-ExtUtils-Manifest:0
 *   Adding to list: perl-core/CPAN-Meta:0
 *                   virtual/perl-CPAN-Meta:0
 *   Adding to list: perl-core/libnet:0
 *                   virtual/perl-libnet:0
 *   Adding to list: perl-core/Data-Dumper:0
 *                   virtual/perl-Data-Dumper:0
 *   Adding to list: perl-core/Encode:0
 *                   virtual/perl-Encode:0
 *   Adding to list: perl-core/ExtUtils-MakeMaker:0
 *                   virtual/perl-ExtUtils-MakeMaker:0
 *   Adding to list: perl-core/File-Temp:0
 *                   virtual/perl-File-Temp:0
 *   Adding to list: perl-core/Module-CoreList:0
 *                   virtual/perl-Module-CoreList:0
 *   Adding to list: x11-terms/rxvt-unicode:0
 *   Adding to list: dev-python/subunit:0
 *   Adding to list: dev-perl/XML-XPath:0
 *   Adding to list: dev-perl/XML-Twig:0
 *   Adding to list: dev-perl/IO-String:0
 *   Adding to list: dev-perl/ExtUtils-Depends:0
 *   Adding to list: dev-perl/Linux-DesktopFiles:0
 *   Adding to list: dev-perl/HTTP-Daemon:0
 *   Adding to list: dev-perl/OLE-StorageLite:0
 *   Adding to list: dev-perl/IO-stringy:0
 *   Adding to list: dev-perl/Crypt-PasswdMD5:0
 *   Adding to list: dev-perl/XML-NamespaceSupport:0
 *   Adding to list: dev-perl/File-BaseDir:0
 *   Adding to list: dev-perl/IO-Socket-SSL:0
 *   Adding to list: dev-perl/Net-DBus:0
 *   Adding to list: dev-perl/XML-Filter-BufferText:0
 *   Adding to list: dev-perl/File-MimeInfo:0
 *   Adding to list: dev-perl/Locale-gettext:0
 *   Adding to list: dev-perl/LWP-MediaTypes:0
 *   Adding to list: dev-perl/Encode-Locale:0
 *   Adding to list: dev-perl/SGMLSpm:0
 *   Adding to list: dev-perl/DateManip:0
 *   Adding to list: dev-perl/Text-Iconv:0
 *   Adding to list: dev-perl/HTML-Tagset:0
 *   Adding to list: dev-perl/JSON:0
 *   Adding to list: dev-perl/Data-Dump:0
 *   Adding to list: dev-perl/libxml-perl:0
 *   Adding to list: dev-perl/libwww-perl:0
 *   Adding to list: dev-perl/Authen-SASL:0
 *   Adding to list: dev-perl/Unicode-EastAsianWidth:0
 *   Adding to list: dev-perl/Archive-Zip:0
 *   Adding to list: dev-perl/XML-Simple:0
 *   Adding to list: dev-perl/Module-Build:0
 *   Adding to list: dev-perl/Unicode-Map:0
 *   Adding to list: dev-perl/HTTP-Date:0
 *   Adding to list: dev-perl/XML-Parser:0
 *   Adding to list: dev-perl/URI:0
 *   Adding to list: dev-perl/XML-LibXML:0
 *   Adding to list: dev-perl/Text-CSV_XS:0
 *   Adding to list: dev-perl/File-DesktopEntry:0
 *   Adding to list: dev-perl/XML-SAX-Base:0
 *   Adding to list: dev-perl/yaml:0
 *   Adding to list: dev-perl/HTTP-Negotiate:0
 *   Adding to list: dev-perl/Net-SSLeay:0
 *   Adding to list: dev-perl/extutils-pkgconfig:0
 *   Adding to list: dev-perl/WWW-RobotRules:0
 *   Adding to list: dev-perl/Text-Unidecode:0
 *   Adding to list: dev-perl/Crypt-RC4:0
 *   Adding to list: dev-perl/Digest-SHA1:0
 *   Adding to list: dev-perl/Digest-Perl-MD5:0
 *   Adding to list: dev-perl/libintl-perl:0
 *   Adding to list: dev-perl/XML-SAX:0
 *   Adding to list: dev-perl/HTTP-Message:0
 *   Adding to list: dev-perl/HTML-Parser:0
 *   Adding to list: dev-perl/IO-HTML:0
 *   Adding to list: dev-perl/Tie-IxHash:0
 *   Adding to list: dev-perl/Net-HTTP:0
 *   Adding to list: dev-perl/HTTP-Cookies:0
 *   Adding to list: dev-perl/LWP-Protocol-https:0
 *   Adding to list: dev-perl/Error:0
 *   Adding to list: dev-perl/Spreadsheet-ParseExcel:0
 *   Adding to list: dev-perl/File-Listing:0
 *   Adding to list: dev-perl/Digest-HMAC:0
 *   Adding to list: dev-perl/Net-SMTP-SSL:0
 *   Adding to list: dev-perl/Cairo:0
 *   Adding to list: dev-perl/XML-Handler-YAWriter:0
 *   Adding to list: dev-perl/XML-SAX-Writer:0
 * emerge -v1 --backtrack=200 net-fs/samba:0 net-irc/pisg:0 net-irc/irssi:0 dev-vcs/gitolite:0 dev-vcs/git:0 perl-core/ExtUtils-Manifest:0 virtual/perl-ExtUtils-Manifest:0 perl-core/CPAN-Meta:0 virtual/perl-CPAN-Meta:0 perl-core/libnet:0 virtual/perl-libnet:0 perl-core/Data-Dumper:0 virtual/perl-Data-Dumper:0 perl-core/Encode:0 virtual/perl-Encode:0 perl-core/ExtUtils-MakeMaker:0 virtual/perl-ExtUtils-MakeMaker:0 perl-core/File-Temp:0 virtual/perl-File-Temp:0 perl-core/Module-CoreList:0 virtual/perl-Module-CoreList:0 x11-terms/rxvt-unicode:0 dev-python/subunit:0 dev-perl/XML-XPath:0 dev-perl/XML-Twig:0 dev-perl/IO-String:0 dev-perl/ExtUtils-Depends:0 dev-perl/Linux-DesktopFiles:0 dev-perl/HTTP-Daemon:0 dev-perl/OLE-StorageLite:0 dev-perl/IO-stringy:0 dev-perl/Crypt-PasswdMD5:0 dev-perl/XML-NamespaceSupport:0 dev-perl/File-BaseDir:0 dev-perl/IO-Socket-SSL:0 dev-perl/Net-DBus:0 dev-perl/XML-Filter-BufferText:0 dev-perl/File-MimeInfo:0 dev-perl/Locale-gettext:0 dev-perl/LWP-MediaTypes:0 dev-perl/Encode-Locale:0 dev-perl/SGMLSpm:0 dev-perl/DateManip:0 dev-perl/Text-Iconv:0 dev-perl/HTML-Tagset:0 dev-perl/JSON:0 dev-perl/Data-Dump:0 dev-perl/libxml-perl:0 dev-perl/libwww-perl:0 dev-perl/Authen-SASL:0 dev-perl/Unicode-EastAsianWidth:0 dev-perl/Archive-Zip:0 dev-perl/XML-Simple:0 dev-perl/Module-Build:0 dev-perl/Unicode-Map:0 dev-perl/HTTP-Date:0 dev-perl/XML-Parser:0 dev-perl/URI:0 dev-perl/XML-LibXML:0 dev-perl/Text-CSV_XS:0 dev-perl/File-DesktopEntry:0 dev-perl/XML-SAX-Base:0 dev-perl/yaml:0 dev-perl/HTTP-Negotiate:0 dev-perl/Net-SSLeay:0 dev-perl/extutils-pkgconfig:0 dev-perl/WWW-RobotRules:0 dev-perl/Text-Unidecode:0 dev-perl/Crypt-RC4:0 dev-perl/Digest-SHA1:0 dev-perl/Digest-Perl-MD5:0 dev-perl/libintl-perl:0 dev-perl/XML-SAX:0 dev-perl/HTTP-Message:0 dev-perl/HTML-Parser:0 dev-perl/IO-HTML:0 dev-perl/Tie-IxHash:0 dev-perl/Net-HTTP:0 dev-perl/HTTP-Cookies:0 dev-perl/LWP-Protocol-https:0 dev-perl/Error:0 dev-perl/Spreadsheet-ParseExcel:0 dev-perl/File-Listing:0 dev-perl/Digest-HMAC:0 dev-perl/Net-SMTP-SSL:0 dev-perl/Cairo:0 dev-perl/XML-Handler-YAWriter:0 dev-perl/XML-SAX-Writer:0

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R    ] virtual/perl-Data-Dumper-2.158.0::gentoo  0 KiB
[ebuild   R    ] perl-core/File-Temp-0.230.400-r1::gentoo  0 KiB
[ebuild   R    ] virtual/perl-ExtUtils-MakeMaker-7.40.100_rc::gentoo  0 KiB
[ebuild  N     ] virtual/perl-Scalar-List-Utils-1.410.0::gentoo  0 KiB
[ebuild   R    ] dev-perl/XML-NamespaceSupport-1.110.0-r1::gentoo  0 KiB
[ebuild   R    ] dev-perl/XML-Parser-2.440.0::gentoo  0 KiB
[ebuild   R    ] dev-perl/LWP-MediaTypes-6.20.0-r1::gentoo  0 KiB
[ebuild   R    ] virtual/perl-ExtUtils-Manifest-1.700.0-r1::gentoo  0 KiB
[ebuild   R    ] virtual/perl-libnet-3.50.0::gentoo  0 KiB
[ebuild   R    ] dev-perl/Encode-Locale-1.30.0-r1::gentoo  0 KiB
[ebuild   R    ] dev-perl/Text-Iconv-1.700.0-r1::gentoo  0 KiB
[ebuild   R    ] perl-core/Encode-2.730.0::gentoo  0 KiB
[ebuild   R    ] dev-perl/OLE-StorageLite-0.190.0-r1::gentoo  0 KiB
[ebuild   R    ] dev-perl/HTML-Tagset-3.200.0-r1::gentoo  0 KiB
[ebuild   R    ] dev-perl/Unicode-Map-0.112.0-r1::gentoo  0 KiB
[ebuild   R    ] dev-perl/XML-SAX-Base-1.80.0-r1::gentoo  0 KiB
[ebuild     U  ] dev-perl/Net-SSLeay-1.650.0-r1::gentoo [1.650.0::gentoo] 0 KiB
[ebuild   R    ] dev-perl/extutils-pkgconfig-1.150.0::gentoo  0 KiB
[ebuild   R    ] dev-perl/Crypt-RC4-2.020.0-r1::gentoo  0 KiB
[ebuild   R    ] perl-core/ExtUtils-Manifest-1.700.0::gentoo  0 KiB
[ebuild   R    ] perl-core/Module-CoreList-5.201.505.200::gentoo  0 KiB
[ebuild   R    ] virtual/perl-Module-CoreList-5.201.505.200-r2::gentoo  0 KiB
[ebuild   R    ] dev-perl/IO-String-1.80.0-r1::gentoo  0 KiB
[ebuild   R    ] dev-perl/SGMLSpm-1.03-r7::gentoo  0 KiB
[ebuild   R    ] dev-perl/Data-Dump-1.230.0::gentoo  0 KiB
[ebuild   R    ] dev-perl/libintl-perl-1.240.0::gentoo  0 KiB
[ebuild   R    ] virtual/perl-File-Temp-0.230.400-r3::gentoo  0 KiB
[ebuild   R    ] dev-perl/HTTP-Date-6.20.0-r1::gentoo  0 KiB
[ebuild   R    ] virtual/perl-Encode-2.730.0::gentoo  0 KiB
[ebuild   R    ] dev-perl/URI-1.680.0::gentoo  USE="{-test}" 0 KiB
[ebuild   R    ] virtual/perl-CPAN-Meta-2.150.1::gentoo  0 KiB
[ebuild   R    ] dev-perl/IO-Socket-SSL-2.12.0::gentoo  USE="-idn" 0 KiB
[ebuild   R    ] dev-perl/XML-XPath-1.130.0-r1::gentoo  0 KiB
[ebuild   R    ] dev-perl/ExtUtils-Depends-0.404.0::gentoo  0 KiB
[ebuild   R    ] dev-perl/IO-stringy-2.111.0::gentoo  0 KiB
[ebuild   R    ] dev-perl/JSON-2.900.0::gentoo  USE="{-test}" 0 KiB
[ebuild   R    ] dev-perl/libxml-perl-0.80.0-r1::gentoo  0 KiB
[ebuild   R    ] dev-perl/Text-CSV_XS-1.190.0::gentoo  USE="{-test}" 0 KiB
[ebuild   R    ] dev-perl/Digest-Perl-MD5-1.900.0::gentoo  0 KiB
[ebuild   R    ] dev-perl/HTML-Parser-3.710.0-r1::gentoo  USE="{-test}" 0 KiB
[ebuild   R    ] dev-perl/Digest-HMAC-1.30.0-r1::gentoo  0 KiB
[ebuild   R    ] net-irc/pisg-0.73-r1::gentoo  0 KiB
[ebuild   R    ] perl-core/CPAN-Meta-2.143.240::gentoo  USE="{-test}" 0 KiB
[ebuild   R    ] perl-core/libnet-1.270.0::gentoo  USE="-sasl" 0 KiB
[ebuild   R    ] perl-core/Data-Dumper-2.154.0::gentoo  0 KiB
[ebuild   R    ] dev-perl/Unicode-EastAsianWidth-1.330.0-r1::gentoo  0 KiB
[ebuild   R    ] dev-perl/yaml-1.150.0::gentoo  USE="{-test}" 0 KiB
[ebuild   R    ] dev-perl/Text-Unidecode-1.230.0::gentoo  0 KiB
[ebuild   R    ] dev-perl/Digest-SHA1-2.130.0-r1::gentoo  0 KiB
[ebuild     U  ] dev-perl/Module-Build-0.421.400::gentoo [0.420.500::gentoo] USE="{-test}" 298 KiB
[ebuild   R    ] dev-perl/Net-HTTP-6.60.0::gentoo  0 KiB
[ebuild   R    ] dev-perl/Authen-SASL-2.160.0-r1::gentoo  USE="-kerberos" 0 KiB
[ebuild   R    ] dev-perl/WWW-RobotRules-6.20.0::gentoo  0 KiB
[ebuild   R    ] dev-perl/IO-HTML-1.1.0::gentoo  USE="{-test}" 0 KiB
[ebuild   R    ] dev-perl/File-Listing-6.40.0-r1::gentoo  0 KiB
[ebuild   R    ] dev-perl/Net-SMTP-SSL-1.30.0::gentoo  USE="{-test}" 0 KiB
[ebuild   R    ] dev-perl/XML-Handler-YAWriter-0.230.0-r1::gentoo  0 KiB
[ebuild   R    ] perl-core/ExtUtils-MakeMaker-7.40.0-r1::gentoo  0 KiB
[ebuild   R    ] dev-perl/Archive-Zip-1.490.0::gentoo  USE="{-test}" 0 KiB
[ebuild   R    ] dev-perl/Spreadsheet-ParseExcel-0.650.0::gentoo  USE="unicode -cjk {-test}" 0 KiB
[ebuild   R    ] dev-perl/File-BaseDir-0.30.0-r1::gentoo  USE="{-test}" 0 KiB
[ebuild   R    ] dev-perl/HTTP-Message-6.60.0-r1::gentoo  0 KiB
[ebuild   R    ] dev-perl/Tie-IxHash-1.230.0::gentoo  USE="{-test}" 0 KiB
[ebuild   R    ] dev-perl/Error-0.170.240::gentoo  USE="{-test}" 0 KiB
[ebuild   R    ] net-irc/irssi-0.8.17::gentoo  USE="ipv6 perl proxy ssl (-selinux) -socks5" 0 KiB
[ebuild   R    ] x11-terms/rxvt-unicode-9.21::gentoo  USE="256-color fading-colors focused-urgency font-styles mousewheel perl startup-notification vanilla xft -alt-font-width -blink -buffer-on-clear -iso14755 -pixbuf -secondary-wheel -unicode3 -wcwidth" 0 KiB
[ebuild   R    ] dev-perl/Linux-DesktopFiles-0.90.0::gentoo  0 KiB
[ebuild   R    ] dev-perl/Crypt-PasswdMD5-1.400.0::gentoo  0 KiB
[ebuild   R    ] dev-perl/DateManip-6.490.0::gentoo  USE="{-test}" 0 KiB
[ebuild   R    ] dev-perl/File-DesktopEntry-0.40.0-r1::gentoo  USE="{-test}" 0 KiB
[ebuild   R    ] dev-perl/HTTP-Daemon-6.10.0-r1::gentoo  0 KiB
[ebuild   R    ] dev-perl/HTTP-Negotiate-6.0.1-r1::gentoo  0 KiB
[ebuild   R    ] dev-perl/HTTP-Cookies-6.0.1-r1::gentoo  0 KiB
[ebuild   R    ] dev-perl/libwww-perl-6.50.0::gentoo  USE="ssl" 0 KiB
[ebuild   R    ] dev-perl/LWP-Protocol-https-6.60.0::gentoo  0 KiB
[ebuild   R    ] dev-perl/XML-SAX-0.990.0-r1::gentoo  0 KiB
[ebuild   R    ] dev-perl/File-MimeInfo-0.270.0::gentoo  USE="{-test}" 0 KiB
[ebuild   R    ] dev-perl/XML-Filter-BufferText-1.10.0-r1::gentoo  0 KiB
[ebuild   R    ] dev-perl/XML-LibXML-2.12.100::gentoo  USE="{-test}" 0 KiB
[ebuild   R    ] dev-perl/XML-SAX-Writer-0.560.0::gentoo  0 KiB
[ebuild   R    ] dev-perl/XML-Simple-2.200.0-r1::gentoo  0 KiB
[ebuild   R    ] dev-perl/XML-Twig-3.490.0::gentoo  USE="nls" 0 KiB
[ebuild   R    ] dev-python/mimeparse-0.1.4-r1::gentoo  PYTHON_TARGETS="python2_7 python3_3 python3_4* -pypy -pypy3%" 0 KiB
[ebuild     U  ] dev-python/packaging-15.3-r1::gentoo [15.3::gentoo] USE="{-test}" PYTHON_TARGETS="python2_7 python3_3 python3_4* -pypy -pypy3" 0 KiB
[ebuild   R    ] dev-python/colorama-0.3.3::gentoo  USE="-examples" PYTHON_TARGETS="python2_7 python3_3 python3_4* -pypy -pypy3%" 0 KiB
[ebuild   R    ] dev-python/distlib-0.2.1::gentoo  PYTHON_TARGETS="python2_7 python3_3 python3_4* -pypy -pypy3" 0 KiB
[ebuild   R    ] dev-perl/Net-DBus-1.0.0-r1::gentoo  USE="{-test}" 0 KiB
[ebuild   R    ] dev-perl/Locale-gettext-1.50.0-r1::gentoo  0 KiB
[ebuild   R    ] dev-perl/Cairo-1.105.0::gentoo  USE="{-test}" 0 KiB
[ebuild   R    ] dev-python/six-1.9.0-r1::gentoo  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_3 python3_4* -pypy -pypy3" 0 KiB
[ebuild   R    ] dev-python/extras-0.0.3::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_3 python3_4* -pypy -pypy3%" 0 KiB
[ebuild   R    ] dev-python/ipaddress-1.0.14::gentoo  PYTHON_TARGETS="python2_7 python3_3 python3_4* -pypy -pypy3" 0 KiB
[ebuild   R    ] dev-python/progress-1.2::gentoo  PYTHON_TARGETS="python2_7 python3_3 python3_4* -pypy -pypy3" 0 KiB
[ebuild   R    ] dev-python/chardet-2.3.0::gentoo  PYTHON_TARGETS="python2_7 python3_3 python3_4* -pypy -pypy3" 0 KiB
[ebuild   R    ] dev-python/requests-2.7.0::gentoo  PYTHON_TARGETS="python2_7 python3_3 python3_4* -pypy -pypy3" 0 KiB
[ebuild   R    ] dev-python/retrying-1.3.3::gentoo  PYTHON_TARGETS="python2_7 python3_3 python3_4* -pypy -pypy3" 0 KiB
[ebuild   R    ] dev-python/html5lib-0.999999::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_3 python3_4* -pypy -pypy3" 0 KiB
[ebuild     U  ] dev-vcs/git-2.5.1::gentoo [2.5.0::gentoo] USE="blksha1 curl gpg gtk iconv nls pcre perl python threads tk webdav -cgi -cvs -doc -emacs -gnome-keyring -highlight -mediawiki (-ppcsha1) -subversion {-test} -xinetd" PYTHON_TARGETS="python2_7" 4,024 KiB
[ebuild   R    ] dev-vcs/gitolite-3.6.3::gentoo  USE="(-selinux) -tools -vim-syntax" 0 KiB
[ebuild     U  ] dev-python/pbr-1.6.0::gentoo [1.2.0::gentoo] USE="{-test}" PYTHON_TARGETS="python2_7 python3_3 python3_4* -pypy% -pypy3%" 98 KiB
[ebuild  N     ] dev-python/lockfile-0.10.2::gentoo  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_3 python3_4 -pypy -pypy3" 0 KiB
[ebuild  N     ] dev-python/CacheControl-0.11.5::gentoo  USE="-redis {-test}" PYTHON_TARGETS="python2_7 python3_3 python3_4 -pypy -pypy3" 0 KiB
[ebuild     U  ] dev-python/pip-7.1.2::gentoo [7.0.3::gentoo] PYTHON_TARGETS="python2_7 python3_3 python3_4* -pypy -pypy3" 0 KiB
[ebuild   R    ] dev-python/linecache2-1.0.0::gentoo  USE="{-test}" PYTHON_TARGETS="python2_7 python3_3 python3_4* -pypy% -pypy3%" 0 KiB
[ebuild   R    ] dev-python/traceback2-1.4.0::gentoo  PYTHON_TARGETS="python2_7 python3_3 python3_4* -pypy% -pypy3%" 0 KiB
[ebuild     U  ] dev-python/unittest2-1.1.0::gentoo [1.0.1-r1::gentoo] PYTHON_TARGETS="python2_7 python3_3 python3_4* -pypy% -pypy3%" 80 KiB
[ebuild     U  ] dev-python/testtools-1.8.0::gentoo [1.7.1::gentoo] USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_3 python3_4* -pypy% -pypy3%" 204 KiB
[ebuild   R    ] dev-python/subunit-1.1.0::gentoo  USE="-static-libs {-test}" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7 python3_4* -pypy -pypy3% -python3_3*" 0 KiB
[ebuild   R    ] net-fs/samba-4.1.19::gentoo  USE="acl client cups fam winbind -addns -ads -aio -avahi -cluster -dmapi -gnutls -iprint -ldap -quota (-selinux) -syslog -systemd {-test}" PYTHON_TARGETS="python2_7" 0 KiB
[blocks B      ] <perl-core/ExtUtils-MakeMaker-7.40.100_rc ("<perl-core/ExtUtils-MakeMaker-7.40.100_rc" is blocking virtual/perl-ExtUtils-MakeMaker-7.40.100_rc)
[blocks B      ] <perl-core/libnet-3.50.0 ("<perl-core/libnet-3.50.0" is blocking virtual/perl-libnet-3.50.0)
[blocks B      ] <perl-core/Data-Dumper-2.158.0 ("<perl-core/Data-Dumper-2.158.0" is blocking virtual/perl-Data-Dumper-2.158.0)

Total: 109 packages (8 upgrades, 3 new, 98 reinstalls), Size of downloads: 4,702 KiB
Conflict: 3 blocks (3 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-perl/Module-Build:0

  (dev-perl/Module-Build-0.421.400:0/0::gentoo, ebuild scheduled for merge) pulled in by
    dev-perl/Module-Build:0 (Argument)

  (dev-perl/Module-Build-0.420.500:0/0::gentoo, installed) pulled in by
    ~dev-perl/Module-Build-0.420.500 required by (virtual/perl-Module-Build-0.420.500-r2:0/0::gentoo, installed)
    ^                      ^^^^^^^^^                                                                                                                                   


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (virtual/perl-libnet-3.50.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    virtual/perl-libnet:0
    virtual/perl-libnet required by (dev-perl/libwww-perl-6.50.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-libnet required by (dev-perl/Net-SMTP-SSL-1.30.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-libnet required by @selected

  (virtual/perl-ExtUtils-MakeMaker-7.40.100_rc:0/0::gentoo, ebuild scheduled for merge) pulled in by
    >=virtual/perl-ExtUtils-MakeMaker-6.56 required by (perl-core/CPAN-Meta-2.143.240:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-ExtUtils-MakeMaker required by (dev-perl/JSON-2.900.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-ExtUtils-MakeMaker required by (dev-perl/Module-Build-0.421.400:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-ExtUtils-MakeMaker required by (dev-perl/IO-stringy-2.111.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-ExtUtils-MakeMaker:0
    virtual/perl-ExtUtils-MakeMaker required by (dev-perl/LWP-Protocol-https-6.60.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-ExtUtils-MakeMaker required by (dev-perl/URI-1.680.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-ExtUtils-MakeMaker required by (dev-perl/IO-Socket-SSL-2.12.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-ExtUtils-MakeMaker required by (dev-perl/Net-SMTP-SSL-1.30.0:0/0::gentoo, ebuild scheduled for merge)
    >=virtual/perl-ExtUtils-MakeMaker-6.300.0 required by (dev-perl/IO-HTML-1.1.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-ExtUtils-MakeMaker required by (dev-perl/ExtUtils-Depends-0.404.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-ExtUtils-MakeMaker required by (dev-perl/File-MimeInfo-0.270.0:0/0::gentoo, ebuild scheduled for merge)
    =virtual/perl-ExtUtils-MakeMaker-7.40.100_rc required by (dev-perl/Module-Build-0.421.400:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-ExtUtils-MakeMaker required by (dev-perl/yaml-1.150.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-ExtUtils-MakeMaker required by (dev-perl/Archive-Zip-1.490.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-ExtUtils-MakeMaker required by (dev-perl/Spreadsheet-ParseExcel-0.650.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-ExtUtils-MakeMaker required by (dev-perl/Unicode-EastAsianWidth-1.330.0-r1:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-ExtUtils-MakeMaker required by (dev-perl/Digest-Perl-MD5-1.900.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-ExtUtils-MakeMaker required by (dev-perl/Cairo-1.105.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-ExtUtils-MakeMaker required by (dev-perl/Text-CSV_XS-1.190.0:0/0::gentoo, ebuild scheduled for merge)
    virtual/perl-ExtUtils-MakeMaker required by (dev-perl/Text-Unidecode-1.230.0:0/0::gentoo, ebuild scheduled for merge)

  (perl-core/libnet-1.270.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/libnet:0

  (perl-core/ExtUtils-MakeMaker-7.40.0-r1:0/0::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/ExtUtils-MakeMaker:0

  (perl-core/Data-Dumper-2.154.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    perl-core/Data-Dumper:0

  (virtual/perl-Data-Dumper-2.158.0:0/0::gentoo, ebuild scheduled for merge) pulled in by
    virtual/perl-Data-Dumper required by (dev-perl/ExtUtils-Depends-0.404.0:0/0::gentoo, ebuild scheduled for merge)
    >=virtual/perl-Data-Dumper-2.154.0 required by (dev-lang/perl-5.22.0:0/5.22::gentoo, installed)
    =virtual/perl-Data-Dumper-2.158.0 required by (dev-perl/Module-Build-0.421.400:0/0::gentoo, ebuild scheduled for merge)
    =virtual/perl-Data-Dumper-2.158.0 required by (dev-perl/Module-Build-0.420.500:0/0::gentoo, installed)
    virtual/perl-Data-Dumper required by (dev-perl/Module-Build-0.421.400:0/0::gentoo, ebuild scheduled for merge)
    =virtual/perl-Data-Dumper-2.158.0 required by (dev-lang/perl-5.22.0:0/5.22::gentoo, installed)
    virtual/perl-Data-Dumper:0
    virtual/perl-Data-Dumper required by (dev-perl/Module-Build-0.420.500:0/0::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages

 * perl-cleaner is stopping here:
 * Fix the problem and start perl-cleaner again.
 *
 *
 * Note that upgrading Perl with emerge option --ignore-built-slot-operator-deps=y is not supported.



Code:

emerge -avuD @system --with-bdeps=y

 * IMPORTANT: 3 news items need reading for repository 'gentoo'.
 * Use eselect news read to view new items.


These are the packages that would be merged, in order:

Calculating dependencies                                                                                          [ ok ]                                                                                                                           ... done!
[ebuild     U  ] dev-libs/expat-2.1.0-r5::gentoo [2.1.0-r4::gentoo] USE="unicode -examples -static-libs" ABI_X86="32 (64) (-x32)" 550 KiB
[ebuild     U  ] sys-libs/timezone-data-2015f::gentoo [2015e::gentoo] USE="nls -leaps_timezone" 469 KiB
[ebuild     U  ] dev-libs/lzo-2.09:2::gentoo [2.08-r1:2::gentoo] USE="-examples -static-libs" ABI_X86="32 (64) (-x32)" 581 KiB
[ebuild     U  ] sys-devel/binutils-config-4-r4::gentoo [4-r3::gentoo] 0 KiB
[ebuild     U  ] dev-libs/mpfr-3.1.3_p4::gentoo [3.1.3::gentoo] USE="-static-libs" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild     U  ] sys-apps/debianutils-4.5.1::gentoo [4.4::gentoo] USE="-static" 148 KiB
[ebuild  r  U  ] net-firewall/iptables-1.4.21-r3:0/10::gentoo [1.4.21-r1:0/0::gentoo] USE="ipv6 -conntrack% -netlink -pcap% -static-libs" 535 KiB
[ebuild     U  ] dev-libs/libpcre-8.37-r2:3::gentoo [8.37-r1:3::gentoo] USE="bzip2 cxx jit pcre16 readline recursion-limit (unicode) zlib -libedit -pcre32 -static-libs" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild     U  ] sys-devel/bc-1.06.95-r2::gentoo [1.06.95-r1::gentoo] USE="readline -libedit -static" 0 KiB
[ebuild     U  ] x11-proto/xproto-7.0.28::gentoo [7.0.27::gentoo] USE="-doc" ABI_X86="32 (64) (-x32)" 294 KiB
[ebuild     U  ] x11-proto/kbproto-1.0.7::gentoo [1.0.6-r1::gentoo] ABI_X86="32 (64) (-x32)" 245 KiB
[ebuild     U  ] x11-proto/randrproto-1.5.0::gentoo [1.4.1::gentoo] ABI_X86="32 (64) (-x32)" 139 KiB
[ebuild     U  ] dev-libs/nettle-3.1.1:0/6::gentoo [2.7.1-r4:0/4::gentoo] USE="gmp -doc (-neon) -static-libs {-test}" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="-aes%" 1,809 KiB
[ebuild     U  ] x11-libs/libfontenc-1.1.3::gentoo [1.1.2::gentoo] USE="-static-libs" 295 KiB
[ebuild     U  ] x11-libs/libXrandr-1.5.0::gentoo [1.4.2::gentoo] USE="-static-libs" ABI_X86="32 (64) (-x32)" 308 KiB
[ebuild     U  ] app-misc/pax-utils-1.1.1::gentoo [1.0.3::gentoo] USE="python seccomp%* -caps -debug%" 613 KiB
[ebuild     U  ] virtual/perl-Text-ParseWords-3.300.0::gentoo [3.290.0-r1::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Test-Harness-3.350.0::gentoo [3.330.0::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Perl-OSType-1.8.0::gentoo [1.7.0::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-Module-Metadata-1.0.26::gentoo [1.0.19::gentoo] 0 KiB
[ebuild     U  ] virtual/perl-JSON-PP-2.273.0::gentoo [2.272.30::gentoo] 0 KiB
[ebuild   R    ] x11-proto/xcb-proto-1.11::gentoo  ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7 python3_3 python3_4*" 0 KiB
[ebuild     U  ] dev-python/packaging-15.3-r1::gentoo [15.3::gentoo] USE="{-test}" PYTHON_TARGETS="python2_7 python3_3 python3_4* -pypy -pypy3" 0 KiB
[ebuild     U  ] dev-python/setuptools-18.2-r3::gentoo [18.2-r2::gentoo] USE="{-test}" PYTHON_TARGETS="python2_7 python3_3 python3_4 -pypy -pypy3" 0 KiB
[ebuild     U  ] sys-apps/portage-2.2.20.1::gentoo [2.2.20::gentoo] USE="(ipc) -build -doc -epydoc (-selinux) -xattr" LINGUAS="-ru" PYTHON_TARGETS="python3_3 python3_4* -pypy -python2_7" 0 KiB
[ebuild     U  ] app-eselect/eselect-java-0.1.0-r1::gentoo [0.1.0::gentoo] 15 KiB
[ebuild     U  ] sys-libs/cracklib-2.9.6::gentoo [2.9.4::gentoo] USE="nls python zlib -static-libs {-test}" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="-python2_7*" 628 KiB
[ebuild     U  ] sys-libs/libcap-2.24-r2::gentoo [2.24-r1::gentoo] USE="pam -static-libs" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild     U  ] media-libs/tiff-4.0.5::gentoo [4.0.3-r6::gentoo] USE="cxx jpeg zlib -jbig -lzma -static-libs {-test}" ABI_X86="32 (64) (-x32)" 2,086 KiB
[ebuild     U  ] dev-tcltk/blt-2.4z-r13::gentoo [2.4z-r12::gentoo] USE="X jpeg -static-libs" 0 KiB
[ebuild     U  ] x11-libs/libXt-1.1.5::gentoo [1.1.4::gentoo] USE="-static-libs" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild     U  ] x11-libs/libXaw-1.0.13::gentoo [1.0.12::gentoo] USE="-deprecated -doc -static-libs" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild     U  ] virtual/libusb-1-r2:1::gentoo [1-r1:1::gentoo] USE="udev" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild  N F   ] dev-java/oracle-jdk-bin-1.8.0.60:1.8::gentoo  USE="alsa awt cups fontconfig nsplugin -derby -doc -examples -javafx -jce -pax_kernel (-selinux) -source" 176,991 KiB
[ebuild  NS    ] virtual/jdk-1.8.0:1.8::gentoo [1.7.0:1.7::gentoo] 0 KiB
[ebuild  NS    ] virtual/jre-1.8.0:1.8::gentoo [1.7.0:1.7::gentoo] 0 KiB
[ebuild     U  ] sys-devel/gettext-0.19.5.1-r1::gentoo [0.19.4::gentoo] USE="acl cxx java ncurses nls openmp -cvs -doc -emacs -git -static-libs" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild     U  ] sys-libs/db-6.0.35:6.0::gentoo [6.0.30-r1:6.0::gentoo] USE="cxx java -doc -examples -tcl {-test}" ABI_X86="32 (64) (-x32)" 35,677 KiB
[ebuild     U  ] media-libs/libjpeg-turbo-1.4.1::gentoo [1.4.0::gentoo] USE="java static-libs" ABI_X86="32 (64) (-x32)" 1,494 KiB
[ebuild     UD ] dev-lang/perl-5.20.2-r1:0/5.20::gentoo [5.22.0:0/5.22::gentoo] USE="berkdb gdbm -debug -doc -ithreads" 0 KiB
[ebuild     U  ] sys-libs/pam-1.2.1-r1::gentoo [1.2.0::gentoo] USE="berkdb cracklib filecaps%* nls pie -audit -debug -nis (-selinux) {-test} -vim-syntax" ABI_X86="32 (64) (-x32)" 1,250 KiB
[ebuild     U  ] net-dns/libidn-1.32::gentoo [1.30::gentoo] USE="java nls -doc -emacs -mono -static-libs" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild  rR    ] sys-apps/iproute2-4.1.1::gentoo  USE="berkdb iptables ipv6 -atm -minimal (-selinux)" 0 KiB
[ebuild     U  ] dev-libs/openssl-1.0.2d::gentoo [1.0.2c::gentoo] USE="asm tls-heartbeat zlib -bindist -gmp -kerberos -rfc3779 -sctp -static-libs {-test} -vanilla" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="(sse2)" 5,172 KiB
[ebuild  rR    ] sys-apps/util-linux-2.26.2::gentoo  USE="cramfs ncurses nls pam python suid tty-helpers udev unicode -caps -fdformat (-selinux) -slang -static-libs -systemd {-test}" ABI_X86="32 (64) (-x32)" PYTHON_SINGLE_TARGET="python3_4 -python2_7 -python3_3" PYTHON_TARGETS="python3_4 -python2_7 -python3_3" 0 KiB
[ebuild     U  ] sys-apps/hwids-20150717-r1::gentoo [20150421::gentoo] USE="net pci udev usb" 0 KiB
[ebuild     U  ] sys-devel/llvm-3.6.2:0/3.6::gentoo [3.6.1:0/3.6::gentoo] USE="libffi ncurses python static-analyzer xml -clang -debug -doc -gold -libedit -multitarget -ocaml {-test}" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7 -pypy" VIDEO_CARDS="-radeon" 0 KiB
[ebuild     U  ] net-libs/gnutls-3.3.17.1::gentoo [3.3.15-r1::gentoo] USE="crywrap cxx nls openssl zlib -dane -doc -examples -guile -pkcs11 -static-libs {-test}" ABI_X86="32 (64) (-x32)" LINGUAS="en uk -cs -de -fi -fr -it -ms -nl -pl -sv -vi -zh_CN" 6,192 KiB
[ebuild     U  ] x11-libs/gdk-pixbuf-2.30.8-r1:2::gentoo [2.30.8:2::gentoo] USE="X introspection jpeg tiff -debug -jpeg2k {-test}" ABI_X86="32 (64) (-x32)" 1,306 KiB
[ebuild     U  ] dev-libs/atk-2.16.0-r1::gentoo [2.16.0::gentoo] USE="introspection nls {-test}" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild     U  ] media-libs/mesa-11.0.0_rc2::gentoo [10.5.6::gentoo] USE="classic dri3 egl gallium gbm llvm nptl udev -bindist -d3d9 -debug -gles1 -gles2 -opencl -openmax -osmesa -pax_kernel -pic (-selinux) -vaapi -vdpau -wayland -xa -xvmc" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="(-freedreno) -i915 -i965 -ilo -intel -nouveau -r100 -r200 -r300 -r600 -radeon -radeonsi -vmware" 7,082 KiB
[ebuild     U  ] media-libs/harfbuzz-0.9.41:0/0.9.18::gentoo [0.9.40:0/0.9.18::gentoo] USE="cairo glib graphite icu introspection truetype -fontconfig% -static-libs {-test}" ABI_X86="32 (64) (-x32)" 1,161 KiB
[ebuild     U  ] dev-util/intltool-0.51.0::gentoo [0.50.2-r1::gentoo] 0 KiB
[ebuild     U  ] sys-apps/texinfo-6.0::gentoo [5.2::gentoo] USE="nls -static" 3,991 KiB
[ebuild     U  ] net-misc/openssh-7.1_p1::gentoo [6.8_p1-r5::gentoo] USE="X hpn pam pie ssl -X509 -bindist -debug -kerberos -ldap -ldns -libedit -sctp (-selinux) -skey -ssh1* -static" 0 KiB
[ebuild     U  ] dev-util/gtk-update-icon-cache-3.16.4::gentoo [3.16.3::gentoo] 310 KiB
[ebuild     U  ] dev-util/cmake-3.3.1-r1::gentoo [3.2.3::gentoo] USE="ncurses qt4 -doc -emacs -qt5 -system-jsoncpp {-test}" 6,426 KiB
[ebuild  NS    ] dev-lang/spidermonkey-1.8.5-r4:0/mozjs185::gentoo [17.0.0-r3:17::gentoo, 24.2.0-r2:24::gentoo] USE="-debug -minimal -static-libs {-test}" 6,021 KiB
[ebuild     U  ] sys-auth/polkit-0.113::gentoo [0.112-r3::gentoo] USE="gtk introspection nls pam -examples -jit -kde (-selinux) -systemd {-test%}" 1,415 KiB
[ebuild     U  ] sys-apps/dbus-1.8.20::gentoo [1.8.16::gentoo] USE="X -debug -doc (-selinux) -static-libs -systemd {-test}" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild     U  ] x11-misc/xdg-utils-1.1.0_rc3_p20150825::gentoo [1.1.0_rc3_p20150119::gentoo] USE="perl -doc" 257 KiB
[ebuild     U  ] net-print/cups-2.0.4::gentoo [2.0.2-r1::gentoo] USE="X acl dbus java pam python ssl threads usb -debug -kerberos -lprng-compat (-selinux) -static-libs -systemd -xinetd -zeroconf" ABI_X86="32 (64) (-x32)" LINGUAS="-ca -cs -de -es -fr -it -ja -pt_BR -ru" PYTHON_TARGETS="python2_7" 8,594 KiB
[ebuild     U  ] dev-libs/dbus-glib-0.104::gentoo [0.102::gentoo] USE="-debug -static-libs {-test} (-doc%)" ABI_X86="32 (64) (-x32)" 0 KiB
[ebuild     U  ] x11-libs/gtk+-3.16.5:3::gentoo [3.16.3:3::gentoo] USE="X cups introspection (-aqua) -broadway -cloudprint -colord -debug -examples {-test} -vim-syntax -wayland -xinerama" ABI_X86="32 (64) (-x32)" 0 KiB

Total: 64 packages (56 upgrades, 1 downgrade, 1 new, 3 in new slots, 3 reinstalls), Size of downloads: 272,039 KiB
Fetch Restriction: 1 package (1 unsatisfied)

Fetch instructions for dev-java/oracle-jdk-bin-1.8.0.60:
 *
 * Oracle requires you to download the needed files manually after
 * accepting their license through a javascript capable web browser.
 *
 * Download the following files:
 *   jdk-8u60-linux-x64.tar.gz
 * at 'http://www.oracle.com/technetwork/java/javase/downloads/jdk8-downloads-2133151.html'
 * and move them to '/usr/portage/distfiles'
 *
 * If the above mentioned urls do not point to the correct version anymore,
 * please download the files from Oracle's java download archive:
 *
 *    http://www.oracle.com/technetwork/java/javase/downloads/java-archive-javase8-2177648.html#jdk-8u60-oth-JPR
 *

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.22.0:0/5.22::gentoo, installed) pulled in by
    =dev-lang/perl-5.22* required by (virtual/perl-Carp-1.360.0:0/0::gentoo, installed)
    ^              ^^^^^                                                                                                                     
    dev-lang/perl:0/5.22=[-build(-)] required by (dev-perl/extutils-pkgconfig-1.150.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                       
    (and 29 more with the same problems)

  (dev-lang/perl-5.20.2-r1:0/5.20::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.20* required by (virtual/perl-Test-Simple-1.1.2:0/0::gentoo, installed)
    ^              ^^^^^                                                                                                                           
    dev-lang/perl:0/5.20=[-build(-)] required by (dev-perl/libintl-perl-1.240.0:0/0::gentoo, installed)
                 ^^^^^^^^                                                                                                                 
    (and 74 more with the same problems)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.





Time for an emerge -C dev-perl/* and attempt a reconstruction w.r.t. broken packages


--edit--
obmenu-generator and xrvt-unicode are now working ... what can be done to streamline perl's upgrade...
_________________
The best argument against democracy is a five-minute conversation with the average voter
Great Britain is a republic, with a hereditary president, while the United States is a monarchy with an elective king
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page Previous  1, 2, 3  Next
Page 2 of 3

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum