Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED]Mathematica
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
mubai
n00b
n00b


Joined: 10 Jul 2004
Posts: 32
Location: Sweden

PostPosted: Wed Aug 13, 2014 11:10 am    Post subject: Reply with quote

chi86 wrote:
I tried to unmerge everthing witch came up with:
Code:
equery depends apache

but at the next update it was back again.... but I think your right it can't be the problem!


Looks like you have som USE-flag that makes portage bring it back constantly?
Back to top
View user's profile Send private message
chi86
Apprentice
Apprentice


Joined: 30 Jul 2013
Posts: 164
Location: Austria

PostPosted: Wed Aug 13, 2014 11:26 am    Post subject: Reply with quote

mubai wrote:
Looks like you have som USE-flag that makes portage bring it back constantly?


I don't think I have ... I looked through my package.use and didn't find anything

Code:
x11-base/xorg-server udev
gnome-base/gnome-session branding
# required by x11-terms/guake-0.4.4
# required by @preserved-rebuild (argument)
>=x11-libs/vte-0.28.2-r206:0 python
>=dev-qt/qtwebkit-4.8.5 icu
# required by www-client/chromium-34.0.1847.116
# required by @selected
# required by @world (argument)
>=sys-libs/zlib-1.2.8-r1 minizip
# required by www-client/chromium-34.0.1847.116
# required by @selected
# required by @world (argument)
=dev-libs/libxml2-2.9.1-r1 icu
app-editors/emacs xft gsettings gconf
# required by app-text/pdftk-1.44
# required by pdftk (argument)
>=sys-devel/gcc-4.7.3-r1:4.7 gcj
# required by www-client/chromium-35.0.1916.114-r1
# required by @selected
# required by @world (argument)
>=dev-libs/libxml2-2.9.1-r4 icu
# required by media-gfx/blender-2.71
# required by blender (argument)
=dev-cpp/glog-0.3.3 gflags
=dev-util/gtk-builder-convert-2.24.24 -python_single_target_python3_4 python_single_target_python2_7
=dev-util/gtk-builder-convert-2.24.24 -python_targets_python3_4 python_targets_python2_7
=media-libs/libmediaart-0.4.0 -qt4 qt5
# required by mail-client/thunderbird-24.6.0[gstreamer]
# required by @selected
# required by @world (argument)
>=media-plugins/gst-plugins-meta-0.10-r9:0.10 ffmpeg
# required by dev-python/numpy-1.8.1
# required by dev-python/pygtk-2.24.0-r4
# required by dev-python/gnome-python-base-2.28.1-r1
# required by dev-python/gconf-python-2.28.1-r1
# required by x11-terms/guake-0.4.4
# required by @selected
# required by @world (argument)
#####=dev-python/setuptools-5.4.1 python_targets_python3_4
=media-gfx/blender-2.71 python_single_target_python3_4 python_targets_python3_4
# required by dev-python/numpy-1.8.1
# required by media-gfx/blender-2.71
# required by blender (argument)
=dev-python/setuptools-5.4.1 python_targets_python3_4
# required by media-gfx/blender-2.71
# required by blender (argument)
>=dev-python/numpy-1.8.1 python_targets_python3_4
# required by media-gfx/blender-2.71
# required by blender (argument)
>=dev-python/requests-2.3.0 python_targets_python3_4
media-gfx/blender cycles ffmpeg sdl tiff python_single_target_python3_4 python_targets_python3_4
# required by media-gfx/blender-2.71[ffmpeg]
# required by blender (argument)
=media-video/libav-9.14 theora
# required by dev-python/requests-2.3.0
# required by media-gfx/blender-2.71
# required by blender (argument)
>=dev-python/chardet-2.2.1 python_targets_python3_4
=sci-libs/hdf5-1.8.10 -cxx -threads mpi
# required by media-gfx/blender-2.71[ffmpeg]
# required by blender (argument)
=media-video/ffmpeg-2.3 theora
# required by sci-libs/hdf5-1.8.10[mpi]
# required by media-libs/openimageio-1.1.1
# required by media-gfx/blender-2.71[cycles,-openimageio]
# required by blender (argument)
>=virtual/mpi-2.0-r3 romio
# required by virtual/mpi-2.0-r3
# required by sci-libs/hdf5-1.8.10[mpi]
# required by media-libs/openimageio-1.1.1
# required by media-gfx/blender-2.71[cycles,-openimageio]
# required by blender (argument)
=sys-cluster/openmpi-1.4.3 romio
# required by sys-devel/prelink-20130503
# required by app-emulation/wine-1.6.2[prelink]
# required by wine (argument)
>=dev-libs/elfutils-0.158 static-libs
# required by dev-vcs/git-1.8.5.5[perl,subversion]
# required by sys-devel/gettext-0.18.3.2[git]
# required by app-editors/gedit-plugins-3.12.1
# required by @selected
# required by @world (argument)
>=dev-vcs/subversion-1.8.9 perl -dso
# required by dev-python/matplotlib-1.3.1
# required by sci-mathematics/sage-6.2::sage-on-gentoo
# required by sci-mathematics/sage-doc-6.2::sage-on-gentoo
=x11-base/xorg-server-1.15.0 xvfb
# required by sci-libs/scipy-0.12.1
# required by sci-mathematics/sage-6.2::sage-on-gentoo
# required by sci-mathematics/sage-doc-6.2::sage-on-gentoo
>=dev-python/numpy-1.8.1 lapack
# required by sci-mathematics/sage-6.2::sage-on-gentoo
# required by sci-mathematics/sage-doc-6.2::sage-on-gentoo
>=sci-mathematics/maxima-5.33.0 ecls
# required by sci-mathematics/sage-6.2::sage-on-gentoo
# required by sci-mathematics/sage-doc-6.2::sage-on-gentoo
=sci-mathematics/pari-2.5.5-r2 gmp data
# required by sci-mathematics/sage-6.2::sage-on-gentoo
# required by sci-mathematics/sage-doc-6.2::sage-on-gentoo
>=sci-libs/linbox-1.3.2 sage
# required by sci-mathematics/sage-6.2::sage-on-gentoo
# required by sci-mathematics/sage-doc-6.2::sage-on-gentoo
>=sci-mathematics/flint-2.4.4-r1 ntl
# required by sci-mathematics/sage-6.2::sage-on-gentoo
# required by sci-mathematics/sage-doc-6.2::sage-on-gentoo
=sci-mathematics/gmp-ecm-6.4.4-r2 -openmp
# required by sci-mathematics/sage-6.2::sage-on-gentoo
# required by sci-mathematics/sage-doc-6.2::sage-on-gentoo
>=sci-mathematics/eclib-20140128 flint
# required by sci-mathematics/sage-6.2::sage-on-gentoo
# required by sci-mathematics/sage-doc-6.2::sage-on-gentoo
>=sci-mathematics/lcalc-1.23-r5 pari
# required by sci-mathematics/polybori-0.8.3-r2::sage-on-gentoo
# required by sci-mathematics/sage-6.2::sage-on-gentoo
# required by sci-mathematics/sage-doc-6.2::sage-on-gentoo
=dev-libs/boost-1.52.0-r7 python



and i don't think there is something in my make.conf:

Code:
USE="a52 aac acpi additions alsa branding cairo cdr compat cups dbus dts dvd dvdr emboss encode exif
fam firefox flac gif git -glamor gnome gpm gtk hal hpcups jpeg -kde lcms ldap libnotify mad mikmod mng modules mp3
mp4 mpeg mulitilib nsplugin ogg opengl pango pulseaudio pdf png ppds qt4 scanner sdl spell
startup-notification subversion svg threads tiff truetype vorbis udev unicode usb X xcb x264 xml xv
xvid systemd"
Back to top
View user's profile Send private message
mir3x
Guru
Guru


Joined: 02 Jun 2012
Posts: 429

PostPosted: Wed Aug 13, 2014 10:46 pm    Post subject: Reply with quote

Yes u have, check equery uses php

U have +apache2, right ?

Set -apache2 in make.conf in USE.

Its derived from global profile
_________________
Installation aborted to prevent system self-destruction
Back to top
View user's profile Send private message
chi86
Apprentice
Apprentice


Joined: 30 Jul 2013
Posts: 164
Location: Austria

PostPosted: Thu Aug 14, 2014 7:26 am    Post subject: Reply with quote

Thanks for the tip!
Back to top
View user's profile Send private message
mubai
n00b
n00b


Joined: 10 Jul 2004
Posts: 32
Location: Sweden

PostPosted: Mon Aug 18, 2014 11:19 am    Post subject: Reply with quote

chi86,

Any updates in this matter?
Back to top
View user's profile Send private message
chi86
Apprentice
Apprentice


Joined: 30 Jul 2013
Posts: 164
Location: Austria

PostPosted: Mon Aug 18, 2014 11:22 am    Post subject: Reply with quote

I had to work on the weekend, therefore i had no time to destoy my gentoo (downgrade glibc :wink: ) I try to do it this week
Back to top
View user's profile Send private message
chi86
Apprentice
Apprentice


Joined: 30 Jul 2013
Posts: 164
Location: Austria

PostPosted: Mon Sep 08, 2014 5:41 am    Post subject: Downgrade glibc Reply with quote

Hi,
this weekend I had time and downgraded my glibc from version 2.19-r1 to 2.17. It took ages and the result was that Mathematica still wont start ;(

I also installed the new Mathematica 10 after i finished the downgrade but it wont start, due to the same error message as under Mathematica 8 and 9.

I have no idea whats the problem ;( .... Any ideas????

Thanks!
Back to top
View user's profile Send private message
chi86
Apprentice
Apprentice


Joined: 30 Jul 2013
Posts: 164
Location: Austria

PostPosted: Fri Sep 19, 2014 6:30 am    Post subject: Reply with quote

I still haven't figured out whats the problem .... It has to be my Gentoo because on the Virtual Maschine where I have Win7 installed Mathematica works fine, therefore i now have to use this annoying Windows again because i need Mathematica :evil:

Any help would be greatly appreciated.
Back to top
View user's profile Send private message
chi86
Apprentice
Apprentice


Joined: 30 Jul 2013
Posts: 164
Location: Austria

PostPosted: Mon Sep 29, 2014 6:01 pm    Post subject: ;( Reply with quote

Hi,

so just now something wired happened, I got a new laptop because the old one was really old ;) and I followed the instruction and installed gentoo with gnome (as i always do it) and I thought that Mathematica also wont work on the new system ... but it does :?

Now I have no idea what the problem is .....

Does this mean I also have to setup my work pc because that would suck!

Is there a way to compare the two systems and find out what package (I think it is caused by a package I have on the work pc) causes the problem?

Can it be a wrong setting in my systemd?

No clue what I should do! Any ideas?
Back to top
View user's profile Send private message
chi86
Apprentice
Apprentice


Joined: 30 Jul 2013
Posts: 164
Location: Austria

PostPosted: Sat Oct 04, 2014 9:48 am    Post subject: Reply with quote

And it stopped working again 8O :D

I emerged:
- dropbox
- thunderbird (earlybid)
- emacs
- vlc
.. in order to emerge vlc i had to set the qt4 flag in make.conf ...

qlop -ql:

Code:
Wed Oct  1 20:19:01 2014 >>> dev-util/patchelf-0.6
Wed Oct  1 20:19:09 2014 >>> media-libs/libpng-1.2.51
Wed Oct  1 20:20:47 2014 >>> net-misc/dropbox-2.10.2
Thu Oct  2 21:29:04 2014 >>> media-libs/vo-aacenc-0.1.3
Thu Oct  2 21:29:20 2014 >>> dev-libs/libevent-2.0.21-r1
Thu Oct  2 21:29:40 2014 >>> media-sound/lame-3.99.5-r1
Thu Oct  2 21:29:52 2014 >>> media-libs/xvid-1.3.3
Thu Oct  2 21:30:29 2014 >>> media-libs/gstreamer-0.10.36-r2
Thu Oct  2 21:31:13 2014 >>> media-libs/gst-plugins-base-0.10.36-r1
Thu Oct  2 21:31:28 2014 >>> media-libs/gst-plugins-ugly-0.10.19-r1
Thu Oct  2 21:32:13 2014 >>> media-libs/gst-plugins-bad-0.10.23-r2
Thu Oct  2 21:32:54 2014 >>> media-libs/gst-plugins-good-0.10.31-r1
Thu Oct  2 21:33:09 2014 >>> media-plugins/gst-plugins-ogg-0.10.36-r1
Thu Oct  2 21:33:24 2014 >>> media-plugins/gst-plugins-xvideo-0.10.36-r1
Thu Oct  2 21:33:38 2014 >>> media-plugins/gst-plugins-alsa-0.10.36-r1
Thu Oct  2 21:33:52 2014 >>> media-plugins/gst-plugins-x-0.10.36-r1
Thu Oct  2 21:34:07 2014 >>> media-plugins/gst-plugins-vorbis-0.10.36-r1
Thu Oct  2 21:34:20 2014 >>> media-plugins/gst-plugins-cdparanoia-0.10.36-r1
Thu Oct  2 21:34:31 2014 >>> media-plugins/gst-plugins-mad-0.10.19-r1
Thu Oct  2 21:34:45 2014 >>> media-plugins/gst-plugins-flac-0.10.31-r1
Thu Oct  2 21:34:56 2014 >>> media-plugins/gst-plugins-a52dec-0.10.19-r1
Thu Oct  2 21:35:12 2014 >>> media-plugins/gst-plugins-resindvd-0.10.23-r1
Thu Oct  2 21:35:23 2014 >>> media-plugins/gst-plugins-x264-0.10.19-r1
Thu Oct  2 21:35:38 2014 >>> media-plugins/gst-plugins-xvid-0.10.23-r1
Thu Oct  2 21:35:54 2014 >>> media-plugins/gst-plugins-dts-0.10.23-r1
Thu Oct  2 21:36:05 2014 >>> media-plugins/gst-plugins-dvdread-0.10.19-r1
Thu Oct  2 21:36:20 2014 >>> media-plugins/gst-plugins-faad-0.10.23-r1
Thu Oct  2 21:36:34 2014 >>> media-plugins/gst-plugins-pulse-0.10.31-r1
Thu Oct  2 21:38:07 2014 >>> media-video/ffmpeg-1.2.6-r1
Thu Oct  2 21:38:18 2014 >>> media-plugins/gst-plugins-mpeg2dec-0.10.19-r1
Thu Oct  2 21:38:22 2014 >>> virtual/ffmpeg-9-r1
Thu Oct  2 21:38:33 2014 >>> media-plugins/gst-plugins-ffmpeg-0.10.13_p201211-r2
Thu Oct  2 21:38:37 2014 >>> media-plugins/gst-plugins-meta-0.10-r9
Thu Oct  2 22:05:57 2014 >>> mail-client/thunderbird-24.8.0
Fri Oct  3 12:55:15 2014 >>> dev-libs/re2-0_p20130115
Fri Oct  3 12:55:22 2014 >>> dev-libs/jsoncpp-0.5.0-r1
Fri Oct  3 12:55:32 2014 >>> dev-util/re2c-0.13.5-r1
Fri Oct  3 12:55:41 2014 >>> media-sound/gsm-1.0.13-r1
Fri Oct  3 12:55:49 2014 >>> dev-libs/dotconf-1.3
Fri Oct  3 12:56:01 2014 <<< sys-libs/zlib-1.2.8-r1
Fri Oct  3 12:56:02 2014 >>> sys-libs/zlib-1.2.8-r1
Fri Oct  3 12:56:15 2014 >>> app-arch/snappy-1.1.1
Fri Oct  3 12:56:26 2014 >>> x11-libs/libXScrnSaver-1.2.2-r1
Fri Oct  3 12:56:41 2014 >>> dev-util/ninja-1.4.0
Fri Oct  3 12:57:27 2014 <<< dev-libs/libxml2-2.9.1-r4
Fri Oct  3 12:57:28 2014 >>> dev-libs/libxml2-2.9.1-r4
Fri Oct  3 12:57:34 2014 >>> dev-python/simplejson-3.3.0
Fri Oct  3 12:57:56 2014 >>> media-sound/sox-14.4.1
Fri Oct  3 12:58:04 2014 >>> app-accessibility/espeak-1.47.11-r1
Fri Oct  3 12:58:19 2014 >>> app-accessibility/speech-dispatcher-0.8-r2
Fri Oct  3 13:03:26 2014 <<< gnome-base/gnome-session-3.12.1
Fri Oct  3 13:03:30 2014 >>> gnome-base/gnome-session-3.12.1
Fri Oct  3 13:16:53 2014 >>> app-admin/eselect-emacs-1.16
Fri Oct  3 13:17:30 2014 >>> net-libs/liblockfile-1.09
Fri Oct  3 13:17:52 2014 >>> app-emacs/emacs-common-gentoo-1.4-r1
Fri Oct  3 13:23:03 2014 >>> app-editors/emacs-24.3-r6
Fri Oct  3 13:23:16 2014 >>> virtual/emacs-24
Fri Oct  3 13:41:04 2014 >>> www-client/chromium-37.0.2062.120
Fri Oct  3 13:54:26 2014 >>> app-office/openoffice-bin-4.1.1
Fri Oct  3 20:56:36 2014 >>> media-libs/libdvbpsi-0.2.2
Fri Oct  3 20:56:58 2014 >>> net-dns/libidn-1.28
Fri Oct  3 20:57:06 2014 >>> gnome-base/gnome-mime-data-2.18.0
Fri Oct  3 20:57:42 2014 >>> gnome-base/gnome-vfs-2.24.4-r2
Fri Oct  3 20:59:45 2014 >>> media-video/vlc-2.1.2
Fri Oct  3 21:06:30 2014 <<< media-video/vlc-2.1.2
Fri Oct  3 21:06:32 2014 >>> media-video/vlc-2.1.2
Fri Oct  3 21:07:30 2014 <<< app-portage/eix-0.29.3
Fri Oct  3 21:07:31 2014 >>> app-portage/eix-0.29.3
Fri Oct  3 21:13:06 2014 <<< media-video/vlc-2.1.2
Fri Oct  3 21:13:07 2014 >>> media-video/vlc-2.1.5
Fri Oct  3 21:36:57 2014 >>> media-libs/libmng-2.0.2-r1
Fri Oct  3 21:40:07 2014 >>> dev-qt/qtcore-4.8.5-r2
Fri Oct  3 21:41:04 2014 >>> dev-qt/qtscript-4.8.5
Fri Oct  3 21:41:08 2014 >>> app-admin/eselect-qtgraphicssystem-1.1.1
Fri Oct  3 21:43:44 2014 >>> dev-qt/qtgui-4.8.5-r3
Fri Oct  3 21:44:05 2014 >>> dev-qt/qtsql-4.8.5
Fri Oct  3 21:45:14 2014 >>> dev-qt/qt3support-4.8.5
Fri Oct  3 21:45:45 2014 <<< app-shells/bash-4.2_p49
Fri Oct  3 21:45:46 2014 >>> app-shells/bash-4.2_p51
Fri Oct  3 21:46:11 2014 >>> dev-qt/qtsvg-4.8.5
Fri Oct  3 21:47:37 2014 <<< dev-util/cmake-2.8.12.2-r1
Fri Oct  3 21:47:39 2014 >>> dev-util/cmake-2.8.12.2-r1
Fri Oct  3 21:48:07 2014 <<< app-text/poppler-0.24.5
Fri Oct  3 21:48:08 2014 >>> app-text/poppler-0.24.5
Fri Oct  3 21:48:22 2014 <<< net-wireless/wpa_supplicant-2.0-r2
Fri Oct  3 21:48:23 2014 >>> net-wireless/wpa_supplicant-2.0-r2
Fri Oct  3 21:48:38 2014 <<< app-crypt/pinentry-0.8.2
Fri Oct  3 21:48:39 2014 >>> app-crypt/pinentry-0.8.2
Fri Oct  3 21:49:06 2014 <<< dev-vcs/git-1.8.5.5
Fri Oct  3 21:49:08 2014 >>> dev-vcs/git-2.0.4
Fri Oct  3 21:49:36 2014 <<< net-dns/avahi-0.6.31-r2
Fri Oct  3 21:49:38 2014 >>> net-dns/avahi-0.6.31-r2
Fri Oct  3 21:50:40 2014 <<< media-sound/pulseaudio-5.0-r2
Fri Oct  3 21:50:41 2014 >>> media-sound/pulseaudio-5.0-r2
Fri Oct  3 21:51:26 2014 <<< net-im/empathy-3.12.5
Fri Oct  3 21:51:28 2014 >>> net-im/empathy-3.12.4
Fri Oct  3 21:53:49 2014 <<< media-video/vlc-2.1.5
Fri Oct  3 21:53:50 2014 >>> media-video/vlc-2.1.5
Fri Oct  3 21:54:27 2014 <<< dev-lang/nasm-2.10.07



After that I wanted to work with Mathematica but it took 5min to start and than again I had the same licence srever issue as on all other computers!

I thought I undo all installations with emerge -C (all new packages) and than emerge @perserved-rebuilds but it is still now working :evil: :cry:
Back to top
View user's profile Send private message
chi86
Apprentice
Apprentice


Joined: 30 Jul 2013
Posts: 164
Location: Austria

PostPosted: Fri Dec 19, 2014 6:31 am    Post subject: Still not working! Reply with quote

After a long time not thinking about Mathematica I tried to repair it the other day ... I did all available updates but I still get the same error.

On a new pc I did a new installation of gentoo and at first it runs perfectly fine but than it just stops ... I hadn't even installed anything, i just fixed the fonts of my chromium (http://superuser.com/questions/726132/chrome-33-shows-ugly-blocky-pixelated-fonts-in-linux ...
Code:
eselect fontconfig enable 29-replace-bitmap-fonts.conf
)

Maybe it is du to wrong or interfering entries in my make.conf:
Code:

# These settings were set by the catalyst build script that automatically
# built this stage.
# Please consult /usr/share/portage/config/make.conf.example for a more
# detailed example.
CFLAGS="-O2 -march=athlon64 -pipe"

MAKEOPTS="-j5"

# WARNING: Changing your CHOST is not something that should be done lightly.
# Please consult http://www.gentoo.org/doc/en/change-chost.xml before changing.
CHOST="x86_64-pc-linux-gnu"
# These are the USE flags that were used in addition to what is provided by the
# profile used for building.

USE="a52 aac acpi additions alsa branding cairo cdr compat consolekit cups dbus dts dvd dvdr emboss encode exif
fam firefox flac gif git glamor gnome gpm gtk hal hpcups jpeg -kde lcms ldap libnotify mad mikmod mng modules mp3
mp4 mpeg mulitilib nsplugin ogg opengl pango pulseaudio pdf png ppds -qt4 scanner sdl spell
startup-notification subversion svg threads tiff truetype vorbis udev unicode usb X xcb x264 xml xv
xvid systemd"

#ABI_X86="64"

##USE_PYTHON='2.7 3.3'

#PYTHON_SINGLE_TARGET="python3_4"
#PYTHON_TARGETS="python3_4"
#RUBY_TARGETS="ruby20"

INPUT_DEVICES="evdev synaptics"
VIDEO_CARDS="radeon"

GENTOO_MIRRORS="http://gentoo.inode.at/ ftp://gentoo.inode.at/source/"
SYNC="rsync://rsync1.at.gentoo.org/gentoo-portage"
source /var/lib/layman/make.conf

XFCE_PLUGINS="brightness clock trash"


Thanks!!!!
Back to top
View user's profile Send private message
chi86
Apprentice
Apprentice


Joined: 30 Jul 2013
Posts: 164
Location: Austria

PostPosted: Sat Jul 25, 2015 9:55 am    Post subject: Reply with quote

I finally fixed the porblem:

https://forums.gentoo.org/viewtopic-t-1010010.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum