Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gnome-terminal in Gnome-3.12 broke? [Solved/Rootcaused]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7051
Location: almost Mile High in the USA

PostPosted: Sat Aug 02, 2014 1:23 pm    Post subject: gnome-terminal in Gnome-3.12 broke? [Solved/Rootcaused] Reply with quote

I got a rude awakening on one of my Gnome-3 boxes, gnome-terminal appeared to stop working.
Not having a command line, I was wondering if I should have installed xterm anyway...

Reading on the web that vte-0.3.36 was needed, this was already taken care of by portage. vte? oh yeah, that library. Workaround: I could run /usr/bin/vte2_90 to get a terminal to work with.

Anyway I noticed with "localectl" that I didn't have a locale set. And

Code:
$ /usr/libexec/gnome-terminal-server
Non UTF-8 locale is not supported!


But if I ran

Code:
LANG=en_US.UTF-8 /usr/libexec/gnome-terminal-server &


Then the next gnome-terminal would work!

but if I localectl set-locale LANG=en_US.UTF-8 it still wouldn't work...

I wonder if this is a side effect of not being able to use gdm... It figures, I suspect...

Solved!

Multiple problems:
* default Locale was not set and gnome-terminal now requires a UTF8 locale
* The main problem is that I'm using SLiM instead of gdm. SLiM does not appear to set LANG (locale) on default. I added this code in my ~/.profile to workaround this problem:

Code:
source /etc/locale.conf
export LANG


This allowed gnome-terminal-server to start, and hence gnome-terminal.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?


Last edited by eccerr0r on Sun Aug 03, 2014 12:55 am; edited 2 times in total
Back to top
View user's profile Send private message
poncho
Tux's lil' helper
Tux's lil' helper


Joined: 06 Mar 2011
Posts: 88

PostPosted: Sat Aug 02, 2014 1:40 pm    Post subject: Re: gnome-terminal in Gnome-3.12 broke? Reply with quote

eccerr0r wrote:
but if I localectl set-locale LANG=en_US.UTF-8 it still wouldn't work...


I think this should be:

Code:
localectl set-locale LANG=en_US.utf8


what does
Code:
localectl list-locales
show?
Back to top
View user's profile Send private message
Logicien
Veteran
Veteran


Joined: 16 Sep 2005
Posts: 1360
Location: Montréal

PostPosted: Sat Aug 02, 2014 1:54 pm    Post subject: Reply with quote

Suppose the locales of the user you are at the prompt are well set, you can just do
Code:
locale > /etc/locale.conf

to set the system locales with Systemd. Use sudo if not root.

Note that /etc/localtime must be set or link to the good locales too. This is mandatory, specially to have the right time with a display manager.
_________________
Paul
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7051
Location: almost Mile High in the USA

PostPosted: Sat Aug 02, 2014 3:24 pm    Post subject: Reply with quote

Good catch, I was assuming with the hyphen as gnome-terminal-server listed with a hyphen... Weird. Alas it still does the same thing.
Code:
$ localectl list-locales
en_US
en_US.iso88591
en_US.utf8
$ cat /etc/locale.conf
LANG=en_US.utf8
$ locale
LANG=
LC_CTYPE="POSIX"
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=
$ localectl
   System Locale: LANG=en_US.utf8
       VC Keymap: us
      X11 Layout: us
       X11 Model: pc105+inet
     X11 Options: terminate:ctrl_alt_bksp
$ /usr/libexec/gnome-terminal-server
Non UTF-8 locale is not supported!

/etc/localtime appears to be linking to the right zoneinfo and times show up correct even after DST starts... hmm

More info

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=746415
https://bbs.archlinux.org/viewtopic.php?id=180103

[Edit More]

I had two machines broken with gnome-terminal 3.12. However, it looks like I was able to (easily) fix my other machine that has a working gdm. By

Code:
# localectl set-locale LANG=en_US.utf-8


This was able to fix this problem after a reboot (probably just restart gdm) and gnome-terminal starts up fine once more.
Code:
$ localectl
   System Locale: LANG=en_US.utf-8

Gnome-terminal-server then starts up just fine for this machine. I suspect that what needs to happen is SLiM on my other machine needs to export LANG= from /etc/locale.conf to gnome-session, which then gnome-terminal-server can run...

Oh well, localization seems to be the way to go unfortunately. Kind of feels bloaty because I can use LANG=C just fine...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum