Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
gnome-light can't be installed, want systemd
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
syn0ptik
Apprentice
Apprentice


Joined: 09 Jan 2013
Posts: 265

PostPosted: Thu Jul 31, 2014 2:21 am    Post subject: gnome-light can't be installed, want systemd Reply with quote

Hello,
I can't install gnome-light
make.conf:
Code:
USE="consolekit bindist curl nss gtk -qt4 -qt3support -kde X dbus mdev gnome -pulseaudio"

and this error:
I use eudev instead of udev, someone suggest me early, now here we are.
Code:
Total: 270 packages (266 new, 2 in new slots, 2 reinstalls), Size of downloads: 325,469 kB
Conflict: 3 blocks (3 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (sys-power/upower-0.99.0-r1:0/2::gentoo, ebuild scheduled for merge) pulled in by
    >=sys-power/upower-0.99 required by (gnome-base/gnome-control-center-3.12.1-r1:2/2::gentoo, ebuild scheduled for merge)
    >=sys-power/upower-0.99[introspection] required by (gnome-base/gnome-shell-3.12.2:0/0::gentoo, ebuild scheduled for merge)
    >=sys-power/upower-0.99 required by (gnome-base/gnome-settings-daemon-3.12.2:0/0::gentoo, ebuild scheduled for merge)
    >sys-power/upower-0.99 required by (x11-wm/mutter-3.12.2:0/0::gentoo, ebuild scheduled for merge)
    sys-power/upower required by (net-misc/networkmanager-0.9.8.10-r1:0/0::gentoo, ebuild scheduled for merge)

  (sys-fs/eudev-1.9-r1:0/0::gentoo, installed) pulled in by
    sys-fs/eudev required by @selected

  (sys-apps/systemd-215-r2:0/2::gentoo, ebuild scheduled for merge) pulled in by
    sys-apps/systemd required by (gnome-base/gnome-settings-daemon-3.12.2:0/0::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-31 required by (gnome-base/gnome-shell-3.12.2:0/0::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-212-r5:0/2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,static-libs(-)?] (>=sys-apps/systemd-212-r5:0/2[abi_x86_64(-)]) required by (virtual/libudev-208:0/1::gentoo, installed)
    >=sys-apps/systemd-186:0=[pam] required by (gnome-base/gdm-3.12.2:0/0::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-44-r1[pam] required by (sys-auth/pambase-20120417-r3:0/0::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-212-r5:0/2[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?,gudev,introspection?,static-libs(-)?] (>=sys-apps/systemd-212-r5:0/2[abi_x86_64(-),gudev,introspection]) required by (virtual/libgudev-208:0/0::gentoo, installed)
    >=sys-apps/systemd-208:0 required by (virtual/udev-208-r2:0/0::gentoo, installed)
    >=sys-apps/systemd-207 required by (sys-apps/gentoo-systemd-integration-4:0/0::gentoo, ebuild scheduled for merge)
    >=sys-apps/systemd-31 required by (gnome-base/gnome-control-center-3.12.1-r1:2/2::gentoo, ebuild scheduled for merge)

  (sys-power/upower-pm-utils-0.9.23-r2:0/0::gentoo, installed) pulled in by
    sys-power/upower-pm-utils required by (net-im/telepathy-mission-control-5.16.2:0/0::gentoo, ebuild scheduled for merge)
    sys-power/upower-pm-utils required by @selected


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by media-sound/pulseaudio-5.0-r2[alsa]
# required by gnome-base/gnome-control-center-3.12.1-r1
# required by gnome-base/gnome-shell-3.12.2
# required by gnome-base/gdm-3.12.2
>=media-plugins/alsa-plugins-1.0.28 pulseaudio
# required by gnome-base/gdm-3.12.2
# required by gnome-base/gnome-shell-3.12.2
# required by x11-terms/gnome-terminal-3.12.3[gnome-shell]
# required by gnome-base/gnome-light-3.12.0
# required by gnome-light (argument)
=sys-auth/pambase-20120417-r3 systemd
# required by x11-libs/glamor-0.6.0-r1
# required by x11-drivers/xf86-video-ati-7.4.0[glamor]
# required by x11-base/xorg-drivers-1.16[video_cards_radeon]
# required by x11-base/xorg-server-1.16.0[xorg]
# required by x11-drivers/xf86-input-mouse-1.9.0
>=media-libs/mesa-10.2.4 gbm

 * IMPORTANT: 5 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

localhost / #
Back to top
View user's profile Send private message
natrix
Guru
Guru


Joined: 23 Aug 2013
Posts: 532

PostPosted: Thu Jul 31, 2014 3:39 am    Post subject: Reply with quote

Hi syn0ptik:

Check it http://wiki.gentoo.org/wiki/Systemd

In the global USEs (make.conf) add the flag "systemd".

You don't forgot add in "/etc/portage/package.use" the next:
Code:
 >=media-plugins/alsa-plugins-1.0.28 pulseaudio
>=media-libs/mesa-10.2.4 gbm


Try it and show the new output.
Back to top
View user's profile Send private message
miket
Guru
Guru


Joined: 28 Apr 2007
Posts: 409
Location: Gainesville, FL, USA

PostPosted: Thu Jul 31, 2014 4:05 am    Post subject: Reply with quote

I take it that Gnome-Light is supposed to be a light-weight Gnome, or Gnome without many of its heavier packages. That's what I gather by the elog message I see in the ebuild:
Code:
Use gnome-base/gnome for the full GNOME Desktop
as released by the GNOME team.

I don't know what you're trying to accomplish. I can see three scenarios: 1. you want a lightweight install of Gnome whether for a resource-limited machine or to avoid the systemd baggage, 2. you're looking for an updated Gnome 2, or 3 you are hoping to get a pared-down version of Gnome 3 but don't mind systemd.

The facts that your USE flags include "mdev -pulseaudio" and you have eudev installed implies that you want to avoid systemd and friends. This leaves scenarious 1 and 2.

If you're looking for #2, the Gnome 2 experience, it looks like you *could* get there by emerging gnome-light 2.32.1-r1 and set up masks for all the version >= 3 dependencies that get pulled in. Rather than track down all the dependency graphs manually, it looks like you could do it by an iterative process of emerging gnome-light, finding the packages cause conflicts, masking the version 3 ebuilds of them, and repeating until you make emerge happy. For example, given the output you posted, add
Code:
>=gnome-base/gnome-control-center-3.0
>=gnome-base/gnome-settings-daemon-3.0
to your /etc/portage/package.mask and try the emerge again. This next time you'll get, at the minimum, gnome-settings-daemon-3.12.2 pulling in things you don't want, so you'll mask the >= 3.0 versions of that one and try again. I have no idea whether you'd successfully get Gnome 2 that way in the end, but that's how I'd imagine you'd go about it.

I'm afraid that case 1 is an impossiblity. Pulseaudio, that you've wanted to disable, is a hard dependency of gnome-light 3 and systemd is a hard dependency of gnome-control-center 3, itself a hard dependency of gnome-light 3. I've heard of people who've managed to get some versions of no-Poettering Gnome 3 to build, but it looks like gnome-light is not the avenue toward that.

As for case 3, I'm afraid I'm no help. Even though I don't use Gnome, I can deduce a lot from looking at the ebuilds and doing pretend emerges. I stay away from the jaws of systemd, so I'm no guide for that.
Back to top
View user's profile Send private message
syn0ptik
Apprentice
Apprentice


Joined: 09 Jan 2013
Posts: 265

PostPosted: Thu Jul 31, 2014 6:20 am    Post subject: Reply with quote

Quote:
In the global USEs (make.conf) add the flag "systemd".

You don't forgot add in "/etc/portage/package.use" the next:

yes, but I can't use gnome 3 with udev?


and I found that I forgot disable -systemd, after that I have this error on installation ebuild:
Code:
These are the packages that would be merged, in order:

Calculating dependencies... done!

The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by gnome-base/gnome-light-3.12.0
# required by gnome-light (argument)
# /etc/portage/package.mask:
=gnome-base/gnome-control-center-3.12.1-r1
# required by gnome-base/gnome-light-3.12.0
# required by gnome-light (argument)
# /etc/portage/package.mask:
=gnome-base/gnome-settings-daemon-3.12.2

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

!!! The ebuild selected to satisfy ">=net-misc/networkmanager-0.9.8[modemmanager]" has unmet requirements.
- net-misc/networkmanager-0.9.8.10-r1::gentoo USE="consolekit dhclient gnutls introspection modemmanager nss ppp wext wifi -avahi -bluetooth -connection-sharing -dhcpcd -resolvconf -systemd -test -vala" ABI_X86="64"

  The following REQUIRED_USE flag constraints are unsatisfied:
    exactly-one-of ( nss gnutls )

  The above constraints are a subset of the following complete expression:
    modemmanager? ( ppp ) exactly-one-of ( nss gnutls ) exactly-one-of ( dhclient dhcpcd )

(dependency required by "gnome-base/gnome-control-center-3.12.1-r1" [ebuild])
(dependency required by "gnome-base/gnome-light-3.12.0" [ebuild])
(dependency required by "gnome-light" [argument])

 * IMPORTANT: 5 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.
Back to top
View user's profile Send private message
Navar
Guru
Guru


Joined: 20 Aug 2012
Posts: 353

PostPosted: Mon Aug 04, 2014 6:56 am    Post subject: Reply with quote

syn0ptik wrote:
yes, but I can't use gnome 3 with udev?

Current versions require the use of systemd.logind instead of consolekit (the seperate udev issue is irrelevant).

Regarding your error message, portage is telling you to use either nss or gnutls useflag for net-misc/networkmanager-0.9.8.10-r1, but not both as you're showing. Pick one. These may be set in your profile settings, make.conf and/or any other package.use files used. One option would be to add a disabled entry for net-misc/networkmanager into a related package.use file.

I have neither set because I don't use modemmanager. For further understanding, from the ebuild:
Code:

REQUIRED_USE="
        modemmanager? ( ppp )
        ^^ ( nss gnutls )
        ^^ ( dhclient dhcpcd )
"

Essentially is telling portage that if modemmanager use flag is set then ppp is required along with only one each of either nss/gnutls and dhclient/dhcpcd.
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 6968

PostPosted: Mon Aug 04, 2014 9:01 am    Post subject: Reply with quote

syn0ptik wrote:
yes, but I can't use gnome 3 with udev?

You cannot use udev/eudev with systemd and you cannot use gnome3 without systemd (you have a way, but without disrespect at all, you should wait to increase your handling of gentoo a bit more before going that way).

So get back to your thinking of what you want :
- gnome3 + systemd
- no systemd with anything but not gnome3 (mate should gave you gnome2 experience alike)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum