Joined: 12 May 2004
|Posted: Sun Jul 27, 2014 11:26 pm Post subject: [ GLSA 201407-05 ] OpenSSL: Multiple vulnerabilities
|Gentoo Linux Security Advisory
Title: OpenSSL: Multiple vulnerabilities (GLSA 201407-05)
Date: July 27, 2014
Multiple vulnerabilities have been found in OpenSSL, possibly
allowing remote attackers to execute arbitrary code.
OpenSSL is an Open Source toolkit implementing the Secure Sockets Layer
(SSL v2/v3) and Transport Layer Security (TLS v1) as well as a general
purpose cryptography library.
Vulnerable: < 1.0.1h-r1
Unaffected: >= 1.0.1h-r1
Unaffected: >= 1.0.0m < 1.0.1
Unaffected: >= 0.9.8z_p1 < 0.9.9
Unaffected: >= 0.9.8z_p2 < 0.9.9
Unaffected: >= 0.9.8z_p3 < 0.9.9
Unaffected: >= 0.9.8z_p4 < 0.9.9
Unaffected: >= 0.9.8z_p5 < 0.9.9
Architectures: All supported architectures
Multiple vulnerabilities have been discovered in OpenSSL. Please review
the OpenSSL Security Advisory [05 Jun 2014] and the CVE identifiers
referenced below for details.
A remote attacker could send specially crafted DTLS fragments to an
OpenSSL DTLS client or server to possibly execute arbitrary code with the
privileges of the process using OpenSSL.
Furthermore, an attacker could force the use of weak keying material in
OpenSSL SSL/TLS clients and servers, inject data across sessions, or
cause a Denial of Service via various vectors.
There is no known workaround at this time.
All OpenSSL users should upgrade to the latest version:
|# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-libs/openssl-1.0.1h-r1"
Security Advisory [05 Jun 2014]