Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[revdep-rebuild] après installation de sources (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
pti-rem
Apprentice
Apprentice


Joined: 14 Oct 2011
Posts: 285

PostPosted: Sun Jul 27, 2014 9:54 pm    Post subject: [revdep-rebuild] après installation de sources (résolu) Reply with quote

J'ai installé Growl on Linux (Gol) à partir des sources du Git
http://mattn.github.io/growl-for-linux/

Et mon revdep-rebuid râle !

Je ne sais pas exclure les libraires de Gol pour que mon revdep-rebuild se passe bien :(

Une petite aide du soir serait la bienvenue :)

Code:
gen2 ~ # revdep-rebuild -v -- --ask
 * Configuring search environment for revdep-rebuild
 * Temporary cache files are located in /var/cache/revdep-rebuild

revdep-rebuild environment:
SEARCH_DIRS="/bin
/lib
/opt/bin
/sbin
/usr/bin
/usr/i686-pc-linux-gnu/gcc-bin/4.7.3
/usr/i686-pc-linux-gnu/lib
/usr/lib
/usr/lib/gcc/i686-pc-linux-gnu/4.7.3
/usr/lib/opengl/xorg-x11/lib
/usr/lib/qt4
/usr/libexec
/usr/local/lib
/usr/sbin"
SEARCH_DIRS_MASK="/lib/modules"
LD_LIBRARY_MASK="libjava.so
libjvm.so
libodbc.so
libodbcinst.so"
PORTAGE_ROOT="/"
EMERGE_OPTIONS="--ask"
ORDER_PKGS="1"
FULL_LD_PATH="1"

 * Checking reverse dependencies
 * Packages containing binaries and libraries broken by a package update
 * will be emerged.

 * Collecting system binaries and libraries
 * Generated new 1_files.rr
 * Collecting complete LD_LIBRARY_PATH
 * Generated new 2_ldpath.rr
 * Checking dynamic linking consistency
[ 96% ]  *   broken /usr/local/lib/growl-for-linux/display/libballoon.la (requires -lgolplug)
 *   broken /usr/local/lib/growl-for-linux/display/libfog.la (requires -lgolplug)
 *   broken /usr/local/lib/growl-for-linux/display/libnico2.la (requires -lgolplug)
 *   broken /usr/local/lib/growl-for-linux/display/libnotify_gol.la (requires -lgolplug)
 *   broken /usr/local/lib/growl-for-linux/subscribe/librhythmbox.la (requires -lgolplug)
 *   broken /usr/local/lib/growl-for-linux/subscribe/libtweets.la (requires -lgolplug)
[ 100% ]                 
 * Generated new 3_broken.rr
 * Assigning files to packages
 *  !!! /usr/local/lib/growl-for-linux/display/libballoon.la not owned by any package is broken !!!
 *   /usr/local/lib/growl-for-linux/display/libballoon.la -> (none)
 *  !!! /usr/local/lib/growl-for-linux/display/libfog.la not owned by any package is broken !!!
 *   /usr/local/lib/growl-for-linux/display/libfog.la -> (none)
 *  !!! /usr/local/lib/growl-for-linux/display/libnico2.la not owned by any package is broken !!!
 *   /usr/local/lib/growl-for-linux/display/libnico2.la -> (none)
 *  !!! /usr/local/lib/growl-for-linux/display/libnotify_gol.la not owned by any package is broken !!!
 *   /usr/local/lib/growl-for-linux/display/libnotify_gol.la -> (none)
 *  !!! /usr/local/lib/growl-for-linux/subscribe/librhythmbox.la not owned by any package is broken !!!
 *   /usr/local/lib/growl-for-linux/subscribe/librhythmbox.la -> (none)
 *  !!! /usr/local/lib/growl-for-linux/subscribe/libtweets.la not owned by any package is broken !!!
 *   /usr/local/lib/growl-for-linux/subscribe/libtweets.la -> (none)
 * Generated new 4_raw.rr and 4_owners.rr
 * Found some broken files, but none of them were associated with known packages
 * Unable to proceed with automatic repairs.
 * The broken files are listed in 4_owners.rr
 * The broken files are:
 *   /usr/local/lib/growl-for-linux/display/libballoon.la
 *   /usr/local/lib/growl-for-linux/display/libfog.la
 *   /usr/local/lib/growl-for-linux/display/libnico2.la
 *   /usr/local/lib/growl-for-linux/display/libnotify_gol.la
 *   /usr/local/lib/growl-for-linux/subscribe/librhythmbox.la
 *   /usr/local/lib/growl-for-linux/subscribe/libtweets.la


Last edited by pti-rem on Sun Jul 27, 2014 10:16 pm; edited 1 time in total
Back to top
View user's profile Send private message
pti-rem
Apprentice
Apprentice


Joined: 14 Oct 2011
Posts: 285

PostPosted: Sun Jul 27, 2014 10:15 pm    Post subject: Reply with quote

Code:
gen2 ~ # rm -iv /usr/local/lib/growl-for-linux/display/libballoon.la
gen2 ~ # rm -iv /usr/local/lib/growl-for-linux/display/libfog.la
gen2 ~ # rm -iv /usr/local/lib/growl-for-linux/display/libnico2.la
gen2 ~ # rm -iv /usr/local/lib/growl-for-linux/display/libnotify_gol.la
gen2 ~ # rm -iv /usr/local/lib/growl-for-linux/subscribe/librhythmbox.la
gen2 ~ # rm -iv /usr/local/lib/growl-for-linux/subscribe/libtweets.la

Code:
gen2 ~ # revdep-rebuild -v -- --ask

Code:
gen2 growl-for-linux # ./configure --prefix=/opt/gol --enable-static
gen2 growl-for-linux # make && make install
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7899
Location: ~Brussels - Belgique

PostPosted: Mon Jul 28, 2014 7:52 am    Post subject: Reply with quote

Hello,

Pourquoi l'as-tu installé à la main, alors qu'une version existe dans l'arbre de portage ? Apparemment, il te manque des dépendances que Gentoo n'arrive pas à déterminer.

As-tu essayé cette version (une version "live" apparemment) ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
pti-rem
Apprentice
Apprentice


Joined: 14 Oct 2011
Posts: 285

PostPosted: Mon Jul 28, 2014 8:12 am    Post subject: Reply with quote

Salut

Je ne sais plus pourquoi j'ai utilisé le Git sur plusieurs machines ; ça remonte à quelques mois pour avoir les notifications Hexchat (irc) et ensuite pour l'établir comme système global de notification.

Je ne sais même plus si j'ai essayé la version masquée 9999

Je pense que ça doit revenir un peu au même quoique je vois qu'aucun drapeau USE n'est proposé pour la version masquée de x11-misc/growl-for-linux-0.6.7

Et mon "À propos" de Growl m'indique que j'ai la version 0.8.1

Je n'ai pas encore assez travaillé Growl, pour des notifications par LAN par exemple

Je pense maintenant avoir plus de possibilités de compilation et avoir une version plus à jour avec le Growl du Git


Last edited by pti-rem on Mon Jul 28, 2014 8:33 am; edited 2 times in total
Back to top
View user's profile Send private message
pti-rem
Apprentice
Apprentice


Joined: 14 Oct 2011
Posts: 285

PostPosted: Mon Jul 28, 2014 8:13 am    Post subject: Reply with quote

j'ai eu une petite peur d'avoir perdu mon texte ;)
case doublon
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 7899
Location: ~Brussels - Belgique

PostPosted: Mon Jul 28, 2014 7:54 pm    Post subject: Reply with quote

By the way, j'utilise les USE libnotify (ou notification) pour que les notifications se fassent via les bulles d'info. Pas besoin de ce truc qui sent la pomme ;)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
pti-rem
Apprentice
Apprentice


Joined: 14 Oct 2011
Posts: 285

PostPosted: Tue Jul 29, 2014 7:48 am    Post subject: Reply with quote

Hello,

Oui je suis d'accord avec toi

J'avais le drapeau libnotify de mon Hexchat mais c'est un travail pour sortir du trou de xchat des collègues d'un salon que j'ai du travailler Hexchat + Growl w7

Je ne me le suis installé qu'après, comme contaminé par mon travail pour eux.

Et j'avais bien vu que j'avais les notifications en double et c'est là que j'ai commencé à comprendre libnotify

Je vais certainement réutiliser ce drapeau
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum