Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Problems with wifi authentication -NetworkManager
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
philip
Guru
Guru


Joined: 10 Jun 2003
Posts: 535
Location: Sweden

PostPosted: Sat Jul 26, 2014 8:34 pm    Post subject: [SOLVED] Problems with wifi authentication -NetworkManager Reply with quote

I have had a working wifi through NetworkManager (and KDE).

After an emerge -uDN world I can no longer connect to my access point.I have not made any re-configuration of the wifi set up.

The nm GUI shows that my access point is detected and I can enter the SSID and password. It attempts to authenticate but seem to deautenticate again for unknown reason.

/var/log/messages shows:

Code:

Jul 26 22:10:06 phils_x1 NetworkManager[2185]: <info> Activation (wlp3s0/wireless): connection 'my_SSID' has security, and secrets exist.  N
o new secrets needed.
Jul 26 22:10:06 phils_x1 NetworkManager[2185]: <info> Config: added 'ssid' value 'my_SSID'
Jul 26 22:10:06 phils_x1 NetworkManager[2185]: <info> Config: added 'scan_ssid' value '1'
Jul 26 22:10:06 phils_x1 NetworkManager[2185]: <info> Config: added 'key_mgmt' value 'WPA-PSK'
Jul 26 22:10:06 phils_x1 NetworkManager[2185]: <info> Config: added 'psk' value '<omitted>'
Jul 26 22:10:06 phils_x1 NetworkManager[2185]: <info> Activation (wlp3s0) Stage 2 of 5 (Device Configure) complete.
Jul 26 22:10:06 phils_x1 NetworkManager[2185]: <info> Config: set interface ap_scan to 1
Jul 26 22:10:06 phils_x1 NetworkManager[2185]: <info> (wlp3s0): supplicant interface state: inactive -> scanning
Jul 26 22:10:10 phils_x1 kernel: [  425.237965] wlp3s0: authenticate with a4:b1:e9:7f:1b:0d
Jul 26 22:10:10 phils_x1 kernel: [  425.240588] wlp3s0: send auth to a4:b1:e9:7f:1b:0d (try 1/3)
Jul 26 22:10:10 phils_x1 NetworkManager[2185]: <info> (wlp3s0): supplicant interface state: scanning -> associating
Jul 26 22:10:10 phils_x1 kernel: [  425.242586] wlp3s0: authenticated
Jul 26 22:10:10 phils_x1 kernel: [  425.243371] wlp3s0: associate with a4:b1:e9:7f:1b:0d (try 1/3)
Jul 26 22:10:10 phils_x1 kernel: [  425.247202] wlp3s0: RX AssocResp from a4:b1:e9:7f:1b:0d (capab=0x411 status=0 aid=2)
Jul 26 22:10:10 phils_x1 kernel: [  425.251460] wlp3s0: associated
Jul 26 22:10:10 phils_x1 kernel: [  425.251739] wlp3s0: deauthenticating from a4:b1:e9:7f:1b:0d by local choice (reason=3)
Jul 26 22:10:10 phils_x1 NetworkManager[2185]: <info> (wlp3s0): supplicant interface state: associating -> 4-way handshake
Jul 26 22:10:10 phils_x1 NetworkManager[2185]: <warn> Connection disconnected (reason -3)
Jul 26 22:10:10 phils_x1 kernel: [  425.255890] cfg80211: Calling CRDA to update world regulatory domain
Jul 26 22:10:10 phils_x1 kernel: [  425.258576] cfg80211: World regulatory domain updated:


It seems "Jul 26 22:10:10 phils_x1 kernel: [ 425.251739] wlp3s0: deauthenticating from a4:b1:e9:7f:1b:0d by local choice (reason=3)" gives the best clue to what goes wrong. I have googled this phrase, but have not been able to isolate the problem.

Any clues welcome.
_________________
/Phil


Last edited by philip on Sun Jul 27, 2014 8:54 am; edited 1 time in total
Back to top
View user's profile Send private message
philip
Guru
Guru


Joined: 10 Jun 2003
Posts: 535
Location: Sweden

PostPosted: Sat Jul 26, 2014 9:15 pm    Post subject: Reply with quote

OK, I am one step closer to a solution:

If I do

#killall wpa_supplicant

and the restart NetworkManager:

#/etc/init.d/NetworkManager restart

Then Netwokmanager connects to the AP.

It must be that I have multiple instances of wpa_supplicant running that casues the problem-
But where, when and why does multiple instances of wpa_supplicant start?
_________________
/Phil
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Sat Jul 26, 2014 9:34 pm    Post subject: Reply with quote

philip wrote:
It must be that I have multiple instances of wpa_supplicant running that casues the problem- But where, when and why does multiple instances of wpa_supplicant start?

phil ... can you post the output of the following:

Code:
# egrep -v '(^#|^$)' /etc/rc.conf
# rc-status --all |tr -s ' '
# wpa_cli ping

best ... khay
Back to top
View user's profile Send private message
philip
Guru
Guru


Joined: 10 Jun 2003
Posts: 535
Location: Sweden

PostPosted: Sat Jul 26, 2014 9:56 pm    Post subject: Reply with quote

Thanks,

I give you the output of these command, first before I do killall wpa_supplicant and restart /etc/intid.d/NetworkManager.
And then the same after I have done killall wpa_supplicant and restart /etc/intid.d/NetworkManager

/** Before I killed all instances of WPA_supplicant and restarted /etc/init.d/NewtworkManager **/
Code:

# egrep -v '(^#|^$)' /etc/rc.conf
rc_interactive="YES"
rc_shell=/sbin/sulogin
rc_hotplug="*"
rc_logger="YES"
rc_log_path="/var/log/rc.log"
unicode="YES"
rc_tty_number=12

# rc-status --all |tr -s ' '
Runlevel: default
 dbus [ started ]
 NetworkManager [ inactive ]
 syslog-ng [ started ]
 ntp-client [ stopped ]
 ntpd [ started ]
 netmount [ scheduled ]
 consolekit [ started ]
 xdm [ started ]
 sshd [ started ]
 local [ started ]
Runlevel: boot
 hwclock [ started ]
 modules [ started ]
 fsck [ started ]
 root [ started ]
 mtab [ started ]
 swap [ started ]
 localmount [ started ]
 sysctl [ started ]
 bootmisc [ started ]
 termencoding [ started ]
 keymaps [ started ]
 hostname [ started ]
 tmpfiles.setup [ started ]
 loopback [ started ]
 urandom [ started ]
 procfs [ started ]
 swapfiles [ started ]
 alsasound [ started ]
Runlevel: sysinit
 sysfs [ started ]
 udev-mount [ started ]
 devfs [ started ]
 dmesg [ started ]
 kmod-static-nodes [ started ]
 tmpfiles.dev [ started ]
 udev [ started ]
Runlevel: shutdown
 killprocs [ stopped ]
 savecache [ stopped ]
 mount-ro [ stopped ]
Dynamic Runlevel: hotplugged
 net.enp0s25 [ inactive ]
 net.wlp3s0 [ inactive ]
Dynamic Runlevel: needed
 xdm-setup [ started ]
Dynamic Runlevel: manual

# wpa_cli ping
Selected interface 'wlp3s0'
PONG



/*** After I killed all instances of WPA_supplicant and restarted /etc/init.d/NewtworkManager ***/
Code:

# egrep -v '(^#|^$)' /etc/rc.conf
rc_interactive="YES"
rc_shell=/sbin/sulogin
rc_hotplug="*"
rc_logger="YES"
rc_log_path="/var/log/rc.log"
unicode="YES"
rc_tty_number=12

# rc-status --all |tr -s ' '
Runlevel: default
 dbus [ started ]
 NetworkManager [ started ]
 syslog-ng [ started ]
 ntp-client [ stopped ]
 ntpd [ started ]
 netmount [ stopped ]
 consolekit [ started ]
 xdm [ started ]
 sshd [ started ]
 local [ started ]
Runlevel: boot
 hwclock [ started ]
 modules [ started ]
 fsck [ started ]
 root [ started ]
 mtab [ started ]
 swap [ started ]
 localmount [ started ]
 sysctl [ started ]
 bootmisc [ started ]
 termencoding [ started ]
 keymaps [ started ]
 hostname [ started ]
 tmpfiles.setup [ started ]
 loopback [ started ]
 urandom [ started ]
 procfs [ started ]
 swapfiles [ started ]
 alsasound [ started ]
Runlevel: sysinit
 sysfs [ started ]
 udev-mount [ started ]
 devfs [ started ]
 dmesg [ started ]
 kmod-static-nodes [ started ]
 tmpfiles.dev [ started ]
 udev [ started ]
Runlevel: shutdown
 killprocs [ stopped ]
 savecache [ stopped ]
 mount-ro [ stopped ]
Dynamic Runlevel: hotplugged
 net.enp0s25 [ inactive ]
 net.wlp3s0 [ inactive ]
Dynamic Runlevel: needed
 xdm-setup [ started ]
Dynamic Runlevel: manual

# wpa_cli ping
Failed to connect to non-global ctrl_ifname: (null)  error: No such file or directory

_________________
/Phil
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Sat Jul 26, 2014 11:16 pm    Post subject: Reply with quote

Phil ...

you're hotpluging all services so net.* are started ... along with NetworkManager. You can probably just comment rc_hotplug or disable net.* ... rc_hotplug="!net.*". I don't use NetworkManager but I imagine it doesn't need hotplugging as it probably 'provide[s] net'.

best ... khay
Back to top
View user's profile Send private message
philip
Guru
Guru


Joined: 10 Jun 2003
Posts: 535
Location: Sweden

PostPosted: Sun Jul 27, 2014 8:52 am    Post subject: Reply with quote

Thanks khayyam,

That seemed to do the trick. I commented out rc_hotplug="*" in /etc/rc.conf. And now NetworkManager connects my wifi correctly.

My knowledge is a bit limited here. Doesn't udev require rc_hotplug="*" in /etc/rc.conf ?

Also isn't usb dependent on rc_hotplug="*" ?

I am not sure if-, when and why I may have enabled rc_hotplug="*" in /etc/rc.conf or if installation of some packge has enabeld it....
_________________
/Phil
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Sun Jul 27, 2014 12:37 pm    Post subject: Reply with quote

philip wrote:
Thanks khayyam, That seemed to do the trick. I commented out rc_hotplug="*" in /etc/rc.conf. And now NetworkManager connects my wifi correctly.

Phil ... you're welcome & good.

philip wrote:
My knowledge is a bit limited here. Doesn't udev require rc_hotplug="*" in /etc/rc.conf ?

No, rc_hotplug means that on udev detecting an interface (wlp3s0, or what have you) the respective service (net.wlp3s0) will be started. In your case this starts services that NetworkManager is already managing. As I said above I'm not using NetworkManager so I'm not sure if it requires hotplug at all ... but you probably don't want everything hotpluged.

philip wrote:
Also isn't usb dependent on rc_hotplug="*" ?

You mean USB network cards? These would also be started similarly to the above, but you will be able to manage them without hotplugging.

philip wrote:
I am not sure if-, when and why I may have enabled rc_hotplug="*" in /etc/rc.conf or if installation of some packge has enabeld it....

You probably did as "[b]y default we do not allow hotplugging" and no package will enable it.

best ... khay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum