Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Clé USB] HS ou pas?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 701
Location: S.O. France

PostPosted: Fri Aug 08, 2014 8:06 pm    Post subject: [Clé USB] HS ou pas? Reply with quote

Bonjour,

J'ai un soucis avec une clé USB que je n'arrive pas a réparer.
Sous windows elle n'est pas reconnue non plus (un driver s'installe mais aucun signe de la clé ensuite)

dmesg (tenté avec un live ubuntu et memes infos)
Code:
[10973.019187] usb 3-1: new high-speed USB device number 3 using xhci_hcd
[10973.136751] usb-storage 3-1:1.0: USB Mass Storage device detected
[10973.136992] scsi7 : usb-storage 3-1:1.0
[10974.142830] scsi 7:0:0:0: WORM              (        ,                4    PQ: 1 ANSI: 5
[10974.143132] scsi 7:0:0:1: WORM              (        ,                4    PQ: 1 ANSI: 5
[10974.143396] scsi 7:0:0:2: WORM              (        ,                4    PQ: 1 ANSI: 5
[10974.143771] scsi 7:0:0:0: Attached scsi generic sg2 type 4
[10974.144035] scsi 7:0:0:1: Attached scsi generic sg3 type 4
[10974.144343] scsi 7:0:0:2: Attached scsi generic sg4 type 4

lsusb
Code:
Bus 003 Device 003: ID 1800:1500

Pas de /dev/sdxx crée, introuvable avec gparted.
En essayant de bouter dessus, le bios la reconnais avec 4 partitions
Code:
clé 8G
(
(
(

Selon vous HS ou je peux tenter d'autres trucs?
Back to top
View user's profile Send private message
USTruck
Guru
Guru


Joined: 21 Aug 2005
Posts: 423
Location: La Louviere (Belgique)

PostPosted: Sat Aug 09, 2014 7:26 am    Post subject: Reply with quote

Bonjour,


[10974.143771] scsi 7:0:0:0: Attached scsi generic sg2 type 4
[10974.144035] scsi 7:0:0:1: Attached scsi generic sg3 type 4
[10974.144343] scsi 7:0:0:2: Attached scsi generic sg4 type 4

La clé est reconnue : sg2, sg3, sg4 ...

Remettre la clé, vérifier quelle identifiant est utilisé :

fdisk /dev/sxy (sxy : sg si sg2, 3, 4 ...)

effacer les partitions existantes et recréer une partition puis la formater

Edit : cela arrive souvent quand la clé est pleine (nombre de fichier ; voir limitation du fat) ou que l'on enlève la clé sans avoir fermer correctement le (les) processus qui l'utilise, cela laisse des fichiers ouvert et peux corrompre le systeme de fichier de la clé.
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 701
Location: S.O. France

PostPosted: Sat Aug 09, 2014 12:17 pm    Post subject: Reply with quote

Effectivement quand je la branche, il apparait 3 entrees dans /dev (sg2, sg3, sg4)
sg0 et sg1 étant déjà présents.

Par contre impossible de faire quoi que ce soit.
fdisk /dev/sg
Code:
fdisk: impossible d'ouvrir /dev/sg: Aucun fichier ou dossier de ce type

fdisk /dev/sg2 ne fait rien, obligé de killer avec ctrl C

mkfs.vfat /dev/sg3
Code:
mkfs.vfat: Attempting to create a too large filesystem
Back to top
View user's profile Send private message
USTruck
Guru
Guru


Joined: 21 Aug 2005
Posts: 423
Location: La Louviere (Belgique)

PostPosted: Sun Aug 10, 2014 7:49 am    Post subject: Reply with quote

Bonjour,

sg0 et 1 sont déjà présent avant l'insertion de la clé ?

Il faut d'abord trouver le pourquoi et a quoi il correspond (voir dmesg | grep sg)
Ensuite comprendre pourquoi le système ajoute la clé a sg


Quand la clé est insérée :
lsusb
lsmod
fdisk -l

Si le système n'arrive pas a passer la clé en mode 'disque', donc monter une partition ou du moins la rendre accècible, le hardware de la clé est plus que probablement HS.

Edit : suis réveillé ... oufti. Bon SG c'est l'id interne du systeme pour les disques, udev (ou tout autre systeme) doit en faire un disque ; sdx
voir donc si tu as une entrée dans /dev : sda -> premier disque dur, sdb -> deuxieme ou lecteur CD ou lecteur USB, etc ....
Bonne chance
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 701
Location: S.O. France

PostPosted: Mon Aug 11, 2014 4:39 pm    Post subject: Reply with quote

Quand j'insère la clé, lsmod ne bouge pas, aucune entrée dans fdisk et lsusb tu l'as dans mon 1er post.
Dans /dev j'ai juste sg2, sg3 et sg4 qui se créent.

Je pense aussi a un problème hardware mais j'avais un infime espoir vu que le systeme la detecte (mal mais il l'a detecte)
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 6494

PostPosted: Mon Aug 11, 2014 9:32 pm    Post subject: Reply with quote

Verifie surtout que ta clé n'est pas de protection d'écriture (certaines ont juste un petit locket/switch a pousser), parceque :
[10974.142830] scsi 7:0:0:0: WORM
-> https://en.wikipedia.org/wiki/Write_Once_Read_Many

Sinon tu pourras essayer tous les formattage que tu veux...
Back to top
View user's profile Send private message
sebB
l33t
l33t


Joined: 02 Mar 2011
Posts: 701
Location: S.O. France

PostPosted: Wed Aug 13, 2014 7:22 am    Post subject: Reply with quote

Pas de protection sur la clé.
Je vais la déclarer officiellement foireuse.

@krinn, merci pour le lien car mes recherches n'avais pas abouties.
Les seuls résultats que je trouvais concernaient le virus WORM.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum