Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Can't set default locales (at xorg session)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
DeIM
Apprentice
Apprentice


Joined: 11 Apr 2006
Posts: 256

PostPosted: Mon Jul 14, 2014 3:30 am    Post subject: [Solved] Can't set default locales (at xorg session) Reply with quote

Hi, I installed Gentoo with xorg and openbox.
Code:
$ locale
LANG=
LC_CTYPE="POSIX"
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=
$ eselect locale list
Available targets for the LANG variable:
  [1]   C
  [2]   POSIX
  [3]   cs_CZ
  [4]   cs_CZ.iso88592
  [5]   cs_CZ.utf8 *
  [6]   czech
  [7]   en_US
  [8]   en_US.iso88591
  [9]   en_US.utf8
  [ ]   (free form)
$ cat /etc/env.d/02locale
# Configuration file for eselect
# This file has been automatically generated.
LANG="cs_CZ.utf8"

Why the selected locale is not really set - only after . /etc/profile? How can I set it?
Thanks


Last edited by DeIM on Tue Jul 15, 2014 5:45 pm; edited 1 time in total
Back to top
View user's profile Send private message
DeIM
Apprentice
Apprentice


Joined: 11 Apr 2006
Posts: 256

PostPosted: Tue Jul 15, 2014 8:06 am    Post subject: Reply with quote

Hi again. I've tried to set
Code:
export LANG=cs_CZ.utf8

to autostart of openbox, but this lang is set only in terminal emulator. When I start lefapad from roxterm it is in czech but opened by grun it't in english :(

I think that I'm still missing something.

Older PC is OK, but I didn't find any differences :(
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 6965

PostPosted: Tue Jul 15, 2014 11:47 am    Post subject: Reply with quote

https://forums.gentoo.org/viewtopic-t-995464.html
-> https://www.youtube.com/watch?v=tO5sxLapAts
Back to top
View user's profile Send private message
DeIM
Apprentice
Apprentice


Joined: 11 Apr 2006
Posts: 256

PostPosted: Tue Jul 15, 2014 3:50 pm    Post subject: Reply with quote

I think it must be some configure misunderstand of xdm or slim. I know the difference between older PC and the new one now: On older PC I run xorg by startx command from console so locales was set properly (same as on new PC in console). I found this problem on all pcs starting with slim. Those started over startx command are all in good locales.

But when I start openbox session over slim I'm still getting:
Code:
$ locale
LANG=
LC_CTYPE="POSIX"
LC_NUMERIC="POSIX"
LC_TIME="POSIX"
LC_COLLATE="POSIX"
LC_MONETARY="POSIX"
LC_MESSAGES="POSIX"
LC_PAPER="POSIX"
LC_NAME="POSIX"
LC_ADDRESS="POSIX"
LC_TELEPHONE="POSIX"
LC_MEASUREMENT="POSIX"
LC_IDENTIFICATION="POSIX"
LC_ALL=


Current configuration:
Code:
$ eselect locale list
Available targets for the LANG variable:
  [1]   C
  [2]   POSIX
  [3]   cs_CZ
  [4]   cs_CZ.iso88592
  [5]   cs_CZ.utf8
  [6]   czech
  [7]   en_US
  [8]   en_US.iso88591
  [9]   en_US.utf8
  [10]  cs_CZ.UTF-8 *
  [ ]   (free form)
$ cat /etc/env.d/02locale
LANG="cs_CZ.UTF-8"
$ cat .config/openbox/environment
LANG="cs_CZ.UTF-8"


I had no problem generating locales. my locale.gen:
Code:
cs_CZ ISO-8859-2
cs_CZ.UTF-8 UTF-8
en_US ISO-8859-1
en_US.UTF-8 UTF-8

When I stop xdm and start openbox by startx it is in czech.
Back to top
View user's profile Send private message
DeIM
Apprentice
Apprentice


Joined: 11 Apr 2006
Posts: 256

PostPosted: Tue Jul 15, 2014 3:59 pm    Post subject: Reply with quote

I think it's fixed now:
Only added export LANG="cs_CZ.UTF-8" to .config/openbox/environment

Is it OK?
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Tue Jul 15, 2014 5:33 pm    Post subject: Reply with quote

DeIM wrote:
I think it's fixed now:
Only added export LANG="cs_CZ.UTF-8" to .config/openbox/environment

Is it OK?


Personally, I'd be setting that in my shell init file, but this looks like it should works too.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum