Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Some unwanted quirks in gentoo with Cinnamon 2.2.13/14
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Palme
n00b
n00b


Joined: 31 May 2014
Posts: 62

PostPosted: Sat Jul 12, 2014 2:09 pm    Post subject: Some unwanted quirks in gentoo with Cinnamon 2.2.13/14 Reply with quote

Hi all, hoping you can help me out with 2 problems which confuses me.


The other day I installed the Cinnamon desktop environment, . Ever since then I have a few quirks which I would like to be undone and returned to their default behaviour:

1) The wallpaper doesn't work , by that I mean that whatever I change my desktop background to when logged into gentoo, it doesn't change on the login (desktop) , the changes are only made on the lock-screen.

2) occasionally The desktop icons "Computer and Home" fail to appear when booting into the desktop,
even when enabled in Cinnamon Settings > Desktop."Trash", "Mounted Volumes" etc. also fail to appear (if checked) in this caseThe selected wallpaper is displayed correctly

I even reinstalled cinnamon with their entire deep dependency tree

Code:
emerge -eva =gnome-extra/cinnamon-2.2.13


and it took 25 hours and 30 minutes but nothing has changed :(

Many thanks for any help in advance.


Last edited by Palme on Wed Jul 23, 2014 10:13 am; edited 1 time in total
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7051
Location: almost Mile High in the USA

PostPosted: Tue Jul 15, 2014 4:41 am    Post subject: Reply with quote

Have you tried etc-update to make sure there are no config files that need to be updated?

What happens if you create another user and try running it there? (i.e. do you have some old config files lying around?)
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Palme
n00b
n00b


Joined: 31 May 2014
Posts: 62

PostPosted: Tue Jul 15, 2014 12:57 pm    Post subject: Reply with quote

thanks eccerr0r for replay

I've already tried etc-update but alle files are up2date

i created a new user but the same problems still exist

maybe someone know how to reset Cinnamon?

i tried

Code:
gsettings reset-recursively org.cinnamon


but i get

Code:
 "WARNING **: failed to commit changes to dconf: The connection is closed
Back to top
View user's profile Send private message
gentooP4
Apprentice
Apprentice


Joined: 20 Sep 2010
Posts: 182
Location: NZ

PostPosted: Thu Jul 17, 2014 9:54 am    Post subject: Reply with quote

I have a similar wallpaper issues with Cinnamon on Archlinux. The only way I can effectively change it is to find an image and use the right-click/set as wallpaper route.
Back to top
View user's profile Send private message
Palme
n00b
n00b


Joined: 31 May 2014
Posts: 62

PostPosted: Wed Jul 23, 2014 10:09 am    Post subject: Reply with quote

even this does not work under gentoo

//
Now I made a complete fresh installation of Gentoo + Cinnamon but the problem still exist

Code:
emerge --info
Portage 2.2.8-r1 (default/linux/amd64/13.0/desktop, gcc-4.7.3, glibc-2.17, 3.12.21-gentoo-r1 x86_64)
=================================================================
System uname: Linux-3.12.21-gentoo-r1-x86_64-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_4000+-with-gentoo-2.2
KiB Mem:     2050588 total,    690348 free
KiB Swap:    7812092 total,   7812092 free
Timestamp of tree: Tue, 22 Jul 2014 10:30:01 +0000
ld GNU ld (Gentoo 2.23.2 p1.0) 2.23.2
app-shells/bash:          4.2_p45
dev-lang/python:          2.7.6, 3.3.3
dev-util/cmake:           2.8.12.2
dev-util/pkgconfig:       0.28-r1
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.10.3, 1.12.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.13 (virtual/os-headers)
sys-libs/glibc:           2.17
Repositories: gentoo localoverlay
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE@euro"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bindist branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm gtk iconv jpeg lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg multilib ncurses networkmanager nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds qt3support qt4 readline sdl session spell sse sse2 ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, SYNC, USE_PYTHON


I also opened a ticket in Gentoo's Bugzilla,maybe someone has an idea how to fix this

https://bugs.gentoo.org/show_bug.cgi?id=517338

Many thanks for any help in advance.
Back to top
View user's profile Send private message
Palme
n00b
n00b


Joined: 31 May 2014
Posts: 62

PostPosted: Sun Jul 27, 2014 12:54 pm    Post subject: Reply with quote

can anyone please help to solve the problem :|
Back to top
View user's profile Send private message
Clad in Sky
l33t
l33t


Joined: 04 May 2007
Posts: 851
Location: Germany

PostPosted: Sun Jul 27, 2014 3:50 pm    Post subject: Reply with quote

Sorry, no help here, but I have the issue with icons not appearing (trash in my case) on XFCE - so it might not be a problem with cinnamon if your Computer and Home disappear.
_________________
Kali Ma
Now it's autumn of the aeons
Dance with your sword
Now it's time for the harvest
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7051
Location: almost Mile High in the USA

PostPosted: Mon Jul 28, 2014 7:26 pm    Post subject: Reply with quote

not much help in this post either, but I had a recent weird problem (recent = just this past weekend!)

I was trying to get XFCE working on one of my "junk" computers - using an old ATI Rage Pro AGP card. At first it worked just fine, got XFCE running but it was out of date (emerge --sync). I updated everything to latest.

Bad move.

The top bar and the bottom bar was all corrupt, the icons were shrunk and mousing over them didn't work properly. I tried re-emerging some stuff. No dice. Cleared the config in the user account. Still broken.

For the heck of it I popped out the card and replaced it with a GeForce4 MX440 using the nouveau driver I had also installed on the disk.

This time, XFCE worked just fine once more... no changes needed.

Go figure.

I have a feeling the VESA driver may had something to do with it, the ATI Rage Pro AGP, despite being a Mach64 card, does not work with the Mach64 driver (it segfaults on startup).

Some weird driver <-> software issue.

*sigh*
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed watching?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum