Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
firefox 24.6 crashes and returns to kde login screen
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1612

PostPosted: Fri Jul 11, 2014 8:14 pm    Post subject: firefox 24.6 crashes and returns to kde login screen Reply with quote

Hi

Since I upgraded firefox to version 24.6, I manage to use for few minutes with firefox and then it crashes (sometimes by moving to other tab or opening a new tab. When firefox crashes I get a black screen and then returned back to kdm login screen.
I am not sure where the problem is.

Code:
 grep EE Xorg.1.log.old
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[  1738.224] Initializing built-in extension MIT-SCREEN-SAVER
[  1738.232] (EE) Failed to load module "modesetting" (module does not exist, 0)
[  1738.291] (EE) GLX error: Can not get required symbols.


dmesg doesn't give anything useful.

Code:
 tail -50 kdm.log
Initializing built-in extension DPMS
Initializing built-in extension Present
Initializing built-in extension DRI3
Initializing built-in extension X-Resource
Initializing built-in extension XVideo
Initializing built-in extension XVideo-MotionCompensation
Initializing built-in extension XFree86-VidModeExtension
Initializing built-in extension XFree86-DGA
Initializing built-in extension XFree86-DRI
Initializing built-in extension DRI2
[b]Loading extension GLX
klauncher(10057) kdemain: No DBUS session-bus found. Check if you have started the DBUS server.
kdeinit4: Communication error with launcher. Exiting!
kdmgreet(10051)/kdecore (K*TimeZone*): KSystemTimeZones: ktimezoned initialize() D-Bus call failed:  "Not connected to D-Bus server" [/b]

kdmgreet(10051)/kdecore (K*TimeZone*): No time zone information obtained from ktimezoned
Initializing built-in extension Generic Event Extension
Initializing built-in extension SHAPE
Initializing built-in extension MIT-SHM
Initializing built-in extension XInputExtension
Initializing built-in extension XTEST
Initializing built-in extension BIG-REQUESTS
Initializing built-in extension SYNC
Initializing built-in extension XKEYBOARD
Initializing built-in extension XC-MISC
Initializing built-in extension XINERAMA
Initializing built-in extension XFIXES
Initializing built-in extension RENDER
Initializing built-in extension RANDR
Initializing built-in extension COMPOSITE
Initializing built-in extension DAMAGE
Initializing built-in extension MIT-SCREEN-SAVER
Initializing built-in extension DOUBLE-BUFFER
Initializing built-in extension RECORD
Initializing built-in extension DPMS
Initializing built-in extension Present
Initializing built-in extension DRI3
Initializing built-in extension X-Resource
Initializing built-in extension XVideo
Initializing built-in extension XVideo-MotionCompensation
Initializing built-in extension XFree86-VidModeExtension
Initializing built-in extension XFree86-DGA
Initializing built-in extension XFree86-DRI
Initializing built-in extension DRI2
[b]Loading extension GLX
klauncher(10411) kdemain: No DBUS session-bus found. Check if you have started the DBUS server.
kdeinit4: Communication error with launcher. Exiting!
kdmgreet(10405)/kdecore (K*TimeZone*): KSystemTimeZones: ktimezoned initialize() D-Bus call failed:  "Not connected to D-Bus server" [/b]

kdmgreet(10405)/kdecore (K*TimeZone*): No time zone information obtained from ktimezoned


I don't even use flash
This is the output of .xsession-errors

Code:
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 20 (X_GetProperty)
  Resource id:  0x1c000e3
kcminit(10491): "Error launching kaccess. Either KLauncher is not running anymore, or it failed to start the application."

lancelot(10505): couldn't create slave: "Cannot talk to klauncher: Message did not receive a reply (timeout by message bus)"
kdeinit4: Shutting down running client.
"/org/freedesktop/UDisks2/block_devices/sr0" : property "Name" does not exist
"/org/freedesktop/UDisks2/drives/TSSTcorp_CDDVDW_SN_208BB_R8F96GJC501Y9R" : property "DeviceNumber" does not exist
"/org/freedesktop/UDisks2/drives/TSSTcorp_CDDVDW_SN_208BB_R8F96GJC501Y9R" : property "Device" does not exist
Connecting to deprecated signal QDBusConnectionInterface::serviceOwnerChanged(QString,QString,QString)
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
KDE Daemon (kded) already running.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
kbuildsycoca4 running...
"/org/freedesktop/UDisks2/drives/Generic_USB2_2e0_CRW_20100201396000000" : property "DeviceNumber" does not exist
"/org/freedesktop/UDisks2/drives/Generic_USB2_2e0_CRW_20100201396000000" : property "Device" does not exist
X Error: BadWindow (invalid Window parameter) 3
  Major opcode: 20 (X_GetProperty)
  Resource id:  0x1a000a0


I checked D-BUS and it's started.

I"ll be happy to get any ideas. I found via search in other forums that firefox crashes kde. But it's not similar to my case.
Back to top
View user's profile Send private message
gemarcano
Tux's lil' helper
Tux's lil' helper


Joined: 04 Jun 2012
Posts: 88
Location: Virginia

PostPosted: Sun Jul 13, 2014 4:55 pm    Post subject: Reply with quote

What system logger are you using? If possible, try to see those logs (usually those are under /var/log/messages or at least in /var/log) for any mention of segfailt (or just do as root "find /var/log -type f -exec grep -i segfault {} \+").

One thing I can think of, in order to get more output about what's going on, is to open firefox from Konsole and pipe the ouput to a file. For example:
Code:
$ cd
$ firefox &> firefox.log
Then proceed to crash firefox. After it takes KDE down with it, see the firefox.log file in your home directory and see if there are any messages there that may be pertinent.

Still, there seems to be something funny going on with DBus. When KDE is working, if you do a "ps -e | grep dbus", do you see a few lines? For example, mine currently looks like:
Code:
 4472 ?        00:00:00 dbus-daemon
 6135 ?        00:00:00 dbus-launch
 6136 ?        00:00:00 dbus-daemon

Out of curiosity, have you tried running revdep-rebuild just in case? In the past, I've had problems with missing libraries due to upgrades not gone right that are caught by revdep-rebuild. I hope this helps!
Back to top
View user's profile Send private message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1612

PostPosted: Sun Jul 20, 2014 7:18 pm    Post subject: Reply with quote

gemarcano wrote:
What system logger are you using? If possible, try to see those logs (usually those are under /var/log/messages or at least in /var/log) for any mention of segfailt (or just do as root "find /var/log -type f -exec grep -i segfault {} \+").

One thing I can think of, in order to get more output about what's going on, is to open firefox from Konsole and pipe the ouput to a file. For example:
Code:
$ cd
$ firefox &> firefox.log
Then proceed to crash firefox. After it takes KDE down with it, see the firefox.log file in your home directory and see if there are any messages there that may be pertinent.

Still, there seems to be something funny going on with DBus. When KDE is working, if you do a "ps -e | grep dbus", do you see a few lines? For example, mine currently looks like:
Code:
 4472 ?        00:00:00 dbus-daemon
 6135 ?        00:00:00 dbus-launch
 6136 ?        00:00:00 dbus-daemon

Out of curiosity, have you tried running revdep-rebuild just in case? In the past, I've had problems with missing libraries due to upgrades not gone right that are caught by revdep-rebuild. I hope this helps!



Thanks for the tips. Meanwhile, I downgraded to firefox 24.5.0. I will see if this version crashes too.

However, I ran the commands that you suggested. Here are the relevant lines:

Code:
  find /var/log -type f -exec grep -i segfault {} \+
Binary file /var/log/messages matches
/var/log/portage/sys-apps:dbus-1.8.6:20140708-210536.log:config.status: creating test/data/valid-service-files/org.freedesktop.DBus.TestSuiteSegfaultService.service
/var/log/portage/sys-apps:dbus-1.8.6:20140708-210536.log:config.status: creating test/data/valid-service-files-system/org.freedesktop.DBus.TestSuiteSegfaultService.service


I run now the log line to see if something pops up with the downgraded version. if everything is ok, I will upgrade again and run it again.

Yes, I ran revdep-rebuild. It's not the issue.
When I run "ps -e | grep dbus", I see these 3 lines.
Back to top
View user's profile Send private message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1612

PostPosted: Tue Jul 22, 2014 9:28 pm    Post subject: Reply with quote

I upgraded again to 24.6. Firefox crashed again. Here is the output of the crash:

Code:
plugin-container: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.
firefox: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.


So, it's X that crashes. Any idea how to fix it? Why it happens?
Back to top
View user's profile Send private message
gemarcano
Tux's lil' helper
Tux's lil' helper


Joined: 04 Jun 2012
Posts: 88
Location: Virginia

PostPosted: Tue Jul 29, 2014 1:58 am    Post subject: Reply with quote

I don't see that you mentioned it, but what is your graphics card and which driver are you using for it...? Also, is your system a new-ish laptop (did it ever use something called Optimus on Windows)? I'm unsure as to what's going on, but some quick searches online revealed other people experiencing similar things with Ubuntu and Nvidia cards (I think they were using nouveau, but I'm not sure. They claimed the problem left after switching to the Nvidia binary driver). I ask about Optimus because Linux support for it is, well, kind of meh. But it can work.This, along with the driver for your card, may be part of your problem. Does Firefox crash immediately, or when going to a specific website?
Back to top
View user's profile Send private message
queen
Veteran
Veteran


Joined: 19 Jul 2005
Posts: 1612

PostPosted: Wed Jul 30, 2014 8:19 pm    Post subject: Reply with quote

gemarcano wrote:
I don't see that you mentioned it, but what is your graphics card and which driver are you using for it...? Also, is your system a new-ish laptop (did it ever use something called Optimus on Windows)? I'm unsure as to what's going on, but some quick searches online revealed other people experiencing similar things with Ubuntu and Nvidia cards (I think they were using nouveau, but I'm not sure. They claimed the problem left after switching to the Nvidia binary driver). I ask about Optimus because Linux support for it is, well, kind of meh. But it can work.This, along with the driver for your card, may be part of your problem. Does Firefox crash immediately, or when going to a specific website?


I use the intel card. The 2nd graphic card is AMD. It happens to me at specific sites. It doesn't crash immediately. It can work for as long as an hour and then crash.

Yesterday, however after working an hour, it crashed at the site I used. After login and restore firefox tabs, when I tried to enter the same site, it crashed immediately. I had that 3 times in a row.

BTW, I downgraded again to 24.5.0 and it still persists with the crash
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum