Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
pasticci con lftp
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4657
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Thu Jul 10, 2014 11:41 am    Post subject: pasticci con lftp Reply with quote

rabbia.
in una delle mie installazioni, e solo in una, lftp non vuol sapere di connettersi.

nelle installazioni normali, dovrebbe succedere questo:
Code:


cloc3@dell ~ $ lftp 2533398@aruba.it@www.cloc3.net
Password:
lftp 2533398@aruba.it@www.cloc3.net:~> ls
dr-xr-xr-x    2 188531235  users            4096 Mar 25 08:21 .
dr-xr-xr-x    2 188531235  users            4096 Mar 25 08:21 ..
drwxr-xr-x   71 188531235  users            8192 Jun 22 21:07 cloc3.net_Backup_Giornaliero
drwxr-xr-x   71 188531235  users            8192 Jun 22 21:07 cloc3.net_Backup_Settimanale
drwxr-xr-x   71 188531235  users            8192 Jun 22 21:07 www.cloc3.net
lftp 2533398@aruba.it@www.cloc3.net:/>

in quella bacata, invece, il comando ls langue, disponendosi in attesa infinita di riconnessione.
ho già provato a controllare le librerie con revdep-rebuild e a ricompilare a caso cose some openssl et similia, ma senza fortuna.
cosa altro mi può essere capitato di pasticciare?

aggiornamento
dopo avere inserito la modalità di debug in .lftprc, sono giunto alla conclusione che il problema risiedeva nell'inserimento della useflag -socks5 al pacchetto. ricompilato il pacchetto senza quella useflag, lftp ha ripreso a funzionare.

lascio aperto il post, perché non mi sembra comunque corretto che l'aggiunta di una useflag possa determinare simili conseguenze.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Thu Jul 10, 2014 12:41 pm    Post subject: Reply with quote

non è che abilitandola sta in attesa della risposta di un qualche proxy di default?

magari basta agire sulla configurazione per disabilitarlo a runtime.
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum