Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] eix-test-obsolete (packages not in the database)
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
Galanti Davide
Tux's lil' helper
Tux's lil' helper


Joined: 23 Feb 2006
Posts: 148
Location: Milano (Italy)

PostPosted: Wed Jul 09, 2014 5:02 pm    Post subject: [RISOLTO] eix-test-obsolete (packages not in the database) Reply with quote

Non mi era mai successo prima, ergo non sò esattamente come muovermi.

Dopo un aggiornamento del sistema ho dato come di consuetudine il comando "eix-test-obsolete detail".

Questa volta però l'output restituitomi è stato il seguente:

Code:
Installed packages with a version not in the database (or masked):
[U] virtual/perl-Archive-Tar (1.900.0@27/06/14 -> 1.900.0-r1): Virtual for Archive-Tar
[U] virtual/perl-CPAN-Meta (2.120.921@27/06/14 -> 2.120.921-r1): Virtual for CPAN-Meta
[U] virtual/perl-CPAN-Meta-Requirements (2.122.0@27/06/14 -> 2.122.0-r1): Virtual for CPAN-Meta-Requirements
[U] virtual/perl-CPAN-Meta-YAML (0.8.0@27/06/14 -> 0.8.0-r1): Virtual for CPAN-Meta-YAML
[U] virtual/perl-ExtUtils-Command (1.170.0-r3@27/06/14 -> 1.170.0-r4): Virtual for ExtUtils-Command
[U] virtual/perl-ExtUtils-ParseXS (3.180.0@27/06/14 -> 3.180.0-r1): Virtual for ExtUtils-ParseXS
[U] virtual/perl-File-Spec (3.400.0@27/06/14 -> 3.400.0-r1): Virtual for File-Spec
[U] virtual/perl-File-Temp (0.220.0-r2@27/06/14 -> 0.220.0-r3): Virtual for File-Temp
Found 8 matches


Effettivamente tutti questi pacchetti che sono installati nel mio sistema non risultano più essere nel portage di gentoo.

La domanda è la seguente: posso unmergerli senza problemi tramite "unmerge -C" o rischio di fare qualche danno con delle dipendenze?
Perchè "unmerge --depclean" non ci ha pensato lui ha eliminare la spazzatura, se di spazzatura si tratta?
_________________
"Cos'e' che fa dell'uomo un uomo?"
"Sono le scelte che fa, non come comincia le cose, ma come decide di finirle."


Last edited by Galanti Davide on Thu Jul 10, 2014 1:38 pm; edited 1 time in total
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 670

PostPosted: Wed Jul 09, 2014 9:00 pm    Post subject: Reply with quote

provato con :
Code:
# emerge --depclean -a


di solito lava via quello che non serve :lol:

Ps : unmerge --depclean ??? :?:

PPS : eix-test-obsolete controlla ile versioni dei pacchi nei vari /etc/portage/packages* e le confronta con quelle nel portage-tree indicandoti doppioni e pacchetti non più necessari nei files indicati (tipo .keywords .unmask etc etc)
_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
Galanti Davide
Tux's lil' helper
Tux's lil' helper


Joined: 23 Feb 2006
Posts: 148
Location: Milano (Italy)

PostPosted: Wed Jul 09, 2014 9:10 pm    Post subject: Reply with quote

sabayonino wrote:
provato con :
Code:
# emerge --depclean -a


di solito lava via quello che non serve :lol:

Ps : unmerge --depclean ??? :?:

PPS : eix-test-obsolete controlla ile versioni dei pacchi nei vari /etc/portage/packages* e le confronta con quelle nel portage-tree indicandoti doppioni e pacchetti non più necessari nei files indicati (tipo .keywords .unmask etc etc)


Scusa ero stanco quando ho scritto il post.

Ovvio che mi riferivo ad "emerge --depclean" :D, se per questo ho pure scritto "unmerge -C".

Vabbè a parte questi due errori di stanchezza nello scrivere, avevo già provato e non ha cancellato quei pacchetti obsoleti.

Quindi la domanda è: posso rimuoverli tranquillamente tramite "emerge -C" o rischio di creare dei problemi con qualche dipendenza?
_________________
"Cos'e' che fa dell'uomo un uomo?"
"Sono le scelte che fa, non come comincia le cose, ma come decide di finirle."
Back to top
View user's profile Send private message
Galanti Davide
Tux's lil' helper
Tux's lil' helper


Joined: 23 Feb 2006
Posts: 148
Location: Milano (Italy)

PostPosted: Thu Jul 10, 2014 12:24 am    Post subject: Reply with quote

Non riesco a capire come mai dando un "emerge --update --deep --newuse world" mi restituisca che non c'è nulla da aggiornare:

Code:
emerge --update --deep --newuse world

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!

Total: 0 packages, Size of downloads: 0 kB

Nothing to merge; quitting.


Mentre se provo ad aggiornare i singoli pacchetti sopra citati me li aggiorna senza problemi

Code:
emerge --update virtual/perl-Archive-Tar

These are the packages that would be merged, in reverse order:

Calculating dependencies... done!
[ebuild     U  ] virtual/perl-Archive-Tar-1.900.0-r1 [1.900.0] 0 kB

Total: 1 package (1 upgrade), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No] n

Quitting.


Cosa dovrei fare? aggiornarli uno per uno? penso che eliminarli non sia la scelta migliore
_________________
"Cos'e' che fa dell'uomo un uomo?"
"Sono le scelte che fa, non come comincia le cose, ma come decide di finirle."
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Thu Jul 10, 2014 8:46 am    Post subject: Reply with quote

inizia a vedere con
Code:
# equery d <pacchetto>

se c'è qualcosa che te li richiede o che tu non li abbia inseriti (per sbaglio, sono virtuals) nel world file.

se nessuno te li richiede cancellali senza remore.
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
sabayonino
l33t
l33t


Joined: 03 Jan 2012
Posts: 670

PostPosted: Thu Jul 10, 2014 11:15 am    Post subject: Reply with quote

Quote:
--with-bdeps < y | n >
In dependency calculations, pull in build time dependencies that are not strictly required. This defaults to ´n´ for installation
actions, meaning they will not be installed, and ´y´ for the --depclean action, meaning they will not be removed. This setting can
be added to EMERGE_DEFAULT_OPTS (see make.conf(5)) and later overridden via the command line.


Code:
# emerge -uDa --with-bdeps y {system,world} && emerge --depclean -a

_________________
BOINC ed il calcolo distribuito
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Thu Jul 10, 2014 1:01 pm    Post subject: Reply with quote

bdeps va aggiunto anche al depclean...
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
Galanti Davide
Tux's lil' helper
Tux's lil' helper


Joined: 23 Feb 2006
Posts: 148
Location: Milano (Italy)

PostPosted: Thu Jul 10, 2014 1:38 pm    Post subject: Reply with quote

sabayonino wrote:
Quote:
--with-bdeps < y | n >
In dependency calculations, pull in build time dependencies that are not strictly required. This defaults to ´n´ for installation
actions, meaning they will not be installed, and ´y´ for the --depclean action, meaning they will not be removed. This setting can
be added to EMERGE_DEFAULT_OPTS (see make.conf(5)) and later overridden via the command line.


Code:
# emerge -uDa --with-bdeps y {system,world} && emerge --depclean -a


Avevo già risolto questa mattina esattamente con il bdeps

Code:
emerge --update --deep --with-bdeps=y --newuse world


Grazie comunque :D
_________________
"Cos'e' che fa dell'uomo un uomo?"
"Sono le scelte che fa, non come comincia le cose, ma come decide di finirle."
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum