Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Can't start NFS with systemd, works on OpenRC
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
TobiSGD
n00b
n00b


Joined: 14 Apr 2014
Posts: 36

PostPosted: Wed Jul 09, 2014 3:50 pm    Post subject: [SOLVED] Can't start NFS with systemd, works on OpenRC Reply with quote

Hi,

I am currently in the progress of migrating some of my systems to systemd. So far everything works fine, except for one thing: I can't start the NFS server on this machine.

Code:
journalctl -xn
does not show anything, systemctl shows this:
Code:
>>> systemctl status nfs-server.service
● nfs-server.service - NFS server and services
   Loaded: loaded (/usr/lib64/systemd/system/nfs-server.service; enabled)
   Active: failed (Result: exit-code) since Wed 2014-07-09 15:38:29 UTC; 26s ago
  Process: 7436 ExecStart=/usr/sbin/rpc.nfsd $RPCNFSDARGS (code=exited, status=1/FAILURE)
  Process: 7433 ExecStartPre=/usr/sbin/exportfs -r (code=exited, status=0/SUCCESS)
 Main PID: 7436 (code=exited, status=1/FAILURE)

Jul 09 15:38:29 demon rpc.nfsd[7436]: rpc.nfsd: writing fd to kernel failed: errno 111 (Connection refused)
Jul 09 15:38:29 demon rpc.nfsd[7436]: rpc.nfsd: unable to set any sockets for nfsd
Jul 09 15:38:29 demon systemd[1]: nfs-server.service: main process exited, code=exited, status=1/FAILURE
Jul 09 15:38:29 demon systemd[1]: Failed to start NFS server and services.
Jul 09 15:38:29 demon systemd[1]: Unit nfs-server.service entered failed state.

NFS works fine with OpenRC on that same machine, only systemd can't start it.

Can anybody enlighten me on what I am doing wrong?


Last edited by TobiSGD on Wed Jul 09, 2014 8:22 pm; edited 1 time in total
Back to top
View user's profile Send private message
eccerr0r
Watchman
Watchman


Joined: 01 Jul 2004
Posts: 7241
Location: almost Mile High in the USA

PostPosted: Wed Jul 09, 2014 6:14 pm    Post subject: Reply with quote

Do you have rpcbind/portmap service enabled/started? (though I would imagine this should be an explicit dependency).

Are you running the same kernel for OpenRC and systemd?

I don't have a systemd machine up right now so I can't check how this is supposed to work at the moment...
Back to top
View user's profile Send private message
TobiSGD
n00b
n00b


Joined: 14 Apr 2014
Posts: 36

PostPosted: Wed Jul 09, 2014 8:21 pm    Post subject: Reply with quote

I found the solution on this forum, but I had to use Google to search it, the search function here is really horrible: https://forums.gentoo.org/viewtopic-t-980072-start-0.html?sid=c509ab2da03dd8c4ea552070a8938bf6 (2nd post)
Indeed, a few sevices had to be started, a few mounts to be made. I wonder why these files are missing for NFS.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum