Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Problems with sys-power/upower-pm-utils-0.9.23-r2
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
xtz
Apprentice
Apprentice


Joined: 29 Oct 2007
Posts: 181
Location: Singapore

PostPosted: Sat Jul 05, 2014 10:18 pm    Post subject: [SOLVED] Problems with sys-power/upower-pm-utils-0.9.23-r2 Reply with quote

I'm using Xfce with OpenRC (hence - sys-power/upower-pm-utils). After emerging sys-power/upower-pm-utils-0.9.23-r2 a few days ago, my tray icon disappeared and no matter what I do - I cannot get it back. It was okay with the previous version (0.9.23).

xfce4-power-manager.xml looks okay (I changed the value of show-tray-icon from 0 to 1 but still no luck):
Code:
xtz@Xecutor ~ $ cat .config/xfce4/xfconf/xfce-perchannel-xml/xfce4-power-manager.xml
<?xml version="1.0" encoding="UTF-8"?>

<channel name="xfce4-power-manager" version="1.0">
  <property name="xfce4-power-manager" type="empty">
    <property name="show-tray-icon" type="uint" value="1"/>
    <property name="power-button-action" type="uint" value="3"/>
    <property name="hibernate-button-action" type="uint" value="2"/>
    <property name="sleep-button-action" type="uint" value="1"/>
    <property name="inactivity-on-ac" type="uint" value="350"/>
    <property name="dpms-on-ac-sleep" type="uint" value="5"/>
    <property name="dpms-on-ac-off" type="uint" value="10"/>
    <property name="brightness-on-ac" type="uint" value="120"/>
    <property name="brightness-level-on-ac" type="uint" value="40"/>
    <property name="critical-power-action" type="uint" value="2"/>
    <property name="lid-action-on-battery" type="uint" value="2"/>
    <property name="inactivity-on-battery" type="uint" value="15"/>
    <property name="power-save-on-battery" type="bool" value="true"/>
    <property name="dpms-on-battery-off" type="uint" value="5"/>
    <property name="dpms-sleep-mode" type="string" value="suspend"/>
    <property name="presentation-mode" type="bool" value="false"/>
    <property name="inactivity-sleep-mode" type="string" value="Suspend"/>
    <property name="lid-action-on-ac" type="uint" value="1"/>
    <property name="brightness-on-battery" type="uint" value="60"/>
    <property name="dpms-on-battery-sleep" type="uint" value="2"/>
  </property>
</channel>

Any ideas?


Last edited by xtz on Sun Jul 06, 2014 3:26 am; edited 1 time in total
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1699

PostPosted: Sun Jul 06, 2014 1:31 am    Post subject: Reply with quote

Just wondering, but did you happen to also update xfce4-power4-manager about the same time? As, from what I remembered from a older post reguarding the same issue, is that xfce4-power-manager developers decided not to include that applet, in favour for the battery plugin from xfce4-panel instead. Here's the link to that forum post, maybe it'll help you get it sorted out.
https://forums.gentoo.org/viewtopic-t-993856-highlight-xfce4powermanager.html
Back to top
View user's profile Send private message
xtz
Apprentice
Apprentice


Joined: 29 Oct 2007
Posts: 181
Location: Singapore

PostPosted: Sun Jul 06, 2014 3:26 am    Post subject: Reply with quote

ct85711, thanks. That pointed me in the right direction.
It was in fact xfce4-power-manager, but it turns out that since version 1.3.0 I have to include 'battery' in XFCE_PLUGINS. 1.2.0-r2 did not support that.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum