Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved]Networkmanager starts, but is inactive
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
max_power
n00b
n00b


Joined: 01 Aug 2004
Posts: 48
Location: /dev/bed

PostPosted: Sun Jul 06, 2014 1:35 pm    Post subject: [solved]Networkmanager starts, but is inactive Reply with quote

I've updated NetworkManager to version 0.9.8.10-r1 and now it does not manage the networkcards anymore. However if I downgrade Networkmanager the problem is persitant, so at some point I did something that did fucked up my network and I can't find it.

If I'm checking my /var/log/messages new NetworkManager logs emergence

Quote:

kernel: [ 19.210685] traps: NetworkManager[3926] general protection ip:46970e sp:7ffffcdf27c0 error:0 in NetworkManager[400000+104000]
dbus[3797]: [system] Activating service name='org.freedesktop.NetworkManager' (using servicehelper)
dbus[3797]: [system] Activated service 'org.freedesktop.NetworkManager' failed: Launch helper exited with unknown return code 1
/etc/init.d/NetworkManager[3671]: WARNING: NetworkManager has started, but is inactive
/etc/init.d/netmount[3678]: WARNING: netmount is scheduled to start when NetworkManager has started
dbus[3797]: [system] Activating service name='org.freedesktop.NetworkManager' (using servicehelper)
dbus[3797]: [system] Activated service 'org.freedesktop.NetworkManager' failed: Launch helper exited with unknown return code 1


the last two lines are repeating for a while, how can I get a better error message than "unknown return code 1"?


Last edited by max_power on Sun Jul 06, 2014 5:17 pm; edited 1 time in total
Back to top
View user's profile Send private message
saivinoba
n00b
n00b


Joined: 20 May 2014
Posts: 30

PostPosted: Sun Jul 06, 2014 2:52 pm    Post subject: Reply with quote

did you upgrade kernel as well? did any changes to configuration there?
Back to top
View user's profile Send private message
max_power
n00b
n00b


Joined: 01 Aug 2004
Posts: 48
Location: /dev/bed

PostPosted: Sun Jul 06, 2014 3:36 pm    Post subject: Reply with quote

No, same kernel.
Back to top
View user's profile Send private message
saivinoba
n00b
n00b


Joined: 20 May 2014
Posts: 30

PostPosted: Sun Jul 06, 2014 4:46 pm    Post subject: Reply with quote

Are you on systemd or openrc? Gnome/XFCE/KDE? In nm-applet or similar is networking/wireless is disabled?
Back to top
View user's profile Send private message
max_power
n00b
n00b


Joined: 01 Aug 2004
Posts: 48
Location: /dev/bed

PostPosted: Sun Jul 06, 2014 5:00 pm    Post subject: Reply with quote

openrc, KDE kde-misc/plasma-nm as applet. Networking is enabled. Right now I'm using the ethernet with "ifconfig eth0 up && dhcpcd eth0 &"
Back to top
View user's profile Send private message
mackal
Tux's lil' helper
Tux's lil' helper


Joined: 04 Aug 2011
Posts: 87

PostPosted: Sun Jul 06, 2014 5:04 pm    Post subject: Reply with quote

Sync and downgrade dev-libs/libnl.
Back to top
View user's profile Send private message
max_power
n00b
n00b


Joined: 01 Aug 2004
Posts: 48
Location: /dev/bed

PostPosted: Sun Jul 06, 2014 5:17 pm    Post subject: Reply with quote

Thank you mackal!

That solved the problem.

And thanks to saivinoba for responding :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum