Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
installing KDE: systemd blocks udev [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
kikkihiiri
n00b
n00b


Joined: 03 Jul 2014
Posts: 11
Location: Finland

PostPosted: Thu Jul 03, 2014 11:02 am    Post subject: installing KDE: systemd blocks udev [SOLVED] Reply with quote

Hi all. I've tried searching for a solution for this problem but I haven't succeeded yet. So in hope for help I registered to this forum.
I'm totally new with gentoo, i've used dozens of other distros though. If you have thoughts about a possible solution for this, please use detailed language/instructions.

I've installed Gentoo following the handbook. Now I would like to install Xorg and KDE but last time I tried, I lost all of my network interfaces (possibly because I unmerged udev) and had to reinstall gentoo.

I'm trying to install kdebase-meta. This is the error that makes the attempt to fail:

If I run:
Code:
emerge --pretend kde-base/kdebase-meta


Output:
Quote:

[snip]
sys-fs/udev is blocking sys-apps/gentoo-systemd-integration-4, sys-apps/systemd-212-r5
sys-apps/gentoo-systemd-integration is blocking sys-fs/udev-212-r1
sys-apps/systemd is blocking sys-fs/udev-212-r1


I don't think I have systemd installed so I don't understand how it is blocking something. I've selected desktop/kde profile with eselect.

What should I do? Help appreciated.

EDIT: I got rid of the error just by adding --newuse, so
Code:
]emerge --newuse kde-base/kdebase-meta
seems a lot promising. I think i have added -systemd to USE flags, I'm not sure 8)

Last edited by kikkihiiri on Fri Jul 04, 2014 6:04 am; edited 3 times in total
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 6193

PostPosted: Thu Jul 03, 2014 11:28 am    Post subject: Reply with quote

The answer depends on what's pulling systemd - right now, most likely culprit is upower, so read the threads about that.
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Thu Jul 03, 2014 11:36 am    Post subject: Reply with quote

kikkihiiri ...

bugs 515230 perhaps ... try adding the following to package.mask it may allow portage to resolve the dependency (this is assuming you have no intention of using systemd).

/etc/portage/package.mask
Code:
sys-apps/systemd

HTH & best
Back to top
View user's profile Send private message
kikkihiiri
n00b
n00b


Joined: 03 Jul 2014
Posts: 11
Location: Finland

PostPosted: Fri Jul 04, 2014 6:03 am    Post subject: Reply with quote

I was able to start kdm and kde, though some errors occur during startup. Thanks for help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum