Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
cups Canon Pixma iP7250 DBus.Error.ServiceUnknown
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
Duco Ergo Sum
Tux's lil' helper
Tux's lil' helper


Joined: 06 Dec 2005
Posts: 139
Location: Winsford

PostPosted: Wed Jul 02, 2014 5:50 pm    Post subject: cups Canon Pixma iP7250 DBus.Error.ServiceUnknown Reply with quote

Hi there.

I have a Canon Pixma iP7250 printer. I can not print from this printer.

I have installed:

net-print/cups-1.7.1-r1
net-print/cups-filters-1.0.53

Among my first attempts to drive the printer were to get drivers directly from Canon and direct cups to use the PPD file provided there in. This did not help. Later I found the following package to support Canon printers.

~net-print/gutenprint-5.2.10

I am aware that version of gutenprint is unstable but the previous version does not have drivers for my printer series, let alone model.

Once I had installed gutenprint with appropriate version for my printer, I discovered I was missing a filter.

Code:
E [01/Jul/2014:18:01:59 +0100] [Job 14] Unable to start filter "pstocanonij" - No such file or directory.


So I went back to the Canon stock drivers and compiled the filter - pstocanonij.

Now I get the following warning:

Code:
W [01/Jul/2014:18:27:19 +0100] CreateProfile failed: org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files


Others seem to have met this before but without much illumination - https://forums.gentoo.org/viewtopic-p-7536492.html
Back to top
View user's profile Send private message
Duco Ergo Sum
Tux's lil' helper
Tux's lil' helper


Joined: 06 Dec 2005
Posts: 139
Location: Winsford

PostPosted: Tue Jul 08, 2014 3:20 pm    Post subject: Abstract Reply with quote

Perhaps this isn't really a networkng issue as such. Although this is a network printer this topic may better be served else where on the discussion forum?

Any thoughts please?


If the other PCs were already using this printer, I'd consider trading it in for a HP.
Back to top
View user's profile Send private message
Duco Ergo Sum
Tux's lil' helper
Tux's lil' helper


Joined: 06 Dec 2005
Posts: 139
Location: Winsford

PostPosted: Fri Jul 18, 2014 10:17 am    Post subject: Network Printer Reply with quote

Hi everyone.

I have a network printer and I can not print, please see this post - https://forums.gentoo.org/viewtopic-t-994680.html?sid=db89ef5de2527dcb2b151540599b5200

When I posted that I though the issue was due to the way CUPS was talking to the NIC.

Other PCs are able to use this printer Windows & OSX (and a PS 3 although I have tried to send a test page... yet).



I have now installed the TurboPrint application on a thirty day trial. This at least appears to send a print job but then the printer remains inert. The Turboprint software though does information like ink levels and Spooler Message: 'Waiting for printer to finish.'

I appreciate that Turboprint is proprietary software and has it's own support infrastructure but I am sighting it here a point of comparison. My suspicion is that what ever fault is stopping CUPS from working is also preventing Turboprint from working.

I have even thought for a while that it might be poor Canon support in CUPS except gutenprint has three identically named drivers for my printer.


Any thoughts or suggestions would be gratefully received, please.
Back to top
View user's profile Send private message
Duco Ergo Sum
Tux's lil' helper
Tux's lil' helper


Joined: 06 Dec 2005
Posts: 139
Location: Winsford

PostPosted: Fri Jul 18, 2014 2:14 pm    Post subject: Network Printing Problems Reply with quote

Hi everyone.

I have a network printer and I can not print, please see this post - https://forums.gentoo.org/viewtopic-t-994680.html?sid=db89ef5de2527dcb2b151540599b5200

When I posted that I though the issue was due to the way CUPS was talking to the NIC.

Other PCs are able to use this printer Windows & OSX (and a PS 3 although I have tried to send a test page... yet).



I have now installed the TurboPrint application on a thirty day trial. This at least appears to send a print job but then the printer remains inert. The Turboprint software though does information like ink levels and Spooler Message: 'Waiting for printer to finish.'

I appreciate that Turboprint is proprietary software and has it's own support infrastructure but I am sighting it here a point of comparison. My suspicion is that what ever fault is stopping CUPS from working is also preventing Turboprint from working.

I have even thought for a while that it might be poor Canon support in CUPS except gutenprint has three identically named drivers for my printer.


Any thoughts or suggestions would be gratefully received, please.
Back to top
View user's profile Send private message
russK
Apprentice
Apprentice


Joined: 27 Jun 2006
Posts: 280

PostPosted: Sat Jul 19, 2014 6:32 am    Post subject: Reply with quote

Are you using gnome ?

I'm on gnome-3.12 so take my input with a grain of salt, but I think x11-misc/colord might help solve the message
Code:
org.freedesktop.DBus.Error.ServiceUnknown:The name org.freedesktop.ColorManager was not provided by any .service files


On my system colord is brought in by gnome-extra/gnome-color-manager, among others.


HTH

P.S. Although I like gnome-3.12, I wouldn't recommend until it is stable.
Back to top
View user's profile Send private message
Fitzcarraldo
l33t
l33t


Joined: 30 Aug 2008
Posts: 768
Location: United Kingdom

PostPosted: Sat Jul 19, 2014 9:01 am    Post subject: Reply with quote

I don't know if you will help you, but I notice that Gentoo user mbjr has the same printer as you (Canon Pixma iP7250) and he explained how he got it working in his post: https://forums.gentoo.org/viewtopic-p-7537614.html#7537614
_________________
Clevo W230SS: amd64, OpenRC, NVIDIA, KDE / Compal NBLB2: ~amd64, OpenRC, FGLRX, KDE, dual booting with Windows 7 Professional 64-bit
Fitzcarraldo's blog
Back to top
View user's profile Send private message
Duco Ergo Sum
Tux's lil' helper
Tux's lil' helper


Joined: 06 Dec 2005
Posts: 139
Location: Winsford

PostPosted: Sun Jul 20, 2014 11:11 am    Post subject: Reply with quote

Unfortunately that didn't help. The directory usr/lib/cups is missing which as it states is where the magic happens.
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 8580
Location: Somewhere over Atlanta, Georgia

PostPosted: Sun Jul 20, 2014 5:38 pm    Post subject: Reply with quote

Merged above 4 posts.

- John
_________________
I can confirm that I have received between 0 and 999 National Security Letters.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum