Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved] Xresources Not Reflected When in VNC
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
solamour
l33t
l33t


Joined: 21 Dec 2004
Posts: 623
Location: San Diego, CA

PostPosted: Wed Jul 02, 2014 12:02 am    Post subject: [Solved] Xresources Not Reflected When in VNC Reply with quote

I have the following defined for urxvt terminal.
Code:
~/.Xresources
    urxvt.font:         xft:Terminus:pixelsize=16:antialias=false
    urxvt.boldFont:     xft:Terminus:pixelsize=16:antialias=false
    urxvt*scrollBar:    false
    urxvt*background:   black
    urxvt*foreground:   gray

And it is loaded as the following.
Code:
~/.xinitrc
    [[ -f ~/.Xresources ]] && xrdb -load ~/.Xresources
    /usr/bin/startfluxbox

Now, when I start X with "startx", urxvt shows up nicely the way I defined. But when I connect through VNC, none of the values defined in "~/.Xresources" is reflected (i.e. urxvt shows up with the default color and font). It doesn't matter which VNC client I'm using.
Code:
~/.vnc/xstartup
    /usr/bin/startfluxbox

I'm sure I'm missing something simple, but I'm not able to make much progress here. I'd appreciate any suggestions.
__
sol


Last edited by solamour on Wed Jul 09, 2014 4:27 am; edited 1 time in total
Back to top
View user's profile Send private message
solamour
l33t
l33t


Joined: 21 Dec 2004
Posts: 623
Location: San Diego, CA

PostPosted: Wed Jul 02, 2014 8:21 pm    Post subject: Reply with quote

I still haven't figured out why "~/.Xresources" is not loaded when using VNC, but at least passing the values as command line arguments seem to work.

"urxvt -fn xft:Terminus:pixelsize=16:antialias=false -fb xft:Terminus:pixelsize=16:antialias=false +sb -bg black -fg gray"
__
sol
Back to top
View user's profile Send private message
solamour
l33t
l33t


Joined: 21 Dec 2004
Posts: 623
Location: San Diego, CA

PostPosted: Wed Jul 09, 2014 4:27 am    Post subject: Reply with quote

It turned out that loading "~/.Xresources" should be done in "~/.vnc/xstartup" as well, just like it is done in "~/.xinitrc".
Code:
~/.vnc/xstartup
    [[ -f ~/.Xresources ]] && xrdb -load ~/.Xresources    <-- Add this
    /usr/bin/startfluxbox

Once I added it, all settings in "~/.Xresources" were correctly applied even when I connected via VNC.
__
sol
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum