Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Cinnamon Nemo won't mount ntfs volumes.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
shadywack
n00b
n00b


Joined: 30 Aug 2012
Posts: 28

PostPosted: Sun Jun 29, 2014 8:39 pm    Post subject: Cinnamon Nemo won't mount ntfs volumes. Reply with quote

Hello,

First off thanks for taking the time to read this, if you have any suggestions I very much appreciate it.

Anyhow, the problem I'm having is in Cinnamon 2.2.13. When I use Nemo and try to click on my ntfs drives I get the ol "Unable to mount xxx not authorized to perform operation". I use systemd and when I pop into journalctl I see
Code:
org.gtk.Private.UDisks2VolumeMonitor[2829]: ### debug: emit_signal: 0x74b5b0
Jun 29 08:35:23 gentoolicious org.gtk.Private.UDisks2VolumeMonitor[2829]: ### debug: in handle_volume_mount
Jun 29 08:35:23 gentoolicious org.gtk.Private.UDisks2VolumeMonitor[2829]: ### debug: in volume_mount_cb
Jun 29 08:35:23 gentoolicious org.gtk.Private.UDisks2VolumeMonitor[2829]: ### debug:   error: Not authorized to perform operation

(yes, my machine is named gentoolicious 8) )

I have the fuse module loaded, I have ntfs3g installed, and I can simply mount the volume as root no problem, in fact I get this in the log when I do:

Code:
Jun 29 08:37:43 gentoolicious ntfs-3g[31771]: Version 2013.1.13 external FUSE 29
Jun 29 08:37:43 gentoolicious ntfs-3g[31771]: Mounted /dev/sda1 (Read-Write, label "MassiveStorage", NTFS 3.1)
Jun 29 08:37:43 gentoolicious ntfs-3g[31771]: Cmdline options: rw
Jun 29 08:37:43 gentoolicious ntfs-3g[31771]: Mount options: rw,allow_other,nonempty,relatime,fsname=/dev/sda1,blkdev,blksize=4096


When I go into gnome, it can mount the same volume just fine with gvfs, I'm just wondering if there's something else I need to configure? I have looked at polkit but, unfortunately, I'm very poorly studied on polkit and gentoo's implementation of it. I am not sure where or what to put for rules, if that's what someone might think of for a suggestion.

I hate to just file this as a bug in the bugzilla without getting some input first, as I probably have just done something wrong.

Thanks again.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum