Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[gelöst] wine + pipelight
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1113
Location: Buchholz/GER

PostPosted: Fri Jun 27, 2014 7:15 pm    Post subject: [gelöst] wine + pipelight Reply with quote

Moin ihr Lieben,
ich habe heute mal versucht, pipelight zu installieren, um von SkyGo und AmazonPrime zu profitieren. Dummerweise scheitere ich schon an der Installation von wine. Da mich Windowssoftware nie interessiert hat, bin ich da leider nicht besonders im Thema.

Wine und Netflix/Pipelight habe ich gelesen, aber irgendwie bringt es mich nicht weiter.

Code:
[root@sorum:/home/stell]# emerge -av wine

These are the packages that would be merged, in order:

Calculating dependencies /

!!! Problem resolving dependencies for app-emulation/wine
... done!

!!! The ebuild selected to satisfy "wine" has unmet requirements.
- app-emulation/wine-1.7.20::gentoo USE="X alsa cups fontconfig gecko gstreamer jpeg lcms mono mp3 ncurses nls opengl perl pipelight png prelink realtime run-exes scanner ssl threads truetype udisks v4l xcomposite xinerama xml -capi -custom-cflags -dos -gphoto2 -gsm -ldap -netapi -odbc -openal -opencl -osmesa -oss -pulseaudio -samba (-selinux) -test" ABI_X86="32 64 -x32" LINGUAS="de -ar -bg -ca -cs -da -el -en -en_US -eo -es -fa -fi -fr -he -hi -hr -hu -it -ja -ko -lt -ml -nb_NO -nl -or -pa -pl -pt_BR -pt_PT -rm -ro -ru -sk -sl -sr_RS@cyrillic -sr_RS@latin -sv -te -th -tr -uk -wa -zh_CN -zh_TW"

  The following REQUIRED_USE flag constraints are unsatisfied:
    gstreamer? ( pulseaudio )

  The above constraints are a subset of the following complete expression:
    any-of ( abi_x86_32 abi_x86_64 ) test? ( abi_x86_32 ) elibc_glibc? ( threads ) gstreamer? ( pulseaudio ) mono? ( abi_x86_32 ) osmesa? ( opengl )


Wenn ich das ganze mit »USE="pulseaudio" emerge -av wine« anstoße, läuft es zwar los, stirbt dann aber recht klanglos:

Code:
[ ... ]
config.status: creating dlls/explorerframe/Makefile
config.status: creating dlls/ext-ms-win-gdi-devcaps-l1-1-0/Makefile
config.status: creating dlls/faultrep/Makefile
config.status: creating dlls/fltlib/Makefile
 * The ebuild phase 'configure' with pid 31305 appears to have left an
 * orphan process running in the background.


Gibt es da Tricks? Oder 'ne pfiffige Anleitung, die auch mir weiterhelfen könnte?
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D


Last edited by cryptosteve on Sat Jun 28, 2014 8:28 am; edited 1 time in total
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 2744
Location: de

PostPosted: Fri Jun 27, 2014 9:17 pm    Post subject: Reply with quote

Installier halt wine einfach mal ohne gstreamer-Support:
Code:
USE=-gestreamer emerge wine
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1113
Location: Buchholz/GER

PostPosted: Sat Jun 28, 2014 6:01 am    Post subject: Reply with quote

Dabei steigt mir emerge leider genauso aus:
Code:
[ ... ]
config.status: creating dlls/msvcm80/Makefile
config.status: creating dlls/msvcp100/Makefile
config.status: creating dlls/msvcm90/Makefile
config.status: creating dlls/msvcp110/Makefile
config.status: creating dlls/msvcp60/Makefile
 * The ebuild phase 'configure' with pid 7839 appears to have left an
 * orphan process running in the background.

_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1113
Location: Buchholz/GER

PostPosted: Sat Jun 28, 2014 6:04 am    Post subject: Reply with quote

Auf die Gefahr hin, dass das hier 'ne lange Diskussion mit mir selber werden könnte, aber ich dokumentiere das zunächst einfach mal:

Ich habe jetzt mit »MAKEOPTS="-j1" USE="-gstreamer" emerge wine« gestartet und lande jetzt bei folgender (echter) Fehlermeldung:
Code:
checking for jpeglib.h... no
configure: error: libjpeg development files not found, JPEG won't be supported.
This is an error since --with-jpeg was requested.

!!! Please attach the following file when seeking support:
!!! /tmp/portage/portage/app-emulation/wine-1.7.20/work/wine-1.7.20-abi_x86_32.x86/config.log
 * ERROR: app-emulation/wine-1.7.20::gentoo failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *          ebuild.sh, line   93:  Called src_configure
 *        environment, line 5099:  Called multilib-minimal_src_configure
 *        environment, line 4069:  Called multilib_parallel_foreach_abi 'multilib-minimal_abi_src_configure'
 *        environment, line 4357:  Called multibuild_parallel_foreach_variant '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *        environment, line 3962:  Called multibuild_foreach_variant '_multibuild_parallel' '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *        environment, line 3905:  Called _multibuild_run '_multibuild_parallel' '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *        environment, line 3903:  Called _multibuild_parallel '_multilib_multibuild_wrapper' 'multilib-minimal_abi_src_configure'
 *        environment, line 3953:  Called _multilib_multibuild_wrapper 'multilib-minimal_abi_src_configure'
 *        environment, line 1413:  Called multilib-minimal_abi_src_configure
 *        environment, line 4063:  Called multilib_src_configure
 *        environment, line 4485:  Called econf '--sysconfdir=/etc/wine' '--with-alsa' '--without-capi' '--with-cms' '--with-cups' '--with-curses' '--with-dbus' '--with-fontconfig' '--with-gnutls' '--without-gphoto' '--without-gsm' '--without-gstreamer' '--without-hal' '--with-jpeg' '--without-ldap' '--with-mpg123' '--without-netapi' '--with-gettext' '--without-openal' '--without-opencl' '--with-opengl' '--without-osmesa' '--without-oss' '--with-png' '--with-pthread' '--with-sane' '--disable-tests' '--with-freetype' '--with-v4l' '--with-x' '--with-xcomposite' '--with-xinerama' '--with-xml' '--with-xslt' '--with-xattr' '--disable-win64'
 *   phase-helpers.sh, line  584:  Called die
 * The specific snippet of code:
 *                      die "econf failed"

Mal gucken, wie ich das umschiffen kann ...
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1113
Location: Buchholz/GER

PostPosted: Sat Jun 28, 2014 8:59 am    Post subject: Reply with quote

Moin,
so, ich habe es hinbekommen. wine läuft ausreichend gut mit folgendem Aufruf, den ich natürlich nachher noch in meinen /etc/portage/* verankern muss:
Code:
MAKEOPTS="-j1" USE="-gstreamer -jpeg" emerge -av wine

Pipelight selbst habe ich dann nach dem Netflix/Pipelight-Wikiartikel gezogen, gebaut und installiert. ACHTUNG: Wenn man wine via portage baut, muss das Plugin im configure-Aufruf natürlich /usr/bin/wine (statt /usr/local/bin/wine) nehmen.

Als Hinweis sei noch angemerkt, dass ich hier zur Umgehung von Schwierigkeiten meinen User-Agent von Firefox auf einen IE10/Windows geändert habe.

Da auch Werbeblocker & Co solche Angebote gerne aus dem Tritt bringen, habe ich eigentlich fürs VideoOnDemand ein eigenes Firefox-Profil erstellt, das ohne AddOns daher kommt.

Und während SkyGo wohl silverlight5.0 braucht, bedarf es für AmazonPrime eher silverlight5.1. Die Plugins lassen sich leider nicht getrennten Profilen zuweisen, sondern werden für den gesamten Browser gleichermaßen geladen. Daher muss ich - je nachdem, ob es AmazonPrime oder SkyGo sein soll, silverlight5.0 bzw. silverlight5.1 einzelen schalten:

für SkyGo:
$ pipelight-plugin --disable silverlight --enable silverlight5.0

für AmazonPrime:
$ pipelight-plugin --disable silverlight --enable silverlight

Vielleicht hilft's ja dem einen oder anderen ein wenig weiter ...
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
Fijoldar
Apprentice
Apprentice


Joined: 10 Apr 2013
Posts: 208
Location: GER / FFM

PostPosted: Wed Jul 02, 2014 9:14 am    Post subject: Reply with quote

Hi cryptosteve,

danke für die Anleitung :). Ich muss einfach mal fragen: Hat sich der Aufwand insgesamt gelohnt? Wie laufen die Filme mit Pipelight? Ich weiß nur, dass Silverlight schon nativ (Windows + Mac) ziemlich scheiße läuft und extrem Ressourcen-hungrig ist. Das hat mich bisher davon abgehalten, es überhaupt zu versuchen. Vielleicht kannst du ja noch ein kurzes Feedback geben. Würde mich zumindest sehr interessieren.
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5421
Location: Langen (Hessen), Germany

PostPosted: Wed Jul 02, 2014 9:22 am    Post subject: Reply with quote

Also ich nutze es auf meinem HTPC.
Es läuft flüssig im Vollbild. Nur ab und schaltet die Qualität runter, da die Datenübertragung hängt.
Insgesamt läuft es auf dem DualCore mit 1,7GHz sehr gut.
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1113
Location: Buchholz/GER

PostPosted: Wed Jul 02, 2014 11:33 am    Post subject: Reply with quote

Auch hier keine Performanceprobleme, ich habe allerdings auch eine nicht ganz so schmale Kiste (i7 3770k mit 32GB RAM und SSD). Einige Filme bei SkyGo lassen von der Qualität her zu wünschen übrig, sodass es bei einem 24"-TFT bisweilen schon grenzwertig ist. Andere Filme (wie aktuell »The Last Ship« auf TNT Serie HD sind in bestehender Qualität.

Das mir das Plugin während der Wiedergabe abstürzt, ruckelt oder sich nach einer Pause nicht zum erneuten Anlaufen bewegen lassen will, habe ich hingegen noch gar nicht erlebt.

Insgesamt würde ich also sagen: wer SkyGo hat und/oder die Filme von AmazonPrime sehen will, der ist mit dieser Lösung weit besser bedient, als ich zunächst zu hoffen gewagt habe.
_________________
- born to create drama -
cryptosteve - gpg: 0x9B6C7E15
CS Virtual Travel Bug: VF6G5D
Back to top
View user's profile Send private message
Fijoldar
Apprentice
Apprentice


Joined: 10 Apr 2013
Posts: 208
Location: GER / FFM

PostPosted: Thu Jul 03, 2014 6:30 am    Post subject: Reply with quote

Danke! Das hört sich doch gut an. Mit dem neuen "pipelight" Use-Flag sollte sich der Aufwand sogar in Grenzen halten. Bei Gelegenheit muss ich mich da auch mal dransetzen :-).
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1665

PostPosted: Sun Jul 06, 2014 8:07 pm    Post subject: Reply with quote

Hallo,

wollte gerade mal das neuen wine ebuild 1.7.21 testen. Nachdem das 1.7.20 nicht mit pipelight USE Flag bauen konnte....lief alles sauber durch.

Leider kommt dann bei Amazon der Fehler Content Permissions Error 6030.

Hat da jemand eine Idee?

Edit:

habe firefox jetzt mal aus der Konsole gestartet:

Code:


 firefox

(process:28322): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed

(firefox:28322): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::sm-connect after class was initialised

(firefox:28322): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::show-crash-dialog after class was initialised

(firefox:28322): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::display after class was initialised

(firefox:28322): GLib-GObject-WARNING **: Attempt to add property GnomeProgram::default-icon after class was initialised
[PIPELIGHT:LIN:unknown] attached to process.
[PIPELIGHT:LIN:unknown] checking environment variable PIPELIGHT_SILVERLIGHT5_1_CONFIG.
[PIPELIGHT:LIN:unknown] searching for config file pipelight-silverlight5.1.
[PIPELIGHT:LIN:unknown] trying to load config file from '/home/user/.config/pipelight-silverlight5.1'.
[PIPELIGHT:LIN:unknown] trying to load config file from '/etc/pipelight-silverlight5.1'.
[PIPELIGHT:LIN:unknown] trying to load config file from '/usr/share/pipelight/configs/pipelight-silverlight5.1'.
[PIPELIGHT:LIN:unknown] sandbox not found or not installed!
[PIPELIGHT:LIN:silverlight5.1] GPU driver check - Your driver is supported, hardware acceleration enabled.
[PIPELIGHT:LIN:silverlight5.1] using wine prefix directory /home/user/.wine-pipelight.
[PIPELIGHT:LIN:silverlight5.1] checking plugin installation - this might take some time.
[install-dependency] wine-silverlight5.1-installer is already installed in '/home/user/.wine-pipelight'.
[install-dependency] wine-mpg2splt-installer is already installed in '/home/user/.wine-pipelight'.
wine: cannot find L"C:\\windows\\system32\\winemenubuilder.exe"
err:wineboot:ProcessRunKeys Error running cmd L"C:\\windows\\system32\\winemenubuilder.exe -a -r" (2)
[PIPELIGHT:WIN:silverlight5.1] embedded mode         is on.
[PIPELIGHT:WIN:silverlight5.1] windowless mode       is off.
[PIPELIGHT:WIN:silverlight5.1] linux windowless mode is off.
[PIPELIGHT:WIN:silverlight5.1] force SetWindow       is off.
[PIPELIGHT:WIN:silverlight5.1] unity hacks           is off.
[PIPELIGHT:WIN:silverlight5.1] window class hook     is on.
[PIPELIGHT:WIN:silverlight5.1] replaced API function CreateWindowExA.
[PIPELIGHT:WIN:silverlight5.1] replaced API function CreateWindowExW.
[PIPELIGHT:WIN:silverlight5.1] replaced API function TrackPopupMenuEx.
[PIPELIGHT:WIN:silverlight5.1] replaced API function TrackPopupMenu.
fixme:advapi:RegisterTraceGuidsW (0x6f22a7, 0x790120, {aa087e0e-0b35-4e28-8f3a-440c3f51eef1}, 1, 0x67f6c8, (null), (null), 0x790120): stub
[PIPELIGHT:WIN:silverlight5.1] init successful!



Im Browserfenster bei Amazon möchte er jedoch ein Silverlight installieren....
Back to top
View user's profile Send private message
Tinitus
Veteran
Veteran


Joined: 20 Sep 2004
Posts: 1665

PostPosted: Sun Jul 06, 2014 8:27 pm    Post subject: Reply with quote

Habe noochmal die Pluginregdat gelöscht..

Siehe hier:

http://wiki.winehq.org/Pipelight
Wenn der Test OK ist...sollte es gehen.
http://fds-team.de/pipelight/


https://answers.launchpad.net/pipelight/+faq/2349


Würde das dann auch auf einem ARM Board gehen?
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 2744
Location: de

PostPosted: Mon Jul 07, 2014 8:28 am    Post subject: Reply with quote

Tinitus wrote:
Würde das dann auch auf einem ARM Board gehen?

Nein, Pipelight nutzt die x86-Binaries von Windows.
http://linuxundich.de/raspberry-pi/maxdome-watchever-oder-amazon-instant-video-und-der-raspberry-pi/

Und ehrliche Meinung:
Ich nutze zum Abspielen von Musik, Filmen und als Sat-Receiver einen HTPC auf Gentoo-Basis mit VDR und XBMC. Mir würde es im Traum nicht einfallen, mir so ein instabiles Gefrickel wie Pipelight auf den Rechner zu hauen, damit ich mich mit DRM-Mist gängeln lassen kann. Wenn Hollywood & Co. mir etwas verkaufen wollen, sollen sie das in einem vernünftigen Format und zu einem vernünftigen Preis liefern, ansonsten gibt's halt keine Kohle von mir. Silverlight ist definitiv nicht vernünftig. Und diesen Virus dann auch noch über das Gefrickel mit Pipelight ins System zu pressen, ist für mich definitiv unakzeptabel.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum