Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Bug in laptop-mode-tools-1.65? [Solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1769
Location: United Kingdom

PostPosted: Tue Jun 24, 2014 3:49 pm    Post subject: Bug in laptop-mode-tools-1.65? [Solved] Reply with quote

I have just completed an emerge -uvDN world. I notice that upower-pm-utils was upgraded from 0.9.23-r1 to 0.9.23-r2 and laptop-mode-tools was upgraded from 1.64-r2 to 1.65:

Code:
# eix -I upower
[I] sys-power/upower-pm-utils
     Available versions:  0.9.23-r2 {+introspection ios KERNEL="FreeBSD linux"}
     Installed versions:  0.9.23-r2(08:38:02 24/06/14)(introspection -ios KERNEL="linux -FreeBSD")
     Homepage:            http://upower.freedesktop.org/
     Description:         The upstream upower 0.9 git branch for use with sys-power/pm-utils

Code:
# genlop -l | grep upower
     Fri Feb 11 21:23:43 2011 >>> sys-power/upower-0.9.8
     Wed Aug 24 19:35:00 2011 >>> sys-power/upower-0.9.12
     Tue Aug 30 15:45:10 2011 >>> sys-power/upower-0.9.12
     Sat Sep 10 20:53:15 2011 >>> sys-power/upower-0.9.13
     Mon Sep 19 17:13:03 2011 >>> sys-power/upower-0.9.13-r1
     Wed Oct  5 18:06:39 2011 >>> sys-power/upower-0.9.14
     Fri Dec  9 21:46:16 2011 >>> sys-power/upower-0.9.15
     Fri May  4 00:32:10 2012 >>> sys-power/upower-0.9.16
     Fri Jun 29 15:13:47 2012 >>> sys-power/upower-0.9.17
     Sat Aug 11 23:35:33 2012 >>> sys-power/upower-0.9.17-r1
     Tue Sep  4 10:06:38 2012 >>> sys-power/upower-0.9.18
     Thu Jan 10 20:53:10 2013 >>> sys-power/upower-0.9.19
     Fri Mar 29 04:01:13 2013 >>> sys-power/upower-0.9.20-r2
     Mon Sep 23 01:42:57 2013 >>> sys-power/upower-0.9.21
     Thu Oct 10 16:03:49 2013 >>> sys-power/upower-0.9.22
     Fri Nov  8 23:25:21 2013 >>> sys-power/upower-0.9.23
     Mon Mar 17 16:18:10 2014 >>> sys-power/upower-0.9.23-r1
     Thu Mar 27 12:19:04 2014 >>> sys-power/upower-0.9.23-r2
     Fri Jun  6 15:55:46 2014 >>> sys-power/upower-0.99.0-r1
     Sat Jun  7 08:15:57 2014 >>> sys-power/upower-pm-utils-0.9.23-r1
     Tue Jun 24 08:38:24 2014 >>> sys-power/upower-pm-utils-0.9.23-r2

Code:
# eix laptop-mode-tools
[I] app-laptop/laptop-mode-tools
     Available versions:  1.63-r2 (~)1.63-r3 1.64 (~)1.64-r2 (~)1.65 {+acpi apm bluetooth scsi}
     Installed versions:  1.65(08:54:45 24/06/14)(acpi bluetooth -apm -scsi)
     Homepage:            http://www.samwel.tk/laptop_mode/
     Description:         Linux kernel laptop_mode user-space utilities

Code:
# genlop -l | grep laptop-mode-tools
     Mon Nov 22 05:45:53 2010 >>> app-laptop/laptop-mode-tools-1.55-r1
     Thu Sep  8 20:17:39 2011 >>> app-laptop/laptop-mode-tools-1.55-r2
     Sun Jan 15 17:27:46 2012 >>> app-laptop/laptop-mode-tools-1.60
     Mon Feb  6 10:06:28 2012 >>> app-laptop/laptop-mode-tools-1.60-r1
     Thu Jan 10 20:45:28 2013 >>> app-laptop/laptop-mode-tools-1.62
     Fri Jan 11 18:10:22 2013 >>> app-laptop/laptop-mode-tools-1.62-r1
     Fri Mar 29 05:29:44 2013 >>> app-laptop/laptop-mode-tools-1.63
     Thu Apr 18 20:54:02 2013 >>> app-laptop/laptop-mode-tools-1.63-r1
     Mon May 13 11:34:40 2013 >>> app-laptop/laptop-mode-tools-1.63-r2
     Mon Sep 23 02:03:01 2013 >>> app-laptop/laptop-mode-tools-1.64
     Wed Feb  5 19:15:43 2014 >>> app-laptop/laptop-mode-tools-1.64
     Fri Jun  6 16:01:45 2014 >>> app-laptop/laptop-mode-tools-1.64-r1
     Sat Jun 14 19:35:26 2014 >>> app-laptop/laptop-mode-tools-1.64-r2
     Tue Jun 24 08:55:10 2014 >>> app-laptop/laptop-mode-tools-1.65

Now all my USB devices (mouse, keyboard, etc.) keep going to sleep. For example, if I do not move the mouse for a few seconds it goes to sleep and I then have to left-click to wake it up. Before upgrading these two packages (upower-pm-utils and laptop-mode-tools) to latest, everything worked fine. So I checked if auto-suspending had been enabled for some reason even though my laptop is connected to the mains power adapter, and, sure enough, it has:

Code:
# for d in /sys/bus/usb/devices/[0-9]* ; do if [[ -e $d/product ]] ; then echo -e "`basename $d`\t`cat $d/power/control`\t`cat $d/speed`\t`cat $d/product`" ; fi ; done
1-1.2   auto    480     USB2.0 Hub
1-1.2.4 auto    12      Hewlett-Packard ScanJet 3400C
2-1.1   auto    1.5     Microsoft Optical Mouse with Tilt Wheel
2-1.2   auto    12      Fingerprint Sensor   
2-1.3   auto    480     USB 2.0 Camera
2-1.6   auto    480     USB2.0 Hub
2-1.6.2 auto    480     Desktop         
2-1.6.3 auto    480     HD-PCU2
2-1.6.4 auto    1.5     USB Keyboard

All the USB devices are listed as "auto" instead of "on" (see How to prevent a USB mouse auto-suspending in Linux when a laptop’s power supply is disconnected).

Now, I expect I would be able to work around this problem by making CONTROL_USB_AUTOSUSPEND="no" in /etc/laptop-mode/conf.d/usb-autosuspend.conf but that would not be getting to the root cause of the problem.

Is anyone else experiencing this problem with the latest version of upower-pm-utils (0.9.23-r2) and laptop-mode-tools (1.65)? Is it a bug in one of those packages?
_________________
Clevo W230SS: amd64 nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 xf86-video-ati. Dual boot Win 7 Pro 64-bit.
OpenRC eudev elogind & KDE on both.

Fitzcarraldo's blog


Last edited by Fitzcarraldo on Fri Oct 24, 2014 8:10 am; edited 1 time in total
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1769
Location: United Kingdom

PostPosted: Wed Jun 25, 2014 7:34 pm    Post subject: Reply with quote

I have done some investigating, and I'm beginning to suspect there is a bug in laptop-mode-tools version 1.65.

First I downgraded laptop-mode-tools back to version 1.64-r2:

Code:
# eix -I laptop-mode-tools
[U] app-laptop/laptop-mode-tools
     Available versions:  1.63-r2 (~)1.63-r3 1.64 (~)1.64-r2 (~)1.65 {+acpi apm bluetooth scsi}
     Installed versions:  1.64-r2(16:58:58 24/06/14)(acpi bluetooth -apm -scsi)
     Homepage:            http://www.samwel.tk/laptop_mode/
     Description:         Linux kernel laptop_mode user-space utilities

# eix -I upower
[I] sys-power/upower-pm-utils
     Available versions:  0.9.23-r2 {+introspection ios KERNEL="FreeBSD linux"}
     Installed versions:  0.9.23-r2(08:38:02 24/06/14)(introspection -ios KERNEL="linux -FreeBSD")
     Homepage:            http://upower.freedesktop.org/
     Description:         The upstream upower 0.9 git branch for use with sys-power/pm-utils

And then some of the devices were no longer in auto-suspend mode when the mains power adapter was connected to the laptop:

Code:
# for d in /sys/bus/usb/devices/[0-9]* ; do if [[ -e $d/product ]] ; then echo -e "`basename $d`\t`cat $d/power/control`\t`cat $d/speed`\t`cat $d/product`" ; fi ; done
1-1.2   on      480     USB2.0 Hub
1-1.2.4 on      12      Hewlett-Packard ScanJet 3400C
2-1.1   on      1.5     Microsoft Optical Mouse with Tilt Wheel
2-1.2   auto    12      Fingerprint Sensor   
2-1.3   auto    480     USB 2.0 Camera
2-1.6   auto    480     USB2.0 Hub
2-1.6.2 on      480     Desktop         
2-1.6.3 on      480     HD-PCU2
2-1.6.4 on      1.5     USB Keyboard

However the situation shown above was still not completely correct; previously, all devices were shown as "on" rather than "auto". So, next I downgraded upower-pm-utils back to version 0.9.23-r1 (which I had to do using a local overlay, as only version 0.9.23-r2 is in the Portage main tree at the moment):

Code:
# eix -I upower
[U] sys-power/upower-pm-utils
     Available versions:  0.9.23[1] (~)0.9.23-r1[1] 0.9.23-r2 {doc +introspection ios KERNEL="FreeBSD linux"}
     Installed versions:  0.9.23-r1[1](01:34:16 25/06/14)(introspection -ios KERNEL="linux -FreeBSD")
     Homepage:            http://upower.freedesktop.org/
     Description:         The upstream upower 0.9 git branch for use with sys-power/pm-utils

[1] "local_overlay" /usr/local/portage

And then another of the devices (USB2.0 Hub) is not in auto-suspend mode when the mains power adapter is connected to the laptop:

Code:
# for d in /sys/bus/usb/devices/[0-9]* ; do if [[ -e $d/product ]] ; then echo -e "`basename $d`\t`cat $d/power/control`\t`cat $d/speed`\t`cat $d/product`" ; fi ; done
1-1.2   on      480     USB2.0 Hub
1-1.2.4 on      12      Hewlett-Packard ScanJet 3400C
2-1.1   on      1.5     Microsoft Optical Mouse with Tilt Wheel
2-1.2   auto    12      Fingerprint Sensor   
2-1.3   auto    480     USB 2.0 Camera
2-1.6   on      480     USB2.0 Hub
2-1.6.2 on      480     Desktop         
2-1.6.3 on      480     HD-PCU2
2-1.6.4 on      1.5     USB Keyboard

It is still not completely like it used to be: the Fingerprint Sensor and the USB 2.0 Camera (Webcam built-in to the laptop) were both shown as "on" too before.

Very strange. I'm not sure if it's a bug in laptop-mode-tools and/or upower-pm-utils and/or pm-utils. Is anyone else with the latest versions of these packages seeing USB devices in auto-suspend mode even when the mains power adapter is connected to their laptop?
_________________
Clevo W230SS: amd64 nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 xf86-video-ati. Dual boot Win 7 Pro 64-bit.
OpenRC eudev elogind & KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1769
Location: United Kingdom

PostPosted: Tue Oct 21, 2014 6:16 pm    Post subject: Reply with quote

Well, after my post on 25 June I masked >=laptop-mode-tools-1.65, merged 1.64-r2 again and things were back to normal. Then in August I saw Gentoo Bugzilla Bug Report No. 520124 ('app-laptop/laptop-mode-tools-1.65 has broken usb-autosuspend modules') and all became clear(er) thanks to fellow Gentoo and laptop-mode-tools user Ted Tanberry.

A week ago I noticed that an ebuild for laptop-mode-tools-1.66 is available in the Portage main tree and decided to try it. The results were rather bizarre:

a) Sometimes, after booting everything works as expected: the mouse and keyboard do not auto-suspend, and the KDE network management widget shows an available wired connection named "Wired connection 1" (which is eth0).

b) However, sometimes, after booting the mouse and keyboard auto-suspend and the KDE network management widget shows an extra available connection "eth0" in addition to "Wired connection 1". Furthermore, I can connect to "eth0" or "Wired connection 1", but neither provides access to the Internet.

c) In the first case mentioned above, if I then Suspend to RAM and wake the laptop from suspension, from then onwards the keyboard and mouse auto-suspend.

Neither Case b nor Case c above occurred with laptop-mode-tools-1.64.

I despair sometimes! :roll:


EDIT: Actually, I have now discovered that in Case b sometimes it is possible to access the Internet by selecting either "eth0" or "Wired connection 1".
_________________
Clevo W230SS: amd64 nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 xf86-video-ati. Dual boot Win 7 Pro 64-bit.
OpenRC eudev elogind & KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
Roman_Gruber
Advocate
Advocate


Joined: 03 Oct 2006
Posts: 3806
Location: Austro Bavaria

PostPosted: Wed Oct 22, 2014 9:42 am    Post subject: Reply with quote

usb-autosuspend seems the cause for your issues? maybe worth getting rid in the kernel or unloading the module always?

just an idea.
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1769
Location: United Kingdom

PostPosted: Wed Oct 22, 2014 11:55 am    Post subject: Reply with quote

Apparently CONFIG_USB_SUSPEND was dropped after kernel 3.9:

http://cateee.net/lkddb/web-lkddb/USB_SUSPEND.html

Code:
$ cat /usr/src/linux/.config | grep CONFIG_USB_SUSPEND
$

Code:
$ lsmod | grep usb
btusb                  14360  0
bluetooth             189992  30 bnep,btusb,rfcomm

and I am using kernel 3.13.7:

Code:
$ uname -r
3.13.7-gentoo


So I don't think that is the cause of the problem. However, for some reason the laptop_mode initscript activation was removed from the default runlevel at some point. I have no idea why, because it was certainly in the default runlevel in the case of 1.64, as proved by LMT 1.64 working correctly and functionality changing as expected when I edited /etc/laptop-mode/conf.d/usb-autosuspend.conf as installed by LMT 1.64 (see my February 2013 blog post How to prevent a USB mouse auto-suspending in Linux when a laptop’s power supply is disconnected). Anyway, I have now:

a) added LMT 1.66 laptop_mode to the default runlevel;

b) disabled auto-suspend in /etc/laptop-mode/conf.d/usb-autosuspend.conf that was installed by LMT 1.64 (even though LMT 1.66 uses /usr/share/laptop-mode-tools/modules/runtime-pm instead of /usr/share/laptop-mode-tools/modules/usb-autosuspend)*;

* The LMT 1.66 ebuild did not delete the LMT usb-autosuspend module config file.

c) blacklisted in /etc/laptop-mode/conf.d/runtime-pm.conf my mouse, external keyboard and a couple of in-built USB devices;

and will see if the problems still occur over the next few days. The intermittent addition of an extra network connection (my previous post referred) is bizarre, and I cannot see why LMT would cause that, so perhaps it is coincidental and is caused by something else that was updated when I updated world on October 13.

Anyway, I've blogged about the change in LMT functional design after 1.64 in a new post, which explains how to configure LMT 1.66: Laptop Mode Tools revisited due to a change in its functionality.
_________________
Clevo W230SS: amd64 nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 xf86-video-ati. Dual boot Win 7 Pro 64-bit.
OpenRC eudev elogind & KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1769
Location: United Kingdom

PostPosted: Fri Oct 24, 2014 8:10 am    Post subject: Reply with quote

OK, it seems that LMT 1.66 is working as intended. Mind you, it would probably be better to do what Ted Tanberry recommended in Gentoo Bugzilla Bug Report No. 520124, i.e. edit /etc/laptop-mode/conf.d/runtime-pm.conf as follows, to stop all external keyboards, mice and USB HDDs going to sleep if the laptop is on battery power:

Code:
AUTOSUSPEND_RUNTIME_DEVTYPE_BLACKLIST="usbhid usb-storage"


I am still experiencing the phenomenon of a new entry 'eth0' in addition to the entry 'Wired connection 1' in the list of available network connections, but I think that is probably not due to LMT 1.66 and something to do with udev (well, systemd really, given that the udev code was subsumed by systemd and the Gentoo sys-fs/udev ebuild simply extracts it from the systemd tarball). I suppose I could check my theory by switching from udev to eudev, but I can still get a connection to the Internet so I won't bother.

So I'm going to mark this thread as 'Solved'.
_________________
Clevo W230SS: amd64 nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 xf86-video-ati. Dual boot Win 7 Pro 64-bit.
OpenRC eudev elogind & KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
kernelOfTruth
Watchman
Watchman


Joined: 20 Dec 2005
Posts: 6111
Location: Vienna, Austria; Germany; hello world :)

PostPosted: Sat Oct 25, 2014 8:14 pm    Post subject: Reply with quote

Hi Fitzcarraldo,


I'm linking to a post which links back to your blog - hope it helps somehow:

https://forums.gentoo.org/viewtopic-t-995446-highlight-.html
_________________
https://github.com/kernelOfTruth/ZFS-for-SystemRescueCD/tree/ZFS-for-SysRescCD-4.9.0
https://github.com/kernelOfTruth/pulseaudio-equalizer-ladspa

Hardcore Gentoo Linux user since 2004 :D
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1769
Location: United Kingdom

PostPosted: Sun Oct 26, 2014 4:38 pm    Post subject: Reply with quote

Thanks for posting kernelOfTruth but, as mentioned in my previous post, I sorted out my problem with LMT 1.66. It's a pity I did not see the thread you referenced, as it took me a while to understand precisely what Gentoo Bugzilla Bug Report No. 520124 meant, i.e. that LMT 1.66 had switched to using LMT module runtime-pm instead of LMT module usb-autosuspend.

In the thread you referenced, Xywa mentioned a previous alternative approach of disabling USB auto-suspend, by using kernel boot line parameter 'usbcore.autosuspend=-1' (or 'options usbcore autosuspend=-1' in /etc/modprobe.d/usbcore.conf if usbcore is built as a kernel module instead of in-kernel), but, as we know, CONFIG_USB_SUSPEND was dropped after kernel 3.9. Hence LMT is the way to go.

I now think the extra network connection ('eth0') appearing in the list of available connections in my KDE Panel may be due to net-misc/networkmanager, as that extra entry 'eth0' started appearing in the KDE Plasma NM widget's list of available connections after a world update I performed on 13 October merged net-misc/networkmanager-0.9.10.0. Anyway, today I used the KDE Plasma NM widget's connection editor to delete the phantom 'eth0' from its list of available connections to see what would happen, and the next time I booted the laptop the wired connection would no longer work. So I used the KDE Plasma NM widget's connection editor to manually add a new wired connection which I named 'eth0', and the wired connection 'Wired connection 1' now works again. :roll: So I'll leave it.



EDIT Mon 10 Nov 22:13:02 GMT 2014: I think I may have found the reason for the extra entry ("eth0") in the list of available connections in the plasma-nm widget on my KDE Panel. I have now deleted the file /etc/udev/rules.d/70-persistent-net.rules and initscript /etc/init.d/rename_ethX (given in Gentoo Bug Report No. 453494) as I think they were obsoleted by the following two files in later releases of udev for those of us who want to maintain the kernel naming scheme "eth0" and "wlan0" instead of the systemd/udev 'predictable network interface names':

Code:
cat /etc/udev/rules.d/80-net-name-slot.rules
# No, I don't want the switch yet. Thanks.
# http://forums.gentoo.org/viewtopic-t-948718-highlight-.html
# End of file.

Code:
$ cat /etc/udev/rules.d/80-net-setup-link.rules
# No, I don't want the switch.
# http://forums.gentoo.org/viewtopic-p-7507456.html#7507456
# End of file.



EDIT Wed 19 Nov 11:45:30 GMT 2014: I was still was experiencing the problem, even when I just had the above-mentioned files /etc/udev/rules.d/80-net-name-slot.rules and /etc/udev/rules.d/80-net-setup-link.rules present (as well as the empty file /etc/systemd/network/99-default.link), so I deleted the older /etc/udev/rules.d/80-net-name-slot.rules. Even with eudev-2.1.1 that resulted in new 'predictable network interface names' for the wired and wireless network connections, so I added the boot parameter 'net.ifnames=0' to the kernel command line in /etc/default/grub and regenerated /boot/grub/grub.cfg. The problem now seems to be finally solved. The plasma-nm widget on the KDE Panel only shows 'Wired connection 1' and not 'eth0' as well (or the equivalent freedesktop.org 'predictable network interface name' for eth0). So it seems that the only sure-fire way to stop the freedesktop.org naming scheme is to use the kernel boot parameter 'net.ifnames=0'. Looks to me like the cause of the problem was udev (eudev, if that is installed instead of systemd/udev).
_________________
Clevo W230SS: amd64 nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 xf86-video-ati. Dual boot Win 7 Pro 64-bit.
OpenRC eudev elogind & KDE on both.

Fitzcarraldo's blog


Last edited by Fitzcarraldo on Wed Nov 19, 2014 12:04 pm; edited 4 times in total
Back to top
View user's profile Send private message
chutzpah
Developer
Developer


Joined: 24 Mar 2003
Posts: 13
Location: Montreal, QC, Canada

PostPosted: Tue Nov 04, 2014 5:49 am    Post subject: Reply with quote

These udev rules will enable autosuspend for all USB devices except mice and keyboards (you can turn off laptop-mode's support for this after these are added)

Code:
# enable USB autosuspend for all devices
ACTION=="add", SUBSYSTEM=="usb", TEST=="power/control" ATTR{power/control}="auto"
ACTION=="add", SUBSYSTEM=="usb", TEST=="power/autosuspend" ATTR{power/autosuspend}="2"

# don't autosuspend keyboards or mice
ACTION=="add", SUBSYSTEM=="usb", ATTR{bInterfaceClass}=="03", ATTR{bInterfaceSubClass}=="01", ATTR{bInterfaceProtocol}=="01", TEST=="../power/control" ATTR{../power/control}="on"
ACTION=="add", SUBSYSTEM=="usb", ATTR{bInterfaceClass}=="03", ATTR{bInterfaceSubClass}=="01", ATTR{bInterfaceProtocol}=="02", TEST=="../power/control" ATTR{../power/control}="on"
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1769
Location: United Kingdom

PostPosted: Sun Feb 15, 2015 6:28 pm    Post subject: Reply with quote

Just in case someone finds this thread by searching, I want to clarify that the problem of the additional connection entry 'eth0' in the plasma-nm widget was caused by NetworkManager, not udev.

Although I wrote in my two edits of my previous post that deleting some udev files and adding the kernel boot parameter 'net.ifnames=0' appeared to have eliminated the unwanted extra connection 'eth0' in the NetworkManager GUI front-end, I was mistaken. (Mind you, deleting those udev files and adding kernel boot parameter 'net.ifnames=0' did reliably rid me of the so-called Predictable Network Interface Names, so that was grist to the mill.)

I have been breaking my head over this for months and tracked it down to NetworkManager. The big breakthrough yesterday was finding Debian bug report no. 755202: network-manager: keeps creating and using new connection “eth0″ that does not work. My blog post today NetworkManager creates a new connection ‘eth0′ that does not work goes into detail, but the bottom line is to do the following if you find an extra connection appearing for no good reason:

1. Check that your network driver is reliable. You can search the Web to see if other users have experienced problems with the same driver you are using.

2. Make sure the contents of NetworkManager.conf are correct. (See the NetworkManager.conf man page and the GNOME Wiki page on NetworkManager settings to find out what options are available.)

3. Delete all the files (including hidden files) in the directory /etc/NetworkManager/system-connections/ and recreate your connections via the NetworkManager GUI (plasma-nm, nm-applet or whatever) or TUI (nmtui).
_________________
Clevo W230SS: amd64 nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 xf86-video-ati. Dual boot Win 7 Pro 64-bit.
OpenRC eudev elogind & KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
Fitzcarraldo
Veteran
Veteran


Joined: 30 Aug 2008
Posts: 1769
Location: United Kingdom

PostPosted: Tue Mar 10, 2015 1:41 pm    Post subject: Reply with quote

Oh, man. I thought the 'additional eth0 entry' problem was solved, but it isn't. :evil:

My previous post was made while I was away from home on a work trip, and the changes I described seemed to have cured the problem on the networks my laptop was connected to (wired and wireless networks in both office and hotel). I am now back at home and my laptop is connected to my home network via an Ethernet cable. Even with the changes I made (see my previous post), when I boot the laptop NetworkManager sometimes (but not always) has two connections named ‘eth0′, one of them the ‘Active connection’ (but not able to connect to the Internet) and the other an ‘Available connection’. In this situation the wired network icon on the Panel has a yellow question mark superimposed. If I delete the ‘eth0′ active connection and use the other ‘eth0′, the latter works as expected and I have no trouble connecting to the Internet. In Debian bug report no. 755202 user Frederik Himpe added a comment on March 4, 2015 that he is also still experiencing this problem and “It looks like there is a race somewhere, causing the network interface to be brought up before Network Manager is started, and this prevents correct configuration by NM”. So the problem is still unresolved.

Hmm … I wonder if udev does have something to do with it after all. :?

Is anyone else experiencing this behaviour?
_________________
Clevo W230SS: amd64 nvidia-drivers & xf86-video-intel.
Compal NBLB2: ~amd64 xf86-video-ati. Dual boot Win 7 Pro 64-bit.
OpenRC eudev elogind & KDE on both.

Fitzcarraldo's blog
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum