Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
fslsfonts: unable to open server "unix/:7100"
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
pablored
Guest





PostPosted: Fri Apr 26, 2002 12:32 am    Post subject: fslsfonts: unable to open server "unix/:7100" Reply with quote

Font trouble...

I am on a holy quest to improve the appearance of the new Abiword and I have hit a bit of a wall. I'm trying to set up xfs... not even got to antialiasing and MS fonts yet.

/etc/init.d/xfs start runs ok, and I have added all the dirs to the /etc/X11/fs/config file, I have also modified the XF86Config file... removing dirs and adding unix/:7100 (Load and FontPath). However, the font server was not listed within /etc/services.

I have tried adding the lines:
font-service 7100/tcp
font-service 7100/udp

tried restarting x and xfs, rebooting (!)... no success, just an uglier x windows (i left in the misc fonts as a backup, if i remove them from the XF86Config it doesn't start window maker: no fonts found).

What do people have in the /etc/services file for 7100, the font server?

Note: I modified the /etc/init.d/xfs script to change the port from 1 to 7100.

I think that covers everything. Any help would be greatly appreciated, I have searched these forums and scoured google but still need assistance.

For now I am about to pass out from tiredness (uk).
Cheers
Paul
Back to top
lk42pro
Tux's lil' helper
Tux's lil' helper


Joined: 21 Apr 2002
Posts: 114
Location: New Jersey, USA

PostPosted: Fri Apr 26, 2002 12:57 am    Post subject: Reply with quote

this problem is already discussed under Desktop environment..it was a pretty long thread too
Back to top
View user's profile Send private message
Daemon
n00b
n00b


Joined: 18 Apr 2002
Posts: 65

PostPosted: Fri Apr 26, 2002 1:01 am    Post subject: Reply with quote

i think you're only change the 1 to 7100 and forgeting the minus sign. this is not an option sign and you need to remove it cause your starting your server on port -7100 and not 7100. in your /etc/X11/fs/config it should look like this "port 7100" and not "port -7100". try it.
Back to top
View user's profile Send private message
Nitro
Bodhisattva
Bodhisattva


Joined: 08 Apr 2002
Posts: 661
Location: San Francisco

PostPosted: Fri Apr 26, 2002 1:58 am    Post subject: Reply with quote

There seems to be a problem starting the xfs server and running it as the user xfs. Try removing the -droppiv and -user stuff off it and try starting it again. By the way, unless you intend to use it as tcp, you don't need to specify port 7100, just leave it as -1 and in your XF86Config put "unix/:-1" works for me.
_________________
- Kyle Manna

Please, please SEARCH before posting.

There are three kinds of people in the world: those who can count, and those who can't.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum