Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with nvidia
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
laizn
n00b
n00b


Joined: 22 Jun 2014
Posts: 1

PostPosted: Sun Jun 22, 2014 10:33 am    Post subject: Problem with nvidia Reply with quote

Hi all,

I am having a huge problem: after I restarted i cannot start X as nvidia wont load modules:

Code:
[  365.712262] NVRM: [Plug & Play OS] should be set to NO
[  365.712263] NVRM: [Assign IRQ to VGA] should be set to YES
[  365.712273] nvidia: probe of 0000:01:00.0 failed with error -1
[  365.712991] NVRM: The NVIDIA probe routine failed for 1 device(s).
[  365.712994] NVRM: None of the NVIDIA graphics adapters were initialized!
[  365.712996] [drm] Module unloaded
[  365.713498] NVRM: NVIDIA init module failed!
[  365.760440] ------------[ cut here ]------------
[  365.760450] WARNING: CPU: 1 PID: 21777 at fs/proc/generic.c:332 proc_register+0xc8/0x150()
[  365.760452] proc_dir_entry 'driver/nvidia' already registered
[  365.760454] Modules linked in: nvidia(PO+) snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec powernow_k8 snd_hwdep snd_pcm snd_page_alloc snd_timer k8temp snd r8169 soundcore fan mii freq_table thermal button processor
[  365.760469] CPU: 1 PID: 21777 Comm: modprobe Tainted: P        W  O 3.12.21-gentoo-r1 #7
[  365.760471] Hardware name: System manufacturer System Product Name/M2A-VM, BIOS ASUS M2A-VM ACPI BIOS Revision 2302 02/05/2009
[  365.760473]  0000000000000009 ffff88008fcc3b88 ffffffff815679b7 0000000000000007
[  365.760475]  ffff88008fcc3bd8 ffff88008fcc3bc8 ffffffff810402a2 ffffffff819f8ac4
[  365.760477]  ffff880090bc3cb3 ffff880090bc3c40 ffff88014f048340 0000000000000000
[  365.760480] Call Trace:
[  365.760487]  [<ffffffff815679b7>] dump_stack+0x46/0x58
[  365.760491]  [<ffffffff810402a2>] warn_slowpath_common+0x82/0xb0
[  365.760494]  [<ffffffff81040371>] warn_slowpath_fmt+0x41/0x50
[  365.760497]  [<ffffffff81161973>] ? proc_alloc_inum+0x43/0xb0
[  365.760499]  [<ffffffff81161aa8>] proc_register+0xc8/0x150
[  365.760501]  [<ffffffff81161c2d>] proc_mkdir_data+0x4d/0x70
[  365.760504]  [<ffffffff81161c7e>] proc_mkdir_mode+0xe/0x10
[  365.760720]  [<ffffffffa266f5da>] nv_register_procfs+0x3a/0x1b0 [nvidia]
[  365.760790]  [<ffffffffa2af1296>] nvidia_init_module+0x296/0x7ae [nvidia]
[  365.760856]  [<ffffffffa2af17c3>] ? nv_drm_init+0x15/0x15 [nvidia]
[  365.760922]  [<ffffffffa2af1849>] nvidia_frontend_init_module+0x86/0xb8 [nvidia]
[  365.760988]  [<ffffffffa2af17c3>] ? nv_drm_init+0x15/0x15 [nvidia]
[  365.760992]  [<ffffffff810002e2>] do_one_initcall+0xf2/0x140
[  365.760995]  [<ffffffff81061f21>] ? __blocking_notifier_call_chain+0x51/0x60
[  365.761000]  [<ffffffff8109199f>] load_module+0x189f/0x2190
[  365.761002]  [<ffffffff8108ed40>] ? mod_kobject_put+0x50/0x50
[  365.761040]  [<ffffffff8110b581>] ? kernel_read+0x41/0x60
[  365.761044]  [<ffffffff810923c6>] SyS_finit_module+0x86/0x90
[  365.761048]  [<ffffffff8156cae2>] system_call_fastpath+0x16/0x1b
[  365.761050] ---[ end trace 1f94271f8a9a360e ]---
[  365.761214] NVRM: Can't find an IRQ for your NVIDIA card!
[  365.761217] NVRM: Please check your BIOS settings.
[  365.761218] NVRM: [Plug & Play OS] should be set to NO
[  365.761220] NVRM: [Assign IRQ to VGA] should be set to YES
[  365.761776] nvidia: probe of 0000:01:00.0 failed with error -1
[  365.762638] NVRM: The NVIDIA probe routine failed for 1 device(s).
[  365.762641] NVRM: None of the NVIDIA graphics adapters were initialized!
[  365.762643] [drm] Module unloaded
[  365.762759] NVRM: NVIDIA init module failed!
[  365.807773] ------------[ cut here ]------------
[  365.807783] WARNING: CPU: 1 PID: 21784 at fs/proc/generic.c:332 proc_register+0xc8/0x150()
[  365.807785] proc_dir_entry 'driver/nvidia' already registered
[  365.807787] Modules linked in: nvidia(PO+) snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec powernow_k8 snd_hwdep snd_pcm snd_page_alloc snd_timer k8temp snd r8169 soundcore fan mii freq_table thermal button processor
[  365.807801] CPU: 1 PID: 21784 Comm: modprobe Tainted: P        W  O 3.12.21-gentoo-r1 #7
[  365.807803] Hardware name: System manufacturer System Product Name/M2A-VM, BIOS ASUS M2A-VM ACPI BIOS Revision 2302 02/05/2009
[  365.807805]  0000000000000009 ffff88008fe55b88 ffffffff815679b7 0000000000000007
[  365.807807]  ffff88008fe55bd8 ffff88008fe55bc8 ffffffff810402a2 ffffffff819f8ac4
[  365.807810]  ffff88008f41cbb3 ffff88008f41cb40 ffff88014f048340 0000000000000000
[  365.807812] Call Trace:
[  365.807819]  [<ffffffff815679b7>] dump_stack+0x46/0x58
[  365.807823]  [<ffffffff810402a2>] warn_slowpath_common+0x82/0xb0
[  365.807826]  [<ffffffff81040371>] warn_slowpath_fmt+0x41/0x50
[  365.807829]  [<ffffffff81161973>] ? proc_alloc_inum+0x43/0xb0
[  365.807831]  [<ffffffff81161aa8>] proc_register+0xc8/0x150
[  365.807834]  [<ffffffff81161c2d>] proc_mkdir_data+0x4d/0x70
[  365.807836]  [<ffffffff81161c7e>] proc_mkdir_mode+0xe/0x10
[  365.808011]  [<ffffffffa06c15da>] nv_register_procfs+0x3a/0x1b0 [nvidia]
[  365.808143]  [<ffffffffa0b43296>] nvidia_init_module+0x296/0x7ae [nvidia]
[  365.808221]  [<ffffffffa0b437c3>] ? nv_drm_init+0x15/0x15 [nvidia]
[  365.808297]  [<ffffffffa0b43849>] nvidia_frontend_init_module+0x86/0xb8 [nvidia]
[  365.808372]  [<ffffffffa0b437c3>] ? nv_drm_init+0x15/0x15 [nvidia]
[  365.808375]  [<ffffffff810002e2>] do_one_initcall+0xf2/0x140
[  365.808379]  [<ffffffff81061f21>] ? __blocking_notifier_call_chain+0x51/0x60
[  365.808383]  [<ffffffff8109199f>] load_module+0x189f/0x2190
[  365.808385]  [<ffffffff8108ed40>] ? mod_kobject_put+0x50/0x50
[  365.808388]  [<ffffffff8110b581>] ? kernel_read+0x41/0x60
[  365.808391]  [<ffffffff810923c6>] SyS_finit_module+0x86/0x90
[  365.808395]  [<ffffffff8156cae2>] system_call_fastpath+0x16/0x1b
[  365.808397] ---[ end trace 1f94271f8a9a360f ]---
[  365.808660] NVRM: Can't find an IRQ for your NVIDIA card!
[  365.808663] NVRM: Please check your BIOS settings.
[  365.808665] NVRM: [Plug & Play OS] should be set to NO
[  365.808666] NVRM: [Assign IRQ to VGA] should be set to YES
[  365.808739] nvidia: probe of 0000:01:00.0 failed with error -1
[  365.809541] NVRM: The NVIDIA probe routine failed for 1 device(s).
[  365.809544] NVRM: None of the NVIDIA graphics adapters were initialized!
[  365.809546] [drm] Module unloaded
[  365.810311] NVRM: NVIDIA init module failed!
[  365.856643] ------------[ cut here ]------------
[  365.856653] WARNING: CPU: 1 PID: 21791 at fs/proc/generic.c:332 proc_register+0xc8/0x150()
[  365.856655] proc_dir_entry 'driver/nvidia' already registered
[  365.856657] Modules linked in: nvidia(PO+) snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec powernow_k8 snd_hwdep snd_pcm snd_page_alloc snd_timer k8temp snd r8169 soundcore fan mii freq_table thermal button processor
[  365.856671] CPU: 1 PID: 21791 Comm: modprobe Tainted: P        W  O 3.12.21-gentoo-r1 #7
[  365.856673] Hardware name: System manufacturer System Product Name/M2A-VM, BIOS ASUS M2A-VM ACPI BIOS Revision 2302 02/05/2009
[  365.856675]  0000000000000009 ffff88013e52fb88 ffffffff815679b7 0000000000000007
[  365.856677]  ffff88013e52fbd8 ffff88013e52fbc8 ffffffff810402a2 ffffffff819f8ac4
[  365.856680]  ffff880090bc36b3 ffff880090bc3640 ffff88014f048340 0000000000000000
[  365.856682] Call Trace:
[  365.856688]  [<ffffffff815679b7>] dump_stack+0x46/0x58
[  365.856693]  [<ffffffff810402a2>] warn_slowpath_common+0x82/0xb0
[  365.856695]  [<ffffffff81040371>] warn_slowpath_fmt+0x41/0x50
[  365.856698]  [<ffffffff81161973>] ? proc_alloc_inum+0x43/0xb0
[  365.856700]  [<ffffffff81161aa8>] proc_register+0xc8/0x150
[  365.856703]  [<ffffffff81161c2d>] proc_mkdir_data+0x4d/0x70
[  365.856705]  [<ffffffff81161c7e>] proc_mkdir_mode+0xe/0x10
[  365.856911]  [<ffffffffa116d5da>] nv_register_procfs+0x3a/0x1b0 [nvidia]
[  365.856980]  [<ffffffffa15ef296>] nvidia_init_module+0x296/0x7ae [nvidia]
[  365.857011]  [<ffffffffa15ef7c3>] ? nv_drm_init+0x15/0x15 [nvidia]
[  365.857142]  [<ffffffffa15ef849>] nvidia_frontend_init_module+0x86/0xb8 [nvidia]
[  365.857210]  [<ffffffffa15ef7c3>] ? nv_drm_init+0x15/0x15 [nvidia]
[  365.857226]  [<ffffffff810002e2>] do_one_initcall+0xf2/0x140
[  365.857239]  [<ffffffff81061f21>] ? __blocking_notifier_call_chain+0x51/0x60
[  365.857252]  [<ffffffff8109199f>] load_module+0x189f/0x2190
[  365.857255]  [<ffffffff8108ed40>] ? mod_kobject_put+0x50/0x50
[  365.857258]  [<ffffffff8110b581>] ? kernel_read+0x41/0x60
[  365.857261]  [<ffffffff810923c6>] SyS_finit_module+0x86/0x90
[  365.857265]  [<ffffffff8156cae2>] system_call_fastpath+0x16/0x1b
[  365.857267] ---[ end trace 1f94271f8a9a3610 ]---
[  365.857363] NVRM: Can't find an IRQ for your NVIDIA card!
[  365.857366] NVRM: Please check your BIOS settings.
[  365.857367] NVRM: [Plug & Play OS] should be set to NO
[  365.857369] NVRM: [Assign IRQ to VGA] should be set to YES
[  365.857931] nvidia: probe of 0000:01:00.0 failed with error -1
[  365.858728] NVRM: The NVIDIA probe routine failed for 1 device(s).
[  365.858732] NVRM: None of the NVIDIA graphics adapters were initialized!
[  365.858733] [drm] Module unloaded
[  365.858847] NVRM: NVIDIA init module failed!
[  365.905905] ------------[ cut here ]------------
[  365.905916] WARNING: CPU: 1 PID: 21798 at fs/proc/generic.c:332 proc_register+0xc8/0x150()
[  365.905918] proc_dir_entry 'driver/nvidia' already registered
[  365.905920] Modules linked in: nvidia(PO+) snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec powernow_k8 snd_hwdep snd_pcm snd_page_alloc snd_timer k8temp snd r8169 soundcore fan mii freq_table thermal button processor
[  365.905936] CPU: 1 PID: 21798 Comm: modprobe Tainted: P        W  O 3.12.21-gentoo-r1 #7
[  365.905938] Hardware name: System manufacturer System Product Name/M2A-VM, BIOS ASUS M2A-VM ACPI BIOS Revision 2302 02/05/2009
[  365.905940]  0000000000000009 ffff880090bc1b88 ffffffff815679b7 0000000000000007
[  365.905943]  ffff880090bc1bd8 ffff880090bc1bc8 ffffffff810402a2 ffffffff819f8ac4
[  365.905946]  ffff88008f452eb3 ffff88008f452e40 ffff88014f048340 0000000000000000
[  365.905948] Call Trace:
[  365.905955]  [<ffffffff815679b7>] dump_stack+0x46/0x58
[  365.905960]  [<ffffffff810402a2>] warn_slowpath_common+0x82/0xb0
[  365.905963]  [<ffffffff81040371>] warn_slowpath_fmt+0x41/0x50
[  365.905965]  [<ffffffff81161973>] ? proc_alloc_inum+0x43/0xb0
[  365.905968]  [<ffffffff81161aa8>] proc_register+0xc8/0x150
[  365.905971]  [<ffffffff81161c2d>] proc_mkdir_data+0x4d/0x70
[  365.905973]  [<ffffffff81161c7e>] proc_mkdir_mode+0xe/0x10
[  365.906010]  [<ffffffffa1bee5da>] nv_register_procfs+0x3a/0x1b0 [nvidia]
[  365.906288]  [<ffffffffa2070296>] nvidia_init_module+0x296/0x7ae [nvidia]
[  365.906367]  [<ffffffffa20707c3>] ? nv_drm_init+0x15/0x15 [nvidia]
[  365.906442]  [<ffffffffa2070849>] nvidia_frontend_init_module+0x86/0xb8 [nvidia]
[  365.906516]  [<ffffffffa20707c3>] ? nv_drm_init+0x15/0x15 [nvidia]
[  365.906519]  [<ffffffff810002e2>] do_one_initcall+0xf2/0x140
[  365.906522]  [<ffffffff81061f21>] ? __blocking_notifier_call_chain+0x51/0x60
[  365.906527]  [<ffffffff8109199f>] load_module+0x189f/0x2190
[  365.906529]  [<ffffffff8108ed40>] ? mod_kobject_put+0x50/0x50
[  365.906532]  [<ffffffff8110b581>] ? kernel_read+0x41/0x60
[  365.906535]  [<ffffffff810923c6>] SyS_finit_module+0x86/0x90
[  365.906539]  [<ffffffff8156cae2>] system_call_fastpath+0x16/0x1b
[  365.906541] ---[ end trace 1f94271f8a9a3611 ]---
[  365.906730] NVRM: Can't find an IRQ for your NVIDIA card!
[  365.906733] NVRM: Please check your BIOS settings.
[  365.906734] NVRM: [Plug & Play OS] should be set to NO
[  365.906735] NVRM: [Assign IRQ to VGA] should be set to YES
[  365.907126] nvidia: probe of 0000:01:00.0 failed with error -1
[  365.907994] NVRM: The NVIDIA probe routine failed for 1 device(s).
[  365.907998] NVRM: None of the NVIDIA graphics adapters were initialized!
[  365.908000] [drm] Module unloaded
[  365.908242] NVRM: NVIDIA init module failed!
[  365.954198] ------------[ cut here ]------------
[  365.954208] WARNING: CPU: 1 PID: 21805 at fs/proc/generic.c:332 proc_register+0xc8/0x150()
[  365.954210] proc_dir_entry 'driver/nvidia' already registered
[  365.954211] Modules linked in: nvidia(PO+) snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec powernow_k8 snd_hwdep snd_pcm snd_page_alloc snd_timer k8temp snd r8169 soundcore fan mii freq_table thermal button processor
[  365.954225] CPU: 1 PID: 21805 Comm: modprobe Tainted: P        W  O 3.12.21-gentoo-r1 #7
[  365.954227] Hardware name: System manufacturer System Product Name/M2A-VM, BIOS ASUS M2A-VM ACPI BIOS Revision 2302 02/05/2009
[  365.954229]  0000000000000009 ffff88008fa5db88 ffffffff815679b7 0000000000000007
[  365.954231]  ffff88008fa5dbd8 ffff88008fa5dbc8 ffffffff810402a2 ffffffff819f8ac4
[  365.954234]  ffff880090bc3733 ffff880090bc36c0 ffff88014f048340 0000000000000000
[  365.954236] Call Trace:
[  365.954243]  [<ffffffff815679b7>] dump_stack+0x46/0x58
[  365.954247]  [<ffffffff810402a2>] warn_slowpath_common+0x82/0xb0
[  365.954250]  [<ffffffff81040371>] warn_slowpath_fmt+0x41/0x50
[  365.954253]  [<ffffffff81161973>] ? proc_alloc_inum+0x43/0xb0
[  365.954255]  [<ffffffff81161aa8>] proc_register+0xc8/0x150
[  365.954258]  [<ffffffff81161c2d>] proc_mkdir_data+0x4d/0x70
[  365.954260]  [<ffffffff81161c7e>] proc_mkdir_mode+0xe/0x10
[  365.954466]  [<ffffffffa06c15da>] nv_register_procfs+0x3a/0x1b0 [nvidia]
[  365.954595]  [<ffffffffa0b43296>] nvidia_init_module+0x296/0x7ae [nvidia]
[  365.954661]  [<ffffffffa0b437c3>] ? nv_drm_init+0x15/0x15 [nvidia]
[  365.954728]  [<ffffffffa0b43849>] nvidia_frontend_init_module+0x86/0xb8 [nvidia]
[  365.954794]  [<ffffffffa0b437c3>] ? nv_drm_init+0x15/0x15 [nvidia]
[  365.954797]  [<ffffffff810002e2>] do_one_initcall+0xf2/0x140
[  365.954801]  [<ffffffff81061f21>] ? __blocking_notifier_call_chain+0x51/0x60
[  365.954805]  [<ffffffff8109199f>] load_module+0x189f/0x2190
[  365.954807]  [<ffffffff8108ed40>] ? mod_kobject_put+0x50/0x50
[  365.954810]  [<ffffffff8110b581>] ? kernel_read+0x41/0x60
[  365.954813]  [<ffffffff810923c6>] SyS_finit_module+0x86/0x90
[  365.954818]  [<ffffffff8156cae2>] system_call_fastpath+0x16/0x1b
[  365.954820] ---[ end trace 1f94271f8a9a3612 ]---
[  365.954887] NVRM: Can't find an IRQ for your NVIDIA card!
[  365.954892] NVRM: Please check your BIOS settings.
[  365.954894] NVRM: [Plug & Play OS] should be set to NO
[  365.954895] NVRM: [Assign IRQ to VGA] should be set to YES
[  365.954910] nvidia: probe of 0000:01:00.0 failed with error -1
[  365.956056] NVRM: The NVIDIA probe routine failed for 1 device(s).
[  365.956059] NVRM: None of the NVIDIA graphics adapters were initialized!
[  365.956061] [drm] Module unloaded
[  365.956187] NVRM: NVIDIA init module failed!
[  366.002841] ------------[ cut here ]------------
[  366.002852] WARNING: CPU: 0 PID: 21812 at fs/proc/generic.c:332 proc_register+0xc8/0x150()
[  366.002854] proc_dir_entry 'driver/nvidia' already registered
[  366.002855] Modules linked in: nvidia(PO+) snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec powernow_k8 snd_hwdep snd_pcm snd_page_alloc snd_timer k8temp snd r8169 soundcore fan mii freq_table thermal button processor
[  366.002871] CPU: 0 PID: 21812 Comm: modprobe Tainted: P        W  O 3.12.21-gentoo-r1 #7
[  366.002873] Hardware name: System manufacturer System Product Name/M2A-VM, BIOS ASUS M2A-VM ACPI BIOS Revision 2302 02/05/2009
[  366.002875]  0000000000000009 ffff88013e199b88 ffffffff815679b7 0000000000000007
[  366.002877]  ffff88013e199bd8 ffff88013e199bc8 ffffffff810402a2 ffffffff819f8ac4
[  366.002880]  ffff88013e1b05b3 ffff88013e1b0540 ffff88014f048340 0000000000000000
[  366.002882] Call Trace:
[  366.002889]  [<ffffffff815679b7>] dump_stack+0x46/0x58
[  366.002893]  [<ffffffff810402a2>] warn_slowpath_common+0x82/0xb0
[  366.002896]  [<ffffffff81040371>] warn_slowpath_fmt+0x41/0x50
[  366.002898]  [<ffffffff81161973>] ? proc_alloc_inum+0x43/0xb0
[  366.002901]  [<ffffffff81161aa8>] proc_register+0xc8/0x150
[  366.002903]  [<ffffffff81161c2d>] proc_mkdir_data+0x4d/0x70
[  366.002905]  [<ffffffff81161c7e>] proc_mkdir_mode+0xe/0x10
[  366.003011]  [<ffffffffa116d5da>] nv_register_procfs+0x3a/0x1b0 [nvidia]
[  366.003224]  [<ffffffffa15ef296>] nvidia_init_module+0x296/0x7ae [nvidia]
[  366.003292]  [<ffffffffa15ef7c3>] ? nv_drm_init+0x15/0x15 [nvidia]
[  366.003359]  [<ffffffffa15ef849>] nvidia_frontend_init_module+0x86/0xb8 [nvidia]
[  366.003424]  [<ffffffffa15ef7c3>] ? nv_drm_init+0x15/0x15 [nvidia]
[  366.003428]  [<ffffffff810002e2>] do_one_initcall+0xf2/0x140
[  366.003431]  [<ffffffff81061f21>] ? __blocking_notifier_call_chain+0x51/0x60
[  366.003435]  [<ffffffff8109199f>] load_module+0x189f/0x2190
[  366.003438]  [<ffffffff8108ed40>] ? mod_kobject_put+0x50/0x50
[  366.003441]  [<ffffffff8110b581>] ? kernel_read+0x41/0x60
[  366.003444]  [<ffffffff810923c6>] SyS_finit_module+0x86/0x90
[  366.003447]  [<ffffffff8156cae2>] system_call_fastpath+0x16/0x1b
[  366.003449] ---[ end trace 1f94271f8a9a3613 ]---
[  366.003515] NVRM: Can't find an IRQ for your NVIDIA card!
[  366.003523] NVRM: Please check your BIOS settings.
[  366.003530] NVRM: [Plug & Play OS] should be set to NO
[  366.003536] NVRM: [Assign IRQ to VGA] should be set to YES
[  366.003552] nvidia: probe of 0000:01:00.0 failed with error -1
[  366.004307] NVRM: The NVIDIA probe routine failed for 1 device(s).
[  366.004308] NVRM: None of the NVIDIA graphics adapters were initialized!
[  366.004309] [drm] Module unloaded
[  366.004425] NVRM: NVIDIA init module failed!
[  366.057453] ------------[ cut here ]------------
[  366.057463] WARNING: CPU: 0 PID: 21819 at fs/proc/generic.c:332 proc_register+0xc8/0x150()
[  366.057465] proc_dir_entry 'driver/nvidia' already registered
[  366.057467] Modules linked in: nvidia(PO+) snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec powernow_k8 snd_hwdep snd_pcm snd_page_alloc snd_timer k8temp snd r8169 soundcore fan mii freq_table thermal button processor
[  366.057483] CPU: 0 PID: 21819 Comm: modprobe Tainted: P        W  O 3.12.21-gentoo-r1 #7
[  366.057485] Hardware name: System manufacturer System Product Name/M2A-VM, BIOS ASUS M2A-VM ACPI BIOS Revision 2302 02/05/2009
[  366.057487]  0000000000000009 ffff8800915c1b88 ffffffff815679b7 0000000000000007
[  366.057490]  ffff8800915c1bd8 ffff8800915c1bc8 ffffffff810402a2 ffffffff819f8ac4
[  366.057492]  ffff88008f837933 ffff88008f8378c0 ffff88014f048340 0000000000000000
[  366.057495] Call Trace:
[  366.057502]  [<ffffffff815679b7>] dump_stack+0x46/0x58
[  366.057507]  [<ffffffff810402a2>] warn_slowpath_common+0x82/0xb0
[  366.057510]  [<ffffffff81040371>] warn_slowpath_fmt+0x41/0x50
[  366.057512]  [<ffffffff81161973>] ? proc_alloc_inum+0x43/0xb0
[  366.057514]  [<ffffffff81161aa8>] proc_register+0xc8/0x150
[  366.057517]  [<ffffffff81161c2d>] proc_mkdir_data+0x4d/0x70
[  366.057519]  [<ffffffff81161c7e>] proc_mkdir_mode+0xe/0x10
[  366.057735]  [<ffffffffa266f5da>] nv_register_procfs+0x3a/0x1b0 [nvidia]
[  366.057805]  [<ffffffffa2af1296>] nvidia_init_module+0x296/0x7ae [nvidia]
[  366.057873]  [<ffffffffa2af17c3>] ? nv_drm_init+0x15/0x15 [nvidia]
[  366.057941]  [<ffffffffa2af1849>] nvidia_frontend_init_module+0x86/0xb8 [nvidia]
[  366.058007]  [<ffffffffa2af17c3>] ? nv_drm_init+0x15/0x15 [nvidia]
[  366.058039]  [<ffffffff810002e2>] do_one_initcall+0xf2/0x140
[  366.058044]  [<ffffffff81061f21>] ? __blocking_notifier_call_chain+0x51/0x60
[  366.058048]  [<ffffffff8109199f>] load_module+0x189f/0x2190
[  366.058051]  [<ffffffff8108ed40>] ? mod_kobject_put+0x50/0x50
[  366.058054]  [<ffffffff8110b581>] ? kernel_read+0x41/0x60
[  366.058057]  [<ffffffff810923c6>] SyS_finit_module+0x86/0x90
[  366.058061]  [<ffffffff8156cae2>] system_call_fastpath+0x16/0x1b
[  366.058063] ---[ end trace 1f94271f8a9a3614 ]---
[  366.058120] NVRM: Can't find an IRQ for your NVIDIA card!
[  366.058122] NVRM: Please check your BIOS settings.
[  366.058123] NVRM: [Plug & Play OS] should be set to NO
[  366.058124] NVRM: [Assign IRQ to VGA] should be set to YES
[  366.058135] nvidia: probe of 0000:01:00.0 failed with error -1
[  366.058872] NVRM: The NVIDIA probe routine failed for 1 device(s).
[  366.058872] NVRM: None of the NVIDIA graphics adapters were initialized!
[  366.058873] [drm] Module unloaded
[  366.058985] NVRM: NVIDIA init module failed!
[  366.103280] ------------[ cut here ]------------
[  366.103291] WARNING: CPU: 0 PID: 21826 at fs/proc/generic.c:332 proc_register+0xc8/0x150()
[  366.103293] proc_dir_entry 'driver/nvidia' already registered
[  366.103294] Modules linked in: nvidia(PO+) snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec powernow_k8 snd_hwdep snd_pcm snd_page_alloc snd_timer k8temp snd r8169 soundcore fan mii freq_table thermal button processor
[  366.103310] CPU: 0 PID: 21826 Comm: modprobe Tainted: P        W  O 3.12.21-gentoo-r1 #7
[  366.103312] Hardware name: System manufacturer System Product Name/M2A-VM, BIOS ASUS M2A-VM ACPI BIOS Revision 2302 02/05/2009
[  366.103314]  0000000000000009 ffff88008f4d9b88 ffffffff815679b7 0000000000000007
[  366.103317]  ffff88008f4d9bd8 ffff88008f4d9bc8 ffffffff810402a2 ffffffff819f8ac4
[  366.103319]  ffff880090bc3f33 ffff880090bc3ec0 ffff88014f048340 0000000000000000
[  366.103322] Call Trace:
[  366.103329]  [<ffffffff815679b7>] dump_stack+0x46/0x58
[  366.103333]  [<ffffffff810402a2>] warn_slowpath_common+0x82/0xb0
[  366.103336]  [<ffffffff81040371>] warn_slowpath_fmt+0x41/0x50
[  366.103339]  [<ffffffff81161973>] ? proc_alloc_inum+0x43/0xb0
[  366.103341]  [<ffffffff81161aa8>] proc_register+0xc8/0x150
[  366.103344]  [<ffffffff81161c2d>] proc_mkdir_data+0x4d/0x70
[  366.103346]  [<ffffffff81161c7e>] proc_mkdir_mode+0xe/0x10
[  366.103560]  [<ffffffffa06c15da>] nv_register_procfs+0x3a/0x1b0 [nvidia]
[  366.103631]  [<ffffffffa0b43296>] nvidia_init_module+0x296/0x7ae [nvidia]
[  366.103697]  [<ffffffffa0b437c3>] ? nv_drm_init+0x15/0x15 [nvidia]
[  366.103763]  [<ffffffffa0b43849>] nvidia_frontend_init_module+0x86/0xb8 [nvidia]
[  366.103829]  [<ffffffffa0b437c3>] ? nv_drm_init+0x15/0x15 [nvidia]
[  366.103832]  [<ffffffff810002e2>] do_one_initcall+0xf2/0x140
[  366.103836]  [<ffffffff81061f21>] ? __blocking_notifier_call_chain+0x51/0x60
[  366.103840]  [<ffffffff8109199f>] load_module+0x189f/0x2190
[  366.103842]  [<ffffffff8108ed40>] ? mod_kobject_put+0x50/0x50
[  366.103845]  [<ffffffff8110b581>] ? kernel_read+0x41/0x60
[  366.103848]  [<ffffffff810923c6>] SyS_finit_module+0x86/0x90
[  366.103852]  [<ffffffff8156cae2>] system_call_fastpath+0x16/0x1b
[  366.103854] ---[ end trace 1f94271f8a9a3615 ]---
[  366.103911] NVRM: Can't find an IRQ for your NVIDIA card!
[  366.103912] NVRM: Please check your BIOS settings.
[  366.103914] NVRM: [Plug & Play OS] should be set to NO
[  366.103915] NVRM: [Assign IRQ to VGA] should be set to YES
[  366.103924] nvidia: probe of 0000:01:00.0 failed with error -1
[  366.104713] NVRM: The NVIDIA probe routine failed for 1 device(s).
[  366.104716] NVRM: None of the NVIDIA graphics adapters were initialized!
[  366.104717] [drm] Module unloaded
[  366.104829] NVRM: NVIDIA init module failed!
[  366.148756] ------------[ cut here ]------------
[  366.148767] WARNING: CPU: 0 PID: 21833 at fs/proc/generic.c:332 proc_register+0xc8/0x150()
[  366.148768] proc_dir_entry 'driver/nvidia' already registered
[  366.148770] Modules linked in: nvidia(PO+) snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec powernow_k8 snd_hwdep snd_pcm snd_page_alloc snd_timer k8temp snd r8169 soundcore fan mii freq_table thermal button processor
[  366.148785] CPU: 0 PID: 21833 Comm: modprobe Tainted: P        W  O 3.12.21-gentoo-r1 #7
[  366.148787] Hardware name: System manufacturer System Product Name/M2A-VM, BIOS ASUS M2A-VM ACPI BIOS Revision 2302 02/05/2009
[  366.148788]  0000000000000009 ffff88013e395b88 ffffffff815679b7 0000000000000007
[  366.148791]  ffff88013e395bd8 ffff88013e395bc8 ffffffff810402a2 ffffffff819f8ac4
[  366.148793]  ffff88008f8373b3 ffff88008f837340 ffff88014f048340 0000000000000000
[  366.148796] Call Trace:
[  366.148802]  [<ffffffff815679b7>] dump_stack+0x46/0x58
[  366.148806]  [<ffffffff810402a2>] warn_slowpath_common+0x82/0xb0
[  366.148809]  [<ffffffff81040371>] warn_slowpath_fmt+0x41/0x50
[  366.148812]  [<ffffffff81161973>] ? proc_alloc_inum+0x43/0xb0
[  366.148814]  [<ffffffff81161aa8>] proc_register+0xc8/0x150
[  366.148817]  [<ffffffff81161c2d>] proc_mkdir_data+0x4d/0x70
[  366.148819]  [<ffffffff81161c7e>] proc_mkdir_mode+0xe/0x10
[  366.149010]  [<ffffffffa116d5da>] nv_register_procfs+0x3a/0x1b0 [nvidia]
[  366.149127]  [<ffffffffa15ef296>] nvidia_init_module+0x296/0x7ae [nvidia]
[  366.149205]  [<ffffffffa15ef7c3>] ? nv_drm_init+0x15/0x15 [nvidia]
[  366.149281]  [<ffffffffa15ef849>] nvidia_frontend_init_module+0x86/0xb8 [nvidia]
[  366.149349]  [<ffffffffa15ef7c3>] ? nv_drm_init+0x15/0x15 [nvidia]
[  366.149360]  [<ffffffff810002e2>] do_one_initcall+0xf2/0x140
[  366.149363]  [<ffffffff81061f21>] ? __blocking_notifier_call_chain+0x51/0x60
[  366.149368]  [<ffffffff8109199f>] load_module+0x189f/0x2190
[  366.149370]  [<ffffffff8108ed40>] ? mod_kobject_put+0x50/0x50
[  366.149373]  [<ffffffff8110b581>] ? kernel_read+0x41/0x60
[  366.149376]  [<ffffffff810923c6>] SyS_finit_module+0x86/0x90
[  366.149380]  [<ffffffff8156cae2>] system_call_fastpath+0x16/0x1b
[  366.149382] ---[ end trace 1f94271f8a9a3616 ]---
[  366.149445] NVRM: Can't find an IRQ for your NVIDIA card!
[  366.149446] NVRM: Please check your BIOS settings.
[  366.149448] NVRM: [Plug & Play OS] should be set to NO
[  366.149449] NVRM: [Assign IRQ to VGA] should be set to YES
[  366.149459] nvidia: probe of 0000:01:00.0 failed with error -1
[  366.150214] NVRM: The NVIDIA probe routine failed for 1 device(s).
[  366.150217] NVRM: None of the NVIDIA graphics adapters were initialized!
[  366.150219] [drm] Module unloaded
[  366.150323] NVRM: NVIDIA init module failed!
[  366.194597] ------------[ cut here ]------------
[  366.194608] WARNING: CPU: 0 PID: 21840 at fs/proc/generic.c:332 proc_register+0xc8/0x150()
[  366.194610] proc_dir_entry 'driver/nvidia' already registered
[  366.194611] Modules linked in: nvidia(PO+) snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec powernow_k8 snd_hwdep snd_pcm snd_page_alloc snd_timer k8temp snd r8169 soundcore fan mii freq_table thermal button processor
[  366.194626] CPU: 0 PID: 21840 Comm: modprobe Tainted: P        W  O 3.12.21-gentoo-r1 #7
[  366.194628] Hardware name: System manufacturer System Product Name/M2A-VM, BIOS ASUS M2A-VM ACPI BIOS Revision 2302 02/05/2009
[  366.194630]  0000000000000009 ffff88008f8f5b88 ffffffff815679b7 0000000000000007
[  366.194633]  ffff88008f8f5bd8 ffff88008f8f5bc8 ffffffff810402a2 ffffffff819f8ac4
[  366.194635]  ffff88008f4d5b33 ffff88008f4d5ac0 ffff88014f048340 0000000000000000
[  366.194637] Call Trace:
[  366.194643]  [<ffffffff815679b7>] dump_stack+0x46/0x58
[  366.194648]  [<ffffffff810402a2>] warn_slowpath_common+0x82/0xb0
[  366.194651]  [<ffffffff81040371>] warn_slowpath_fmt+0x41/0x50
[  366.194654]  [<ffffffff81161973>] ? proc_alloc_inum+0x43/0xb0
[  366.194656]  [<ffffffff81161aa8>] proc_register+0xc8/0x150
[  366.194658]  [<ffffffff81161c2d>] proc_mkdir_data+0x4d/0x70
[  366.194661]  [<ffffffff81161c7e>] proc_mkdir_mode+0xe/0x10
[  366.194873]  [<ffffffffa1bee5da>] nv_register_procfs+0x3a/0x1b0 [nvidia]
[  366.194943]  [<ffffffffa2070296>] nvidia_init_module+0x296/0x7ae [nvidia]
[  366.195008]  [<ffffffffa20707c3>] ? nv_drm_init+0x15/0x15 [nvidia]
[  366.195105]  [<ffffffffa2070849>] nvidia_frontend_init_module+0x86/0xb8 [nvidia]
[  366.195184]  [<ffffffffa20707c3>] ? nv_drm_init+0x15/0x15 [nvidia]
[  366.195196]  [<ffffffff810002e2>] do_one_initcall+0xf2/0x140
[  366.195207]  [<ffffffff81061f21>] ? __blocking_notifier_call_chain+0x51/0x60
[  366.195212]  [<ffffffff8109199f>] load_module+0x189f/0x2190
[  366.195215]  [<ffffffff8108ed40>] ? mod_kobject_put+0x50/0x50
[  366.195217]  [<ffffffff8110b581>] ? kernel_read+0x41/0x60
[  366.195220]  [<ffffffff810923c6>] SyS_finit_module+0x86/0x90
[  366.195224]  [<ffffffff8156cae2>] system_call_fastpath+0x16/0x1b
[  366.195226] ---[ end trace 1f94271f8a9a3617 ]---
[  366.195287] NVRM: Can't find an IRQ for your NVIDIA card!
[  366.195289] NVRM: Please check your BIOS settings.
[  366.195290] NVRM: [Plug & Play OS] should be set to NO
[  366.195291] NVRM: [Assign IRQ to VGA] should be set to YES
[  366.195302] nvidia: probe of 0000:01:00.0 failed with error -1
[  366.196067] NVRM: The NVIDIA probe routine failed for 1 device(s).
[  366.196070] NVRM: None of the NVIDIA graphics adapters were initialized!
[  366.196071] [drm] Module unloaded
[  366.196175] NVRM: NVIDIA init module failed!
[  366.240193] ------------[ cut here ]------------
[  366.240203] WARNING: CPU: 0 PID: 21847 at fs/proc/generic.c:332 proc_register+0xc8/0x150()
[  366.240205] proc_dir_entry 'driver/nvidia' already registered
[  366.240207] Modules linked in: nvidia(PO+) snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec powernow_k8 snd_hwdep snd_pcm snd_page_alloc snd_timer k8temp snd r8169 soundcore fan mii freq_table thermal button processor
[  366.240222] CPU: 0 PID: 21847 Comm: modprobe Tainted: P        W  O 3.12.21-gentoo-r1 #7
[  366.240224] Hardware name: System manufacturer System Product Name/M2A-VM, BIOS ASUS M2A-VM ACPI BIOS Revision 2302 02/05/2009
[  366.240226]  0000000000000009 ffff88008f801b88 ffffffff815679b7 0000000000000007
[  366.240229]  ffff88008f801bd8 ffff88008f801bc8 ffffffff810402a2 ffffffff819f8ac4
[  366.240231]  ffff88008f837b33 ffff88008f837ac0 ffff88014f048340 0000000000000000
[  366.240234] Call Trace:
[  366.240241]  [<ffffffff815679b7>] dump_stack+0x46/0x58
[  366.240246]  [<ffffffff810402a2>] warn_slowpath_common+0x82/0xb0
[  366.240249]  [<ffffffff81040371>] warn_slowpath_fmt+0x41/0x50
[  366.240251]  [<ffffffff81161973>] ? proc_alloc_inum+0x43/0xb0
[  366.240254]  [<ffffffff81161aa8>] proc_register+0xc8/0x150
[  366.240256]  [<ffffffff81161c2d>] proc_mkdir_data+0x4d/0x70
[  366.240258]  [<ffffffff81161c7e>] proc_mkdir_mode+0xe/0x10
[  366.240469]  [<ffffffffa06c15da>] nv_register_procfs+0x3a/0x1b0 [nvidia]
[  366.240538]  [<ffffffffa0b43296>] nvidia_init_module+0x296/0x7ae [nvidia]
[  366.240604]  [<ffffffffa0b437c3>] ? nv_drm_init+0x15/0x15 [nvidia]
[  366.240670]  [<ffffffffa0b43849>] nvidia_frontend_init_module+0x86/0xb8 [nvidia]
[  366.240736]  [<ffffffffa0b437c3>] ? nv_drm_init+0x15/0x15 [nvidia]
[  366.240740]  [<ffffffff810002e2>] do_one_initcall+0xf2/0x140
[  366.240743]  [<ffffffff81061f21>] ? __blocking_notifier_call_chain+0x51/0x60
[  366.240747]  [<ffffffff8109199f>] load_module+0x189f/0x2190
[  366.240750]  [<ffffffff8108ed40>] ? mod_kobject_put+0x50/0x50
[  366.240753]  [<ffffffff8110b581>] ? kernel_read+0x41/0x60
[  366.240756]  [<ffffffff810923c6>] SyS_finit_module+0x86/0x90
[  366.240760]  [<ffffffff8156cae2>] system_call_fastpath+0x16/0x1b
[  366.240761] ---[ end trace 1f94271f8a9a3618 ]---
[  366.240820] NVRM: Can't find an IRQ for your NVIDIA card!
[  366.240822] NVRM: Please check your BIOS settings.
[  366.240824] NVRM: [Plug & Play OS] should be set to NO
[  366.240825] NVRM: [Assign IRQ to VGA] should be set to YES
[  366.240835] nvidia: probe of 0000:01:00.0 failed with error -1
[  366.241631] NVRM: The NVIDIA probe routine failed for 1 device(s).
[  366.241633] NVRM: None of the NVIDIA graphics adapters were initialized!
[  366.241635] [drm] Module unloaded
[  366.241749] NVRM: NVIDIA init module failed!
[  366.285254] ------------[ cut here ]------------
[  366.285264] WARNING: CPU: 0 PID: 21854 at fs/proc/generic.c:332 proc_register+0xc8/0x150()
[  366.285266] proc_dir_entry 'driver/nvidia' already registered
[  366.285267] Modules linked in: nvidia(PO+) snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec powernow_k8 snd_hwdep snd_pcm snd_page_alloc snd_timer k8temp snd r8169 soundcore fan mii freq_table thermal button processor
[  366.285281] CPU: 0 PID: 21854 Comm: modprobe Tainted: P        W  O 3.12.21-gentoo-r1 #7
[  366.285283] Hardware name: System manufacturer System Product Name/M2A-VM, BIOS ASUS M2A-VM ACPI BIOS Revision 2302 02/05/2009
[  366.285285]  0000000000000009 ffff88013e4f3b88 ffffffff815679b7 0000000000000007
[  366.285288]  ffff88013e4f3bd8 ffff88013e4f3bc8 ffffffff810402a2 ffffffff819f8ac4
[  366.285290]  ffff88008f4d5633 ffff88008f4d55c0 ffff88014f048340 0000000000000000
[  366.285292] Call Trace:
[  366.285299]  [<ffffffff815679b7>] dump_stack+0x46/0x58
[  366.285303]  [<ffffffff810402a2>] warn_slowpath_common+0x82/0xb0
[  366.285306]  [<ffffffff81040371>] warn_slowpath_fmt+0x41/0x50
[  366.285308]  [<ffffffff81161973>] ? proc_alloc_inum+0x43/0xb0
[  366.285311]  [<ffffffff81161aa8>] proc_register+0xc8/0x150
[  366.285313]  [<ffffffff81161c2d>] proc_mkdir_data+0x4d/0x70
[  366.285316]  [<ffffffff81161c7e>] proc_mkdir_mode+0xe/0x10
[  366.285530]  [<ffffffffa116d5da>] nv_register_procfs+0x3a/0x1b0 [nvidia]
[  366.285599]  [<ffffffffa15ef296>] nvidia_init_module+0x296/0x7ae [nvidia]
[  366.285665]  [<ffffffffa15ef7c3>] ? nv_drm_init+0x15/0x15 [nvidia]
[  366.285731]  [<ffffffffa15ef849>] nvidia_frontend_init_module+0x86/0xb8 [nvidia]
[  366.285797]  [<ffffffffa15ef7c3>] ? nv_drm_init+0x15/0x15 [nvidia]
[  366.285800]  [<ffffffff810002e2>] do_one_initcall+0xf2/0x140
[  366.285804]  [<ffffffff81061f21>] ? __blocking_notifier_call_chain+0x51/0x60
[  366.285808]  [<ffffffff8109199f>] load_module+0x189f/0x2190
[  366.285810]  [<ffffffff8108ed40>] ? mod_kobject_put+0x50/0x50
[  366.285813]  [<ffffffff8110b581>] ? kernel_read+0x41/0x60
[  366.285816]  [<ffffffff810923c6>] SyS_finit_module+0x86/0x90
[  366.285820]  [<ffffffff8156cae2>] system_call_fastpath+0x16/0x1b
[  366.285822] ---[ end trace 1f94271f8a9a3619 ]---
[  366.285879] NVRM: Can't find an IRQ for your NVIDIA card!
[  366.285881] NVRM: Please check your BIOS settings.
[  366.285883] NVRM: [Plug & Play OS] should be set to NO
[  366.285884] NVRM: [Assign IRQ to VGA] should be set to YES
[  366.285894] nvidia: probe of 0000:01:00.0 failed with error -1
[  366.286110] NVRM: The NVIDIA probe routine failed for 1 device(s).
[  366.286112] NVRM: None of the NVIDIA graphics adapters were initialized!
[  366.286114] [drm] Module unloaded
[  366.286226] NVRM: NVIDIA init module failed!


I don't know what the issue is.. I think I only changed performance settings from adaptive to maximum in nvidia-settings
Plug & play support in BIOS changed from NO to YES and back...doesn't help. Is mainboard broken ?

any hints whatsever are most welcome. thanks in advance!!

EDIT:
Either downgrade to nvidia-drivers-334.21-r3 and/or Intel microcode loading = M seem to have fixed it
Back to top
View user's profile Send private message
krinn
Watchman
Watchman


Joined: 02 May 2003
Posts: 6960

PostPosted: Sun Jun 22, 2014 1:07 pm    Post subject: Re: Problem with nvidia Reply with quote

For my own knowledge: as you expose the warn_slowpath kind of errors, are you using bumblebee?
Back to top
View user's profile Send private message
Ty[L]eR
Apprentice
Apprentice


Joined: 18 May 2004
Posts: 190
Location: it

PostPosted: Mon Jun 23, 2014 7:33 am    Post subject: Reply with quote

Same here and I'm running a desktop gtx 460, it doesn't happen if i blacklist nvidia from autoload and let X loading it after the initial boot.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum