Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Installation Gentoo sur lapotop UEFI!!!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
HazeC5
Apprentice
Apprentice


Joined: 16 May 2007
Posts: 227
Location: Devant l'écran

PostPosted: Sat Jun 21, 2014 4:21 pm    Post subject: Installation Gentoo sur lapotop UEFI!!! Reply with quote

Salut la communauté, j'espère que tout va pour le mieux pour la majorité d'entre vous!

Voilà ce qui m'amène. J'ai acquis un PC portable Acer Asprie V5-471, d'occasion avec windows 8 installé.

Alors je comptais virer ce windows pour y mettre Gentoo, seulement voilà, rien que pour booter sur un liveCD je dois désactiver "UEFI" dans le bios et activer "legacy mode".

Seulement voilà, après quelques recherches il semblerai que ce soit compliqué d'installer un OS avec ce fichu UEFI. Au départ je comptais installer Gentoo sur 1 clé USB 3.0, et compiler en tmpfs...
Mais à l'instant j'ai pu re-dimensionner la partition principale où windows 8 est installer, je vais donc pouvoir y mettre Gentoo.
Cependant j'aimerai éviter d'avoir à toujours permuter les options relatives à UEFI dans le BIOS.
Existe t-il une méthode pour y arriver ? C'est à dire booter sur Gentoo tout an ayant UEFI activé.
Si oui laquelle?

Ou auriez vous des howto dédiés à ce problème en particulier?

Merci d'avance et bon week-end! :wink:
_________________
<--Pentium Quad-Core Q8400 -- Ram 6Go -- AsusTek P5QL-VM-- Intel G 43/45 HD --Son 5.1 Logitech -->
<-Enlightenment 17-svn Kernel CK-sources-3.7.10->
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 2916
Location: Paris

PostPosted: Sat Jun 21, 2014 6:27 pm    Post subject: Reply with quote

Si je ne me plante pas, c'est pas tant UEFI que la fonctionnalité Secure Boot de UEFI qui t'empêche de booter Gentoo. Puisqye le sysrescd peut être booté en UEFI par ex.
_________________
-PC: 2500K/P8Z68V, 8Go, R9-290, M4 256Go, MX100 512Go
-Home servers (hardened): µ-serv Gen8 G1610T ; NF9D-2700, 4Go ; [DS61, i3 2100T, 16Go ; µ-serv N40L]
-Réseau: ERL-3 + 3x switches GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
USTruck
Guru
Guru


Joined: 21 Aug 2005
Posts: 423
Location: La Louviere (Belgique)

PostPosted: Sat Jun 21, 2014 7:23 pm    Post subject: Reply with quote

Bonsoir,

https://wiki.gentoo.org/wiki/UEFI_Gentoo_AMD64_Quick_Install_Guide

Une recherche sur le wiki pourrai bien t'aider, tout en anglais malheureusement .....
Back to top
View user's profile Send private message
HazeC5
Apprentice
Apprentice


Joined: 16 May 2007
Posts: 227
Location: Devant l'écran

PostPosted: Sat Jun 21, 2014 9:12 pm    Post subject: Reply with quote

Re-Salut :!:

El_Goretto Dans mon BIOS justement l'option "secure_boot" est toujours grisée, aussi bien lorsque UEFI est activé que lorsque c'est "legacy mode" qui l'est.
Alors j'ai tenté plusieurs manipulations pour voir si cette option "secure_boot" se dégrise, or non, il n'y a rien à faire elle reste grisée quoi que je fasse.

Merci pour le lien USTruck je vais regarder ça à la loupe, l'anglais ce n'est pas grave je maîtrise, à part quelques mots très techniques dans l'ensemble je me débrouille très bien.

:arrow: Si d'autres idées vous viennent, n'hésitez pas, svp! Merci d'avance.

Merci @tous ,et bon week-end :!:
_________________
<--Pentium Quad-Core Q8400 -- Ram 6Go -- AsusTek P5QL-VM-- Intel G 43/45 HD --Son 5.1 Logitech -->
<-Enlightenment 17-svn Kernel CK-sources-3.7.10->
Back to top
View user's profile Send private message
El_Goretto
Moderator
Moderator


Joined: 29 May 2004
Posts: 2916
Location: Paris

PostPosted: Mon Jun 23, 2014 7:41 pm    Post subject: Reply with quote

Certains fournisseurs de BIOS embarque des "cheat codes" plus ou moins secret, comme gigabyte et son "ctl+F1" qui affiche souvent 1 ou 2 menus en plus. Enfin... çà c'était "avant", en BIOS/UEFI avec affichage texte type BIOS, et non en UEFI graphique où je ne sais pas si c'est encore valide comme manip'.
_________________
-PC: 2500K/P8Z68V, 8Go, R9-290, M4 256Go, MX100 512Go
-Home servers (hardened): µ-serv Gen8 G1610T ; NF9D-2700, 4Go ; [DS61, i3 2100T, 16Go ; µ-serv N40L]
-Réseau: ERL-3 + 3x switches GS108Tv2
-NAS: RN312
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4931

PostPosted: Tue Jun 24, 2014 10:57 am    Post subject: Reply with quote

Jamais eu "la chance" de tomber sur un bios aussi restrictif.

Ça doit être faisable vu que ce gus a réussit: http://notebookblog.cz/ostatni/software/linux-na-acer-aspire-v5-471-linux-on-acer-aspire-v5-471/
Contacte le si besoin, peut-être n'est ce qu'une question de version de bios.
Back to top
View user's profile Send private message
HazeC5
Apprentice
Apprentice


Joined: 16 May 2007
Posts: 227
Location: Devant l'écran

PostPosted: Wed Jun 25, 2014 7:35 am    Post subject: Reply with quote

Salut.

Je suis toujours dans l'attente de l'arrivée d'une commande, elle ne saurait tarder je pense, plus qu'une question d'un ou 2 jours.

Si j'ai bien suivi et compris la page wiki d'USTruck on dirait bien que grâce à cette manipulation, du coup on peut se passer d'un boot loader tel que grub ou lilo, et c'est exactement ce que j'ai lu sur ce forum, où un utilisateur dit justement qu'il existe une méthode permettant de se passer de grub/lilo!

J'en conclu que c'est de la méthode du wiki dont il fait allusion (faudrait que je retrouve le post, mais là je dois partir, et de mémoire il ne donnait pas plus de précision grâce à ce qui est écrit sur la page wiki ci-dessus, qu'en pensez vous?

Dès que je reçois ma commande je me lance sur l'installation de Gentoo,,ça risque d'être sportif et/ou un peu prise de tête, mais étant donné que d'autres y sont arrivés il n'y a pas de raison que je n'y arrive pas à mon tout :!: :wink:

Je repasse dès que je débuterai l'installation, et je ne manquerai pas de rajouter des compléments d'infos si besoin.
Merci @tous, et bonne journée :wink:
_________________
<--Pentium Quad-Core Q8400 -- Ram 6Go -- AsusTek P5QL-VM-- Intel G 43/45 HD --Son 5.1 Logitech -->
<-Enlightenment 17-svn Kernel CK-sources-3.7.10->
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 5844
Location: ~Brussels - Belgique

PostPosted: Wed Jun 25, 2014 7:54 am    Post subject: Reply with quote

Hello HazeC5,

En effet, pour du "single boot", il suffit de compiler le kernel en mode EFI, et de le renommer "bootx64.efi" et le placer dans une partition EFI, dans boot/efi
(ou quelque chose du genre, je n'ai pas mon portable EFI sous la main à l'instant).

Si l'UEFI le supporte, il y a aussi moyen d'écrire une entrée dans le menu UEFI, mais ça n'a pas fonctionné pour moi.

Par contre, pour un UEFI sécurisé, c'est un peu plus compliqué, il y a un howto de Greg KH.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
HazeC5
Apprentice
Apprentice


Joined: 16 May 2007
Posts: 227
Location: Devant l'écran

PostPosted: Sun Jun 29, 2014 9:57 pm    Post subject: Reply with quote

Salut. :wink:

Bien je vais commencer l'installation de gentoo sur une clé USB 3.0 mais spécialement pour le laptop et en UEFI donc.

Pour commencer la clé usb 32G en 3.0 était reconnue mais il l'a déconnectée de suite, alors que la même (marque et modèle) mais en 16G 3.0 était reconnue sans problème de suite. Après l'avoir branché sur ce PC et vu qu'elle était ok, je l'ai donc branchée sur un port 2.0 du laptop et là elle était reconnue, j'ai donc retesté sur le port 3.0 et cette fois c'est ok elle est détectée correctement.

Cette installation commence bien...Surtout qu'avec le liveCD system-rescueCD 4.2.0 il utilise parted et non fdisk pour le partitionnement, or je ne connais que fdisk. Enfin je vais finir par y arriver.

[ÉDIT] Autant pour moi, fdisk est bien présent sur ce liveCD, j'avais du faire une erreur pour ne pas le trouver avant... :oops: [/ÉDIT]

Question:
- Puisque j'installe Gentoo sur une clé usb et la swap sur 1 autre clé usb spécialement dédiée à cet usage, ne vaut-il pas mieux que dans le fstab j'utilise les UUID plutôt que les /dev/sd[b-c-d]x ?
Perso ça me semble plus sur pour être certain que ça boot toujours quelque soit le port et l'ordre dans lequel je branche les clés.

Sinon XavierMiller si tu fais mention du "secure_boot" pour l'UEFI sécurisé, le mien est grisé quoi que je fasse, donc je ne pense pas être concerné.

L'entrée dans le menu UEFI dont tu parles, est-ce la dernière partie de cette page du wiki ? Ou c'est encore autre chose ?

Merci @vous :wink:

Bonne journée/soirée :!:
_________________
<--Pentium Quad-Core Q8400 -- Ram 6Go -- AsusTek P5QL-VM-- Intel G 43/45 HD --Son 5.1 Logitech -->
<-Enlightenment 17-svn Kernel CK-sources-3.7.10->
Back to top
View user's profile Send private message
HazeC5
Apprentice
Apprentice


Joined: 16 May 2007
Posts: 227
Location: Devant l'écran

PostPosted: Sun Jun 29, 2014 10:32 pm    Post subject: Reply with quote

Bon j'suis dégoûté, la clé de 32G était reconnue, j'ai pu y crée les partitions mais maintenant sur le port 3.0 plus moyen qu'il la reconnaisse...Alors que sur les ports 2.0 ça passe...

Je comprends pas pourquoi il fait son difficile...D'autant qu'avec la clé de 16G ça passe à chaque fois, mais je trouve que ça fait un peu léger pour installer Gentoo dessus !

J'arrête pour ce soir ça m'a mis les nerfs cette histoire. :cry: :twisted:

Bonne soirée.
_________________
<--Pentium Quad-Core Q8400 -- Ram 6Go -- AsusTek P5QL-VM-- Intel G 43/45 HD --Son 5.1 Logitech -->
<-Enlightenment 17-svn Kernel CK-sources-3.7.10->
Back to top
View user's profile Send private message
Mika15
n00b
n00b


Joined: 09 Dec 2010
Posts: 25
Location: Barcelona, Spain

PostPosted: Wed Jul 02, 2014 9:25 am    Post subject: Reply with quote

Bonjour Haze C5,

Moi j'ai un Dell avec UEFI activé Windows 8 et Gentoo installé.

Pour installer la Gentoo je suis passé par une Ubuntu USB (l'UEFI fonctionne avec Ubuntu) et pour le boot j'ai utilisé rEFInd (http://www.rodsbooks.com/refind/) en l'installant et le configurant depuis Windows.

Ça fonctionne parfaitement, je n'ai plus de Grub, c'est rEFInd qui me sert de boot loader et franchement je suis très content de la solution.

Si tu as besoin de plus d'infos, n'hésite pas.

Cordialement.
Back to top
View user's profile Send private message
kwenspc
Advocate
Advocate


Joined: 21 Sep 2003
Posts: 4931

PostPosted: Wed Jul 09, 2014 10:21 am    Post subject: Reply with quote

Mika15 wrote:

Moi j'ai un Dell avec UEFI activé Windows 8 et Gentoo installé.

UEFI _avec_ SecureBoot? Parce qu'UEFI n'est pas un problème si le SecureBoot est inhibé.
Back to top
View user's profile Send private message
Gaug
Guru
Guru


Joined: 30 Oct 2003
Posts: 376
Location: Longueuil,Québec,Canada

PostPosted: Wed Jul 16, 2014 5:57 pm    Post subject: Reply with quote

J'ai lu dans un post qu'il fallait créer un mot de passe administrateur dans le bios pour pouvoir désactiver le secure boot dans se portable
http://community.acer.com/t5/Windows-Tablets/w510-Why-is-Secure-Boot/m-p/10445#M817

Et regarde se wiki pour l'installation uefi avec grub2

http://wiki.gentoo.org/wiki/GRUB2
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum