Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Dualhead mit Nouveau will nicht [solved]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
slick
Bodhisattva
Bodhisattva


Joined: 20 Apr 2003
Posts: 3490

PostPosted: Sat Jun 21, 2014 12:50 pm    Post subject: Dualhead mit Nouveau will nicht [solved] Reply with quote

Ich benötige etwas Hilfe mit Nouveau und Dualhead. Ich habe mich an http://wiki.gentoo.org/wiki/Xorg/Multihead orientiert und das wie folgt eingerichtet:

/etc/X11/xorg.conf.d/41-monitor-DVI.conf
Code:
Section "Monitor"
   Identifier     "DVI"
EndSection



/etc/X11/xorg.conf.d/41-monitor-VGA.conf
Code:
Section "Monitor"
   Identifier     "VGA"
   Option         "RightOf"   "DVI"
EndSection


/etc/X11/xorg.conf.d/50-video.conf
Code:
Section "Device"
   Identifier   "Card0"
   Driver      "nouveau"
   Option      "Monitor-DVI-I-1"   "DVI"
   Option      "Monitor-VGA-1"      "VGA"
EndSection


Gemäß meinem Verständnis des Wiki Artikel sollte das reichen. Ich habe jedoch weiterhin das gleiche Bild auf beiden Bildschirmen. Was mache ich falsch?

Hier noch: xrandr -q
Code:

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
DVI-I-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 477mm x 268mm
   1920x1080      60.0*+
   1680x1050      60.0 
   1280x1024      75.0     60.0 
   1440x900       59.9 
   1280x960       60.0 
   1152x864       75.0 
   1024x768       75.1     70.1     60.0 
   832x624        74.6 
   800x600        72.2     75.0     60.3     56.2 
   640x480        75.0     72.8     66.7     60.0 
   720x400        70.1 
VGA-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 477mm x 268mm
   1920x1080      60.0*+
   1680x1050      60.0 
   1280x1024      75.0     60.0 
   1440x900       59.9 
   1280x960       60.0 
   1152x864       75.0 
   1024x768       75.1     70.1     60.0 
   832x624        74.6 
   800x600        72.2     75.0     60.3     56.2 
   640x480        75.0     72.8     66.7     60.0 
   720x400        70.1 
HDMI-1 disconnected (normal left inverted right x axis y axis)


Der manuelle Befehl
Code:
xrandr --output VGA-1 --right-of DVI-I-1

erzeugt die Ausgabe so wie ich sie haben möchte.


Last edited by slick on Mon Jun 23, 2014 2:30 pm; edited 1 time in total
Back to top
View user's profile Send private message
slick
Bodhisattva
Bodhisattva


Joined: 20 Apr 2003
Posts: 3490

PostPosted: Mon Jun 23, 2014 2:30 pm    Post subject: Reply with quote

Gelöst. Problem war nicht die Konfiguration von Xorg sondern eine alte Display Konfiguration von XFCE.

Folgende Xorg Konfiguration war ausreichend:

/etc/X11/xorg.conf.d/dualhead.conf
Code:
Section "Monitor"
    Identifier  "DVI-I-1"
    Option      "Primary" "true"
EndSection

Section "Monitor"
    Identifier  "VGA-1"
    Option      "RightOf" "DVI-I-1"
EndSection


Jedoch merkt sich XFCE z.T. alte Bildschirmeinstellungen und stellt den Bildschirm trotz geänderter xorg.conf Einstellungen nicht wie gewünscht dar. Die XFCE Einstellungen sollte man daher vor Tests/Anpassungen der Xorg-Konfiguration unter Einstellungen -> Einstellungseditor -> (Kanal) display (Rechtsklick) -> Zurücksetzen zurücksetzen.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum