Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ERROR: wicd failed to start
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
windex
n00b
n00b


Joined: 09 Dec 2012
Posts: 70

PostPosted: Mon Jun 16, 2014 8:42 pm    Post subject: ERROR: wicd failed to start Reply with quote

Decided to flee LXDE in favor of the comparative shelter of KDE. Fixed a couple of problems related to xinitrc, etc.

Now we're back to wicd – it compiles and installs, but I can't get the service to start

etc/init.d/wicd -d -v start
http://codepad.org/mBCKkS7A


* ERROR: wicd failed to start
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Tue Jun 17, 2014 1:38 am    Post subject: Reply with quote

windex ... please check the following is enabled:

Code:
# grep CFG80211_WEXT /usr/src/linux/.config

HTH & best ... khay
Back to top
View user's profile Send private message
windex
n00b
n00b


Joined: 09 Dec 2012
Posts: 70

PostPosted: Thu Jun 19, 2014 9:59 pm    Post subject: Reply with quote

khayyam wrote:
windex ... please check the following is enabled:

Code:
# grep CFG80211_WEXT /usr/src/linux/.config

HTH & best ... khay


Wow! You were right!

Added the flag to the kernel. Recompiled. Copied the new kernel over. Reconfigured grub. Rebooted. Re-emerged wicd. Next restarted wicd

Code:

# service wicd restart
 * Stopping wicd daemon and closing connections ...                                                                                                             [ ok ]
 * Starting wicd daemon ...


And it worked for about an hour. Had to power-down the laptop. When I rebooted, the wicd (kde-based) applet is still correctly managing my wired NIC, but it no longer shows
wireless activity, and the wired controls are not working - clicking the wired icon does not reconnect. The only thing that appears to work is the network traffic graph.

Config files here:
http://codepad.org/QBTLUO1r
Back to top
View user's profile Send private message
khayyam
Watchman
Watchman


Joined: 07 Jun 2012
Posts: 6228
Location: Room 101

PostPosted: Thu Jun 19, 2014 10:33 pm    Post subject: Reply with quote

windex wrote:
Wow! You were right!

windex ... why so surprised? :) ... anyhow, can't help with it failing as wicd is not something I use, sorry.

best ... khay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum