Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
kwin compositing suddenly stopped working
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Dragonlord
Guru
Guru


Joined: 22 Aug 2004
Posts: 400
Location: Switzerland

PostPosted: Mon Jun 16, 2014 5:22 pm    Post subject: kwin compositing suddenly stopped working Reply with quote

I've updated two days ago my system (which means an update somewhere from up to 1 week ago) and KWin suddenly stopped working. It starts up without compositing and claims to have disabled it because OpenGL detection failed. I don't know where the problem is. I re-merged ati-driver, xorg-server and kwin but to no avail.

Anybody has a similar problem since a couple of days and an idea what could be the cause?

- ati-driver stayed the same
- kernel stayed the same

What this change is XOrg (I've seen the update flash by). Could there be a problem with XOrg or MESA?

Anything that's useful trying to re-emerge?

EDIT:
Code:
x11-base/xorg-server-1.15.0:0/1.15.0 (now after update)
x11-drivers/ati-drivers-14.4_p1 (stayed the same)
3.10.7-gentoo-r1 kernel (stayed the same)
kde-base/kwin-4.11.9 (no idea if this updated... I guess not)


EDIT:
Could this be somehow related to it? From the XOrg logs:

Code:
[  4768.164] (EE) AIGLX error: failed to open /usr/X11R6/lib64/modules/dri/fglrx_dri.so, error[/usr/X11R6/lib64/modules/dri/fglrx_dri.so: cannot open shared object file:
No such file or directory]




EDIT:
Managed to retrieve the old XOrg log from during the crash. It looks like this:

Code:
[  4766.963] (EE)
[  4766.963] (EE) Backtrace:
[  4766.987] (EE) 0: /usr/bin/X (xorg_backtrace+0x42) [0x58f152]
[  4766.987] (EE) 1: /usr/bin/X (0x400000+0x192dc9) [0x592dc9]
[  4766.987] (EE) 2: /lib64/libpthread.so.0 (0x7fe86e668000+0x109a0) [0x7fe86e6789a0]
[  4766.987] (EE) 3: /lib64/libc.so.6 (0x7fe86d2b8000+0x3f8f3) [0x7fe86d2f78f3]
[  4766.987] (EE) 4: /usr/lib64/xorg/modules/extensions/libglx.so (0x7fe86bc68000+0x44652) [0x7fe86bcac652]
[  4766.987] (EE) 5: /usr/lib64/xorg/modules/extensions/libglx.so (0x7fe86bc68000+0x1f1c7) [0x7fe86bc871c7]
[  4766.987] (EE) 6: /usr/bin/X (0x400000+0x3d8d6) [0x43d8d6]
[  4766.987] (EE) 7: /usr/bin/X (0x400000+0x4156d) [0x44156d]
[  4766.987] (EE) 8: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x7fe86d2dcbc5]
[  4766.987] (EE) 9: /usr/bin/X (0x400000+0x2c5e1) [0x42c5e1]
[  4766.987] (EE)
[  4766.987] (EE) Segmentation fault at address 0x0
[  4766.987] (EE)
Fatal server error:
[  4766.987] (EE) Caught signal 11 (Segmentation fault). Server aborting
[  4766.987] (EE)
[  4766.987] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
 for help.
[  4766.987] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[  4766.987] (EE)
[  4766.987] (II) AIGLX: Suspending AIGLX clients for VT switch
[  4766.989] (II) fglrx(0): Backup framebuffer data.
[  4767.043] (II) fglrx(0): Backup complete.
[  4767.208] (EE) Server terminated with error (1). Closing log file.

_________________
Leader and Head Programmer: Epsylon, Drag[en]gine and others
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum