Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
amarok fails to start - DBUS timeout
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
lyallp
Veteran
Veteran


Joined: 15 Jul 2004
Posts: 1301
Location: Adelaide/Australia

PostPosted: Sat Feb 06, 2016 7:10 am    Post subject: amarok fails to start - DBUS timeout Reply with quote

I have recently started to find Amarok refusing to start.

I initially thought it was because I upgraded my kernel to 4.1.15-r1 but I rebuilt 4.1.12 and booted it and amarok still refuses to start.

I tried emerging amarok with emptytree, basically building absolutely everything that was required to run amarok.

Still no good.

I use Fluxbox as my Window Manager, so I don't have a full blown KDE environment for Amarok to start in, but that has never been a problem till the last few days.

Suggestions welcomed.

Detailed info follows :-

Code:
$ amarok --debug
amarok: BEGIN: App::App()
amarok:   BEGIN: void App::continueInit()
amarok:     BEGIN: EngineController::EngineController()
amarok:     END__: EngineController::EngineController() [Took: 0s]
amarok:     BEGIN: void EngineController::initializePhonon()
KCrash: Application 'amarok' crashing...
KCrash: Attempting to start  from kdeinit
KCrash: Connect sock_file=/home/lyall/.kde4/socket-lyalls-pc/kdeinit4__0
KCrash: Attempting to start  directly
unnamed app(6334): Communication problem with  "amarok" , it probably crashed.
Error message was:  "org.freedesktop.DBus.Error.NoReply" : " "Message did not receive a reply (timeout by message bus)" "

KCrash failed to exec(), errno = 2


I did an 'strace amarok --debug' and I think that the following output segment seems relevant
Code:

socket(PF_LOCAL, SOCK_STREAM|SOCK_CLOEXEC, 0) = 4
connect(4, {sa_family=AF_LOCAL, sun_path=@"/tmp/dbus-HxFSEcGQK2"}, 23) = 0
fcntl(4, F_GETFL)                       = 0x2 (flags O_RDWR)
fcntl(4, F_SETFL, O_RDWR|O_NONBLOCK)    = 0
geteuid()                               = 1000
getsockname(4, {sa_family=AF_LOCAL, NULL}, [2]) = 0
poll([{fd=4, events=POLLOUT}], 1, 0)    = 1 ([{fd=4, revents=POLLOUT}])
sendto(4, "\0", 1, MSG_NOSIGNAL, NULL, 0) = 1
sendto(4, "AUTH EXTERNAL 31303030\r\n", 24, MSG_NOSIGNAL, NULL, 0) = 24
poll([{fd=4, events=POLLIN}], 1, 4294967295) = 1 ([{fd=4, revents=POLLIN}])
read(4, "OK 3238714f88c702433f1e131256b59"..., 2048) = 37
poll([{fd=4, events=POLLOUT}], 1, 4294967295) = 1 ([{fd=4, revents=POLLOUT}])
sendto(4, "NEGOTIATE_UNIX_FD\r\n", 19, MSG_NOSIGNAL, NULL, 0) = 19
poll([{fd=4, events=POLLIN}], 1, 4294967295) = 1 ([{fd=4, revents=POLLIN}])
read(4, "AGREE_UNIX_FD\r\n", 2048)      = 15
poll([{fd=4, events=POLLOUT}], 1, 4294967295) = 1 ([{fd=4, revents=POLLOUT}])
sendto(4, "BEGIN\r\n", 7, MSG_NOSIGNAL, NULL, 0) = 7
poll([{fd=4, events=POLLIN|POLLOUT}], 1, 4294967295) = 1 ([{fd=4, revents=POLLOUT}])
sendmsg(4, {msg_name(0)=NULL, msg_iov(2)=[{"l\1\0\1\0\0\0\0\1\0\0\0n\0\0\0\1\1o\0\25\0\0\0/org/fre"..., 128}, {"", 0}], msg_controllen=0, msg_flags=0}, MSG_NOSIGNAL) = 128
poll([{fd=4, events=POLLIN}], 1, 25000) = 1 ([{fd=4, revents=POLLIN}])
recvmsg(4, {msg_name(0)=NULL, msg_iov(1)=[{"l\2\1\1\n\0\0\0\1\0\0\0=\0\0\0\6\1s\0\5\0\0\0:1.42\0\0\0"..., 2048}], msg_controllen=0, msg_flags=MSG_CMSG_CLOEXEC}, MSG_CMSG_CLOEXEC) = 260
recvmsg(4, 0x7ffd449ebbe0, MSG_CMSG_CLOEXEC) = -1 EAGAIN (Resource temporarily unavailable)
sendmsg(4, {msg_name(0)=NULL, msg_iov(2)=[{"l\1\0\1\23\0\0\0\2\0\0\0\177\0\0\0\1\1o\0\25\0\0\0/org/fre"..., 144}, {"\16\0\0\0org.kde.amarok\0", 19}], msg_controllen=0, msg_flags=0}, MSG_NOSIGNAL) = 163
poll([{fd=4, events=POLLIN}], 1, 25000) = 1 ([{fd=4, revents=POLLIN}])
recvmsg(4, {msg_name(0)=NULL, msg_iov(1)=[{"l\2\1\1\4\0\0\0\3\0\0\0=\0\0\0\6\1s\0\5\0\0\0:1.42\0\0\0"..., 2048}], msg_controllen=0, msg_flags=MSG_CMSG_CLOEXEC}, MSG_CMSG_CLOEXEC) = 84
recvmsg(4, 0x7ffd449eb8b0, MSG_CMSG_CLOEXEC) = -1 EAGAIN (Resource temporarily unavailable)
sendmsg(4, {msg_name(0)=NULL, msg_iov(2)=[{"l\1\0\0015\0\0\0\3\0\0\0\202\0\0\0\1\1o\0\20\0\0\0/MainApp"..., 152}, {"\0\0\0\0-\0\0\0\0\0\0\v/home/lyall\0\0\0\1\377\377\377\377\0"..., 53}], msg_controllen=0, msg_flags=0}, MSG_NOSIGNAL) = 205
poll([{fd=4, events=POLLIN}], 1, 4294967295amarok: BEGIN: App::App()
amarok:   BEGIN: void App::continueInit()
amarok:     BEGIN: EngineController::EngineController()
amarok:     END__: EngineController::EngineController() [Took: 0.001s]
amarok:     BEGIN: void EngineController::initializePhonon()
) = 1 ([{fd=4, revents=POLLIN}])
recvmsg(4, {msg_name(0)=NULL, msg_iov(1)=[{"l\3\1\1=\0\0\0\4\0\0\0n\0\0\0\5\1u\0\3\0\0\0\4\1s\0\"\0\0\0"..., 2048}], msg_controllen=0, msg_flags=MSG_CMSG_CLOEXEC}, MSG_CMSG_CLOEXEC) = 189
recvmsg(4, 0x7ffd449ebae0, MSG_CMSG_CLOEXEC) = -1 EAGAIN (Resource temporarily unavailable)
umask(0)                                = 022
umask(022)                              = 0
stat(".", {st_mode=S_IFDIR|0755, st_size=8192, ...}) = 0
getcwd("/home/lyall", 4096)             = 12
stat("/home/lyall/.krcdirs", 0x7ffd449ea7c0) = -1 ENOENT (No such file or directory)
readlink("/proc/self/exe", "/usr/bin/amarok", 4096) = 15
getuid()                                = 1000


Code:
lyall@lyalls-pc ~
$ emerge --info

Portage 2.2.26 (python 3.4.3-final-0, default/linux/amd64/13.0/desktop, gcc-4.9.3, glibc-2.21-r1, 4.1.12-gentoo x86_64)
=================================================================
System uname: Linux-4.1.12-gentoo-x86_64-Intel-R-_Core-TM-2_Quad_CPU_Q9400_@_2.66GHz-with-gentoo-2.2
KiB Mem:     8179000 total,   5486288 free
KiB Swap:    8388600 total,   8388600 free
Timestamp of repository gentoo: Mon, 01 Feb 2016 00:45:01 +0000
sh bash 4.3_p42-r1
ld GNU ld (Gentoo 2.25.1 p1.1) 2.25.1
app-shells/bash:          4.3_p42-r1::gentoo
dev-java/java-config:     2.2.0::gentoo
dev-lang/perl:            5.20.2::gentoo
dev-lang/python:          2.7.10-r1::gentoo, 3.3.5-r2::gentoo, 3.4.3-r1::gentoo
dev-util/cmake:           3.3.1-r1::gentoo
dev-util/pkgconfig:       0.28-r2::gentoo
sys-apps/baselayout:      2.2::gentoo
sys-apps/openrc:          0.19.1::gentoo
sys-apps/sandbox:         2.10-r1::gentoo
sys-devel/autoconf:       2.13::gentoo, 2.69::gentoo
sys-devel/automake:       1.11.6-r1::gentoo, 1.14.1::gentoo, 1.15::gentoo
sys-devel/binutils:       2.25.1-r1::gentoo
sys-devel/gcc:            4.9.3::gentoo
sys-devel/gcc-config:     1.7.3::gentoo
sys-devel/libtool:        2.4.6::gentoo
sys-devel/make:           4.1-r1::gentoo
sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers)
sys-libs/glibc:           2.21-r1::gentoo
Repositories:

gentoo
    location: /portage/gentoo
    sync-type: rsync
    sync-uri: rsync://mirror.internode.on.net/gentoo-portage
    priority: -1000

java
    location: /portage/local/layman/java
    masters: gentoo
    priority: 0

sunrise
    location: /portage/local/layman/sunrise
    masters: gentoo
    priority: 1

voyageur
    location: /portage/local/layman/voyageur
    masters: gentoo
    priority: 2

gamerlay
    location: /portage/local/layman/gamerlay
    masters: gentoo
    priority: 3

sabayon-distro
    location: /portage/local/layman/sabayon-distro
    masters: gentoo
    priority: 4

local_repo
    location: /portage/local
    priority: 5

ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -mtune=native -march=native -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /lib/udev/rules.d /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt /var/lib/hsqldb /var/lib/sabnzbd/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -mtune=native -march=native -pipe"
DISTDIR="/portage/gentoo/distfiles"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs collision-protect config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://mirror.internode.on.net/pub/gentoo ftp://mirror.pacific.net.au/linux/Gentoo"
LANG="en_AU.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j8"
PKGDIR="/portage/gentoo/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/tmp"
USE="X a52 aac acl acpi alsa amd64 amr apache2 avahi berkdb bluetooth branding bzip2 cairo cdb cdda cddb cdio cdr cleartype cli consolekit corefonts cracklib crypt css cups cxx daap dbus dri dts dvd dvdr emboss encode esd exif ffmpeg firefox flac fortran gd gdbm gdu gif glamor gpm iconv ipod ipv6 java javascript joystick jpeg jpeg2k kde laptop latin1 lcms lm_sensors mad mikmod mmx mmxext mng modules mp3 mp4 mpeg mplayer multilib mysql ncurses nls nptl nsplugin nvidia ogg opengl openmp oss pam pango pcre pdf perl pmu png policykit posix ppds pulseaudio python qt3support qt4 readline real rss samba sdl seccomp semantic-desktop server session smp spell sqlite sse sse2 sse3 ssl svg tcpd threads tiff transcode truetype type1 udev udisks unicode upower usb v4l v4l2 vcd virtuoso vorbis wifi wma wxwidgets x264 xattr xcb xcomposite xine xinerama xml xv xvid xvmc zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="actions alias auth_basic auth_digest authn_anon authn_dbd authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgid dav dav_fs dav_lock dbd deflate dir disk_cache dumpio env expires ext_filter file_cache filter headers ident imagemap include info log_config logio mem_cache mime mime_magic negotiation proxy proxy_ajp proxy_balancer proxy_connect proxy_http rewrite setenvif so speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3 sse4_1 ssse3" DRACUT_MODULES="dm lvm mdraid" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby20 ruby21" USERLAND="GNU" VIDEO_CARDS="nvidia vesa fbdev" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.4"
Unset:  CC, CPPFLAGS, CTARGET, CXX, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

lyall@lyalls-pc ~
$

_________________
...Lyall
Back to top
View user's profile Send private message
lyallp
Veteran
Veteran


Joined: 15 Jul 2004
Posts: 1301
Location: Adelaide/Australia

PostPosted: Sat Feb 06, 2016 11:35 pm    Post subject: Reply with quote

I should add that k3b and ark (both kde apps) work just fine.

I have tried removing ~/.kde4/share directory (renaming it) to no avail.
_________________
...Lyall
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum