Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Xorg - need help with setting up two screens (Monitor + TV)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Dearn
n00b
n00b


Joined: 15 Jun 2014
Posts: 1

PostPosted: Sun Jun 15, 2014 1:45 pm    Post subject: Xorg - need help with setting up two screens (Monitor + TV) Reply with quote

Hello.
I have a problem with setting up my two displays. First of all:
My Monitor is plugged using DVI->VGA adapter, which causes problems with detecting it's resolutions.
It's native resolution is 1920x1080, which is not detected properly.

Which forces me to use

Code:
        Option "UseEDID" "false"   

in Xorg config

This is where real trouble comes - when use I do this, my TV resolutions are not detected properly now Xorg (xrandr) only sees 800x600 resolution, where it's native resolution is "1360x768".

To make it clear: when I don't put
Code:
        Option "UseEDID" "false"   

in config, resolutions on TV are detected fine.

xrandr result:


Code:
xrandr
Screen 0: minimum 8 x 8, current 1920 x 1080, maximum 16384 x 16384
DVI-I-0 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       75.0 +   70.1     60.0 
   1920x1080      60.0*
   1600x1200      65.0     60.0 
   1400x1050      74.8     60.0 
   1280x1024      75.0     60.0 
   1280x960       60.0 
   1152x864       75.0 
   832x624        74.6 
   800x600        75.0     72.2     60.3     56.2 
   700x525        74.8     60.0 
   640x480        75.0     72.8     59.9 
   512x384        70.1     60.0 
   400x300        72.2 
   320x240        72.8     60.1 
DVI-I-1 disconnected (normal left inverted right x axis y axis)
HDMI-0 connected (normal left inverted right x axis y axis)
   800x600        60.3 +





In Xorg.0.log, it says that both Monitors are NOT probing EDI.

But when I try to add custom resolution to it, xrandr returns error:

Code:

dearn@gtx770 ~ $ xrandr --newmode "1368x768_60.00"   85.25  1368 1440 1576 1784  768 771 781 798 -hsync +vsync
dearn@gtx770 ~ $ xrandr --addmode HDMI-0 "1368x768_60.00"
X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  139 (RANDR)
  Minor opcode of failed request:  18 (RRAddOutputMode)
  Serial number of failed request:  39
  Current serial number in output stream:  40


It's the same error, which I had when I tried to add custom resolution to my Monitor (which I have to do) before disabling UseEDID in xorg config.



/var/log/Xorg.0.log
http://pastebin.com/darNpF4k

/etc/X11/xorg.conf.d/01-nvidia.conf
http://pastebin.com/Tgg5JadJ


To summarize, what I would like to achieve is:

TV, plugged with HDMI using 1368x768 (native) resolution
Monitor, plugged with VGA->DVI adapter using 1920x1080 (native, not detectable with EDI) resolution
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum