Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[PORTAGE] media-video/mpeg-tools no compila [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
mrpingo
n00b
n00b


Joined: 14 Jun 2014
Posts: 2

PostPosted: Sat Jun 14, 2014 4:26 pm    Post subject: [PORTAGE] media-video/mpeg-tools no compila [SOLVED] Reply with quote

Hola, buenas tardes, y felicidades por el foro y por el SO! Llevo leyendoos desde hace casi 5 años y me habeis ayudado y explicado mucho con casi todos los problemas que me ha planteado gentoo. Tengo que deciros, que desde que lo probé me ha enamorado completamente por su gran flexibilidad. Me pasé directamente a este SO sin probar ningún otro tipo de linux por lo que había leido, y gracias a los foros y a su increíblemente extensa guía he aprendido a manejarme con soltura. Por ésto y por muchas otras cosas, MUCHAS GRACIAS!

Por otro lado, tengo un pequeño problema. Siempre me han gustado los retos e intentar resolverlos por mi mismo da un gran quebradero de cabeza, pero a la larga es una gran satisfacción e independencia. No os molestaría de no haberme quedado sin ideas, pero desde hace algún tiempo no puedo emerger, de ninguna de las maneras y ninguna de las versiones de mpeg-tools. El caso es que no quiero publicar un bug antes de que le echeis un vistazo porque puede ser que se me haya pasado algo contradictorio por alto en configuración, portage, USEs, ... y cuanto menos problemas dé a los desarrolladores más tiempo tendrán para usarlo con otras cosas más importantes.

Manos a la masa.

Creo que el problema radica en mfwddct compilando mpeg_encode pero después de mucho buscar no encuentro por donde atacar el problema porque emerge tampoco me da mucha información con un compiler: segmentation fault (o yo no sé verla) y parece que sólo me pasa a mi, por eso creo que debe ser algo relacionado con mi entorno.

Os incluyo
emerge --info: http://bpaste.net/show/372016/
build-log: http://bpaste.net/show/372015/

Si necesitais cualquier otra cosa, pedidla y con gran gusto la postearé.

Muchas gracias de antemano por vuestro tiempo y disculpad mi ignorancia si es obvio.


Last edited by mrpingo on Sat Jun 14, 2014 6:26 pm; edited 1 time in total
Back to top
View user's profile Send private message
esteban_conde
Veteran
Veteran


Joined: 04 Jun 2003
Posts: 1583

PostPosted: Sat Jun 14, 2014 4:44 pm    Post subject: Reply with quote

Comprueba que compilador usas con gcc-config -l y prueba a compilar con el otro de los dos que tienes.
_________________
Saludos a tod@s, Esteban.
Back to top
View user's profile Send private message
mrpingo
n00b
n00b


Joined: 14 Jun 2014
Posts: 2

PostPosted: Sat Jun 14, 2014 6:24 pm    Post subject: Reply with quote

Pues muchas gracias Esteban porque ha funcionado! y era algo que no se me había ocurrido probar. ¿Como has dilucidado que era la versión de gcc la que no compilaba el paquete? no se supone que eso lo debería de mirar portage antes de emergerlo? si pudieras explicarmelo para no cometer el mismo error e intentar comprender..
Back to top
View user's profile Send private message
esteban_conde
Veteran
Veteran


Joined: 04 Jun 2003
Posts: 1583

PostPosted: Sun Jun 15, 2014 11:02 am    Post subject: Reply with quote

Quote:
Hola, buenas tardes, y felicidades por el foro y por el SO! Llevo leyendoos desde hace casi 5 años y me habeis ayudado y explicado mucho con casi todos los problemas que me ha planteado gentoo

Pues eso que si llevas ya cinco años leyendo en el foro, habrás visto un montón de fallos de portage pero a mi parecer este no es un fallo de portage.
Quote:
mfwddct.c:170:1: internal compiler error: Segmentation fault

Parece que indica un fallo en el compilador.
Para que portage automatizara compilar usando un compilador u otro no se me ocurren más que trabas.
Hay paquetes que compilarían con el nuevo y sin embargo no funcionarían, creo recordar que virtualbox o quemu tenian ese problema.
Otros como el kernel si se actualizan necesitan un compilador actualizado y portage cumple ya que en update world baja ambas actualizaciones, no sabria decir si avisa o no de ese hecho y de la conveniencia o no de cambiar de versiones, en el caso del kernel lo más fácil es que si no cambias de .config no te de errores de compilación ya que el código a compilar es el mismo y al no obtener ningun error ni te enteras de que version del compilador has usado.
En todo caso tambien parecia difícil que se pudiera llegar al nivel actual cuando con un 486 se tardaban horas en compilar un kernel y si obtenías un "segmentatin fault" se te venia a la cabeza de todo incluso pensabas que el micro se habia fatigado y cortaba por lo sano :lol: , ahora me rio pero entonces la cara se ponia :evil: , gran invento esto de los emoticonos.
Espero que te sirva de algo lo que digo, en todo caso a ver si promovemos respuestas menos peregrinas que seguro más de un compañero conoce.
_________________
Saludos a tod@s, Esteban.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum