Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201406-09 ] GnuTLS: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1655

PostPosted: Fri Jun 13, 2014 8:26 pm    Post subject: [ GLSA 201406-09 ] GnuTLS: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: GnuTLS: Multiple vulnerabilities (GLSA 201406-09)
Severity: normal
Exploitable: remote
Date: June 13, 2014
Bug(s): #501282, #503394, #511840
ID: 201406-09

Synopsis

Multiple vulnerabilities have been discovered in GnuTLS, the worst
of which could lead to arbitrary code execution.


Background

GnuTLS is an Open Source implementation of the TLS 1.2 and SSL 3.0
protocols.


Affected Packages

Package: net-libs/gnutls
Vulnerable: < 2.12.23-r6
Unaffected: >= 2.12.23-r6
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in GnuTLS. Please review
the CVE identifiers referenced below for details.


Impact

A remote attacker could utilize multiple vectors to spoof arbitrary SSL
servers via a crafted certificate, execute arbitrary code or cause a
Denial of Service condition.


Workaround

There is no known workaround at this time.

Resolution

All GnuTLS users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=net-libs/gnutls-2.12.23-r6"
   


References

CVE-2014-0092
CVE-2014-1959
CVE-2014-3465
CVE-2014-3466
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum