Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Strange : autofs on server and NFS
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
anjgentoo
n00b
n00b


Joined: 12 Jun 2007
Posts: 19

PostPosted: Thu Jun 12, 2014 8:42 am    Post subject: Strange : autofs on server and NFS Reply with quote

My problems looks as solved, but I don't understand why it is solved ...

Foreword

This is NOT an issue about mounting NFS directories on a client with autofs on the client side.
This is about fstab mounting on a client of a NFS directory sitting on a server using autofs.

The situation

On my home server, I have an autofs mounted LVM partition, sitting on a couple of big USB disks (quite convenient to scale the server up at will). I use autofs to mount the LVM partition because the LVM partition does not always mount correctly through fstab mount at boot (time to spin the disks). A bit of a theoritical point because the server is always "on", but ... Everything is fine up to this point ... Samba sharing works well, no problem.

The problem

But NFS fails to export the LVM partition. mount -t nfs waits eternally (I stopped it after 10 minutes), even if I make sure the autofs mounting has happened through "ls" or something in a terminal. No error logged, everything seems allright. It looks as if NFS thought he should simply wait for the partition to mount on the server side.

The solution

I have made a link from the LVM partition to somewhere else on the server /home. Then the link mounts perfectly and immediately on the client side. The files are seen with some lag at the first access, due to autofs time to mount the LVM directory itself (normal). Be careful, the mount on the client behaves exactly as an autofs mount point, that is it eats everything on the mount point. No way to mount different server directories as subdirectories on the client mount point. I have had to make a different mount point for the other server directories to see them.

The question

This was a trial & error solution. If somebody can explain this in detail, I am interested. In particular, why is the mounted link behaving on the client as an autofs mount ? Other more logical solutions ?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum