Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problemas de bloqueo al actualizar[abierto]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Spanish
View previous topic :: View next topic  
Author Message
Jack Krauser
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jan 2011
Posts: 117

PostPosted: Thu Jun 12, 2014 4:14 am    Post subject: Problemas de bloqueo al actualizar[abierto] Reply with quote

Hola amigos, heme una vez más aquí molestando con un pequeño problema:

cuando intento actualizar mi sistema tengo el siguiente error:

Code:

Conflict: 11 blocks (1 unsatisfied)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/libgpg-error:0

  (dev-libs/libgpg-error-1.12::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/libgpg-error-1.11 required by (app-crypt/gnupg-2.0.22::gentoo, installed)

  (dev-libs/libgpg-error-1.10::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/libgpg-error-1.8[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (dev-libs/libgcrypt-1.5.3-r100::gentoo, ebuild scheduled for merge)


Y aún hay más información que me da emerge:

Code:

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-libs/libgcrypt-1.5.3::gentoo, installed) pulled in by
    >=dev-libs/libgcrypt-1.2.2:0= required by (app-crypt/libsecret-0.16::gentoo, installed)
    >=dev-libs/libgcrypt-1.4:0 required by (app-crypt/gnupg-2.0.22::gentoo, installed)
    >=dev-libs/libgcrypt-1.1.90:0= required by (net-misc/vino-3.10.1::gentoo, installed)
    >=dev-libs/libgcrypt-1.2.2:0/11= required by (gnome-base/gnome-keyring-3.10.1::gentoo, installed)
    >=dev-libs/libgcrypt-1.1.42:0= required by (dev-libs/libxslt-1.1.28-r1::gentoo, installed)
    >=dev-libs/libgcrypt-1.2.2:0/11= required by (app-crypt/gcr-3.10.1::gentoo, installed)
    >=dev-libs/libgcrypt-1.2.2:0= required by (gnome-base/gnome-keyring-3.10.1::gentoo, installed)
    >=dev-libs/libgcrypt-1.2.2:0= required by (app-crypt/gcr-3.10.1::gentoo, installed)
    >=dev-libs/libgcrypt-1.2.2:0/11= required by (app-crypt/libsecret-0.16::gentoo, installed)
    >=dev-libs/libgcrypt-1.4.2:0 required by (net-libs/gtk-vnc-0.5.3::gentoo, installed)
    dev-libs/libgcrypt:0 required by (dev-libs/totem-pl-parser-3.10.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/libgcrypt-1.4.5:0= required by (media-libs/libquvi-0.9.4::gentoo, installed)
    dev-libs/libgcrypt:0 required by (media-libs/libmtp-1.1.6-r1::gentoo, installed)
    >=dev-libs/libgcrypt-1.1.90:0/11= required by (net-misc/vino-3.10.1::gentoo, installed)
    >=dev-libs/libgcrypt-1.4.5:0/11= required by (media-libs/libquvi-0.9.4::gentoo, installed)
    >=dev-libs/libgcrypt-1.1.42:0/11= required by (dev-libs/libxslt-1.1.28-r1::gentoo, installed)

  (dev-libs/libgcrypt-1.5.3-r100::gentoo, ebuild scheduled for merge) pulled in by
    dev-libs/libgcrypt:11 required by (www-client/google-chrome-beta-36.0.1985.67_p1::gentoo, ebuild scheduled for merge)
    dev-libs/libgcrypt:11/11 required by (media-sound/spotify-0.9.10.17::gentoo, ebuild scheduled for merge)


Y otra información más que proporciona emerge:

Code:

The following packages are causing rebuilds:

  (dev-libs/icu-52.1::gentoo, ebuild scheduled for merge) causes rebuilds for:
    (media-libs/harfbuzz-0.9.23::gentoo, ebuild scheduled for merge)
    (media-libs/libvisio-0.0.30::gentoo, ebuild scheduled for merge)
    (app-misc/tracker-0.16.4::gentoo, ebuild scheduled for merge)
    (media-libs/raptor-2.0.9::gentoo, ebuild scheduled for merge)
    (app-text/libmspub-0.0.6::gentoo, ebuild scheduled for merge)
    (sys-apps/gptfdisk-0.8.8::gentoo, ebuild scheduled for merge)
    (media-libs/libcdr-0.0.14::gentoo, ebuild scheduled for merge)


La verdad esto de los errores aún es confuso para mi y por eso recurro a ustedes a que me ayuden a entender (que me enseñen) como solucionar éste tipo de bloqueos en emerge porque por más que he leído pues aún no entiendo (y eso que llevo usando gentoo como 2 años XD) y la verdad es que ya no quiero ser molestia a la comunidad por cuestiones como éstas...

PD: Si ayuda algo más de información me gustaría añadir que tengo dos versiones de python:

Code:

# eselect python list       
Available Python interpreters:
  [1]   python2.7
  [2]   python3.3 *


Y en actualizaciones anteriores, cuando tenía bloqueos, era porque algunos paquetes necesitaban la versión 2.7 y otros la 3.3 y mientras actualizaba pues alternaba de versión y conseguí actualizar (eso pasó un par de actualizaciones atrás). Supuse que ese problema iba a tener de nuevo pero al hacer lo que hice antes pues no me funcionó y mi otra pregunta es: como compilo todo mi sistema para que tengo una sola versión de python?


Bueno... Espero su ayuda y disculpen poner todo el código aquí :cry: , a la próxima lo pondré en pastebin :wink:
Back to top
View user's profile Send private message
esteban_conde
Veteran
Veteran


Joined: 04 Jun 2003
Posts: 1592

PostPosted: Thu Jun 12, 2014 10:15 am    Post subject: Reply with quote

Quote:
La verdad esto de los errores aún es confuso para mi y por eso recurro a ustedes a que me ayuden a entender (que me enseñen) como solucionar éste tipo de bloqueos en emerge porque por más que he leído pues aún no entiendo (y eso que llevo usando gentoo como 2 años XD) y la verdad es que ya no quiero ser molestia a la comunidad por cuestiones como éstas...
Este foro se retroalimenta, muy probablemente de aquí a algún tiempo yo mismo tenga que volver a este post pues aunque se me repita tu situación es posible que se me haya olvidado algún detalle.
Quote:
>=dev-libs/libgpg-error-1.8[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (dev-libs/libgcrypt-1.5.3-r100::gentoo, ebuild scheduled for merge)
¿Que contiene la variable CFLAGS=" " en /etc/make.conf?, interpreto que no sabe para que ABI compilar.
Quote:
[1] python2.7
[2] python3.3 *

Creo que de momento hay que tener instalados ambos ya que no se puede prescindir de la versión 2.7 ya que la versión 3.X no cubre todas las situaciones.
En cuanto a lo demás creo que deberias correr revdep-rebuild ya que suele resolver alguna situación embarazosa o al menos aislar los problemas.
_________________
Saludos a tod@s, Esteban.
Back to top
View user's profile Send private message
Jack Krauser
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jan 2011
Posts: 117

PostPosted: Thu Jun 12, 2014 3:26 pm    Post subject: Reply with quote

Hola esteban_conde gracias por tomarte el tiempo en darme tu ayuda ^_^

esteban_conde wrote:
Este foro se retroalimenta, muy probablemente de aquí a algún tiempo yo mismo tenga que volver a este post pues aunque se me repita tu situación es posible que se me haya olvidado algún detalle.


Es verdad ya que nunca se termina de aprender :)

esteban_conde wrote:
¿Que contiene la variable CFLAGS=" " en /etc/make.conf?, interpreto que no sabe para que ABI compilar.


Haciendo una consulta al archivo make.conf pues tengo:

Code:

# less /etc/portage/make.conf | grep CFLAGS           
CFLAGS="-march=native -O2 -pipe"
CXXFLAGS="${CFLAGS}"


Que seǵun el handbook creo estar en los valores recomendados...

esteban_conde wrote:
creo que deberias correr revdep-rebuild ya que suele resolver alguna situación embarazosa o al menos aislar los problemas.


Acabo de hacer lo que me recomiendas y el resultado fue:

Code:

 # revdep-rebuild
 * Configuring search environment for revdep-rebuild

 * Checking reverse dependencies
 * Packages containing binaries and libraries broken by a package update
 * will be emerged.

 * Collecting system binaries and libraries
 * Generated new 1_files.rr
 * Collecting complete LD_LIBRARY_PATH
 * Generated new 2_ldpath.rr
 * Checking dynamic linking consistency
[ 100% ]                 

 * Dynamic linking on your system is consistent... All done.


Ahora, probando de nuevo a actualizar sigo teniendo el mismo error =/
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 988

PostPosted: Thu Jun 12, 2014 7:21 pm    Post subject: Reply with quote

@Jack Krauser:

Code:
(dev-libs/libgpg-error-1.10::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/libgpg-error-1.8[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by (dev-libs/libgcrypt-1.5.3-r100::gentoo, ebuild scheduled for merge)

Parece que estas usando paquetes estables pero el bloqueo se produce porque emerge quiere instalar un paquete marcado como en pruebas: dev-libs/libgcrypt-1.5.3-r100

Debes tenerlo aceptado en package.accept_keywords. Tendras que quitarlo de ahi.
Back to top
View user's profile Send private message
Jack Krauser
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jan 2011
Posts: 117

PostPosted: Thu Jun 12, 2014 7:32 pm    Post subject: Reply with quote

quilosaq wrote:

Parece que estas usando paquetes estables pero el bloqueo se produce porque emerge quiere instalar un paquete marcado como en pruebas: dev-libs/libgcrypt-1.5.3-r100

Debes tenerlo aceptado en package.accept_keywords. Tendras que quitarlo de ahi.


Como puedes ver eso? La verdad es que aun no logro ver lo que ves... Puedes explicarme por favor?
Back to top
View user's profile Send private message
quilosaq
l33t
l33t


Joined: 22 Dec 2009
Posts: 988

PostPosted: Thu Jun 12, 2014 8:17 pm    Post subject: Reply with quote

Lo intentaré.

Code:
1 Conflict: 11 blocks (1 unsatisfied)
2
3 !!! Multiple package instances within a single package slot have been pulled
4 !!! into the dependency graph, resulting in a slot conflict:
5
6 dev-libs/libgpg-error:0
7
8  (dev-libs/libgpg-error-1.12::gentoo, ebuild scheduled for merge) pulled in by
9    >=dev-libs/libgpg-error-1.11 required by (app-crypt/gnupg-2.0.22::gentoo, installed)
10
11  (dev-libs/libgpg-error-1.10::gentoo, ebuild scheduled for merge) pulled in by
12    >=dev-libs/libgpg-error-1.8[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by
13 (dev-libs/libgcrypt-1.5.3-r100::gentoo, ebuild scheduled for merge)


En la línea 9 dice que tienes app-crypt/gnupg-2.0.22 instalado. Miro en
http://packages.gentoo.org/package/app-crypt/gnupg
y veo que la versión 2.0.22 está marcada como estable. De ahí deduzco que usas un sistema, en general, estable.

En la línea 11 dice que es necesario instalar dev-libs/libgpg-error-1.10 y en la 13 dice que se necesita como requerimiento para instalar dev-libs/libgcrypt-1.5.3-r100. Miro en
http://packages.gentoo.org/package/dev-libs/libgcrypt
y veo que la versión 1.5.3-r100 está marcada como en pruebas (~) además de enmascarada (masked).

Para que emerge necesite hacer ésto último sólo veo dos posibilidades: o todo tu sistema esta con paquetes en pruebas o has aceptado expresamente esa versión de libgcrypt. Me inclino por la segunda posibilidad pero puedo estar equivocado.
Back to top
View user's profile Send private message
Jack Krauser
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jan 2011
Posts: 117

PostPosted: Fri Jun 13, 2014 11:12 pm    Post subject: Reply with quote

quilosaq wrote:
Lo intentaré.

Code:
1 Conflict: 11 blocks (1 unsatisfied)
2
3 !!! Multiple package instances within a single package slot have been pulled
4 !!! into the dependency graph, resulting in a slot conflict:
5
6 dev-libs/libgpg-error:0
7
8  (dev-libs/libgpg-error-1.12::gentoo, ebuild scheduled for merge) pulled in by
9    >=dev-libs/libgpg-error-1.11 required by (app-crypt/gnupg-2.0.22::gentoo, installed)
10
11  (dev-libs/libgpg-error-1.10::gentoo, ebuild scheduled for merge) pulled in by
12    >=dev-libs/libgpg-error-1.8[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?] required by
13 (dev-libs/libgcrypt-1.5.3-r100::gentoo, ebuild scheduled for merge)


En la línea 9 dice que tienes app-crypt/gnupg-2.0.22 instalado. Miro en
http://packages.gentoo.org/package/app-crypt/gnupg
y veo que la versión 2.0.22 está marcada como estable. De ahí deduzco que usas un sistema, en general, estable.

En la línea 11 dice que es necesario instalar dev-libs/libgpg-error-1.10 y en la 13 dice que se necesita como requerimiento para instalar dev-libs/libgcrypt-1.5.3-r100. Miro en
http://packages.gentoo.org/package/dev-libs/libgcrypt
y veo que la versión 1.5.3-r100 está marcada como en pruebas (~) además de enmascarada (masked).

Para que emerge necesite hacer ésto último sólo veo dos posibilidades: o todo tu sistema esta con paquetes en pruebas o has aceptado expresamente esa versión de libgcrypt. Me inclino por la segunda posibilidad pero puedo estar equivocado.


Me has iluminado bastante y vamos por partes:

Sí, tengo algunos paquetes de prueba y en alguna actualización emerge me ha pedido que desenmascare a libgcrypt (más o menos por el "abr 29 2014") para mi arquitectura de 64bits:

Code:

pt_keywords/update4
jackkrauseri7gentoo jack # ls -l /etc/portage/package.accept_keywords/update4
-rw-r--r-- 1 root root 39 abr 29 18:02 /etc/portage/package.accept_keywords/update4


El detalle viene que tenía así:

emerge wrote:

=dev-libs/libgcrypt-1.5.3-r100 ~amd64


Y ahora le cambié así:

emerge wrote:

>=dev-libs/libgcrypt-1.5.3-r100 ~amd64


Ejecuté el comando para actualizar y ahora si me pide desenmascarar el paquete que está en conflicto:

emerge wrote:

Conflict: 10 blocks

The following keyword changes are necessary to proceed:
(see "package.accept_keywords" in the portage(5) man page for more details)
# required by app-crypt/gnupg-2.0.22[-static]
# required by kde-base/kleopatra-4.12.5
# required by kde-base/kdepim-meta-4.12.5
# required by kde-base/kde-meta-4.12.5[semantic-desktop]
# required by @selected
# required by @world (argument)
=dev-libs/libgpg-error-1.12-r1 ~amd64



Bueno, analizando lo que dijiste puedo concluir que emerge quiere instalar libgcrypt en una version "masked" y si es asi: ¿No debería emerge haberme informado del asunto como siempre suele hacerlo para añadirlo dentro las "USE"?

Esperemos esto arregle mi problema y pueda finalmente actualizar :)

Gracias amigo quilosaq
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Spanish All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum