Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
LC_NUMERIC cannot change locale
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
brummbaer
n00b
n00b


Joined: 08 Jun 2014
Posts: 14

PostPosted: Mon Jun 09, 2014 7:44 pm    Post subject: LC_NUMERIC cannot change locale Reply with quote

Hallo Leute,

ich bin noch immer am Konfigurieren meines Gentoo. Jetzt habe ich die deutschen Spracheinstellungen gesetzt, erhalte aber laufend die Meldung

Code:
/var/tmp/portage/app-admin/syslog-ng-3.4.7/temp/environment: line 83: warning: setlocale: LC_NUMERIC: cannot change locale (de_DE.UTF-8): No such file or directory
/var/tmp/portage/app-admin/syslog-ng-3.4.7/temp/environment: line 86: warning: setlocale: LC_TIME: cannot change locale (de_DE.UTF-8): No such file or directory


Muss mich das beunruhigen?

Beim locale -a erhalte ich folgendes:
Code:
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_COLLATE to default locale: No such file or directory
C
POSIX
de_DE
de_DE.iso88591
de_DE.iso885915@euro
de_DE@euro
deutsch
en_US
en_US.iso88591
en_US.utf8
german
trusty-7 / #
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2491
Location: Germany

PostPosted: Mon Jun 09, 2014 9:21 pm    Post subject: Reply with quote

Nunja, die Fehlermeldung deutet drauf hin das deine gesetzte de_DE.UTF-8 Locale nicht vorhanden ist - was die "locale -a" Ausgabe auch bestätigt.

In der /etc/locale.gen können die gewünschten Locales gesetzt werden. Dort ist auch ein Pfad (/usr/share/i18n/SUPPORTED) mit angegeben wo die genaue Bezeichnung der unterstützten angegeben ist.
Um die gesetzten Locales dann zu generieren nutze
Code:
locale-gen --help
Back to top
View user's profile Send private message
brummbaer
n00b
n00b


Joined: 08 Jun 2014
Posts: 14

PostPosted: Mon Jun 09, 2014 9:41 pm    Post subject: Reply with quote

Vielen Dank!

Ich hatte die /etc/locale.gen zwar editiert, und dabei die Einträge für deutsch aktiviert, aber mir war nicht aufgefallen, dass kein de_DE.UTF-8 UTF-8 dabei war. Das habe ich korrigiert und mit
Code:
 locale-gen
die loacales neu aufbauen lassen, und nun gibts keinen Fehler mehr.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum