Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
udev blocking systemd on an old system
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
potuz
Apprentice
Apprentice


Joined: 30 Jan 2010
Posts: 260

PostPosted: Sun Jun 08, 2014 2:45 am    Post subject: udev blocking systemd on an old system Reply with quote

Hi list, I'm trying to update a system that hasn't been updated for years. One of the problems is the move from Openrc to Systemd. There's a lot of blockages and circular dependencies and I don't know how to solve them. I've tried many things like trying to emerge first dbus with -systemd as flag, trying to emerge systemd alone, trying to emerge udev alone and so on... If you want I can post each of the outputs here. I'm posting the output of an emerge systemd blockage in the hopes that someone here can help me.

Thanks,
Code:
#  emerge -vuND systemd

These are the packages that would be merged, in order:

Calculating dependencies... done!


[nomerge       ] gnome-base/gnome-2.32.1-r2:2.0  USE="cups policykit -accessibility -cdr -dvdr -ldap -mono"
[nomerge       ]  media-sound/sound-juicer-2.32.0-r1  USE="-debug {-test}"
[nomerge       ]   gnome-base/gvfs-1.12.3  USE="cdda gdu gnome-keyring http udev -afp -archive -avahi -bluetooth -bluray -doc -fuse -gphoto2 -ios -samba (-udisks)"
[nomerge       ]    gnome-base/gnome-keyring-3.10.1 [2.32.1-r1] USE="caps%* filecaps%* pam -debug (-selinux) {-test}"
[nomerge       ]     app-crypt/gcr-3.10.1:0/1  USE="gtk introspection vala -debug {-test}"
[nomerge       ]      x11-libs/gtk+-3.10.8:3 [3.4.4:3] USE="X colord cups introspection (-aqua) -debug -examples (-packagekit) {-test} -vim-syntax -wayland -xinerama"
[nomerge       ]       net-print/cups-1.7.1-r1 [1.5.2-r4] USE="X acl dbus pam ssl systemd%* threads usb -debug -gnutls -java -kerberos -lprng-compat% -python (-selinux) -static-libs -xinetd -zeroconf% (-avahi%) (-filters%*) (-jpeg%*) (-ldap%*) (-perl%) (-png%*) (-slp%) (-tiff%*)" LINGUAS="es -ca% -fr -it -ja -ru (-da%) (-de%) (-eu%) (-fi%) (-id%) (-ko%) (-nl%) (-no%) (-pl%) (-pt%*) (-pt_BR%) (-sv%) (-zh%) (-zh_TW%)" PYTHON_SINGLE_TARGET="python2_7%* (-python2_6)" PYTHON_TARGETS="python2_7%* (-python2_6)"
[ebuild  N     ]        net-print/cups-filters-1.0.53  USE="dbus foomatic jpeg png tiff -perl -static-libs -zeroconf" 1,282 kB
[ebuild     U  ]         net-print/cups-1.7.1-r1 [1.5.2-r4] USE="X acl dbus pam ssl systemd%* threads usb -debug -gnutls -java -kerberos -lprng-compat% -python (-selinux) -static-libs -xinetd -zeroconf% (-avahi%) (-filters%*) (-jpeg%*) (-ldap%*) (-perl%) (-png%*) (-slp%) (-tiff%*)" LINGUAS="es -ca% -fr -it -ja -ru (-da%) (-de%) (-eu%) (-fi%) (-id%) (-ko%) (-nl%) (-no%) (-pl%) (-pt%*) (-pt_BR%) (-sv%) (-zh%) (-zh_TW%)" PYTHON_SINGLE_TARGET="python2_7%* (-python2_6)" PYTHON_TARGETS="python2_7%* (-python2_6)" 8,534 kB
[ebuild     U  ]       x11-misc/colord-1.0.3:0/1 [0.1.21:0/0] USE="gusb introspection systemd%* udev -examples -extra-print-profiles% -scanner -vala (-doc%) (-gtk%*)" 1,058 kB
[nomerge       ] gnome-base/gnome-2.32.1-r2:2.0  USE="cups policykit -accessibility -cdr -dvdr -ldap -mono"
[nomerge       ]  gnome-base/gdm-2.20.11-r1  USE="branding consolekit gnome-keyring ipv6 pam tcpd -accessibility -afs -dmx -remote (-selinux) -xinerama"
[nomerge       ]   x11-libs/gksu-2.0.2-r1  USE="gnome -doc"
[nomerge       ]    x11-libs/libgksu-2.0.12-r1:2  USE="nls -doc -static-libs"
[nomerge       ]     app-admin/sudo-1.8.5_p2  USE="ldap nls pam -offensive (-selinux) -skey"
[ebuild     U  ]      sys-auth/pambase-20120417-r3 [20101024-r2] USE="consolekit cracklib gnome-keyring sha512 systemd%* -debug -minimal -mktemp -pam_krb5 -pam_ssh -passwdqc (-selinux)" 4 kB
[ebuild     U  ]       sys-auth/consolekit-0.4.6 [0.4.5_p20120320-r1] USE="acl pam policykit -debug -doc (-selinux) -systemd-units% {-test}" 370 kB
[ebuild     U  ]        sys-auth/polkit-0.112-r1 [0.107-r1] USE="gtk introspection nls pam systemd* -examples -kde (-selinux)" 1,396 kB
[nomerge       ] sys-apps/systemd-208-r3:0/1  USE="acl filecaps firmware-loader gudev introspection kmod pam policykit tcpd -audit -cryptsetup -doc -gcrypt -http -lzma -python -qrcode (-selinux) {-test} -vanilla -xattr" ABI_X86="(64) (-32) (-x32)" PYTHON_SINGLE_TARGET="python2_7 -python3_2 -python3_3" PYTHON_TARGETS="python2_7 python3_3 -python3_2"
[ebuild  N     ]  sys-apps/gentoo-systemd-integration-4  52 kB
[ebuild  N     ]   sys-apps/systemd-208-r3:0/1  USE="acl filecaps firmware-loader gudev introspection kmod pam policykit tcpd -audit -cryptsetup -doc -gcrypt -http -lzma -python -qrcode (-selinux) {-test} -vanilla -xattr" ABI_X86="(64) (-32) (-x32)" PYTHON_SINGLE_TARGET="python2_7 -python3_2 -python3_3" PYTHON_TARGETS="python2_7 python3_3 -python3_2" 2,335 kB
[nomerge       ] gnome-base/gdm-2.20.11-r1  USE="branding consolekit gnome-keyring ipv6 pam tcpd -accessibility -afs -dmx -remote (-selinux) -xinerama"
[nomerge       ]  x11-misc/xdg-utils-1.1.0_rc2 [1.1.0_rc1_p20120319] USE="perl -doc"
[ebuild     U  ]   app-text/xmlto-0.0.25 [0.0.24-r1] USE="-latex" 114 kB
[nomerge       ] gnome-base/gnome-2.32.1-r2:2.0  USE="cups policykit -accessibility -cdr -dvdr -ldap -mono"
[nomerge       ]  x11-themes/gnome-themes-standard-3.4.2
[nomerge       ]   x11-libs/gtk+-3.4.4:3  USE="X colord cups introspection (-aqua) -debug -examples (-packagekit) {-test} -vim-syntax (-wayland) -xinerama"
[nomerge       ]    x11-misc/colord-1.0.3:0/1 [0.1.21:0/0] USE="gusb introspection systemd%* udev -examples -extra-print-profiles% -scanner -vala (-doc%) (-gtk%*)"
[ebuild     U  ]     dev-libs/libgusb-0.1.6 [0.1.3] USE="introspection%* -static-libs -vala%" 257 kB
[ebuild     U  ]      virtual/libusb-1-r1:1 [1:1] USE="udev%*" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ]       dev-libs/libusb-1.0.18:1 [1.0.9:1] USE="udev%* -debug -doc -examples% -static-libs {-test%}" ABI_X86="(64%*) (-32) (-x32)" 491 kB
[nomerge       ] sys-apps/systemd-208-r3:0/1  USE="acl filecaps firmware-loader gudev introspection kmod pam policykit tcpd -audit -cryptsetup -doc -gcrypt -http -lzma -python -qrcode (-selinux) {-test} -vanilla -xattr" ABI_X86="(64) (-32) (-x32)" PYTHON_SINGLE_TARGET="python2_7 -python3_2 -python3_3" PYTHON_TARGETS="python2_7 python3_3 -python3_2"
[ebuild  N     ]  sys-fs/udev-init-scripts-26-r2  5 kB
[ebuild     U  ]  sys-apps/hwids-20140317 [20121119] USE="udev%*" 1,585 kB
[ebuild     U  ]  sys-apps/util-linux-2.24.1-r2 [2.21.2] USE="cramfs ncurses nls pam%* suid%* udev unicode -bash-completion% -caps% -cytune% -fdformat% -python% (-selinux) -slang -static-libs {-test%} -tty-helpers% (-crypt%*) (-ddate%) (-old-linux%) (-perl%) (-uclibc%)" PYTHON_SINGLE_TARGET="python2_7%* -python3_2% -python3_3% (-python3_4)" PYTHON_TARGETS="python2_7%* python3_3%* -python3_2% (-python3_4)" 3,461 kB
[ebuild     U  ]   virtual/udev-208-r1 [171] USE="gudev introspection kmod%* (-selinux) -static-libs (-hwdb%*) (-keymap%*)" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild   R    ]  sys-apps/dbus-1.6.18-r1  USE="X systemd* -debug -doc (-selinux) -static-libs {-test}" ABI_X86="(64) (-32) (-x32)" 0 kB

Total: 17 packages (12 upgrades, 4 new, 1 reinstall), Size of downloads: 20,938 kB

 * Error: circular dependencies:

(sys-apps/util-linux-2.24.1-r2::gentoo, ebuild scheduled for merge) depends on
 (virtual/udev-208-r1::gentoo, ebuild scheduled for merge) (buildtime)
  (sys-apps/systemd-208-r3::gentoo, ebuild scheduled for merge) (runtime)
   (sys-apps/util-linux-2.24.1-r2::gentoo, ebuild scheduled for merge) (buildtime)

 * Note that circular dependencies can often be avoided by temporarily
 * disabling USE flags that trigger optional dependencies.

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.16.3::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.16* required by (virtual/perl-Digest-MD5-2.510.0-r2::gentoo, installed)
    >=dev-lang/perl-5.16 required by (perl-core/CPAN-Meta-2.120.921::gentoo, ebuild scheduled for merge)
    (and 53 more with the same problems)

  (dev-lang/perl-5.12.4-r1::gentoo, installed) pulled in by
    dev-lang/perl[-build] required by (dev-perl/Error-0.170.160::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/HTTP-Negotiate-6.0.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/HTML-Parser-3.690.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-vcs/subversion-1.7.7::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/Algorithm-Diff-1.190.200::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/Net-SSLeay-1.490.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-vcs/git-1.7.8.6::gentoo, installed)
    dev-lang/perl[-build] required by (perl-core/Storable-2.20::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/libwww-perl-6.30.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/Unicode-EastAsianWidth-1.320.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/WWW-RobotRules-6.10.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/HTTP-Cookies-6.0.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/IO-Socket-SSL-1.440.0::gentoo, installed)
    ~dev-lang/perl-5.12.4 required by (virtual/perl-MIME-Base64-3.08::gentoo, installed)
    (and 1 more with the same problems)

gnome-base/gnome-keyring:0

  (gnome-base/gnome-keyring-2.32.1-r1::gentoo, installed) pulled in by
    <gnome-base/gnome-keyring-3 required by (net-im/empathy-2.34.0-r2::gentoo, installed)

  (gnome-base/gnome-keyring-3.10.1::gentoo, ebuild scheduled for merge) pulled in by
    >=gnome-base/gnome-keyring-3.1.92 required by (gnome-base/libgnome-keyring-3.10.1::gentoo, ebuild scheduled for merge)

x11-libs/gtk+:3

  (x11-libs/gtk+-3.10.8::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/gtk+-3.4.4::gentoo, installed) pulled in by
    <x11-libs/gtk+-3.5:3 required by (x11-themes/gnome-themes-standard-3.4.2::gentoo, installed)

dev-libs/libgcrypt:0

  (dev-libs/libgcrypt-1.5.3::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/libgcrypt-1.5.0-r2::gentoo, installed) pulled in by
    >=dev-libs/libgcrypt-1.1.90:0/0= required by (net-misc/vino-2.32.2-r1::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
potuz
Apprentice
Apprentice


Joined: 30 Jan 2010
Posts: 260

PostPosted: Sun Jun 08, 2014 2:50 am    Post subject: Reply with quote

This is the one for sys-apps/dbus -systemd which as far as I remember was the first step in my own system when I updated to gnome 3.
Code:
# emerge -avuND dbus

These are the packages that would be merged, in order:

Calculating dependencies... done!


[nomerge       ] gnome-base/gnome-2.32.1-r2:2.0  USE="cups policykit -accessibility -cdr -dvdr -ldap -mono"
[nomerge       ]  media-sound/sound-juicer-2.32.0-r1  USE="-debug {-test}"
[nomerge       ]   gnome-base/gvfs-1.12.3  USE="cdda gdu gnome-keyring http udev -afp -archive -avahi -bluetooth -bluray -doc -fuse -gphoto2 -ios -samba (-udisks)"
[nomerge       ]    gnome-base/gnome-keyring-3.10.1 [2.32.1-r1] USE="caps%* filecaps%* pam -debug (-selinux) {-test}"
[nomerge       ]     app-crypt/gcr-3.10.1:0/1  USE="gtk introspection vala -debug {-test}"
[nomerge       ]      x11-libs/gtk+-3.10.8:3 [3.4.4:3] USE="X colord cups introspection (-aqua) -debug -examples (-packagekit) {-test} -vim-syntax -wayland -xinerama"
[nomerge       ]       net-print/cups-1.7.1-r1 [1.5.2-r4] USE="X acl dbus pam ssl systemd%* threads usb -debug -gnutls -java -kerberos -lprng-compat% -python (-selinux) -static-libs -xinetd -zeroconf% (-avahi%) (-filters%*) (-jpeg%*) (-ldap%*) (-perl%) (-png%*) (-slp%) (-tiff%*)" LINGUAS="es -ca% -fr -it -ja -ru (-da%) (-de%) (-eu%) (-fi%) (-id%) (-ko%) (-nl%) (-no%) (-pl%) (-pt%*) (-pt_BR%) (-sv%) (-zh%) (-zh_TW%)" PYTHON_SINGLE_TARGET="python2_7%* (-python2_6)" PYTHON_TARGETS="python2_7%* (-python2_6)"
[ebuild  N     ]        net-print/cups-filters-1.0.53  USE="dbus foomatic jpeg png tiff -perl -static-libs -zeroconf" 1,282 kB
[ebuild     U  ]         net-print/cups-1.7.1-r1 [1.5.2-r4] USE="X acl dbus pam ssl systemd%* threads usb -debug -gnutls -java -kerberos -lprng-compat% -python (-selinux) -static-libs -xinetd -zeroconf% (-avahi%) (-filters%*) (-jpeg%*) (-ldap%*) (-perl%) (-png%*) (-slp%) (-tiff%*)" LINGUAS="es -ca% -fr -it -ja -ru (-da%) (-de%) (-eu%) (-fi%) (-id%) (-ko%) (-nl%) (-no%) (-pl%) (-pt%*) (-pt_BR%) (-sv%) (-zh%) (-zh_TW%)" PYTHON_SINGLE_TARGET="python2_7%* (-python2_6)" PYTHON_TARGETS="python2_7%* (-python2_6)" 8,534 kB
[ebuild     U  ]       x11-misc/colord-1.0.3:0/1 [0.1.21:0/0] USE="gusb introspection systemd%* udev -examples -extra-print-profiles% -scanner -vala (-doc%) (-gtk%*)" 1,058 kB
[nomerge       ] gnome-base/gnome-2.32.1-r2:2.0  USE="cups policykit -accessibility -cdr -dvdr -ldap -mono"
[nomerge       ]  gnome-base/gdm-2.20.11-r1  USE="branding consolekit gnome-keyring ipv6 pam tcpd -accessibility -afs -dmx -remote (-selinux) -xinerama"
[nomerge       ]   x11-libs/gksu-2.0.2-r1  USE="gnome -doc"
[nomerge       ]    x11-libs/libgksu-2.0.12-r1:2  USE="nls -doc -static-libs"
[nomerge       ]     app-admin/sudo-1.8.5_p2  USE="ldap nls pam -offensive (-selinux) -skey"
[ebuild     U  ]      sys-auth/pambase-20120417-r3 [20101024-r2] USE="consolekit cracklib gnome-keyring sha512 systemd%* -debug -minimal -mktemp -pam_krb5 -pam_ssh -passwdqc (-selinux)" 4 kB
[ebuild     U  ]       sys-auth/consolekit-0.4.6 [0.4.5_p20120320-r1] USE="acl pam policykit -debug -doc (-selinux) -systemd-units% {-test}" 370 kB
[ebuild     U  ]        sys-auth/polkit-0.112-r1 [0.107-r1] USE="gtk introspection nls pam systemd* -examples -kde (-selinux)" 1,396 kB
[nomerge       ] sys-apps/openrc-0.12.4  USE="ncurses netifrc pam unicode -debug -newnet (-prefix) (-selinux) -static-libs -tools"
[nomerge       ]  sys-auth/pambase-20120417-r3 [20101024-r2] USE="consolekit cracklib gnome-keyring sha512 systemd%* -debug -minimal -mktemp -pam_krb5 -pam_ssh -passwdqc (-selinux)"
[nomerge       ]   sys-apps/systemd-208-r3:0/1  USE="acl filecaps firmware-loader gudev introspection kmod pam policykit tcpd -audit -cryptsetup -doc -gcrypt -http -lzma -python -qrcode (-selinux) {-test} -vanilla -xattr" ABI_X86="(64) (-32) (-x32)" PYTHON_SINGLE_TARGET="python2_7 -python3_2 -python3_3" PYTHON_TARGETS="python2_7 python3_3 -python3_2"
[ebuild  N     ]    sys-apps/gentoo-systemd-integration-4  52 kB
[ebuild  N     ]     sys-apps/systemd-208-r3:0/1  USE="acl filecaps firmware-loader gudev introspection kmod pam policykit tcpd -audit -cryptsetup -doc -gcrypt -http -lzma -python -qrcode (-selinux) {-test} -vanilla -xattr" ABI_X86="(64) (-32) (-x32)" PYTHON_SINGLE_TARGET="python2_7 -python3_2 -python3_3" PYTHON_TARGETS="python2_7 python3_3 -python3_2" 2,335 kB
[nomerge       ] gnome-base/gdm-2.20.11-r1  USE="branding consolekit gnome-keyring ipv6 pam tcpd -accessibility -afs -dmx -remote (-selinux) -xinerama"
[nomerge       ]  x11-misc/xdg-utils-1.1.0_rc2 [1.1.0_rc1_p20120319] USE="perl -doc"
[ebuild     U  ]   app-text/xmlto-0.0.25 [0.0.24-r1] USE="-latex" 114 kB
[nomerge       ] gnome-base/gnome-2.32.1-r2:2.0  USE="cups policykit -accessibility -cdr -dvdr -ldap -mono"
[nomerge       ]  x11-themes/gnome-themes-standard-3.4.2
[nomerge       ]   x11-libs/gtk+-3.4.4:3  USE="X colord cups introspection (-aqua) -debug -examples (-packagekit) {-test} -vim-syntax (-wayland) -xinerama"
[nomerge       ]    x11-misc/colord-1.0.3:0/1 [0.1.21:0/0] USE="gusb introspection systemd%* udev -examples -extra-print-profiles% -scanner -vala (-doc%) (-gtk%*)"
[ebuild     U  ]     dev-libs/libgusb-0.1.6 [0.1.3] USE="introspection%* -static-libs -vala%" 257 kB
[ebuild     U  ]      virtual/libusb-1-r1:1 [1:1] USE="udev%*" ABI_X86="(64%*) (-32) (-x32)" 0 kB
[ebuild     U  ]       dev-libs/libusb-1.0.18:1 [1.0.9:1] USE="udev%* -debug -doc -examples% -static-libs {-test%}" ABI_X86="(64%*) (-32) (-x32)" 491 kB
[nomerge       ] x11-misc/colord-1.0.3:0/1 [0.1.21:0/0] USE="gusb introspection systemd%* udev -examples -extra-print-profiles% -scanner -vala (-doc%) (-gtk%*)"
[nomerge       ]  sys-apps/systemd-208-r3:0/1  USE="acl filecaps firmware-loader gudev introspection kmod pam policykit tcpd -audit -cryptsetup -doc -gcrypt -http -lzma -python -qrcode (-selinux) {-test} -vanilla -xattr" ABI_X86="(64) (-32) (-x32)" PYTHON_SINGLE_TARGET="python2_7 -python3_2 -python3_3" PYTHON_TARGETS="python2_7 python3_3 -python3_2"
[ebuild  N     ]   sys-fs/udev-init-scripts-26-r2  5 kB
[ebuild     U  ]   sys-apps/hwids-20140317 [20121119] USE="udev%*" 1,585 kB
[ebuild     U  ]   sys-apps/util-linux-2.24.1-r2 [2.21.2] USE="cramfs ncurses nls pam%* suid%* udev unicode -bash-completion% -caps% -cytune% -fdformat% -python% (-selinux) -slang -static-libs {-test%} -tty-helpers% (-crypt%*) (-ddate%) (-old-linux%) (-perl%) (-uclibc%)" PYTHON_SINGLE_TARGET="python2_7%* -python3_2% -python3_3% (-python3_4)" PYTHON_TARGETS="python2_7%* python3_3%* -python3_2% (-python3_4)" 3,461 kB
[ebuild     U  ]    virtual/udev-208-r1 [171] USE="gudev introspection kmod%* (-selinux) -static-libs (-hwdb%*) (-keymap%*)" ABI_X86="(64%*) (-32) (-x32)" 0 kB

Total: 16 packages (12 upgrades, 4 new), Size of downloads: 20,938 kB

 * Error: circular dependencies:

(sys-apps/util-linux-2.24.1-r2::gentoo, ebuild scheduled for merge) depends on
 (virtual/udev-208-r1::gentoo, ebuild scheduled for merge) (buildtime)
  (sys-apps/systemd-208-r3::gentoo, ebuild scheduled for merge) (runtime)
   (sys-apps/util-linux-2.24.1-r2::gentoo, ebuild scheduled for merge) (buildtime)

 * Note that circular dependencies can often be avoided by temporarily
 * disabling USE flags that trigger optional dependencies.

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-lang/perl:0

  (dev-lang/perl-5.16.3::gentoo, ebuild scheduled for merge) pulled in by
    =dev-lang/perl-5.16* required by (virtual/perl-Digest-MD5-2.510.0-r2::gentoo, installed)
    >=dev-lang/perl-5.16 required by (perl-core/CPAN-Meta-2.120.921::gentoo, ebuild scheduled for merge)
    (and 53 more with the same problems)

  (dev-lang/perl-5.12.4-r1::gentoo, installed) pulled in by
    dev-lang/perl[-build] required by (dev-perl/Error-0.170.160::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/HTTP-Negotiate-6.0.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/HTML-Parser-3.690.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-vcs/subversion-1.7.7::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/Algorithm-Diff-1.190.200::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/Net-SSLeay-1.490.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-vcs/git-1.7.8.6::gentoo, installed)
    dev-lang/perl[-build] required by (perl-core/Storable-2.20::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/libwww-perl-6.30.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/Unicode-EastAsianWidth-1.320.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/WWW-RobotRules-6.10.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/HTTP-Cookies-6.0.0::gentoo, installed)
    dev-lang/perl[-build] required by (dev-perl/IO-Socket-SSL-1.440.0::gentoo, installed)
    ~dev-lang/perl-5.12.4 required by (virtual/perl-MIME-Base64-3.08::gentoo, installed)
    (and 1 more with the same problems)

gnome-base/gnome-keyring:0

  (gnome-base/gnome-keyring-2.32.1-r1::gentoo, installed) pulled in by
    <gnome-base/gnome-keyring-3 required by (net-im/empathy-2.34.0-r2::gentoo, installed)

  (gnome-base/gnome-keyring-3.10.1::gentoo, ebuild scheduled for merge) pulled in by
    >=gnome-base/gnome-keyring-3.1.92 required by (gnome-base/libgnome-keyring-3.10.1::gentoo, ebuild scheduled for merge)

x11-libs/gtk+:3

  (x11-libs/gtk+-3.10.8::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (x11-libs/gtk+-3.4.4::gentoo, installed) pulled in by
    <x11-libs/gtk+-3.5:3 required by (x11-themes/gnome-themes-standard-3.4.2::gentoo, installed)

dev-libs/libgcrypt:0

  (dev-libs/libgcrypt-1.5.3::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

  (dev-libs/libgcrypt-1.5.0-r2::gentoo, installed) pulled in by
    >=dev-libs/libgcrypt-1.1.90:0/0= required by (net-misc/vino-2.32.2-r1::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum