Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] emerge of qemu-2.0.0 complains about KVM_AMD
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
kikko
n00b
n00b


Joined: 29 Apr 2014
Posts: 39
Location: Milan, IT

PostPosted: Fri Jun 06, 2014 8:59 pm    Post subject: [SOLVED] emerge of qemu-2.0.0 complains about KVM_AMD Reply with quote

During world update ( emerge -DNuva @world ), qemu failed to build with this message:

Code:
 cat /var/tmp/portage/app-emulation/qemu-2.0.0/temp/build.log
* Package:    app-emulation/qemu-2.0.0
 * Repository: gentoo
 * Maintainer: cardoe@gentoo.org qemu@gentoo.org
 * USE:        aio alsa amd64 bluetooth caps curl elibc_glibc fdt filecaps gtk jpeg kernel_linux ncurses opengl png pulseaudio python_targets_python2_7 qemu_softmmu_targets_i386 qemu_softmmu_targets_x86_64 qemu_user_targets_i386 qemu_user_targets_x86_64 sdl seccomp spice threads usb usbredir userland_GNU uuid vhost-net vnc
 * FEATURES:   preserve-libs sandbox userpriv usersandbox
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /lib/modules/3.12.20-gentoo/build
 * Found sources for kernel version:
 *     3.12.20-gentoo
 * Checking for suitable kernel configuration options...
 *   If you have an AMD CPU, you must enable KVM_AMD in your kernel configuration.
 * Please check to make sure these options are set correctly.
 * Failure to do so may cause unexpected problems.
 * The kvm/qemu-kvm wrappers no longer exist, but your libvirt
 * instances are still pointing to it.  Please update your
 * configs in /etc/libvirt/qemu/ to use the -enable-kvm flag
 * and the right system binary (e.g. qemu-system-x86_64).
 * ERROR: app-emulation/qemu-2.0.0::gentoo failed (pretend phase):
 *   update your virt configs to not use qemu-kvm
 *
 * Call stack:
 *           ebuild.sh, line  93:  Called pkg_pretend
 *   qemu-2.0.0.ebuild, line 225:  Called die
 * The specific snippet of code:
 *              die "update your virt configs to not use qemu-kvm"
 *
 * If you need support, post the output of `emerge --info '=app-emulation/qemu-2.0.0::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=app-emulation/qemu-2.0.0::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/app-emulation/qemu-2.0.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-emulation/qemu-2.0.0/temp/die.env'.
 * Working directory: '/usr/lib64/portage/pym'
 * S: '/var/tmp/portage/app-emulation/qemu-2.0.0/work/qemu-2.0.0'

I haven't enabled KVM_AMD in my Kernel config... since I'm on Intel :D
Code:
cat /proc/cpuinfo | grep -m 1 "model name"
model name      : Intel(R) Core(TM) i3 CPU       M 380  @ 2.53GHz

KVM is in the kernel, not as a module
Code:
zcat /proc/config.gz | grep KVM
CONFIG_HAVE_KVM=y
CONFIG_HAVE_KVM_IRQCHIP=y
CONFIG_HAVE_KVM_IRQ_ROUTING=y
CONFIG_HAVE_KVM_EVENTFD=y
CONFIG_KVM_APIC_ARCHITECTURE=y
CONFIG_KVM_MMIO=y
CONFIG_KVM_ASYNC_PF=y
CONFIG_HAVE_KVM_MSI=y
CONFIG_HAVE_KVM_CPU_RELAX_INTERCEPT=y
CONFIG_KVM=y
CONFIG_KVM_INTEL=y
# CONFIG_KVM_AMD is not set

Any idea? Should I have to file a bug for this?


Last edited by kikko on Sat Jun 07, 2014 12:00 pm; edited 1 time in total
Back to top
View user's profile Send private message
Hu
Watchman
Watchman


Joined: 06 Mar 2007
Posts: 9394

PostPosted: Fri Jun 06, 2014 9:58 pm    Post subject: Reply with quote

No, you should read the output you posted. The KVM_AMD notice is not why it died. It died because you need to "update your virt configs to not use qemu-kvm".
Back to top
View user's profile Send private message
krinn
Advocate
Advocate


Joined: 02 May 2003
Posts: 4816

PostPosted: Fri Jun 06, 2014 11:37 pm    Post subject: Re: emerge of qemu-2.0.0 complains about KVM_AMD on Intel Reply with quote

Here's the bug for the "why"?
https://bugs.gentoo.org/show_bug.cgi?id=506566
Back to top
View user's profile Send private message
kikko
n00b
n00b


Joined: 29 Apr 2014
Posts: 39
Location: Milan, IT

PostPosted: Sat Jun 07, 2014 11:59 am    Post subject: Reply with quote

whoops, I didn't examined the output! :oops:
Thank you very much, problem solved
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum