Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Multiple package instances within a single package slot have
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Phredus
n00b
n00b


Joined: 07 Feb 2013
Posts: 47

PostPosted: Fri Jun 06, 2014 7:53 pm    Post subject: Multiple package instances within a single package slot have Reply with quote

I am very new to Gentoo but I love it. Where should I post this? I’m trying to get help in getting my system back to health. Please could you direct me to the right place. Thank you

minig ~ # emerge --update --deep --with-bdeps=y --newuse world
Calculating dependencies... done!
[ebuild U ] sys-libs/timezone-data-2014a [2013d]
[ebuild U ] app-portage/portage-utils-0.53 [0.41] USE="nls%*"
[ebuild U ] dev-libs/gmp-5.1.3-r1 [5.1.2]
[ebuild U ] kde-base/kde-env-4.12.5 [4.11.5]
[ebuild U ] sys-kernel/linux-headers-3.13 [3.9]
[ebuild U ] dev-libs/libical-0.48-r2 [0.48] USE="-static-libs%"
[ebuild U ] sys-apps/sysvinit-2.88-r7 [2.88-r4]
[ebuild U ] dev-libs/icu-51.2-r2 [51.2-r1]
[ebuild U ] media-libs/libjpeg-turbo-1.3.1 [1.3.0-r3]
[ebuild U ] dev-libs/openssl-1.0.1h-r1 [1.0.1g]
[ebuild N ] sys-libs/libcap-2.22-r2 USE="pam"
[ebuild U ] app-admin/eselect-ctags-1.16 [1.15]
[ebuild NS ] sys-kernel/gentoo-sources-3.12.20 [3.10.7-r1, 3.10.17, 3.12.13] USE="symlink -build -deblob -experimental"
[ebuild U ] media-libs/libdvdread-4.2.1 [4.2.0]
[ebuild U ] dev-libs/libxml2-2.9.1-r4 [2.9.1-r1] PYTHON_TARGETS="(-python3_4)"
[ebuild U ] sys-process/procps-3.3.9 [3.3.8-r2]
[ebuild U ] media-libs/libdvdnav-4.2.1 [4.2.0]
[blocks b ] <media-libs/libdvdnav-4.2.1 ("<media-libs/libdvdnav-4.2.1" is blocking media-libs/libdvdread-4.2.1)
[ebuild R ] x11-libs/libxcb-1.10 USE="xkb*"
[ebuild U ] media-libs/flac-1.3.0 [1.2.1-r4]
[ebuild U ] sys-apps/mlocate-0.26-r1 [0.26]
[ebuild U ] sys-apps/help2man-1.43.3 [1.40.11]
[ebuild U ] x11-libs/libvdpau-0.7 [0.5]
[ebuild U ] x11-misc/xkeyboard-config-2.11 [2.9]
[ebuild U ] sys-apps/kmod-17 [16] USE="-python%" PYTHON_TARGETS="python2_7%* python3_3%* -python3_2% (-python3_4)"
[ebuild U ] net-misc/openssh-6.6_p1-r1 [5.9_p1-r4] USE="-ldns%"
[ebuild U ] sys-apps/openrc-0.12.4 [0.11.8] USE="netifrc%* -tools%"
[blocks b ] <sys-apps/openrc-0.12 ("<sys-apps/openrc-0.12" is blocking sys-apps/kmod-17, net-misc/netifrc-0.2.2)
[blocks b ] net-misc/netifrc ("net-misc/netifrc" is blocking sys-apps/openrc-0.11.8)
[ebuild N ] net-misc/netifrc-0.2.2
[ebuild U ] sys-kernel/genkernel-3.4.49.2 [3.4.45.1]
[ebuild R ] dev-libs/glib-2.38.2-r1 USE="(mime%*)"
[ebuild U ] x11-misc/shared-mime-info-1.2-r1 [1.0] USE="{-test%}"
[ebuild U ] x11-libs/gdk-pixbuf-2.30.7-r1 [2.30.7]
[ebuild U ] dev-perl/File-MimeInfo-0.170.0 [0.150.0]
[ebuild U ] sys-auth/polkit-0.112-r1 [0.112]
[ebuild U ] virtual/glu-9.0-r1 [9.0]
[ebuild U ] x11-drivers/nvidia-drivers-334.21-r3 [325.15] USE="-uvm%"
[ebuild U ] dev-qt/qtgui-4.8.5-r2 [4.8.5-r1]
[ebuild U ] dev-util/cmake-2.8.12.2 [2.8.10.2-r2] USE="(-qt5)"
[ebuild U ] kde-base/oxygen-icons-4.12.5 [4.10.5]
[ebuild U ] dev-libs/soprano-2.9.4 [2.9.2]
[ebuild U ] sys-devel/llvm-3.3-r3 [3.1-r2] USE="static-analyzer%* xml%* -clang% -doc% -python%" PYTHON_TARGETS="python2_7%* (-pypy) (-python2_6)" VIDEO_CARDS="-radeon%"
[ebuild N ] media-gfx/graphite2-1.2.1 USE="-perl {-test}"
[ebuild U ] media-libs/mesa-10.0.4 [9.1.6] USE="-llvm-shared-libs% -opencl%" VIDEO_CARDS="(-freedreno) -ilo%"
[ebuild U ] app-office/akonadi-server-1.11.0 [1.9.2] USE="qt4%* (-qt5)"
[ebuild U ] x11-libs/cairo-1.12.16 [1.12.14-r4]
[ebuild U ] virtual/opengl-7.0-r1 [7.0]
[ebuild U ] app-text/poppler-0.24.5 [0.24.3]
[ebuild R ] media-libs/libsdl-1.2.15-r4 USE="sound%* (-audio%*)"
[ebuild U ] media-libs/glu-9.0.0-r1 [9.0.0]
[ebuild N ] media-libs/harfbuzz-0.9.23 USE="cairo glib graphite truetype -icu -introspection -static-libs"
[ebuild U ] x11-libs/pango-1.36.3 [1.30.1]
[ebuild U ] net-libs/libproxy-0.4.11-r1 [0.4.10-r1] PYTHON_TARGETS="python2_7%* (-python2_6)"
[ebuild U ] net-libs/glib-networking-2.38.2 [2.32.3]
[ebuild U ] net-libs/libsoup-2.44.2 [2.38.1]
[ebuild U ] sys-apps/gptfdisk-0.8.8 [0.8.6]
[ebuild N ] app-text/xmlto-0.0.25 USE="-latex"
[ebuild U ] x11-misc/xdg-utils-1.1.0_rc2 [1.1.0_rc1_p20120319]
[ebuild U ] x11-libs/gtk+-2.24.23 [2.24.17]
[ebuild U ] media-video/nvidia-settings-331.20 [304.60]
[ebuild U ] sys-fs/udev-212-r1 [204]
[ebuild N ] virtual/libgudev-208 USE="introspection -static-libs"
[ebuild N ] virtual/libudev-208 USE="-static-libs"
[ebuild U ] virtual/udev-208-r2 [200]
[ebuild U ] sys-apps/hwids-20140317 [20130329]
[ebuild U ] sys-apps/util-linux-2.24.1-r2 [2.22.2] USE="pam%* -bash-completion% -caps% -cytune% -fdformat% -python% -tty-helpers%" PYTHON_SINGLE_TARGET="python2_7%* -python3_2% -python3_3% (-python3_4)" PYTHON_TARGETS="python2_7%* python3_3%* -python3_2% (-python3_4)"
[ebuild U ] sys-fs/udev-init-scripts-26-r2 [26]
[blocks b ] <sys-fs/udev-init-scripts-26-r1 ("<sys-fs/udev-init-scripts-26-r1" is blocking net-misc/netifrc-0.2.2)
[blocks b ] >=net-misc/netifrc-0.2.1 (">=net-misc/netifrc-0.2.1" is blocking sys-fs/udev-init-scripts-26)
[ebuild U ] dev-libs/libatasmart-0.19-r1 [0.19]
[ebuild U ] sys-fs/udisks-2.1.3 [2.1.0]
[ebuild U ] dev-libs/libusb-1.0.18 [1.0.9] USE="udev%* -examples% {-test%}"
[ebuild U ] virtual/libusb-1-r1 [1] USE="udev%*"
[ebuild U ] net-print/cups-1.7.1-r1 [1.6.4] USE="-systemd%" LINGUAS="-it%"
[ebuild U ] x11-base/xorg-server-1.15.0 [1.14.3-r2] USE="-unwind%"
[ebuild N ] sys-apps/systemd-208-r3 USE="acl filecaps firmware-loader gudev introspection kmod pam (policykit) tcpd -audit -cryptsetup -doc -gcrypt -http -lzma -python -qrcode (-selinux) {-test} -vanilla -xattr" PYTHON_SINGLE_TARGET="python2_7 -python3_2 -python3_3" PYTHON_TARGETS="python2_7 python3_3 -python3_2"
[ebuild N ] sys-apps/gentoo-systemd-integration-2
[ebuild U ] sys-power/upower-0.9.23-r3 [0.9.21]
[ebuild U ] kde-base/kdelibs-4.12.5 [4.10.5-r1]
[ebuild U ] kde-base/nepomuk-core-4.12.5 [4.10.5] USE="-epub%"
[ebuild U ] kde-base/katepart-4.12.5 [4.10.5]
[ebuild U ] kde-base/nepomuk-widgets-4.12.5 [4.10.5]
[ebuild U ] kde-base/kdesu-4.12.5 [4.10.5]
[ebuild U ] kde-base/khelpcenter-4.12.5 [4.10.5]
[ebuild U ] kde-base/libkworkspace-4.11.9 [4.10.5]
[ebuild U ] kde-base/kephal-4.11.9 [4.10.5]
[ebuild U ] kde-base/kdepimlibs-4.12.5 [4.10.5]
[ebuild U ] kde-base/kactivities-4.12.5 [4.10.5]
[ebuild U ] kde-base/ksysguard-4.11.9 [4.10.5]
[ebuild U ] kde-base/libplasmagenericshell-4.11.9 [4.10.5]
[ebuild U ] kde-base/kcheckpass-4.11.9 [4.10.5]
[ebuild U ] kde-base/libkexiv2-4.12.5 [4.10.5]
[ebuild U ] kde-base/libplasmaclock-4.11.9 [4.10.5] USE="semantic-desktop%*"
[ebuild U ] kde-base/libtaskmanager-4.11.9 [4.10.5]
[ebuild U ] kde-base/plasma-runtime-4.12.5 [4.10.5]
[ebuild U ] kde-base/plasma-workspace-4.11.9 [4.10.5-r2] PYTHON_SINGLE_TARGET="python2_7%* (-python2_6)" PYTHON_TARGETS="python2_7%* (-python2_6)"
[ebuild U ] kde-base/kcminit-4.11.9 [4.10.5]
[ebuild U ] kde-base/libkonq-4.12.5 [4.10.5]
[ebuild U ] kde-base/kdepasswd-4.12.5 [4.10.5]
[ebuild U ] kde-base/kdm-4.11.9-r1 [4.10.5-r1] USE="-systemd%"
[ebuild U ] kde-base/ksmserver-4.11.9 [4.10.5]
[ebuild U ] kde-base/krunner-4.11.9 [4.10.5]
[ebuild U ] app-text/ghostscript-gpl-9.10-r2 [9.05-r1] LINGUAS="-de%"
[ebuild U ] net-print/cups-filters-1.0.53 [1.0.36-r1] USE="dbus%* foomatic%*"
[blocks b ] <net-print/cups-filters-1.0.36-r2 ("<net-print/cups-filters-1.0.36-r2" is blocking app-text/ghostscript-gpl-9.10-r2)
[uninstall ] net-print/foomatic-filters-4.0.17
[blocks b ] net-print/foomatic-filters ("net-print/foomatic-filters" is blocking net-print/cups-filters-1.0.53)
[ebuild U ] x11-drivers/xf86-input-evdev-2.8.2 [2.8.1]
[ebuild U ] x11-drivers/xf86-input-synaptics-1.7.4 [1.7.1]
[ebuild U ] net-misc/dhcpcd-6.2.0-r1 [5.6.4] USE="ipv6%* udev%*"
[ebuild U ] kde-base/kdeplasma-addons-4.12.5 [4.10.5]
[blocks B ] sys-fs/udev ("sys-fs/udev" is blocking sys-apps/systemd-208-r3)
[blocks B ] sys-apps/gentoo-systemd-integration ("sys-apps/gentoo-systemd-integration" is blocking sys-fs/udev-212-r1)
[blocks B ] sys-apps/systemd ("sys-apps/systemd" is blocking sys-fs/udev-204, sys-fs/udev-212-r1)

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-base/xorg-server:0

(x11-base/xorg-server-1.15.0::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(x11-base/xorg-server-1.14.3-r2::gentoo, installed) pulled in by
x11-base/xorg-server:0/1.14.3= required by (x11-drivers/xf86-input-keyboard-1.7.0::gentoo, installed)
x11-base/xorg-server:0/1.14.3= required by (x11-drivers/xf86-input-mouse-1.9.0::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


* Error: The above package list contains packages which cannot be
* installed at the same time on the same system.

(sys-fs/udev-212-r1::gentoo, ebuild scheduled for merge) pulled in by
>=sys-fs/udev-208:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,static-libs?] (>=sys-fs/udev-208:0/0[abi_x86_32(-)]) required by (virtual/libudev-208::gentoo, ebuild scheduled for merge)
>=sys-fs/udev-208 required by (virtual/udev-208-r2::gentoo, ebuild scheduled for merge)
>=sys-fs/udev-208-r1:0/0[abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,gudev,introspection?,static-libs?] (>=sys-fs/udev-208-r1:0/0[abi_x86_32(-),gudev,introspection]) required by (virtual/libgudev-208::gentoo, ebuild scheduled for merge)

(sys-apps/systemd-208-r3::gentoo, ebuild scheduled for merge) pulled in by
>=sys-apps/systemd-200 required by (sys-power/upower-0.9.23-r3::gentoo, ebuild scheduled for merge)
>=sys-apps/systemd-207 required by (sys-apps/gentoo-systemd-integration-2::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

minig ~ #


Last edited by Phredus on Fri Jun 06, 2014 10:24 pm; edited 3 times in total
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1692

PostPosted: Fri Jun 06, 2014 8:50 pm    Post subject: Reply with quote

The issue on upower & systemd can be worked around by 3 ways. Anymore upower is depending on systemd, which is the main cause of these problems popping up.

1. If you don't need hibernates or suspends functionality, you can just change the use for kdelibs -upower and to unmerge upower.

2. Otherwise you can just do emerge -C upower && emerge upower-pm-utils

3. You could keyword upower-0.99.0-r1 for your system and use that version. However, upower-0.99 will only support hibernate & suspend functionality with systemd installed. But will run without systemd fine (for the moment at least).

The second option has you remove the upower package and install the branch off version of it that does NOT use systemd. It will still provide the hibernate and suspend functionality. Now later on in the future, I can't say on if kde will follow along with gnome and force everyone to use systemd or not. Personaly, I dislike systemd, so I'm doing the upower-pm-utils option. If you want to switch to systemd, you can (I don't know enough on systemd to guide you on that).
Back to top
View user's profile Send private message
Phredus
n00b
n00b


Joined: 07 Feb 2013
Posts: 47

PostPosted: Fri Jun 06, 2014 10:32 pm    Post subject: Reply with quote

I ran
Code:
emerge --sync


then I ran
Code:
minig ~ # emerge --update --deep --with-bdeps=y --newuse world


Updated Output:
Code:

>>> Installing (20 of 104) sys-apps/mlocate-0.26-r1
 * >>> SetGID: [chmod o-r] /usr/bin/locate ...                           [ ok ]
 * The database for the locate command is generated daily by a cron job,
 * if you install for the first time you can run the updatedb command manually ow.
 *
 * Note that the /etc/updatedb.conf file is generic,
 * please customize it to your system requirements.

>>> Emerging (21 of 104) sys-apps/help2man-1.43.3
 * help2man-1.43.3.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...           [ ok ]
>>> Unpacking source...
>>> Unpacking help2man-1.43.3.tar.gz to /var/tmp/portage/sys-apps/help2man-1.433/work
>>> Source unpacked in /var/tmp/portage/sys-apps/help2man-1.43.3/work
>>> Preparing source in /var/tmp/portage/sys-apps/help2man-1.43.3/work/help2man1.43.3 ...
 * Applying help2man-1.36.4-respect-LDFLAGS.patch ...                    [ ok ]
 * Applying help2man-1.38.4-linguas.patch ...                            [ ok ]
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/sys-apps/help2man-1.43.3/work/help2mn-1.43.3 ...
./configure --prefix=/usr --build=i686-pc-linux-gnu --host=i686-pc-linux-gnu --andir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdi=/etc --localstatedir=/var/lib --enable-nls
checking for perl... perl
checking for module Locale::gettext... no
checking for msgfmt... /usr/bin/msgfmt
checking for i686-pc-linux-gnu-gcc... i686-pc-linux-gnu-gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether i686-pc-linux-gnu-gcc accepts -g... yes
checking for i686-pc-linux-gnu-gcc option to accept ISO C89... none needed
checking for library containing dlsym... -ldl
checking for library containing bindtextdomain... none required
configure: error: perl module Locale::gettext required

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/sys-apps/help2man-1.43.3/work/help2man-1.43.3/config.log
 * ERROR: sys-apps/help2man-1.43.3::gentoo failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *          ebuild.sh, line   93:  Called src_configure
 *        environment, line 1826:  Called econf '--enable-nls'
 *   phase-helpers.sh, line  584:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *
 * If you need support, post the output of `emerge --info '=sys-apps/help2man-143.3::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-apps/help2man-1.3.3::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/sys-apps/help2man-1.4.3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-apps/help2ma-1.43.3/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-apps/help2man-1.43.3/work/help2man-.43.3'
 * S: '/var/tmp/portage/sys-apps/help2man-1.43.3/work/help2man-1.43.3'

>>> Failed to emerge sys-apps/help2man-1.43.3, Log file:

>>>  '/var/tmp/portage/sys-apps/help2man-1.43.3/temp/build.log'

 * Messages for package sys-apps/sysvinit-2.88-r7:

 * The last/lastb/mesg/mountpoint/sulogin/utmpdump/wall tools have been moved t
 * sys-apps/util-linux. The pidof tool has been moved to sys-process/procps.

 * Messages for package sys-kernel/gentoo-sources-3.12.21-r1:

 * If you are upgrading from a previous kernel, you may be interested
 * in the following document:
 *   - General upgrade guide: http://www.gentoo.org/doc/en/kernel-upgrade.xml

 * Messages for package dev-libs/libxml2-2.9.1-r4:

 * Building package for python3.3 only while python3.2 is active.
 * Please consider switching the active Python 3 interpreter:
 *
 *      eselect python set --python3 python3.3
 *
 * Please note that after switching the active Python interpreter,
 * you may need to run 'python-updater' to rebuild affected packages.
 *
 * For more information on PYTHON_TARGETS and python.eclass
 * compatibility, please see the relevant Wiki article [1].
 *
 * [1] https://wiki.gentoo.org/wiki/Project:Python/PYTHON_TARGETS
 * Building package for python3.3 only while python3.2 is active.
 * Please consider switching the active Python 3 interpreter:
 *
 *      eselect python set --python3 python3.3
 *
 * Please note that after switching the active Python interpreter,
 * you may need to run 'python-updater' to rebuild affected packages.
 *
 * For more information on PYTHON_TARGETS and python.eclass
 * compatibility, please see the relevant Wiki article [1].
 *
 * [1] https://wiki.gentoo.org/wiki/Project:Python/PYTHON_TARGETS

 * Messages for package sys-apps/mlocate-0.26-r1:

 * The database for the locate command is generated daily by a cron job,
 * if you install for the first time you can run the updatedb command manually ow.
 *
 * Note that the /etc/updatedb.conf file is generic,
 * please customize it to your system requirements.

 * Messages for package sys-apps/help2man-1.43.3:

 * ERROR: sys-apps/help2man-1.43.3::gentoo failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *          ebuild.sh, line   93:  Called src_configure
 *        environment, line 1826:  Called econf '--enable-nls'
 *   phase-helpers.sh, line  584:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *
 * If you need support, post the output of `emerge --info '=sys-apps/help2man-143.3::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=sys-apps/help2man-1.3.3::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/sys-apps/help2man-1.4.3/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/sys-apps/help2ma-1.43.3/temp/environment'.
 * Working directory: '/var/tmp/portage/sys-apps/help2man-1.43.3/work/help2man-.43.3'
 * S: '/var/tmp/portage/sys-apps/help2man-1.43.3/work/help2man-1.43.3'

 * Regenerating GNU info directory index...
 * Processed 103 info files.

!!! existing preserved libs:
>>> package: media-libs/libpng-1.6.10
 *  - /usr/lib/libpng15.so.15
 *  - /usr/lib/libpng15.so.15.17.0
 *      used by /usr/bin/gs (app-text/ghostscript-gpl-9.05-r1)
 *      used by /usr/lib/libcairo.so.2.11200.14 (x11-libs/cairo-1.12.14-r4)
 *      used by /usr/lib/libcupsfilters.so.1.0.0 (net-print/cups-filters-1.0.36r1)
 *      used by 4 other files
>>> package: media-libs/libjpeg-turbo-1.3.1
 *  - /usr/lib/libjpeg.so.8
 *  - /usr/lib/libjpeg.so.8.0.2
 *      used by /usr/bin/gs (app-text/ghostscript-gpl-9.05-r1)
 *      used by /usr/bin/jpegicc (media-libs/lcms-1.19)
 *      used by /usr/bin/jpgicc (media-libs/lcms-2.5)
 *      used by 6 other files
Use emerge @preserved-rebuild to rebuild packages using these libraries
 * After world updates, it is important to remove obsolete packages with
 * emerge --depclean. Refer to `man emerge` for more information.
minig ~ #
Back to top
View user's profile Send private message
Phredus
n00b
n00b


Joined: 07 Feb 2013
Posts: 47

PostPosted: Fri Jun 06, 2014 10:34 pm    Post subject: I'm not sure if this will help you help me, thank you. Reply with quote

This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by GNU help2man configure 1.43.3, which was
generated by GNU Autoconf 2.69. Invocation command line was

$ ./configure --prefix=/usr --build=i686-pc-linux-gnu --host=i686-pc-linux-g$

## --------- ##
## Platform. ##
## --------- ##

hostname = minig
uname -m = i686
uname -r = 3.10.7-gentoo-r1
uname -s = Linux
uname -v = #1 SMP Sun Nov 3 11:32:13 PST 2013

/usr/bin/uname -p = Intel(R) Atom(TM) CPU N270 @ 1.60GHz
Back to top
View user's profile Send private message
ct85711
Veteran
Veteran


Joined: 27 Sep 2005
Posts: 1692

PostPosted: Sat Jun 07, 2014 6:36 pm    Post subject: Reply with quote

From what I'm seeing, this looks like your issue is
Quote:
configure: error: perl module Locale::gettext required


It's from not running perl-cleaner --all, after updating your perl. Run that command, and it should rebuild any broken perl packages and fix that issue. Then you'll be able to continue updating your system.
Back to top
View user's profile Send private message
Phredus
n00b
n00b


Joined: 07 Feb 2013
Posts: 47

PostPosted: Mon Jun 09, 2014 4:02 am    Post subject: I cleaned up and was able to do a complete emerge. Reply with quote

I cannot get the linux-3.12.21-gentoo-r1 kernel to run altho it is selected in eselect it still shows 3.10.7-gentoo-r1 in uname -r.

Please help

Code:

minig ~ # eselect kernel list
Available kernel symlink targets:
  [1]   linux-3.12.21-gentoo-r1 *
minig ~ # uname -r
3.10.7-gentoo-r1
minig ~ #
Back to top
View user's profile Send private message
Phredus
n00b
n00b


Joined: 07 Feb 2013
Posts: 47

PostPosted: Mon Jun 09, 2014 9:35 am    Post subject: Solved, I was able to emerge with no problem, Thank you Reply with quote

ct85711 wrote:
From what I'm seeing, this looks like your issue is
Quote:
configure: error: perl module Locale::gettext required


It's from not running perl-cleaner --all, after updating your perl. Run that command, and it should rebuild any broken perl packages and fix that issue. Then you'll be able to continue updating your system.




Thank you so much that fixed all the issues related to updating the my system. emerge ran without errors, system is up to date.


Thank you again
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum