Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Chromium 35 mixes keyboard languages [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
mhex
Tux's lil' helper
Tux's lil' helper


Joined: 18 Feb 2005
Posts: 139
Location: Germany/Berlin

PostPosted: Sat May 31, 2014 7:54 am    Post subject: Chromium 35 mixes keyboard languages [SOLVED] Reply with quote

With Chromium 35 suddenly all my german Umlaute and ß keys map to english e.g. [;'- instead of üöäß, however other keys still
map to german e.g. z,y etc.

I didn't set LANG etc. in /etc/env.d/02locale, i never did and everything works until now

If i set LANG to e.g. de_DE.UTF-8 everything is okay only Midnight Commander can't use the proper fonts for drawing lines.

I just see that input on the tty (not X) is completely messed up, no backspace, strange key mapping

the /etc/conf.d/keymaps is for years

Code:

keymap="de"

windowkeys="YES"

extended_keymaps="backspace keypad euro2"

dumpkeys_charset=""

fix_euro="NO"


What happened suddenly?

Thanks for any hints


Last edited by mhex on Sat Jun 07, 2014 6:22 am; edited 1 time in total
Back to top
View user's profile Send private message
Kidov
n00b
n00b


Joined: 20 Jul 2006
Posts: 56
Location: Finland

PostPosted: Sat May 31, 2014 2:40 pm    Post subject: Reply with quote

I have the same problem with google-chrome-35.0.1916.114_p1. I'm using finnish keyboard layout and all other keys work as they should except "finnish special letters" Ö and Ä
Back to top
View user's profile Send private message
subox
n00b
n00b


Joined: 20 Nov 2006
Posts: 33
Location: Bytów/Szczecin

PostPosted: Tue Jun 03, 2014 5:52 pm    Post subject: Reply with quote

https://code.google.com/p/chromium/issues/detail?id=376632
Back to top
View user's profile Send private message
mhex
Tux's lil' helper
Tux's lil' helper


Joined: 18 Feb 2005
Posts: 139
Location: Germany/Berlin

PostPosted: Sat Jun 07, 2014 6:29 am    Post subject: Reply with quote

I solved it by setting LANG in

/etc/env.d/02locale[/

to UTF-8 e.g. for German layout

Code:
LANG="de_DE.UTF-8"


Code:
env-update


and restart desktop or better the whole system

additionally installed corefonts and set kde konsole font to Andale mono which supports
UTF-8 line drawing for the midnight commander..

hth
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum