Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Xorg doesn't start
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Wed May 28, 2014 10:06 am    Post subject: [SOLVED] Xorg doesn't start Reply with quote

Hi, I'm installing gentoo, on laptop with Ati graphic card.

I've installed and configured all the system, but when i boot gentoo, when it start xorg (kdm) it gives me a black screen. I use fglrx driver (ati proprietary)

Here my xorg log: http://pastebin.com/V1Zw3qQJ

Here my xorg.conf (generated with X -configure and aticonfig): http://pastebin.com/EZYzKkQ6

My /etc/portage/make.conf: http://pastebin.com/9BnzY17m

My /etc/conf.d/modules: http://pastebin.com/riARQTji


If you need other info, ask me :)

Thank you.


Last edited by lordalbert on Fri May 30, 2014 11:00 am; edited 1 time in total
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Wed May 28, 2014 11:21 am    Post subject: Reply with quote

The laptop appears to have dual AMD/Intel graphics. For the Intel driver to work, you need to enable CONFIG_DRM_I915_KMS in your kernel.
Back to top
View user's profile Send private message
lordalbert
l33t
l33t


Joined: 26 Nov 2006
Posts: 832
Location: Italy

PostPosted: Thu May 29, 2014 11:24 am    Post subject: Reply with quote

Ok, thank you. Now it works.

I disabled CONGIG_DRM becouse when emerge ati-drivers, it gives me the error/warning:

Code:

*   CONFIG_DRM must be disabled or compiled as a module and not loaded for direct
 *              rendering to work.
 * Please check to make sure these options are set correctly.
 * Failure to do so may cause unexpected problems.
 *   CONFIG_DRM must be disabled or compiled as a module and not loaded for direct
 *              rendering to work.
 * Please check to make sure these options are set correctly.
 * Failure to do so may cause unexpected problems.


but re-enable CONFIG_DRM and intel support, it works....[/code]
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 2152
Location: Berlin, Germany

PostPosted: Fri May 30, 2014 8:57 am    Post subject: Reply with quote

I don't know if that warning is still accurate. You can set CONFIG_DRM and CONFIG_DRM_I915 to build as modules if there are problems with 3D acceleration and ati-drivers.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum