Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] libvirt demands ipv6
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3237
Location: de

PostPosted: Tue May 20, 2014 4:51 pm    Post subject: [solved] libvirt demands ipv6 Reply with quote

Hi there,

after a long time with some updates I wanted to start qemu with libvirt. And of course, it's not running anymore:

Code:
Virtuelles Netzwerk «default» konnte nicht gestartet werden: direct firewall backend requested, but /sbin/ip6tables is not available: Datei oder Verzeichnis nicht gefunden

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/uihelpers.py", line 689, in validate_network
    virnet.create()
  File "/usr/lib64/python2.7/site-packages/libvirt.py", line 2669, in create
    if ret == -1: raise libvirtError ('virNetworkCreate() failed', net=self)
libvirtError: direct firewall backend requested, but /sbin/ip6tables is not available: Datei oder Verzeichnis nicht gefunden

Or in English:
Virtual network «default» couldn't be started, direct firewall backend requested, but /sbin/ip6tables is not available: File or directory not found.

That sounds logical to me. I don't have any ipv6 support yet. But I didn't find an option to deactivate ipv6. For my side, there's no need for any ipv6 support. How can I deactivate that?

If I remove the network adapters from the virtual machine, I can start the guests.

Installed versions:
  • libvirt-1.2.4 (caps libvirtd macvtap nfs nls numa parted pcap policykit qemu systemd udev vepa virt-network -audit -avahi -firewalld -fuse -iscsi -lvm -lxc -openvz -phyp -rbd -sasl -selinux -uml -virtualbox -xen ELIBC="glibc")
  • qemu-2.0.0 ((aio alsa bluetooth caps curl fdt filecaps gtk jpeg ncurses opengl png python sdl seccomp spice ssh static-user threads usb uuid vhost-net vnc xfs -accessibility -debug -glusterfs -iscsi -pulseaudio -rbd -sasl -selinux -smartcard -static -static-softmmu -systemtap -tci -test -tls -usbredir -vde -virtfs -xattr -xen KERNEL="linux -FreeBSD" PYTHON_TARGETS="python2_7 -python2_6" QEMU_SOFTMMU_TARGETS="arm i386 x86_64 -aarch64 -alpha -cris -lm32 -m68k -microblaze -microblazeel -mips -mips64 -mips64el -mipsel -moxie -or32 -ppc -ppc64 -ppcemb -s390x -sh4 -sh4eb -sparc -sparc64 -unicore32 -xtensa -xtensaeb")


Last edited by musv on Sun May 25, 2014 6:34 am; edited 1 time in total
Back to top
View user's profile Send private message
turtles
Veteran
Veteran


Joined: 31 Dec 2004
Posts: 1341

PostPosted: Wed May 21, 2014 1:38 am    Post subject: Reply with quote

What are your use flags? Are you not using virt-network?
Oops nevermind I see you posted them right there.
_________________
Donate to Gentoo
Back to top
View user's profile Send private message
musv
Advocate
Advocate


Joined: 01 Dec 2002
Posts: 3237
Location: de

PostPosted: Sun May 25, 2014 6:33 am    Post subject: Reply with quote

It seems libvirt is really looking for the hardcoded "/sbin/ip6tables". 8O

I've set a Symlink:

Code:
lrwxrwxrwx 1 root root 8 25. Mai 08:01 /sbin/ip6tables -> iptables


Works.
Back to top
View user's profile Send private message
Moriah
Advocate
Advocate


Joined: 27 Mar 2004
Posts: 2115
Location: Kentucky

PostPosted: Sat Aug 23, 2014 7:32 pm    Post subject: Reply with quote

Ran into the same problem today. Hadn't used KVM in several weeks, did a few updates during that time, then KVM failed to start for the same reason. The symlink fix was elegantly simple, and work great for me. Thanks for the answer! :mrgreen:
_________________
The MyWord KJV Bible tool is at http://www.elilabs.com/~myword

Foghorn Leghorn is a Warner Bros. cartoon character.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum